none
Exchange 2003 вообще не может доставить почту RRS feed

  • Вопрос

  • Домен на W2K3 company.local. Echange 2003 SP2 с самого начала, сразу после установки не выполняет свою прямую обязанность: отправку и прием почты.

       Просто через его SMTP-сервер, можно отправить письмо на любой ящик в другом домене, и оно доходит.

       Невозможно отправить письмо в этот домен ни с ящика этого же домена, ни с внешнего ящика (подключаясь к Exchange SMTP-серверу), ни даже самому себе. В журнале событий "Система" регистрируется событие: источник - MSExchangeMTA, категория - X.400 Service, ID - 290, тип - Предупреждение, описание - "A non-delivery report (reason code unable-to-transfer and diagnostic code unrecognised-OR-name) is being generated for message С=RU;A=company.ru;P=company.local;L=SERVER<цифры>. It was originally destined for C=RU;A=company.ru;P=company.local;O=Company;DDATongue TiedMTP=user(a)company.ru; (recipient number 1), and was to be redirected to . [MTA DISP:RESULT 16 136] (12)".

       Иными словами, Exchange понятия не имеет, как доставлять письма внутри организации. Возможно, надо указать правильные значения в политике Recipient Policies->Default Policies. Но там указаны параметры X.400, которые применяются к ящикам юзеров. А какие у самого сервера эти параметры (O, A, P) не знаю. В чем ещё причина, даже не предполагаю.

       Могу предоставить всю необходимую дополнительную информацию. Заранее благодарен за помощь.

    • Перемещено Tina_Tian 19 марта 2012 г. 1:42 forum merge (От:Exchange Server 2003/2000/5.5)
    14 июня 2008 г. 14:59

Все ответы

  • Попробуй прописать в политике Recipient Policies->Default Policies SMTP Adress @company.local и @company.ru (последний поставь как default), ну и сами ящики у пользователей должны быть прописаны подобным образом

    15 июня 2008 г. 16:56
  • Не думаю, что это поможет... Проверьте правила формирования адреса x400. Всюду где встречал, было 'A= ', а у Вас почему то там company.ru стоит... Видимо двойной аттрибут получается. В организации есть x400 коннекторы?

    16 июня 2008 г. 5:35
    Модератор
  •  Isotonic написано:

    Домен на W2K3 company.local. Echange 2003 SP2 с самого начала, сразу после установки не выполняет свою прямую обязанность: отправку и прием почты.

       Просто через его SMTP-сервер, можно отправить письмо на любой ящик в другом домене, и оно доходит.

       Невозможно отправить письмо в этот домен ни с ящика этого же домена, ни с внешнего ящика (подключаясь к Exchange SMTP-серверу), ни даже самому себе. В журнале событий "Система" регистрируется событие: источник - MSExchangeMTA, категория - X.400 Service, ID - 290, тип - Предупреждение, описание - "A non-delivery report (reason code unable-to-transfer and diagnostic code unrecognised-OR-name) is being generated for message С=RU;A=company.ru;P=company.local;L=SERVER<цифры>. It was originally destined for C=RU;A=company.ru;P=company.local;O=Company;DDAMTP=user(a)company.ru; (recipient number 1), and was to be redirected to . [MTA DISP:RESULT 16 136] (12)".

       Иными словами, Exchange понятия не имеет, как доставлять письма внутри организации. Возможно, надо указать правильные значения в политике Recipient Policies->Default Policies. Но там указаны параметры X.400, которые применяются к ящикам юзеров. А какие у самого сервера эти параметры (O, A, P) не знаю. В чем ещё причина, даже не предполагаю.

       Могу предоставить всю необходимую дополнительную информацию. Заранее благодарен за помощь.

     

    Предоставляйте exchdump /smtp

     

    п.с. у вас вообще открытый релэй из вашего описания, а так же отсуствие в RP smtp адресации

    16 июня 2008 г. 9:13
  • Да, relay пока открытый. Когда описывал, имел только ввиду, что с отправкой в это направление проблем нет.

    mail.company.local - 2 записи типа "A" на собственном DNS, разрешаются в IP-адреса SMTP-серверов ISP-в.

    В организации нет X.400 коннекторов. Я думаю про параметры X.400 потому, что их вроде Exchange сам по себе использует. 'A= ' поменял сам, просто пробовал различные варианты, мне кажется, что 'A=' - это публичное имя домена организации, поэтому подставил company.ru

     

    Exchange Dump

    17 июня 2008 г. 2:06
  • Привет!

    "X400:c=RU;a=company.ru;p=company.local;o=Company;"
          "SMTPAngrycompany.ru"
          "smtpAngrycompany.local"
    а вот так зачем сделано?

    Думаю будет достаточно одного SMTPадреса и в X400 подправьте. Х400 не используется у вас для передачи наружу почты. Сделайте одну политику с company.ru и все. Зачем такой огород то городить? GAL пересоберете и будете внутри домена отправлять по внешнему суффиксу почты. Это же все равно только атрибут пользователя.

    Что то слова из меня с трудов выходят

    Уберите company.local одним словом
    17 июня 2008 г. 5:36
    Модератор
  •  Isotonic написано:

    Да, relay пока открытый. Когда описывал, имел только ввиду, что с отправкой в это направление проблем нет.

    mail.company.local - 2 записи типа "A" на собственном DNS, разрешаются в IP-адреса SMTP-серверов ISP-в.

    В организации нет X.400 коннекторов. Я думаю про параметры X.400 потому, что их вроде Exchange сам по себе использует. 'A= ' поменял сам, просто пробовал различные варианты, мне кажется, что 'A=' - это публичное имя домена организации, поэтому подставил company.ru

     

    Exchange Dump

     

    все же информацию вы решили не предоставлять  , дело ваше

    17 июня 2008 г. 9:49
  •  Sergey Krylov написано:
     Isotonic написано:

    Да, relay пока открытый. Когда описывал, имел только ввиду, что с отправкой в это направление проблем нет.

    mail.company.local - 2 записи типа "A" на собственном DNS, разрешаются в IP-адреса SMTP-серверов ISP-в.

    В организации нет X.400 коннекторов. Я думаю про параметры X.400 потому, что их вроде Exchange сам по себе использует. 'A= ' поменял сам, просто пробовал различные варианты, мне кажется, что 'A=' - это публичное имя домена организации, поэтому подставил company.ru

     

    Exchange Dump

     

    все же информацию вы решили не предоставлять  , дело ваше

     

    В первом сообщении написал. что готов "предоставить всю необходимую дополнительную информацию". Dump я выложил - http://isotonic.narod.ru/temp/exchdump.htm. Нужен какой-то другой?

    17 июня 2008 г. 18:48
  •  Oleg Krylov написано:

    Привет!

    "X400:c=RU;a=company.ru;p=company.local;o=Company;"
          "SMTPAngrycompany.ru"
          "smtpAngrycompany.local"
    а вот так зачем сделано?

    Думаю будет достаточно одного SMTPадреса и в X400 подправьте. Х400 не используется у вас для передачи наружу почты. Сделайте одну политику с company.ru и все. Зачем такой огород то городить? GAL пересоберете и будете внутри домена отправлять по внешнему суффиксу почты. Это же все равно только атрибут пользователя.

    Что то слова из меня с трудов выходят

    Уберите company.local одним словом

     

    Убрал company.local из SMTP, из X.400 убрал company.local из поля 'p=', а поле 'a=' очистить, чтобы было как у всех, не удалось: пишет, что это required field. Поэтому в нем сейчас находится company.ru.

    17 июня 2008 г. 19:14
  • После перезапуска сервера ничего не изменилось. Ужас, как бесит, что у меня, и только у меня, Exchange после установки не работает, хотя по-любому задумывалось, что будет между юзерами домена даже без настройки.

    17 июня 2008 г. 19:16
  •  Isotonic написано:

    Убрал company.local из SMTP, из X.400 убрал company.local из поля 'p=', а поле 'a=' очистить, чтобы было как у всех, не удалось: пишет, что это required field. Поэтому в нем сейчас находится company.ru.

    В поле 'p= ' поставьте company.ru Конечно должно работать и без настройки, но при условии введения верных исходных данных.
    18 июня 2008 г. 2:53
    Модератор
  • Бесполезно.

    Мне кажется, что у меня не работает не доставка по SMTP, а доставка через службу X.400, ведь видимо именно она используется внутри организации. Необходимо как -то включить отладку/ведение журналов ExchangeMTA, чтобы у меня было больше информации.

    28 июня 2008 г. 14:50
  •  Isotonic написано:

    Бесполезно.

    Мне кажется, что у меня не работает не доставка по SMTP, а доставка через службу X.400, ведь видимо именно она используется внутри организации. Необходимо как -то включить отладку/ведение журналов ExchangeMTA, чтобы у меня было больше информации.

     

    Вы данные реальные можете предоставить или нет ? а то так и будем ходить бродить вокруг да около

    30 июня 2008 г. 9:22