none
PC ушел в цикл перезагрузок при развертывании Windows 7 x64 RRS feed

  • Общие обсуждения

  • Уважаемые, подскажите пожалуйста по следующему вопросу:

    Проблема у нас образовалась с развертыванием Windows7 x64 средствами SCCM

    Постараюсь описать суть:

    1.        Взяли wim с DVD диска – распространили на DP

    2.        winPE x64 – тоже распространили

    3.        создали task

    4.        создали advertising на него

    5.        в коллекцию соответствующую включили по МАС адресу железную машину.

    В итоге комп грузится по PXE находит объявление и начинает ставить ОС – довольно долго производит установку – потом рестарт и при первом запуске виндовс вылетает такое сообщение:

    Не удалось выполнить синтаксический разбор или обработку файлов ответов для автоматической установки при проходе [specialize].Параметры, указанные в файле ответов, не могут быть применены. Ошибка при обработке параметров для компонентов [Microsoft-Windows-Shell-Setup].

    Жму ОК

    Restart

    И вываливается такое сообщение:

    Компьтер неожиданно перезагрузился, или возникла непредвиденная ошибка. Невозможно продолжить установку Windows. Чтобы установитьWindows, нажмите кнопку «ок» для перезагрузки компьютера, а затем перезапустите установку.

    Жму ОК

    Restart и снова это сообщение-в цикл в общем уходит машина.

    Что не так-непойму. в логе smspxe вроде без ошибок всё. Отчет на Задание тоже без "матерных слов".

    12 апреля 2010 г. 4:41

Все ответы

  • какая версия SCCM у вас установлена?
    поддержка Win7 добавлена в SP3.
    просмотрите ссылку http://social.technet.microsoft.com/Forums/en/w7itproinstall/thread/706af5a1-89f5-4bad-9646-efedf7b365d7 


    с уважением Андреев А.В. Если сообщение помогло решить проблему - отметьте ее как ответ, если было информативным - проголосуйте за сообщение. Не будем оставлять решенные посты без отметок, это затруднит поиск решения другим.
    12 апреля 2010 г. 7:28
  • последнее и единственное обновление было сделано в конце января 2010 г. соответственно сейчас sccm выглядит так:

    12 апреля 2010 г. 11:59
  • Ошибка очень похожа, на то, что попытались поставить на деплоймент оригинальный wim file, без предварительного build and capture
    12 апреля 2010 г. 13:40
  • хорошо, сегодня сделал build and capture в соответствии с инструкцией пошагово: http://www.windows-noob.com/forums/index.php?/topic/667-deploy-windows-7/ и снова заноза: доходит до места "after the format the Windows 7 installation begins" (см. пред.ссылку) и вываливает сообщение с ошибкой 80004005.

    далее пока тикает счетчик на рестарт копипастим smstslog из папок X:\windows\temp\smstslog\ и c:\_smstasksequence (ибо кроме этой папки нет ничего на С) и видим следующее: windows setup failed: code 31 failed и to restore content for driver .

    Причем проверил на трех машинах: две из них были железные и одна виртуалка.

    p.s. мужики мне в отпуск уходить надо в конце недели, а эту траблу надо обязательно забороть - поможите чем можите )

    13 апреля 2010 г. 13:33
  • Утро вечера мудренее как говорится: с утра изучил еще раз логи и локализировал место где вылетает в даун установка - происходит это на шаге "Настройка Windows и Configuration Manager" в моем task sequence. Идем туда и видим что там фигурирует только установка пакета "Microsoft Клиент Configuration Manager 4.0 Все", его я проверил - точки распространения обновил - состояние пакета кажет "Установлено". Что же не нравится то этому SCCM?
    14 апреля 2010 г. 6:04
  • Была точно такая же проблема, когда пытался разворачивать ОС из OS Package. Пытался победить дня три, докопался только до того, что система не может найти или применить какие-то boot-critical драйверы, предположительно для стореджа.

    Обошел проблему, используя только файл install.wim из дистрибутива. Ну то есть, прибил OS Package, подцепил OS Image и всё. Малость не то, что хотелось, но система ставится и работает.


    Чтобы понять рекурсию, нужно сначала понять рекурсию.
    14 апреля 2010 г. 6:11
  • Утро вечера мудренее как говорится: с утра изучил еще раз логи и локализировал место где вылетает в даун установка - происходит это на шаге "Настройка Windows и Configuration Manager" в моем task sequence. Идем туда и видим что там фигурирует только установка пакета "Microsoft Клиент Configuration Manager 4.0 Все", его я проверил - точки распространения обновил - состояние пакета кажет "Установлено". Что же не нравится то этому SCCM?


    В примере Capture Task Sequence, у Вас и Capture не проходит?

    P.S. А, так сказать, "руками" не пробовали установить этот Windows на эту машину.

    P.S.S. Проблемы с Deployment бывают, не только когда не хватает драйверов после разворачивания системы, но и когда есть лишние в BootImage.

    14 апреля 2010 г. 7:03
  • 2Jevgenijs Geizans:

    руками ставил с ДВД диска эту виндовс 7 много раз - он точно рабочий. Про дрова согласен: поэтому убрал - и в логе всё желтое с руганью на отсутствие драйверов на железо разного типа. А по факту та же ошибка на том же шаге.

    может как вариант добавить к bootImage только нужные драйвера, как их только определить: добавить все имеющиеся и убирать те которые в логе обруганы будут?

    14 апреля 2010 г. 7:39
  • обычно нужны только storage, network

    у меня на практике было не больше 2-5 штук (разумеется зависит от уникальности железа на предприятии)

    14 апреля 2010 г. 7:44
  • может как вариант добавить к bootImage только нужные драйвера, как их только определить: добавить все имеющиеся и убирать те которые в логе обруганы будут?

    Драйверы, импортированные к Boot image, не имеют отношения к этой проблеме. Они нужны только для того, чтобы WinPE смог опознать сторедж и сеть, и смог загрузить и навернуть всё, что потребуется.

     

    Если используется установка путем применения OS Install Package, нужно, чтобы загрузчик (boot image) был той же разрядности, что и накатываемая ОС. Установке же с голого WIM-файла по барабану.


    Чтобы понять рекурсию, нужно сначала понять рекурсию.
    14 апреля 2010 г. 7:55
  • В логе была ошибка Windows setup 31 - attached device not functioning

    похожая ситуация:

    http://social.technet.microsoft.com/Forums/en-US/configmgrosd/thread/6f786395-b98c-415b-86df-bd8ed741f542

    14 апреля 2010 г. 8:01
  • хорошо, давайте я опишу что я вообще делаю "от и до" как говорится. А вы мне скажите можно ли так делать и должно ли на практике заработать такое чудовище. Сразу скажу, что моделирую самую простую ситуацию по развертыванию виндовс 7:

    1. беру образ windows 7 enterprise - копирую его содержимое на доступный UNC.

    2. в CMConsole: Добавляем образ загрузки x32 выбирая файл \\SCCM\Operating Systems\Windows 7 x86\sources\boot.wim,

    затем Импортируем образ ОС из файла \\SCCM\Operating Systems\Windows 7 x86\sources\install.wim

    3. распространяем их на соответствующие точки распространения.

    4. создаем Последовательность задач (какие пункты и с какими параметрами напишу потом, если сама схема в целом верная окажется)

    5. делаем advertise на этот task sequence, применяем его к коллекции в которую импортирован по MAC комп.

    6. ну и дальше запускаем процесс установки.

    Сторонние дрова никакие не включил в bootimage.

     

    14 апреля 2010 г. 11:09
  • 1.х86 или х64 (всё таки)

    2. я не знаю как в русской консоли, но это должен быть не OS Image, a OS Install Package

    14 апреля 2010 г. 11:29
  • 1. в последнем варианте всё для x32

    2. почему нельзя в OS Image? в OS Install Package пробовал ранее:

    "хорошо, сегодня сделал build and capture в соответствии с инструкцией пошагово: http://www.windows-noob.com/forums/index.php?/topic/667-deploy-windows-7/ и снова заноза: доходит до места "after the format the Windows 7 installation begins" (см. пред.ссылку) и вываливает сообщение с ошибкой 80004005.

    далее пока тикает счетчик на рестарт копипастим smstslog из папок X:\windows\temp\smstslog\ и c:\_smstasksequence (ибо кроме этой папки нет ничего на С) и видим следующее: windows setup failed: code 31 failed и to restore content for driver .

    Причем проверил на трех машинах: две из них были железные и одна виртуалка."

    14 апреля 2010 г. 11:50
  • 2. я не знаю как в русской консоли, но это должен быть не OS Image, a OS Install Package


    Есть и OS Install Package, и OS Image. В первом случае это просто копия диска с дистрибутивом, во втором - отдельный WIM-файл. Два вида исходников для двух разных режимов развертывания.
    Чтобы понять рекурсию, нужно сначала понять рекурсию.
    14 апреля 2010 г. 12:10
  • в указанной инструкции всё чётко прописано.

    проблема может быть с OS Sources или сетью

    1. закачать OS Install Package заново (содержимое всего диска!)

    2. поменять параметр Install from Distribution point на Download and Install

    было бы неплохо увидеть подробности в Task Sequence "Применить операционную систему"

    14 апреля 2010 г. 12:14
  • хорошо, считаем что схему утвердили )

    теперь подробнее:

    1. перезалил OS Install Package заново

    2. это где менять? русскую консоль ведь юзаю.

    Task Sequence "Применить операционную систему"

    14 апреля 2010 г. 13:48
  • 2. (сейчас отвечу почти по русски :) )в настройках Distribution Points в Advertisement Properties для этого Task Sequence

    а настройки "Применить операционную систему" могут быть интересны, если на компьютере не одна парциция, а несколько (например, присутствует сервисная парциция), можно указать куда инсталировать систему

    15 апреля 2010 г. 5:23
  • относительно выбранной схемы: она работает.

    только одно НО: у меня винда ставится и пакеты все ставятся, только в процессе развертывания вылетает ошибка 00000032 и в итоге комп в workgroup, а не в домене как указано в task-e. У кого нить такое было?

    15 апреля 2010 г. 13:25
  • При Capture нельзя делать Join Domain. Мы получаем только wim для распространения.

    Строим новый, уже Deployment Task Sequence, там и добавляем в Domain

    15 апреля 2010 г. 14:40
  • хорошо, сделал именно так: 

    "Строим новый, уже Deployment Task Sequence, там и добавляем в Domain"

    И всё равно в домен невключило (((

    В логе Advertise написано что ОС поставлена и сразу после строка такого содержания:

    "Механизму выполнения последовательности задач не удалось выполнить действие (Присоединиться к домену или рабочей группе) в группе () с кодом ошибки 50"

    16 апреля 2010 г. 4:17
  • А сеть поднялась, уже в Windows, драйвера добавляли?

    У вас есть другие, удачные Deployments на этот момент?

    16 апреля 2010 г. 6:01
  • "Удачные Deployments" есть под ХР и там кстати в домен включало без проблем.

    Дрова не ставил, но в диспетчере устройств указано что сетевые адаптеры внорме (локально то я захожу на машину под Администратором).

    16 апреля 2010 г. 6:19
  • Давай тогда новую тему и TSLOG в студию

    16 апреля 2010 г. 6:35
  • Здравствуйте, fetisov . Можете отметить те сообщения, которые были полезными и ответ, если он есть?

    Поможем друг другу стать лучше! Отметим правильные ответы и полезные сообщения! Посетите наш блог http://blogs.technet.com/ru_forum_support/default.aspx
    22 апреля 2010 г. 7:36
    Модератор
  • Уважаемый пользователь!


    В вашей теме отсутствует активность в течение последних 5 дней. При отсутствии каких-либо действий в течение 2 последующих дней, тема будет переведена в разряд обсуждений. Вы можете возобновить дискуссию, просто оставив сообщение в данной теме.


    Поможем друг другу стать лучше! Отметим правильные ответы и полезные сообщения! Посетите наш блог http://blogs.technet.com/ru_forum_support/default.aspx
    Модератор
  • Добрый день, можно эту тему вообще удалить наверное, перечитал свежим взглядом и понял, что ничего полезного тут нет.
    17 марта 2011 г. 8:45
  • В итоге побороли?

    17 марта 2011 г. 16:57
    Отвечающий