none
Не удается установить/удалить компонент net framework 3.0 windows 2008 sp2 из управления ролями и компонентами. RRS feed

  • Вопрос

  • Не удается установить/удалить  компонент net framework 3.0 windows 2008  Enterprise sp2  (Лицензионный) из управления ролями и компонентами.

    Хотел установить Exchange  2010 он требует net framework 3.5 sp 1, пытался установить, так установщик требует net framework 3.0, а эта версия установлена в "Диспетчер сервера->Компоненты->Возможности .Net Framework 3.0". При установке в систему net framework 3.0 с сервиспаками и без (а так же fix) выдает, что "Продукт не поддерживается в операционной системе Vista ". Пытаюсь удалить из компонентов выдает ошибку:

    ____________________________________________________________________

    Возможности .NET Framework 3.0: Ошибка при удалении

    <Ошибка>: Не удалось выполнить отмену установки XPS Viewer, код ошибки 0x80070643. В процессе установки произошла неисправимая ошибка
    <Ошибка>: Не удалось выполнить отмену установки Non-HTTP Activation, код ошибки 0x80070643. В процессе установки произошла неисправимая ошибка
    <Ошибка>: Не удалось выполнить отмену установки HTTP Activation, код ошибки 0x80070643. В процессе установки произошла неисправимая ошибка
    <Ошибка>: Не удалось выполнить отмену установки .NET Framework 3.0, код ошибки 0x80070643. В процессе установки произошла неисправимая ошибка
    Следующие компоненты не удалены:
    .NET Framework 3.0
    Средство просмотра XPS
    Активация WCF
    Активация через HTTP

    Не-HTTP активация

    _________________________________________________________________________________________

    Запускал dotnetfx_cleanup_tool, типа все удалено.

    MicrosoftFixit.ProgramInstallUninstall.RNP.15529420623632055.9.1.Run - выдает ошибку "это средство не подходит для этой операционной системы".

    Microsoft_.NET_Framework_Repair_Tool - куча логов, ничего не исправлено.

    Подскажите пожалуйста в какую сторону копать (переустанавливать систему не буду, стоит AD).

    На сервере установлен net framework 1.1, 4.5.1. 

    Встроенный framework 2.0 в службах не запускается, говорит что остановлена за ненадобностью.


    • Изменено ostrojinskiy 26 февраля 2014 г. 7:07
    26 февраля 2014 г. 6:15

Ответы

Все ответы