none
установка из msi завершается с кодом 11305 RRS feed

  • Общие обсуждения

  • В логах пишется "Product: OpenQuant 2 -- Error 1305. Error reading from file D:\projects\OQ291\OpenQuant 2.91.msi. System error 0. Verify that the file exists and that you can access it."

    Файл не поврежден и не находится на СД/сетевом диске, потому как только что извлечен из архива. С другими msi точно такая же история.

    На ЖД бедов нет - смотрем в самтре диска. ФС прочекана - ошибок нет.

    Запуск из под админа и под обычным юзером не имеют разницы.

    Запускал винду с минимальными сервисами - получил облом по факту не стартовавшего сервиса инсталяции. Хотя в доке это был один из вариантов решения проблемы :)

    вин 7 х64. автоапдейты включены. место на диске есть. msi-файл был записан в каталог юзера и под его правами. После неудачной инсталляции может быть изменен и удален без проблем, т.е. прав хватает.

    • Изменен тип Yuriy Lenchenkov 17 января 2011 г. 9:23 пользователь покинул тему
    2 января 2011 г. 6:44

Все ответы

  • Уважаемые модераторы!

    В моей теме отсутствует активность в течение последних 5 дней. При отсутствии каких-либо действий в течение 2 последующих дней, мне придется принять превентивные меры. Вы можете возобновить дискуссию, просто оставив сообщение в данной теме.

    5 января 2011 г. 6:24
  • проверьте, правильно ли у вас работают системные переменные %systemroot% и т.п.

    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий
    6 января 2011 г. 12:00
  • Добрый день, Юрий!

    Запустил cmd и набрал там set. Вот что из этого получилось:

    ---------------------

    ALLUSERSPROFILE=C:\ProgramData
    APPDATA=C:\Users\user\AppData\Roaming
    CommonProgramFiles=C:\Program Files\Common Files
    CommonProgramFiles(x86)=C:\Program Files (x86)\Common Files
    CommonProgramW6432=C:\Program Files\Common Files
    COMPUTERNAME=BIG-COMP
    ComSpec=C:\Windows\system32\cmd.exe
    FP_NO_HOST_CHECK=NO
    HOMEDRIVE=C:
    HOMEPATH=\Users\user
    LOCALAPPDATA=C:\Users\user\AppData\Local
    LOGONSERVER=\\BIG-COMP
    NUMBER_OF_PROCESSORS=2
    OS=Windows_NT
    Path=C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\Common Files\Acronis\SnapAPI\
    PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC
    PROCESSOR_ARCHITECTURE=AMD64
    PROCESSOR_IDENTIFIER=AMD64 Family 15 Model 107 Stepping 2, AuthenticAMD
    PROCESSOR_LEVEL=15
    PROCESSOR_REVISION=6b02
    ProgramData=C:\ProgramData
    ProgramFiles=C:\Program Files
    ProgramFiles(x86)=C:\Program Files (x86)
    ProgramW6432=C:\Program Files
    PROMPT=$P$G
    PSModulePath=C:\Windows\system32\WindowsPowerShell\v1.0\Modules\
    PUBLIC=C:\Users\Public
    SESSIONNAME=Console
    SystemDrive=C:
    SystemRoot=C:\Windows
    TEMP=C:\Users\user\AppData\Local\Temp
    TMP=C:\Users\user\AppData\Local\Temp
    USERDOMAIN=big-comp
    USERNAME=user
    USERPROFILE=C:\Users\user
    VS100COMNTOOLS=C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\Tools\
    windir=C:\Windows
    ---------------------

    Я тут конечно ничего не понимаю, но с виду все корректно.

    Какие еще методы и направления пробовать?

    6 января 2011 г. 16:22
  • сверьте ветку реестра hklm\system\currentcontrolset\services\msiserver с заведомо рабочим компьютером с такой же версией ос или экспортируйте ее с заведомо рабочей ос и импортируйте в свою, предварительно сделав резервную копию.

    про %systemroot%  проверьку сделайте в командной строке cd %systemroot% - должны будете перейти в каталог ОС, обычно c:\windows

    попробуйте сделать msiexec /regserver


    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий
    10 января 2011 г. 11:30
  • ветку реестра взял из виртуальной машины (вин7 х64). Импортировал.

    при cd %systemroot% попадаю в C:\Windows, как и логично было предположить исходя из SystemRoot=C:\Windows

    сделал msiexec /regserver - ничего не изменилось, перезагрузился, изменений нет.

     

    сегодня еще в логах посыпались кернел трейсинг ивент.

    штатный бекап уже как пару недель не работает, скорость на шарах упала с 30 мб/с до максимум 10 мб/с.

     

    ну ладно, будем считать что я сломал винду, работая больше трех месяцев из под юзера с минимальными правами.

    10 января 2011 г. 12:50
  • работая под юзером с минимальными правами, врядли бы у вас возникли вопросы по ошибкам инсталлера :)


    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий
    10 января 2011 г. 13:12