none
Не работает поиск по глобальному списку адресов в OWA RRS feed

  • Вопрос

  • Добрый день, коллеги.
    Проблема следующая:
    Есть сервер с ISA2006, есть внутренний Exchange 2003.
    На ISA опубликован exchange OWA. Все работает нормально, кроме поиска по глобальному списку адресов.
    При попытке поиска человека появляется окно Unknown Error. В логах все нормально. ISA - domain member.
    Внутри сети поиск работает нормально.

    24 августа 2007 г. 8:17

Все ответы

  • Говоришь внутри сети поиск работает нормально, имеешь ввиду OWA или MS Outlook?

    В логах где смотрел? На клиенте, на exchange и на ISA?

    24 августа 2007 г. 10:51
  • Да, при просмотре почты через OWA внутри сети поиск работает. Если идти туда снаружи на опубликованный ISA ресурс OWA, то наблюдается такая ошибка. Не вижу ошибок ни в логах иса , ни в логах iis на exchange.
    24 августа 2007 г. 14:27
  • Никто не встречался с подобной проблемой?
    27 августа 2007 г. 12:23
  •  

    Дайте ссылку на эту тему в разделе Exchang-а - возможно спецы по Exchange помогут.
    28 августа 2007 г. 2:37
    Модератор
  •  

    Просмотрел логи везде, на ISA все нормально, на Exchange http статус 200. Поставил Firefox - поиск чудесным образом работает. Возможно проблемы с какими-либо апдейтами для Exchange или IE. Хотя внутри сети все работает прекрасно. Пробовал для IE6/7
    28 августа 2007 г. 7:56
  • У вас единственный Exchange сервер

    Публикация проводилась по похожему сценарию?

    Publishing Outlook Web Access (OWA) Sites using ISA Server 2004 Firewalls (v 1.1)

    http://www.isaserver.org/articles/2004owapub.html

    28 августа 2007 г. 11:56
  • Да, похоже, статья была другой.

    1. Есть ИСА с 2 интерфейсами. OWA опубликован на внешнем с именем owa.org_name.dom. Доступ осуществляется по https, сертификат импортирован в локальное хранилище ИСА. Сессия https устанавливается только между внешним клиентом и ИСА сервером, внутри ИСА ходит в exchange по http.

    2. Далее с помощью мастера пуликации OWA он, собственно, опубликован. На ИСА используется form based authentication (basic authentication)

    3. Как я говорил, все работает нормально за исключением пользования поиском по глобальному адресному листу, поиск по контактам работает также нормально. Причем после исследования http трафика, нашел GET запрос, который возвращает результат поиска и тоже нормально работает. Тоесть ошибка появляется в момент нажатия кнопки "поиск". В Firefox все работает, но это несколько не устраивает.

    4. В логах серверов все чисто.

    5. Да, внутри сети поиск работает в IE6/7.

    6. Поиск по русскому и англоязычному интернету результатов пока не принес... я один такой?)))))

    28 августа 2007 г. 12:59
  •  

    У вас должен быть открыт еще порт запроса к серверу глобального каталога по идее. 3268 и 389

    28 августа 2007 г. 13:39
  • Логично, но мне почемуто кажется, что поиск в лдапе должно осуществлять веб-приложние (OWA) а результаты поиска возвращать по http.

    Создал еще одно правило публикации, казалось бы идентичное, но без использования ssl на внешнем интерфейсе и... поиск работает))))

    Где-то проблема с авторизацией, вот только где?

    28 августа 2007 г. 13:53
  • да. странности меня преследуют. Поиск заработал без SSL, но перестали работать вложения)))).

    Если включить SSL, то вложения работают, но не работает поиск.

     

    28 августа 2007 г. 14:09
  •  DaKl написано:

    У вас должен быть открыт еще порт запроса к серверу глобального каталога по идее. 3268 и 389

    Ничего подобного. Для OWA не нужно ничего, кроме порта 443. И для соединения ISA с Exchange CAS / front-end - тоже. С глобальным каталогом общается уже Exchange сервер.

    29 августа 2007 г. 3:30
  •  Andrey Larin написано:

    да. странности меня преследуют. Поиск заработал без SSL, но перестали работать вложения)))).

    Если включить SSL, то вложения работают, но не работает поиск.

     

     

    Это говорит о том, что публикация выполнена некорректно. Идите на isaserver.org - там есть статьи о публикации OWA.

    29 августа 2007 г. 5:34
    Модератор
  • У нас такая же схема работает и внутри и снаружи.

    1. Попробуйте на OWA консоли в закладке Параметры, раздел Безопасность загрузить "Установка последней версии элемента управления S/MIME"

    2. ПРоверьте стоит ли в листнере Require all users to authentication

    3. В правиле публикации посмотри на закладке Users стоит ли галочка Basic delegation

    29 августа 2007 г. 6:02
  • По пунктам 2 и 3 все нормально.

    При попытке загрузки последней версии s/mime возникает ошибка.

    хотя не понятно как s/mime влияет на работу поиска?
    31 августа 2007 г. 8:45
  • Ошибка обновлений s/mime клиента связана с установленным сервисом паком 1 или 2 для Exchange 2003 и неустановленным апдейтом для этого самого клиента s/mime - он ставиться отдельно.

     

    http://support.microsoft.com/?kbid=883543 - попробуйте это на сервере с owa

     

    Клиент s/mime отвечает за обработку подписанных писем, т.е. подписать или проверить подпись.

     

    Т.к. в ISA нет управляемого фильтра HTTPS, то вопрос скорее всего именно в контроле доступа к внутреннему ресурсы фаерволом, т.е. подскажите пожалуйста какой тип авторизации насторен на Exchnage 2003 Web Access и какой тип авторизаци настроен в ISA 2006?

     

    Попробуй вариант: За авторизацию отвечает Exchange 2003 с авторизацией пользователей собственными средствами (iis filter) посредством веб-интерфейса, а ISA 2006 выступает в роли посредника (форвардера) не применя собственных средств для авторизации.

    31 августа 2007 г. 9:22
  •  

    Данное обновление не устанавливается, ибо на Exchange уже установлен SP2.

     

    Настройки правила:

    ISA 2006: Requests appear to come from ISA Server, HTML from authentication AD (FBA with AD), Authentication Delegetion - Basic. В exchange для OWA стоит Basic Authentication

     

     

     

     

    29 февраля 2008 г. 7:55