none
Удалил почтовые ящики баз данных RRS feed

  • Вопрос

  • Добрый день,

    По запарке удалил почтовые ящики баз данных, те которые создаются в OU Microsoft Exchange System Objects

    Попробовал создать почтовые ящики с такими же именами по статье, командой 

    New-Mailbox -Arbitration -Name "SystemMailbox{e0e13cb6-bd1c-4a67-b483-3fe8db9d3631}" -UserPrincipalName "SystemMailbox{e0e13cb6-bd1c-4a67-b483-3fe8db9d3631}@domen.corp"


    Теперь почтовые базы отмонтировались, и не монтируются. Подскажите пожалуйстакак восстановить?При попытке подключения базы выдает ошибку :

    --------------------------------------------------------
    Microsoft Exchange Error
    --------------------------------------------------------
    Failed to mount database 'R01'.

    R01
    Failed
    Error:
    Active Directory operation failed on dc01.domen.corp. The object 'CN=SystemMailbox{97387715-59d8-471e-aa3a-54681bee03a3},CN=Microsoft Exchange System Objects,DC=domen,DC=corp' already exists.

    The object exists.




    --------------------------------------------------------
    OK
    --------------------------------------------------------

    • Изменено Stierlitz 21 ноября 2013 г. 15:40
    21 ноября 2013 г. 15:17

Ответы

  • Если бы всё было так просто.., размонтировались базы без проблем, а вот монтироваться не захотели, так и написав что не могут найти свой системный почтовый ящик.

    Решил удалением базы их конфигурации, и созданием новой базы с о старым файлом базы.

    • Помечено в качестве ответа Maksim BarakinEditor 22 ноября 2013 г. 9:34
    22 ноября 2013 г. 9:17

Все ответы

  • Добрый вечер!

    Удалите то что Вы создали.

    Выполните команду setup.com /PrepareAD c установочного дистрибутива.

    После завершения комманды Вы увидите вновь созданные системные учетные записи.

    Используя EMS выполните команды:

    Enable-Mailbox –Arbitration –Identity “FederatedEmail.1c1f4d9b-8179-3148-33bf-00a95fa1e042”
    Enable-Mailbox –Arbitration –Identity “SystemMailbox{2f05a927-8645-4003-adad-9b80758e88b}”
    Enable-Mailbox –Arbitration –Identity “SystemMailbox{e9dc1c39-67c3-4034-b678-e6c29d823eс8}”

    Важно - дистрибутив должен быть с тем же сервис паком что и существующий Exchange. 
    • Изменено Zaza Abramov 21 ноября 2013 г. 18:22
    • Предложено в качестве ответа Maksim BarakinEditor 21 ноября 2013 г. 20:01
    • Отменено предложение в качестве ответа Maksim BarakinEditor 22 ноября 2013 г. 5:30
    21 ноября 2013 г. 18:14
  • Если сами учетки не улаляли, то setup.com /preparead выполнять не нужно.

    Blog - Smtp25.ru

    21 ноября 2013 г. 20:01
    Отвечающий
  • Вы не поняли, удалены не системные почтовые ящики, а ящики или объекты(хз что это) которые создаются при создании почтовой базы в OU Microsoft Exchange System Objects. Вот их то и не может найти Exchange, поэтому не монтирует базы.


    21 ноября 2013 г. 20:15
  • Какой командой удаляли?
    21 ноября 2013 г. 20:47
  • Удалял мышкой, в консоли ADUC 
    22 ноября 2013 г. 5:12
  • Удалите эти ящики (через команду disable-mailbox), которые создавали командой New-Mailbox. И попробуйте смонтировать базу.

    Blog - Smtp25.ru


    • Изменено Maksim BarakinEditor 22 ноября 2013 г. 5:33
    • Предложено в качестве ответа Zaza Abramov 22 ноября 2013 г. 6:02
    22 ноября 2013 г. 5:31
    Отвечающий
  • Вы удалили учетные служебные учетные записи SystemMailbox*, которые создаются для каждой базы. Ящики у них есть, но они скрытые. Если вы удаляете эти учетные записи, то они автоматически создаются при монтировании базы.

    Blog - Smtp25.ru

    22 ноября 2013 г. 5:56
    Отвечающий
  • Если бы всё было так просто.., размонтировались базы без проблем, а вот монтироваться не захотели, так и написав что не могут найти свой системный почтовый ящик.

    Решил удалением базы их конфигурации, и созданием новой базы с о старым файлом базы.

    • Помечено в качестве ответа Maksim BarakinEditor 22 ноября 2013 г. 9:34
    22 ноября 2013 г. 9:17