none
Веб-приложение Microsoft SharePoint Foundation не запускается RRS feed

  • Вопрос

  • SharePoint 2010 и MSSQL 2008 R2 установлены на разных серверах.

    Была схожая проблема http://social.technet.microsoft.com/Forums/ru-RU/sharepointru/thread/d88db3b2-d062-45b7-9898-d103538d9954

    После устранения, перестали запускаться рабочие процессы. На одном из сайтов фермы, веб-части не отображали контент, показывая ошибку.(скрин к сожалению предоставить не могу), не работали личные сайты.

    Проведено восстановление фермы с бэкапа. Все работает, но есть одна проблема в самом шарепоинте -  Веб-приложение Microsoft SharePoint Foundation находится в состояние запуска, но не запускается. Что с этим делать, как запустить службу? 

    Состояние служб на данный момент.

Ответы

Все ответы

  • учетная запись фермы имеет права локального администратора?
  • да, имеет. 
  • Посмотрите Event Log на сервере, думаю там будет ответ.
    • Помечено в качестве ответа Roman Zhukov 7 июня 2012 г. 13:24
  • То что было в Event log

    Имя журнала:   Application

    Источник:      Microsoft-SharePoint Products-SharePoint Foundation

    Дата:          31.05.2012 3:24:29

    Код события:   5586

    Категория задачи: База данных

    Уровень:       Ошибка

    Ключевые слова:

    Описание:

    Неизвестное исключение SQL 207. См. ниже дополнительные сведения об ошибке из SQL Server.

    Invalid column name 'tp_Level'.

     

    Имя журнала:   Application

    Источник:      Microsoft-SharePoint Products-SharePoint Foundation

    Дата:          31.05.2012 3:32:14

    Код события:   5586

    Категория задачи: База данных

    Уровень:       Ошибка

    Ключевые слова:

    Описание:

    Неизвестное исключение SQL 9002. См. ниже дополнительные сведения об ошибке из SQL Server.

    The transaction log for database 'SharePoint_AdminContent_591e92e8-b578-412d-b575-74dde1cbe5a4' is full. To find out why space in the log cannot be reused, see the log_reuse_wait_desc column in sys.databases


    Не знаю как Вам, но я никакой связи с невозможностью запуска службы не обнаружила, решением стало выполнение команды:

    stsadm -o provisionservice -action start -servicetype spwebservice

    Служба запустилась - все работает. Указанные ошибки после непосредственного перезапуска службы устранены не были, причина ошибок найдена.

    • Предложено в качестве ответа Ex-man 8 июня 2012 г. 1:11