none
Помогите разобраться с версиями .Net Framework RRS feed

  • Вопрос

  •  

    Доброе время суток.

    Помогите, пожалуйста, разобраться с версиями .Net Framework.

    Какие версии нужно ставить для работы всех приложений написанных на .Net? Включая старые, написанные на Net Framework 1.1.

    Поиск выдает противоречивые результаты. Достаточно ли для работы всех приложений, написанных на Net установить Net Framework 3.5? Или нужно ставить еще 1.1 и 2.0 и 3.0?

    23 декабря 2007 г. 14:43

Ответы

  •  

    Обычно можно использовать последнюю версию платформы .NET Framework для запуска приложений, созданных в более ранних версиях .NET Framework.

     

    http://support.microsoft.com/kb/829019/

     

    Но совсем не обязательно. Некоторые приложения могут требовать конкретную версию .NET Framework.

    23 декабря 2007 г. 19:36
    Модератор

Все ответы

  •  

    Обычно можно использовать последнюю версию платформы .NET Framework для запуска приложений, созданных в более ранних версиях .NET Framework.

     

    http://support.microsoft.com/kb/829019/

     

    Но совсем не обязательно. Некоторые приложения могут требовать конкретную версию .NET Framework.

    23 декабря 2007 г. 19:36
    Модератор
  • Только что провел эксперимент.

    Была поставлена с нуля Windows XP Professional SP2, затем .Net Framework 3.5.

    Когда я зашел в "Установка и удаление программ", то я увидел там:

    .Net Framework 2.0 SP1

    .Net Framework 3.0 SP1

    .Net Framework 3.5

    Таким образом, недостает только 1.1.

    Спасибо!

    24 декабря 2007 г. 15:02