none
Странная проблема с eSATA RRS feed

  • Общие обсуждения

  • Уважаемые Господа!

    Есть такая странная проблема с подключением внешнего диска по eSATA :
    все нормально, если подключать сразу после старта системы.
    Если подключать через минуту (примерно) после появления рабочего стола, то система не реагирует, диск не виден.
    Когда диск подключен, его можно нормально отключить, после этого его можно еще раз нормально подключить, если сделать это сразу, а не ждать минуту.
    В том случае, если диск не подключается, можно зайти в диспетчер устройств, найти там " Стандартный контроллер SATA ACHI", отключить его, потом снова задействовать и все ОК, диск снова подключился!
    Когда диск подключен, он работает нормально сколь угодно долго.

    Материнская плата ASUS P9X79, контроллер eSATA - ASMedia 106, система Windows 10 Pro 64.
    Ставил драйвера с сайта ASUS для этого контроллера - ничего не меняется.
    Теперь откатился назад на стандартные драйвера, т.к. разницы никакой.
    Пробовал менять параметры питания для устройств PCI-express,- разницы нет.
    Еще пробовал проследить записи в системном журнале, но ничего подозрительного не нашел.
    Раньше, на Windows 7 этот контроллер вопросов не вызывал.

    • Изменен тип Anton Sashev Ivanov 1 июня 2016 г. 10:26 Тема переведена в разряд обсуждений по причиние отсутствия активности

Все ответы

  • Здравствуйте,

    Уточните в каком режиме работают диски в БИОС-е (BIOS)?

    Убедитесь в БИОС-е (BIOS), чтобы в AHCI mode.

    P.S. Detection of hot swap disconnection and connection of eSATA drives is performed by the AHCI functions of the disk controller.

    Best Regards, Andrei ...
    MCP

    Модератор
  •  

    Ставил драйвера с сайта ASUS для этого контроллера - ничего не меняется.

    Здравствуйте,

    Драйвер который Вы устанавливали был для Windows 10 или для более ранних ОС установленный в режимеме совместимости?

  • По всей видимости, этот контроллер работает в режиме ACHI.
    В биосе нет явной настройки этого режима. Есть только enable/disable и hotplug - enable/disable.

    Внутренние диски и контроллер(чипсетный) работают в режиме ACHI. На некоторых там стоит режим HOT PLUG, так как подключены через внешние корзины. Тут все работает как надо, без вопросов, причем без ручной установки драйверов производителя. При попытке поставить драйвер чипсета с сайта ASUS выходит ошибка, что мол в системе уже стоят дрова свежее.

    Вопрос только к контроллеру ASMedia 1061, который имеет два выхода eSATA на задней панели.

  • Драйвер для контроллера ASMedia 1061 был именно для Windows 10 64bit.

    После установки этого драйвера вместо двух устройств
    "Стандартный контроллер SATA ACHI"
    появляется одно устройство
    "Контроллер ASMedia 106x"
    что в принципе логично, так как у данного контроллера два порта на задней панели.

    Но дело в том, что это ничего не меняет. Странное поведение одинаково на обоих дровах.
    Только что обновил прошивку BIOS до самой последней, правда она датирована 2014г...
    Не помогло.

    К сожалению, у меня нет пока возможности попробовать другие внешние устройства eSATA. У меня только два одинаковых корпуса для HDD - AgeSTAR с портами eSATA и USB 2,0. На одном из устройств порт eSATA не работает изначально(брак). На втором этот порт работал нормально с Win7.
    Честно говоря эти AgeSTAR выглядят не очень... Может проблема в этом AgeSTAR-е?
    У кого-нибудь есть опыт работы с ними под Win10?

  • Посмотрите рекомендации насчет АgeStar здесь.