none
Owa error Exchange 2013 CU13 SDServerErr; System.Xml.XmlException RRS feed

  • Вопрос

  • Добрый день! Возникла проблема со входом через owa, при этом ошибки в журалах не фиксируются. Имеется конфигурация 1CAS + 2MB. Изменения в конфигурации не производились, и восстановление CAS на неделю назад результата не принесло.

    :-(
    something went wrong
    An unexpected error occurred and your request couldn't be handled.
    X-ClientId: WZZZ - S0Q0 - AROT - RYQRG
    X-OWA-Error: SDServerErr;System.Xml.XmlException
    X-OWA-Version: 15.0.1210.3
    X-FEServer: EX01
    X-BEServer: ex04.corp.com
    Date: 23.07.2016 22:06:16

    Пробовал пересоздавать виртуальных каталог и менять биндинги но ни чего не помогает.

    Также отследил http запрос ошибку 500 выдает на странице https://mail.corp.com/owa/sessiondata.ashx?appcacheclient=1

    Произошла непредвиденная ошибка, и запрос обработать не удалось.

    24 июля 2016 г. 8:15

Ответы

Все ответы

  • а сертификат у вас что из себя представляет? Не пробовали его пересоздать и проверить, чтобы в привязках был подключен именно он?

    Киньте скрин привязок иис

    24 июля 2016 г. 8:53
  • Сертификат COMODO SSL Wildcard

    https://social.technet.microsoft.com/Forums/getfile/903027

    24 июля 2016 г. 9:11
  • что в логах иис?
    24 июля 2016 г. 10:32
  • CAS role IIS logs -

    2016-07-24 07:26:23 10.0.1.1 POST /owa/plt1.ashx cId=3011444f-7b76-4af8-ad09-4d4110f3f474&msg=SDServerErr&tg=&MDB=3111d1c6-ec5f-4037-bea8-04bd65047383&sdCoId=20114d4f-7176-4af8-ad33-4d4110f3f444_1661345182536&sds=500&fe=EX01&be=EX04&cbe=ex04.corp.com&cver=15.0.1210.3&sdver=15.0.1210.3&rand=1469345183617&rpo=0&off=0&pal=0&rfe=3&te=0&PLT=fS,0,dLS,0,dLE,0,cS,0,cE,0,reqS,0,resS,46,resE,47,domL,76,pE,1238,now,1239&lbv=15.0.1044.29&icv=15.0.1044.29&iacr=15.0.1044.29&lcver=15.0.1044.29&accu=ru-ru&acth=base&acdc=0&lhn=mail.corp.com&chn=mail.corp.com&acs=1&mf=nf&CorrelationID=<empty>;&ClientId=WXVYJPSZAAHXYTZFF0ZQ&Res=preboot.js,tim=st,113,fS,0,dLS,0,dLE,0,cS,0,cE,0,reqS,0,resS,0,resE,76,pE,335&Res=boot.0.mouse.js,tim=st,114,fS,0,dLS,0,dLE,0,cS,0,cE,0,reqS,0,resS,0,resE,85,pE,583&Res=boot.1.mouse.js,tim=st,115,fS,0,dLS,0,dLE,0,cS,0,cE,0,reqS,0,resS,0,resE,98,pE,1012&Res=sessiondata.ashx,tim=st,151,fS,0,dLS,0,dLE,0,cS,0,cE,0,reqS,0,resS,85,resE,86&Res=boot.mouse.strings.localized.min.js,tim=st,1009,fS,0,dLS,0,dLE,0,cS,0,cE,0,reqS,0,resS,0,resE,38,pE,1194&Res=globalize.culture.ru-ru.js,tim=st,1009,fS,0,dLS,0,dLE,0,cS,0,cE,0,reqS,0,resS,0,resE,40,pE,1228&Res=sprite1.mouse.css,tim=st,1010,fS,0,dLS,0,dLE,0,cS,0,cE,0,reqS,0,resS,0,resE,41&Res=boot.mouse.css,tim=st,1011,fS,0,dLS,0,dLE,0,cS,0,cE,0,reqS,0,resS,0,resE,43&refUrl=https%3A%2F%2Fmail.corp.com%2Fowa%2F%3Fver%3D15.0.1210.3%26cver%3D15.0.1044.29%26cf%3D0%26vC%3D0&Err=System.Xml.XmlException&cafeReqId=fb7c4730-9f1d-47d6-8382-643491f7e86c; 443 CORP\aduser 10.1.1.1 Chrome/5.0+(Windows+NT+6.3;+Win64;+x64;+rv:47.0)+Gecko/1+Chrome/47.0 https://mail.corp.com/owa/?ver=15.0.1210.3&cver=15.0.1044.29&cf=0&vC=0 200 0 0 78
    2016-07-24 07:26:23 10.0.1.1 GET /owa/ ver=15.0.1210.3&cver=15.0.1044.29&cf=0&vC=0&bO=1&CorrelationID=<empty>;&ClientId=WXVYJPSZAAHXYTZFF0ZQ&cafeReqId=d3576b56-d501-46a9-8245-761f4c58aca6; 443 CORP\aduser 10.1.1.1 Chrome/5.0+(Windows+NT+6.3;+Win64;+x64;+rv:47.0)+Gecko/1+Chrome/47.0 https://mail.corp.com/owa/?ver=15.0.1210.3&cver=15.0.1044.29&cf=0&vC=0 200 0 0 31
    2016-07-24 07:26:23 10.0.1.1 POST /owa/sessiondata.ashx appcacheclient=0&bO=1&CorrelationID=3011444f-7b76-4af8-ad09-4d4110f3f474_1469345183801;&ClientId=WXVYJPSZAAHXYTZFF0ZQ&cafeReqId=6e1771f2-71d1-415f-9118-1a111cbf6ce9; 443 CORP\aduser 10.1.1.1 Chrome/5.0+(Windows+NT+6.3;+Win64;+x64;+rv:47.0)+Gecko/1+Chrome/47.0 https://mail.corp.com/owa/?ver=15.0.1210.3&cver=15.0.1044.29&cf=0&vC=0&bO=1 500 0 0 140
    2016-07-24 07:26:23 10.0.1.1 POST /ews/exchange.asmx &CorrelationID=<empty>;&ClientId=GNGYUWSE0SRRKIXYHEW&cafeReqId=832e2ebb-8aac-439a-91a8-d967dcc16cd0; 443 - 10.1.1.3 JWebServices+for+Exchange+2.0,+www.independentsoft.com - 401 0 0 15
    2016-07-24 07:26:24 10.0.1.1 POST /owa/plt1.ashx cId=3011444f-7b76-4af8-ad09-4d4110f3f474&msg=SDServerErr&tg=&MDB=3111d1c6-ec5f-4037-bea8-04bd65047383&sdCoId=3011444f-7b76-4af8-ad09-4d4110f3f474_1469345183801&sds=500&fe=EX01&be=EX04&cbe=ex04.corp.com&cver=15.0.1210.3&sdver=15.0.1210.3&rand=1469345184625&rpo=0&off=0&pal=0&rfe=1&te=0&PLT=uES,44,uEE,46,fS,6,dLS,0,dLE,0,cS,0,cE,0,reqS,0,resS,31,resE,31,domL,38,pE,928,now,928&lbv=15.0.1044.29&icv=15.0.1044.29&iacr=15.0.1044.29&lcver=15.0.1210.3&accu=ru-ru&acth=base&acdc=0&lhn=mail.corp.com&chn=mail.corp.com&acs=1&mf=nf&CorrelationID=<empty>;&ClientId=WXVYJPSZAAHXYTZFF0ZQ&Res=preboot.js,tim=st,65,fS,0,dLS,0,dLE,0,cS,0,cE,0,reqS,0,resS,0,resE,73,pE,238&Res=boot.0.mouse.js,tim=st,66,fS,0,dLS,0,dLE,0,cS,0,cE,0,reqS,0,resS,0,resE,82,pE,500&Res=boot.1.mouse.js,tim=st,67,fS,0,dLS,0,dLE,0,cS,0,cE,0,reqS,0,resS,0,resE,94,pE,746&Res=sessiondata.ashx,tim=st,109,fS,0,dLS,0,dLE,0,cS,0,cE,0,reqS,0,resS,85,resE,86&Res=boot.mouse.strings.localized.min.js,tim=st,754,fS,0,dLS,0,dLE,0,cS,0,cE,0,reqS,0,resS,0,resE,27,pE,874&Res=globalize.culture.ru-ru.js,tim=st,755,fS,0,dLS,0,dLE,0,cS,0,cE,0,reqS,0,resS,0,resE,28,pE,917&Res=sprite1.mouse.css,tim=st,756,fS,0,dLS,0,dLE,0,cS,0,cE,0,reqS,0,resS,0,resE,29&Res=boot.mouse.css,tim=st,758,fS,0,dLS,0,dLE,0,cS,0,cE,0,reqS,0,resS,0,resE,30&refUrl=https%3A%2F%2Fmail.corp.com%2Fowa%2F%3Fver%3D15.0.1210.3%26cver%3D15.0.1044.29%26cf%3D0%26vC%3D0%26bO%3D1&Err=System.Xml.XmlException&cafeReqId=a4f932e6-09c1-47c7-9b14-b70b7c64fe3a; 443 CORP\aduser 10.1.1.1 Chrome/5.0+(Windows+NT+6.3;+Win64;+x64;+rv:47.0)+Gecko/1+Chrome/47.0 https://mail.corp.com/owa/?ver=15.0.1210.3&cver=15.0.1044.29&cf=0&vC=0&bO=1 200 0 0 78
    2016-07-24 07:26:24 10.0.1.1 GET /owa/auth/errorfe.aspx owaError=SDServerErr;System.Xml.XmlException&owaVer=15.0.1210.3&be=ex04.corp.com&msg=ErrorUnexpectedFailure&CorrelationID=<empty>;&ClientId=WXVYJPSZAAHXYTZFF0ZQ&cafeReqId=f0e75757-baea-4cf8-a177-a77b8e5ccc5f; 443 - 10.1.1.1 Chrome/5.0+(Windows+NT+6.3;+Win64;+x64;+rv:47.0)+Gecko/1+Chrome/47.0 https://mail.corp.com/owa/?ver=15.0.1210.3&cver=15.0.1044.29&cf=0&vC=0&bO=1 200 0 0 0

    MailBox role IIS logs - 2016-07-24 11:05:02 10.0.1.2 POST /powershell clientApplication=ActiveMonitor;PSVersion=4.0 80 corp\sm_341833febe8d55d89 10.0.1.2 Microsoft+WinRM+Client - 200 0 0 0
    2016-07-24 11:05:02 10.0.1.2 POST /powershell clientApplication=ActiveMonitor;PSVersion=4.0 80 corp\sm_341833febe8d55d89 10.0.1.2 Microsoft+WinRM+Client - 500 0 64 312
    2016-07-24 11:05:02 10.0.1.2 POST /powershell clientApplication=ActiveMonitor;PSVersion=4.0 80 corp\sm_341833febe8d55d89 10.0.1.2 Microsoft+WinRM+Client - 200 0 0 0
    24 июля 2016 г. 11:19
  • С чем может быть связано? Даже в какую копать сторону не пойму
    24 июля 2016 г. 14:28
  • копать можно в сторону иис, сертификата. Скажите, а остальные компоненты у вас в порядке? почта бегает, аутлук подключается?

    Давайте начнем с анализа состояния:

    Get-ServerHealth server1 | ?{$_.HealthSetName -eq "OWA"}

    Подробнее смотрите тут - https://technet.microsoft.com/en-us/library/ms.exch.scom.owa%28v=exchg.150%29.aspx?f=255&MSPPError=-2147217396

    24 июля 2016 г. 16:49
  • Да остальное все работает, ecp тоже работает. Пробовал добавить дополнительный CAS сервер на нем таже самая ошибка. Что может быть с сертификатом? он действительный и привязан к сайту.


    [PS] C:\ps>Get-ServerHealth ex01 | ?{$_.HealthSetName -eq "OWA"}
    Выполняется создание нового сеанса для неявного удаленного взаимодействия команды "Get-ServerHealth"...

    Server          State           Name                 TargetResource       HealthSetName   AlertValue ServerComp
                                                                                                         onent
    ------          -----           ----                 --------------       -------------   ---------- ----------
    ex01     NotApplicable   MaintenanceFailur...                      OWA             Healthy    None
    ex01     NotApplicable   OwaCtpMonitor                             OWA             Healthy    None
    ex01     NotApplicable   MaintenanceTimeou...                      OWA             Healthy    None



    ----- Internal URL Health Checks:
    Testing https://mail.corp.com/owa/healthcheck.htm OK
    Testing https://mail.corp.com/ecp/healthcheck.htm OK
    Testing https://mail.corp.com/OAB/healthcheck.htm OK
    Testing https://mail.corp.com/rpc/healthcheck.htm OK
    Testing https://mail.corp.com/EWS/Exchange.asmx/healthcheck.htm OK
    Testing https://mail.corp.com/mapi/healthcheck.htm OK
    Testing https://mail.corp.com/Microsoft-Server-ActiveSync/healthcheck.htm OK
    Testing https://mail.corp.com/autodiscover/autodiscover.xml/healthcheck.htm OK

    ----- External URL Health Checks:
    Testing https://mail.corp.com/owa/healthcheck.htm OK
    Testing https://mail.corp.com/ecp/healthcheck.htm OK
    Testing https://mail.corp.com/OAB/healthcheck.htm OK
    Testing https://mail.corp.com/rpc/healthcheck.htm OK
    Testing https://mail.corp.com/ews/exchange.asmx/healthcheck.htm OK
    Testing https://mail.corp.com/mapi/healthcheck.htm OK
    Testing https://mail.corp.com/Microsoft-Server-ActiveSync/healthcheck.htm OK

    ----- Per-Server Health Checks:

    Server: EX01.corp.com
    Testing https://EX01.corp.com/owa/healthcheck.htm OK
    Testing https://EX01.corp.com/ecp/healthcheck.htm OK
    Testing https://EX01.corp.com/oab/healthcheck.htm OK
    Testing https://EX01.corp.com/rpc/healthcheck.htm OK
    Testing https://EX01.corp.com/ews/healthcheck.htm OK
    Testing https://EX01.corp.com/mapi/healthcheck.htm OK
    Testing https://EX01.corp.com/Microsoft-Server-ActiveSync/healthcheck.htm OK
    Testing https://EX01.corp.com/Autodiscover/healthcheck.htm OK





    24 июля 2016 г. 16:59
  • странно. как-то мало у вас мониторов.

    давайте логи иис рыть. в прошлый раз они у вас были какие-то неинформативные.

    Во-первых, зайдите в ову, запомните время входа. Зайдите в ивент вьювер и посмотрите какие события сгенерировались, не обязательно ошибки. Посмотрите что записалось в логи иис в это время.

    24 июля 2016 г. 17:24
  • которые ошибки я писал единственное что есть. и в браузере она именно так и обозначается как ошибка 500 в логах IIS C:\inetpub\logs\LogFiles\W3SVC1

    2016-07-24 07:26:23 10.0.1.1 POST /owa/sessiondata.ashx appcacheclient=0&bO=1&CorrelationID=3011444f-7b76-4af8-ad09-4d4110f3f474_1469345183801;&ClientId=WXVYJPSZAAHXYTZFF0ZQ&cafeReqId=6e1771f2-71d1-415f-9118-1a111cbf6ce9; 443 CORP\aduser 10.1.1.1 Chrome/5.0+(Windows+NT+6.3;+Win64;+x64;+rv:47.0)+Gecko/1+Chrome/47.0 https://mail.corp.com/owa/?ver=15.0.1210.3&cver=15.0.1044.29&cf=0&vC=0&bO=1 500 0 0 140

    В Event Viewer :

    Срок действия сертификата STARTTLS скоро истекает: субъект: EX01.corp.com, отпечаток: 1687C1DDE0AE53564A57A513518C81FD6A37B557, осталось часов: 1834. Чтобы создать новый сертификат, запустите командлет New-ExchangeCertificate.

    Срок действия сертификата внутреннего транспорта истекает. Отпечаток:1687C1DDE0AE53564A57A513518C81FD6A37B557, осталось часов: 1834

    [PS] C:\ps>get-exchangecertificate -server ex01

    Thumbprint                                Services   Subject
    ----------                                --------   -------
    37F8D2E891BF81670826DED0796CCCD73DDE2744  I..WS..    CN=mail.corp.com
    1687C1DDE0AE53564A57A513518C81FD6A37B557  ...W...    CN=*.corp.com, OU=COMODO SSL Wildcard,
    3981A24DA335060747409A167729A4C3F362BC14  .P..S..    CN=Federation
    96EB547FF820C17D85FCD34D7B40CA505D5A9F57  .......    CN=WMSvc-DBOARD-EX01
    5BF9ABE85DADD070B1BAF505E08E799BF538DB7F  ....S..    CN=*.corp.com, OU=COMODO SSL Wildcard,


    [PS] C:\ps>Get-ServerHealth ex01 | ?{$_.HealthSetName -like "*OWA*"}

    Server          State           Name                 TargetResource       HealthSetName   AlertValue ServerComp
                                                                                                         onent
    ------          -----           ----                 --------------       -------------   ---------- ----------
    ex01     NotApplicable   MaintenanceFailur...                      OWA             Healthy    None
    ex01     Online          OWAProxyTestMonitor  MSExchangeOWAAppPool OWA.Proxy       Healthy    OwaProxy
    ex01     Online          OWAProxyTestMonitor  MSExchangeOWACale... OWA.Proxy       Healthy    OwaProxy
    ex01     NotApplicable   OwaCtpMonitor                             OWA             Healthy    None
    ex01     NotApplicable   MaintenanceTimeou...                      OWA             Healthy    None



    [PS] C:\ps>Get-ServerHealth ex02 | ?{$_.HealthSetName -like "*OWA*"}

    Server          State           Name                 TargetResource       HealthSetName   AlertValue ServerCom
                                                                                                         onent
    ------          -----           ----                 --------------       -------------   ---------- ---------
    ex02     NotApplicable   MaintenanceFailur...                      OWA             Healthy    None
    ex02     NotApplicable   OwaIMInitializati... OWA.Protocol.Dep     OWA.Protocol... Healthy    None
    ex02     NotApplicable   OwaSelfTestMonitor                        OWA.Protocol    Healthy    None
    ex02     NotApplicable   OwaDeepTestMonitor                        OWA.Protocol    Healthy    None
    ex02     NotApplicable   OwaTooManyWebAppS... OWA                  OWA             Healthy    None
    ex02     NotApplicable   PrivateWorkingSet... msexchangeowaapppool OWA.Protocol    Healthy    None
    ex02     NotApplicable   PrivateWorkingSet... msexchangeowaapppool OWA.Protocol    Healthy    None
    ex02     NotApplicable   ProcessProcessorT... msexchangeowaapppool OWA.Protocol    Healthy    None
    ex02     NotApplicable   ProcessProcessorT... msexchangeowaapppool OWA.Protocol    Healthy    None
    ex02     NotApplicable   MaintenanceTimeou...                      OWA             Healthy    None
    ex02     NotApplicable   CreateItem_Create...                      OWA             Healthy    None
    ex02     NotApplicable   CreateItem_Create...                      OWA             Healthy    None
    ex02     NotApplicable   CreateItem_Create...                      OWA             Healthy    None
    ex02     NotApplicable   CreateItem_Create...                      OWA             Healthy    None
    ex02     NotApplicable   CreateItem_MailCo...                      OWA             Healthy    None
    ex02     NotApplicable   FindConversation_...                      OWA             Healthy    None
    ex02     NotApplicable   FindConversation_...                      OWA             Healthy    None
    ex02     NotApplicable   FindConversation_...                      OWA             Healthy    None
    ex02     NotApplicable   FindConversation_...                      OWA             Healthy    None
    ex02     NotApplicable   FindItem_BrowseAl...                      OWA             Healthy    None
    ex02     NotApplicable   FindItem_BrowseNo...                      OWA             Healthy    None
    ex02     NotApplicable   FindItem_BrowseNo...                      OWA             Healthy    None
    ex02     NotApplicable   FindItem_BrowseUn...                      OWA             Healthy    None
    ex02     NotApplicable   GetExtensibilityC...                      OWA.WebServices Healthy    None
    ex02     NotApplicable   GetFileAttachment...                      OWA.Attachments Healthy    None
    ex02     NotApplicable   GetWacAttachmentI...                      OWA.Attachments Healthy    None
    ex02     NotApplicable   GetWacIFrameUrl__...                      OWA.Attachments Healthy    None
    ex02     NotApplicable   PerfTraceCTQ_Docu...                      OWA.Attachments Healthy    None
    ex02     NotApplicable   PerfTraceCTQ_Edit...                      OWA.Attachments Healthy    None
    ex02     NotApplicable   PerfTraceCTQ_GetW...                      OWA.Attachments Healthy    None
    ex02     NotApplicable   ProcessSuiteStora...                      OWA.SuiteSer... Healthy    None
    ex02     NotApplicable   SetNotificationSe...                      OWA.SuiteSer... Healthy    None
    ex02     NotApplicable   SynchronizeWacAtt...                      OWA.Attachments Healthy    None
    ex02     NotApplicable   UpdateItem_Update...                      OWA             Healthy    None
    ex02     NotApplicable   UpdateItem_Update...                      OWA             Healthy    None
    ex02     NotApplicable   WACAutoSave__EXMo...                      OWA.Attachments Healthy    None
    ex02     NotApplicable   WACBadRequest__EX...                      OWA.Attachments Healthy    None
    ex02     NotApplicable   WACCacheEntryExpi...                      OWA.Attachments Healthy    None
    ex02     NotApplicable   WACCheckFile__EXM...                      OWA.Attachments Healthy    None
    ex02     NotApplicable   WACCleanCobaltSto...                      OWA.Attachments Healthy    None
    ex02     NotApplicable   WACCobalt__EXMonitor                      OWA.Attachments Healthy    None
    ex02     NotApplicable   WACGetFile__EXMon...                      OWA.Attachments Healthy    None
    ex02     NotApplicable   WACLock__EXMonitor                        OWA.Attachments Healthy    None
    ex02     NotApplicable   WACMdbCacheUpdate...                      OWA.Attachments Healthy    None
    ex02     NotApplicable   WACPutFile__EXMon...                      OWA.Attachments Healthy    None
    ex02     NotApplicable   WACRefreshLock__E...                      OWA.Attachments Healthy    None
    ex02     NotApplicable   WACUnlock__EXMonitor                      OWA.Attachments Healthy    None
    ex02     NotApplicable   CrashEvent.msexch... msexchangeowaapppool OWA.Protocol    Healthy    None
    ex02     NotApplicable   CreateAttachment_...                      OWA.Attachments Healthy    None
    ex02     NotApplicable   CreateAttachmentF...                      OWA.Attachments Healthy    None
    ex02     NotApplicable   CreateReferenceAt...                      OWA.Attachments Healthy    None
    ex02     NotApplicable   CreateReferenceAt...                      OWA.Attachments Healthy    None
    ex02     NotApplicable   GetAttachmentData...                      OWA.Attachments Healthy    None
    ex02     NotApplicable   GetAttachmentData...                      OWA.Attachments Healthy    None
    ex02     NotApplicable   GetAttachmentData...                      OWA.Attachments Healthy    None


    24 июля 2016 г. 17:48
  • киньте вывод команды:

    Get-OwaVirtualDirectory | fl
    Лучше прикрепите файлом, там много инфы.

    24 июля 2016 г. 19:55
  • https://yadi.sk/d/8U5q_NmPtb2vx
    25 июля 2016 г. 2:59
  • попробуйте задать только следующие типы аутентификации:

    BasicAuthentication

    FormsAuthentication

    у Вас установлены WindowsAuthentication, Ntlm.


    25 июля 2016 г. 4:51
  • Да я пробовал это уже - не работает. X-OWA-Error: SDServerErr;System.Xml.XmlException

    даже возможно не в самой OWE ошибка возникает. Я и хотел узнать из за чего это зависит.

    25 июля 2016 г. 5:41
  • пока что идеи кончились)

    версии exchange на всех серверах одинаковые?

    25 июля 2016 г. 6:03
  • Обновил все сервера после возникновения ошибки, но не помогло Exchange 2013 Cu13.
    25 июля 2016 г. 6:53
  • можно попробовать глянуть что с компонентами на серверах mbx:

    Get-ServerHealth exch02 | ?{$_.AlertValue -eq "Unhealthy"}

    25 июля 2016 г. 7:02
  • Еще одно замечание, перенес виртуалки в изолированную среду на отдельный hyper-v хост, и по какойто причине там owa работает..

    AD,EX01,EX02


    25 июля 2016 г. 7:02
  • все виртуалки?

    значит копайте в сторону сетки на виртуалках. Начните с пересоздания виртуального коммутатора

    25 июля 2016 г. 7:07
  • Пробовал, но как-то без успешно. А как это может быть связано? Единственно на AD не пробовал пересоздавать.
    25 июля 2016 г. 7:13
  • нужно понять чем вообще ваши конфигурации отличаются
    25 июля 2016 г. 8:51
  • удалось решить проблему?
    28 июля 2016 г. 6:04
  • Нет не удалось, сравнение тоже ничего не дало. Возможно это из за внешних сервисов ? Edge или недавно установили Office Online 2016 и WebApps server тоже у нас есть..
    28 июля 2016 г. 18:47
  • Но вы ведь говорите, что на изолированной среде у вас ова работает нормально? Я правильно понимаю? Если да, тогда опишите что из себя представляет изолированная среда.
    28 июля 2016 г. 19:00
  • В IIS на BackEnd сертификат привязан?

    Если делали восстановление, то проверьте InternalNLBBypassUrl


    Сазонов Илья

    https://isazonov.wordpress.com/

    29 июля 2016 г. 3:56
    Модератор
  • Вроде не задано, откатывал с помощью DPM. Изолированная среда - это копия виртуальных машин AD,CAS,MB. Вроде InternalNLBBypassUrl не задано.

    [PS] C:\ps>Get-WebServicesVirtualDirectory | select *


    RunspaceId                      : 23a4eb2d-a4fc-464a-aee2-9c7bc7f1bbb7
    CertificateAuthentication       :
    InternalNLBBypassUrl            :
    GzipLevel                       : Low
    MRSProxyEnabled                 : False
    Name                            : EWS (Default Web Site)
    InternalAuthenticationMethods   : {Ntlm, WindowsIntegrated, WSSecurity, OAuth}
    ExternalAuthenticationMethods   : {Ntlm, WindowsIntegrated, WSSecurity, OAuth}
    LiveIdNegotiateAuthentication   :
    WSSecurityAuthentication        : True
    LiveIdBasicAuthentication       : False
    BasicAuthentication             : False
    DigestAuthentication            : False
    WindowsAuthentication           : True
    OAuthAuthentication             : True
    AdfsAuthentication              : False
    MetabasePath                    : IIS://EX01.corp.com/W3SVC/1/ROOT/EWS
    Path                            : C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy\EWS
    ExtendedProtectionTokenChecking : None
    ExtendedProtectionFlags         : {}
    ExtendedProtectionSPNList       : {}
    AdminDisplayVersion             : Version 15.0 (Build 1210.3)
    Server                          : EX01
    InternalUrl                     : https://mail.corp.com/EWS/Exchange.asmx
    ExternalUrl                     : https://mail.corp.com/ews/exchange.asmx
    AdminDisplayName                :
    ExchangeVersion                 : 0.10 (14.0.100.0)
    DistinguishedName               : CN=EWS (Default Web Site),CN=HTTP,CN=Protocols,CN=EX01,CN=Servers,CN=Exchange
                                      Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=Dashboard Systems,
                                      CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=corp,DC=com
    Identity                        : EX01\EWS (Default Web Site)
    Guid                            : b570167c-e977-4bbd-a51e-a7bfd41acde9
    ObjectCategory                  : corp.com/Configuration/Schema/ms-Exch-Web-Services-Virtual-Directory
    ObjectClass                     : {top, msExchVirtualDirectory, msExchWebServicesVirtualDirectory}
    WhenChanged                     : 27.07.2015 11:03:10
    WhenCreated                     : 04.02.2015 14:06:17
    WhenChangedUTC                  : 27.07.2015 8:03:10
    WhenCreatedUTC                  : 04.02.2015 11:06:17
    OrganizationId                  :
    Id                              : EX01\EWS (Default Web Site)
    OriginatingServer               : AD01.corp.com
    IsValid                         : True
    ObjectState                     : Changed

    RunspaceId                      : 23a4eb2d-a4fc-464a-aee2-9c7bc7f1bbb7
    CertificateAuthentication       :
    InternalNLBBypassUrl            :
    GzipLevel                       : Low
    MRSProxyEnabled                 : False
    Name                            : EWS (Default Web Site)
    InternalAuthenticationMethods   : {Ntlm, WindowsIntegrated, WSSecurity, OAuth}
    ExternalAuthenticationMethods   : {Ntlm, WindowsIntegrated, WSSecurity, OAuth}
    LiveIdNegotiateAuthentication   :
    WSSecurityAuthentication        : True
    LiveIdBasicAuthentication       : False
    BasicAuthentication             : False
    DigestAuthentication            : False
    WindowsAuthentication           : True
    OAuthAuthentication             : True
    AdfsAuthentication              : False
    MetabasePath                    : IIS://EX07.corp.com/W3SVC/1/ROOT/EWS
    Path                            : C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy\EWS
    ExtendedProtectionTokenChecking : None
    ExtendedProtectionFlags         : {}
    ExtendedProtectionSPNList       : {}
    AdminDisplayVersion             : Version 15.0 (Build 1210.3)
    Server                          : EX07
    InternalUrl                     : https://mail.corp.com/EWS/Exchange.asmx
    ExternalUrl                     : https://mail.corp.com/EWS/Exchange.asmx
    AdminDisplayName                :
    ExchangeVersion                 : 0.10 (14.0.100.0)
    DistinguishedName               : CN=EWS (Default Web Site),CN=HTTP,CN=Protocols,CN=EX07,CN=Servers,CN=Exchange
                                      Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=Dashboard Systems,
                                      CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=corp,DC=com
    Identity                        : EX07\EWS (Default Web Site)
    Guid                            : 8aee4d7a-7c64-408e-9731-a8c9eee30fd0
    ObjectCategory                  : corp.com/Configuration/Schema/ms-Exch-Web-Services-Virtual-Directory
    ObjectClass                     : {top, msExchVirtualDirectory, msExchWebServicesVirtualDirectory}
    WhenChanged                     : 25.07.2016 12:16:18
    WhenCreated                     : 25.07.2016 12:10:13
    WhenChangedUTC                  : 25.07.2016 9:16:18
    WhenCreatedUTC                  : 25.07.2016 9:10:13
    OrganizationId                  :
    Id                              : EX07\EWS (Default Web Site)
    OriginatingServer               : AD01.corp.com
    IsValid                         : True
    ObjectState                     : Changed

    29 июля 2016 г. 8:03
  • На IIS backend сертификаты заданы, проверил. А вот еще по поводу сертификатов для служб Exchange, есть полный мануал? Что бы перепроверить? Может их все перегенерировать выдать от CA?
    29 июля 2016 г. 8:17
  • да там все достаточно просто - создаете запрос через ecp (внимательно проверяете все имена), отправляете на ЦС, получаете сертификат, также через еср его импортируете. Дальше распространяете по остальным серверам. 

    Разумеется зеленая строчка в браузере превратится в красную, а у клиентов outlook Будут проблемы с подключением, которые решатся распространением сертификата через gpo

    думаю вам могут помочь статьи:

    http://blog.bissquit.com/mail-servers/exchange-server/sertifikat-exchange-2013/

    http://blog.bissquit.com/mail-servers/exchange-server/lokalnyj-cs-zapros-sertifikata-exchange-2013/


    29 июля 2016 г. 8:21
  • [PS] C:\ps>Get-WebServicesVirtualDirectory -Server ex04 -ShowMailboxVirtualDirectories | Select Name, *URL* | FT
    -AutoSize

    Name                    InternalNLBBypassUrl                                         InternalUrl ExternalUrl
    ----                    --------------------                                         ----------- -----------
    EWS (Exchange Back End) https://ex04.corp.com:444/ews/exchange.asmx


    [PS] C:\ps>Get-WebServicesVirtualDirectory -Server ex02 -ShowMailboxVirtualDirectories | Select Name, *URL* | FT
    -AutoSize

    Name                    InternalNLBBypassUrl                                         InternalUrl ExternalUrl
    ----                    --------------------                                         ----------- -----------
    EWS (Exchange Back End) https://ex02.corp.com:444/ews/exchange.asmx
    29 июля 2016 г. 8:33
  • CU у вас какой? .Net 4.6.1 стоит?

    Сазонов Илья

    https://isazonov.wordpress.com/

    29 июля 2016 г. 8:46
    Модератор
  • cu13 .Net 4.6.1 но проявлялось еще на cu8 4.5 после обновления ситуация не изменилась.
    29 июля 2016 г. 10:26
  • Как ни странно но это копия моего топика, на этот ответ я уже давал ответ. Мне кажется Owa даже до этих атрибутов не доходит. Ошибка появляется во время авторизации, и показывает, что сервер не мог распарсить XML запрос клиента.
    29 июля 2016 г. 12:57
  • Вы разных компьютеров проверяли? Разными браузерами?

    Сазонов Илья

    https://isazonov.wordpress.com/

    29 июля 2016 г. 13:02
    Модератор
  • Конечно.
    29 июля 2016 г. 13:59
  • В IIS сертификат привязан на BackEnd на всех серверах?

    Сазонов Илья

    https://isazonov.wordpress.com/

    29 июля 2016 г. 14:07
    Модератор
  • Да, конечно!
    29 июля 2016 г. 14:19
  • Попробуйте снести  .Net 4.6.1

    Сазонов Илья

    https://isazonov.wordpress.com/

    29 июля 2016 г. 14:40
    Модератор
  • Спасибо, но я уже говорил, что с 4.5 ошибка и возникла, и cu13 полностью поддерживает.Net 4.6.1
    30 июля 2016 г. 8:45
  • Еще одно замечание, перенес виртуалки в изолированную среду на отдельный hyper-v хост, и по какойто причине там owa работает..

    AD,EX01,EX02


    Коллега, ещё раз: я предлагаю вернуться к этому шагу и понять почему на виртуальной среде все работает.

    Я бы начал с пересоздания виртуального коммутатора на рабочем сервере, а также удалил бы сетевой адаптер на сервере и добавил бы новый (придется заново сконфигурировать сеть, поскольку фактически адаптер изменится).

    30 июля 2016 г. 11:44
  • Я бы начал с пересоздания виртуального коммутатора на рабочем сервере

    Если не секрет, какие цели преследуются подобными действиями после такого совета? Какую технологическую подоплёку они под собой несут?
    30 июля 2016 г. 20:47
    Модератор

  • Если не секрет, какие цели преследуются подобными действиями после такого совета? Какую технологическую подоплёку они под собой несут?

    добрый день.

    глючила сеть на виртуалках разок, помогло пересоздание коммутатора.

    ещё на одном сервере по необъяснимым причинам просто отваливалась сетка (правда редко - не чаще раза в месяц) - перезагрузка виртуалки (она была единственная на сервере) эффекта не давала, приходилось пересоздавать коммутатор, но в этом случае был скорее не сервер, а обычный домашний ПК с дешевой внешней сетевухой, которая и глючила. Дрова все стояли и на материнку и на адаптер, тем не менее проблема решилась заменой сетевухи.

    В данном конкретном топике я пытаюсь добиться от автора чем отличается его тестовая среда от реальной и понять почему на тестовом стенде ова работает. 

    Денис, был бы очень рад вашему совету

    31 июля 2016 г. 7:51
  • Пересоздать сложно коммутатор, т.к. используется кластер состоящий из 3х хостов hyper-v 150 VM. По данным от Zabbix сеть не отвативается. Адаптеры удалял перенастраиваю эффекта не дало.
    1 августа 2016 г. 10:02
  • а перед появления вашей проблемы не было падения узлов, на которых расположен Exchange?

    насколько я помню, отказоустойчивость exchange лучше обеспечивать другими механизмами

    1 августа 2016 г. 10:24
  • Были проблемы с Edge сервером и IMAP сертификатом. Сертификат перегенерировал после IMAP SSL заработал, а edge видимо т.к. там был установлен DKIM signer все время падал и почта со внешки не приходила и не отправяллась. Edge я переустановил полностью на новую VM. В этой конфигурации Exchange работал примерно месяц.

    После в четверг сервис owa работал в штатном режиме, а в пятницу перестал (падений, перезапуска, перезагрузок не наблюдалось). И после перезапуска всей системы Exchange(Edge, CAS, 2x MB) проблема с owa осталась.Основная проблема как я понимаю Exchange не может расшифровать POST запрос от клиента по непонятным мне причинам 3-ри раза пытается получить ответ от сервера(перезапуская страницу) и вываливается вот такая ошибка

    X-OWA-Error: SDServerErr;System.Xml.XmlException.


    2 августа 2016 г. 11:16
  • по ошибке owa 500 пытались найти какие-то варианты решения проблемы?

    например вот - https://social.technet.microsoft.com/Forums/exchange/en-US/08d3777c-dc03-4411-8c87-7db37d2f406a/exchange-2013-owa-login-error-http-500?forum=exchangesvrclients

    2 августа 2016 г. 11:34
  • У меня совершенно другая ошибка при POST запросе на авторизацию т.к. Сервер не смог распарсить XML. Сама страничка грузиться исправно.
    2 августа 2016 г. 15:29
  • Owa перестала работать буквально после обновления фермы Sharepoint'a и Web apps'a. Может как-то связано.
    3 августа 2016 г. 9:18
  • я вам как предлагал, так и предлагаю вернуться к моменту, когда у вас все работало на тестовой инфраструктуре.
    3 августа 2016 г. 9:38
  • Проверьте интеграцию с WebApps

    Сазонов Илья

    https://isazonov.wordpress.com/

    • Помечено в качестве ответа Dashboard Systems 3 августа 2016 г. 12:43
    3 августа 2016 г. 9:49
    Модератор
  • Похоже нашел причину, во всем виноват WebApps. Позже отпишусь.
    3 августа 2016 г. 11:44
  • Да все верно, после перенастройки WebApps Owa заработала в штатном режиме без ошибок! Всем спасибо!
    3 августа 2016 г. 12:43