none
outlook 2016-2019 отказывается подключаться к Exchange 2019 RRS feed

  • Вопрос

  • Всем привет. Руководство поставило задачу поставить Екч, но с ним ни разу не работал( но задача есть задача) сидели мирно на Mdeamon , но тут поставили Битрикс ЕРП и понеслось.

    Поставил я в тестовой среде Server 2019 +Exchange 2019, естественно скопировал AD и поднял тестовую машину(на Windows 10  c Outlook 2016)  крутиться все на Xen.

    Все поставилось в принципе без проблем и быстро.

    Owa работает , почта уходит приходит , порты открыты telnet на все порты пускает и почту через него же отправлял.

    Но вот подошли к основному , Оутлук ни в какую не хочет цепляться к Екченжу

    "Отсутствует подключение к MS Exchange. Для завершения операции требуется постоянное или временное подключение  Outlook к серверу." 

    Уже не знаю куда копать,  и что делать.

    Может вы подскажите ну или накидаете пару идей куда двигаться и что крутить.

    Спасибо .

    16 июля 2020 г. 8:50

Ответы

Все ответы

  • SCP (Uri) настроили? Виртуальные директории сконфигурировали? 
    16 июля 2020 г. 8:56
  • Вот тут есть загвоздка, я оставил все по умолчанию, так как не настраивал внешние источники(internet) так как все крутиться внутри закрытой сети), все внутренние адреса в Виртуальных директориях ссылаются на внутреннее имя  сервера (https://testmail.gk.local/) аутентификации не крутил.

    Autodiscover доступен, xml виден. 

    Повторюсь owa/ecp сервисы работают с любого тестового пк.

    16 июля 2020 г. 9:48
  • Любым сниффером (wireshark/fiddler) посмотрите куда стучится outlook за конфигом и сконфигурируйте CSP (https://docs.microsoft.com/en-us/exchange/architecture/client-access/autodiscover?view=exchserver-2019)

    также для корректной работы вам ещё потребуется сертификат.

    16 июля 2020 г. 11:00
  • Любым сниффером (wireshark/fiddler) посмотрите куда стучится outlook за конфигом и сконфигурируйте CSP (https://docs.microsoft.com/en-us/exchange/architecture/client-access/autodiscover?view=exchserver-2019)

    также для корректной работы вам ещё потребуется сертификат.

    А ещё проще - запустите Outlook, щелкните правой кнопкой мыши при зажатом Ctrl на значке Outlook в области уведомлений ("где часы") и в появившемся меню выбирите пункт "Проверка автоконфигурации" (если Ctrl не нажимать, то этого пункта не будет). Там запустите проверку, смотрите, что именно не прошло и думайте.

    PS Для корректной работы Outlook внутри локальной сети хватает самоподписанного сертификата, который автоматически создает установщик Exchange. Так что не пугайте человека раньше времени - полноценный сертификат от коммерческого провайдера ему, скорее всего, понадобится, но для других сценариев использования (для доступа извне, в основном).


    Слава России!


    • Изменено M.V.V. _ 16 июля 2020 г. 12:01
    16 июля 2020 г. 11:59
  • да есть проблема когда захожу на autodiscover.xml получаю ошибку 600.

    Вроде просмотрел все по вашей ссылке , делай запрос get-autodiscovervirtualDirectory |fl internal/external

    получаю пустые значения. 

    Вроде cname/srv/a записи зоны ru все ведут на нужный адреес. Но к сожалению не получает настроек. 

    так же в AD посмотрел значения cn тоже все верно(для моего взгляда) 

    16 июля 2020 г. 12:25
  • Да я поднял уже и сервер сертификации и что только не пробовал(но чувствую где то обычная галочка но где и какая понять не могу)

    Сделал тест в журнале есть только эти  ошибки imap/pop

    Guessmart IMAP: сервер имя сервера порт= 993 ssl= да tls= нет spa=нет,сбой 0x800CCC0D и 0x80040113


    16 июля 2020 г. 12:49
  • Вы случаем не админский пя пытаетесь подключить?

    Попробуйте создать обычного пользователя и проверить на нём + убедиться, что Firewall не блокирует 443 на Exch.

    16 июля 2020 г. 13:30
  • Да пробовал Админом.

    Создал нового пользователя , проблема все та же.

    Фаервол открыт полностью для доменного профиля(телнет пускает на 443, значит открыт)

    16 июля 2020 г. 13:41
  • Выложите весь текст лога

    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий.

    20 июля 2020 г. 10:29
    Модератор
  • Лога чего именно? Тест Аутлук?
    20 июля 2020 г. 14:53
  • Лога чего именно? Тест Аутлук?
    да

    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий.

    20 июля 2020 г. 19:56
    Модератор
  • Оно крутить в xen и там нет копировать вставить, а вставить сюда скрины к сожалению не могу, учетная запись пишет не проверена.

    Если вы про онлайн тест екченджа то тоже не могу сделать так как это закрытая сеть и там нет доступа вовнутрь и внешний мир.

    Есть мысль что проблема в ом что я создал в DNS зону соответствующую имени company.ru и прописал туда записи a ,mx, cn, autodiscover

    Тоесть есть домен company.local, в нем добавил зону company.ru

    туда вписал Mail(A) ip адресс екченджа.

    Autodiscover(cname) mail.company.ru

    Но а тоже время mail.company.ru доступен (пингуеться ,nslookup) проходит, owa работает. Тестовое письмо через telnet приходят уходят. 25 110  143 443 995 2525 и тд порты доступны.

    21 июля 2020 г. 6:19
  • Загрузите скриншот на OneDrive и выложите здесь ссылку на него, либо сделайте запрос на верификацию аккаунта:

    How to Verify Your MSDN/TechNet Forums Account So that You Can Post Images and Links


    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий.

    21 июля 2020 г. 6:36
    Модератор
  • https://1drv.ms/u/s!Am094KLoroi0zCEojQ9mSNf3zuC7?e=x5tqeh
    21 июля 2020 г. 9:36
  • Печатал минут 30 и не отправилось. Теперь уже коротко.

    Поднял Hyper-v  туда server 2019+ad , server 2019+exchange 2019 cu 5, туда win10 +office 2016.

    Все чиста установка без всего.

    назвал домен gkpvg.local,  почта spbex01

    Создал нового пользователя test@gkpvg.local (не менял правила не добавлял домены)

    Захожу в win10  , запускаю https://spbex01.gkpvg.local/autodiscover/autodiscover.xml

    спрашивает пароль , ввел пароль , выдал xml ( в центре сообшения error code 600 и invalid requst)

    Захожу в outlook 

    делаю добавить учетную запись, пишет сертификат ставим его :

    1.установка сетевого подключения(ок)

    2.поиск параметров для test@gkpvg.local(ok)

    3. Вход на поочтовый сервер (ок)

    просит перезапустить ок перезапускаю.

    Выдает сообщение :

     Отсутствует подключение к Exchange, для завершение ооперации требуеться постоянное или временное подключение Outlook к серверу.

    Что делаю не так и куда копать , пробовал все , читал все , ошибка всегда одна и таже.

    owa работает.

    23 июля 2020 г. 7:04
  • Захожу в win10  , запускаю https://spbex01.gkpvg.local/autodiscover/autodiscover.xml

    В информации Autodiscover на тех картинках, которые вы выложили, у вас в URL возвращается другое имя сервера Exchange: spbmail01.gkpvd.local (ну и, до кучи, у вас там еще имя сервера mail.pvg.ru в качестве внешнего, но это пока не важно).

    Разберитесь, как именно называется у вас сервер, и поправьте, что надо поправить (URL для Autodiscover - парметр AutoDiscoverServiceInternalUri в командах Get/Set-ClientAccessService (Get - посмотреть, Set - установить), InternalURL для других виртуальных кталогов, имена в поле SAN сертификата...). Если не знаете, как поправить, напишите, как у вас называется сервер, и какие имена в сертификате.


    Слава России!


    • Изменено M.V.V. _ 23 июля 2020 г. 13:09
    23 июля 2020 г. 13:03
  • Get -ClientAccessService

    SPBEX01

    Get-ClientAccessServer -Identity SPBEX01 | fl AutodiscoverServiceInternalUri

    выдает

    AutodiscoverServiceInternalUri: Https://spbex01.gkpvg.local/Autodiscover/Autodiscover.xml

    Виртуальные каталоги не менял оставил только internal везде обращение на spbex01.gkpvg.local

    В Accepted domain тоже оставил только gkpvg.local по умолчанию


    сервер сейчас у меня spbex01 , домен gkpvg.local (так как поднял все с нуля и не прописывал доп зоны в DNS а заставить работать хотя бы в локальном пространстве)

    В сертификате Microsoft Exchange Server Auth Certificate( пусто)

    В сертификате Microsoft Exchange (spbex01 и spbex01.gkpvg.local)

    В сертификате WMSVC-SHA2( WMSvc-SHA2-SPBEX01)




    24 июля 2020 г. 6:51
  • Повторите автоообнаружение и посмотрите, поменялось ли имя хоста в URL на правильное - spbex01.gkpvg.local

    Слава России!

    24 июля 2020 г. 18:00
  • не много не понял, авто обнаружение в чем? (шел,аутлук,или браузер)
    27 июля 2020 г. 3:22
  • Тест автообнаружения в Outlook. Там, где у вас было несовпадающее имя сервера в URL виртуальных каталогов.

    Слава России!

    27 июля 2020 г. 12:42
  • везде spbex01.gkpvg.local
    27 июля 2020 г. 18:01
  • Видимо информации ни какой нет ни у кого.

    Проблему нашел, сам виноват.

    4 августа 2020 г. 13:43
  • Видимо информации ни какой нет ни у кого.

    Проблему нашел, сам виноват.

    Подскажите скрипт как массово создать ящики в Exch( а то 300 пользователей в AD)

    Сообщите в чем была проблема и как решили, это может быть полезно и другим участникам сообщества.

    Новый Ваш вопрос вынес в отдельную тему

    https://social.technet.microsoft.com/Forums/ru-RU/c6474d35-afe2-4ad0-a760-73f9d79e6dcd/105010721082-107410991087108610831085108010901100?forum=exchange19



    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий.

    19 августа 2020 г. 7:18
    Модератор