none
Поставил 2007 на Virtual Server RRS feed

  • Вопрос

  •  Жуть какая то!

     Поставил в чистеньком тестовом виртуальном домене Exchange 2007. Второй день одолевавет единственная мысль: Подукт сырой до безобразия. 

    1. Дефолтная установка. Единственный сервер Exchange. Все требования выполнил все патчи/апдейты поставил, установка завершилась без ошибок. Вхожу в консоль управления. Вылетает окошко с предупреждением о триальности +окошко с кучей ошибок.

    Перегружаюсь. Ошибки не повторились вроде.

     Спешу с виртуальной обочей станции со свежепоставленым Office 2007 подлючится под доменным админом. Outlook влет нашел сервер - сам настроился как надо. Радуюсь.

      Дальше начинаются чудеса. Посылылаю сам себе письмо. Письмо уходит без ошибок но и без возврата. В отправленых появляется во входящих нет.

     Перезахожу через OWA. Красиво. Снова письмо себе. На этот раз отправленое письмо появляется в папке Черновики.

     На следующий день решаю переустановить Exchange. Все таки не дает покоя окошко с ошибками увиденное после установки. Фигу. Не удаляется роль Mailbox по причине неудаленного Public Folder Database. Данная Database не удаляется потому что содержит некие реплики фолдера. Куда что реплицируется то? Сервер единственный вроде и ничего я ему не указывал реплицировать.

    По докам нахожу некие скрипты EMS для удаления этих таинственных реплик, полдня читаю описания и исходники. Пробую так и эдак - не работает.

      Надоело. Возможно продукт сыроват и надо ждать SP1, возможно недостаточно документации в инете...

    Ну и как вы думаете стану я внедрять такой продукт в производственную систему? А порекомендую ли внедрение клиентам?

     

     

    • Перемещено Hengzhe Li 18 марта 2012 г. 8:12 forum merge (От:Exchange Server 2007)
    28 декабря 2006 г. 14:18

Ответы

  • На 99% проблемма в производительности виртуального сервера.

    Первый раз слышу о подобных проблеммах (хотя описания проблем слишком поверхностно).

    Попробуйте установить на отдельную машину.

    12 января 2007 г. 5:47

Все ответы

  • А Virtual Server поддерживает 64битную гостевую ОС?

    Или Вы поставили 32хбитную бету и удивляетесь теперь тому, что она глючит?

     

    28 декабря 2006 г. 14:30
    Модератор
  • 32х битную но не бету - официальный 120 дневный триал. "не для производственного использования" как писалось при установке. Типа посмотреть и насладится новой версией. Насладился :-)
    28 декабря 2006 г. 14:36
  • Тогда нужно писать багу как положено и куда положено. С номером сборки, симптомами, логом. А то не ясна цель Вашего поста =) Простожалуетесь? =)

    На самом деле я подозреваю, что что-то было сделано неправильно, иначе неясно откуда ошибки на свежеустановленной системе.

    28 декабря 2006 г. 14:41
    Модератор
  • А не сохранился снимок экрана с ошибкой?
    Пожалуйста, пришлите билд Exchange 2007, на какой операционной системе (SP, обновления) и под каким билдом Virtual Server Вы производили установку.
    28 декабря 2006 г. 14:43
  •      Я не жаловался. Я имел ввиду что один вот такой глюк дает представлений и впечатлений о системе гораздо больше чем милионны затраченые на маркетинг.

      Ну ставил я 32х-разрядную "non productive" ( Version 8.0. Build 685.24) на Virtual Server 2005 SP1 beta2 с Windows 2003 Ent SP1 со всеми апдейтами.  Даже знаю теперь какие именно реплики там прячутся FPDAVADMIN показал в скрытых SystemFolders реплики сами на себя (прада удалитьне дал).

     Снимка нет - там список с прокруткой неслабый был. Правда потом он мне еще пару раз показывался - если еще всплывет - скопирую. Но вряд ли. Сколько можно убивать времени на глюки программы при установке? И какой работы от нее ожидать потом.

      А свободного физического 64 разрядного сервера вот нигде не валяется. Как найду - попробую. Ставить  в продакшен не буду ни себе ни другим пожалуй до первого SP.

    28 декабря 2006 г. 15:04
  • Если я правильно понял, у Вас стоит Virtual Server 2005 R2 SP1 Beta 2
    Может проблема в нем, а не в Exchange 2007?
    Может стоит попробовать под Virtual Server 2005 R2.
    28 декабря 2006 г. 16:12
  • Хм... Вы полагаете версия виртуального сервера как то связана с наличием  странных реплик в системном фолдере Public Folders Database? Из за которых Exchange не хочет деинсталироватся? Гугл нашел пару жалоб на  эту же тему на иностранных форумах. Проблема, как я понял, осталась нерешенной.
    29 декабря 2006 г. 7:04
  • Реплики не странные, они и в Exchange 2000/2003 были.

    Exchange 2007 пока планируется последней версией с поддержкой Public Folders и их использование не рекомендуется.

    Наличие Public Folders связано с тем, что при установке Вы выбрали совместимость с клиентами ниже Outlook 2007
    Если бы не указали совместимости, то Public Folders просто бы не было.

    Ошибка, которая у Вас появляется в консоли управления, может быть связана с версией Virtual Server, а не с наличием Public Folders.

    29 декабря 2006 г. 9:48
  •  1. Проблема не в наличии или отсутствии Public Folders и их реплик. Проблема что невозможно деинтсаллировать Exchange. Если это "не баг а фича" то надо крупными буквами писать в доках и при инсталляции во весь экран окно вывести - мол если поставите поддержку Public Folders - то все, труба, избавится сможете только переформатированием винчестера и ручной чисткой AD. У меня уже в виртуальном домене в результате експериментов 3 сервера Exch2007 скопилось - не дает удалить - ставлю на новый. :-).

      2. Причина ошибок не в версии VS - проверено установкой на VMware server (последний  доступной версии).  Кстати на этот раз все вообще прошло "успешно", так что скриншот было не с чего сделать. А результат тот же. Из аутлука по MAPI письма "красиво" улетают в никуда, копия укладывается в "отправленые". Месседж трекинг на сервере их даже и не видет. Никаких ошибок. При теленете на сервер по 25 порту получаю:

    452 4.3.1 Insufficient system resources.

    Естественно та же ошибка и при попытке отправки из аутлук экспресс.

     Ну хоть какое то сообщение о неисправности со стороны сервера. Может сдесь собака порылась? На буржуазнах сайтах встречал совет дать поболее памяти. Выдал все что позволили виртуальные машины (чуть меньше 4G) - результат тот же.

      Вопрос к народу. Хоть кому то удавалось вообще завести этот Exchange 2007 на виртуалке или я один такой эксперементатор?

     

    10 января 2007 г. 8:41
  •  Cookie_Monster написано:

    Вопрос к народу. Хоть кому то удавалось вообще завести этот Exchange 2007 на виртуалке или я один такой эксперементатор?

    Я ставил много раз и на виртуальных, и на реальных машинах. Никаких проблем (нет, ну некоторые разумные проблемы были, но мы их решали).

    10 января 2007 г. 22:51
  • На 99% проблемма в производительности виртуального сервера.

    Первый раз слышу о подобных проблеммах (хотя описания проблем слишком поверхностно).

    Попробуйте установить на отдельную машину.

    12 января 2007 г. 5:47