none
SCCM отчеты ошибка №2147024882 Not enough server storage is available to process this command RRS feed

  • Вопрос

  • Создал свой собственный отчет в SCCM, при загрузке выдется ошибка: Not enough server storage is available to process this command

    Когда выполняю запрос отчета на sql server все отрабатывает.
    Число возвращаемых строк более 20000

    Когда в запросе отчета ограничиваю вывод 1000 строк все отрабатывает и в SCCM.

    ОС на сервере SCCM: windows server 2003 SP2
    SCCM 2007 R2
    как избежать ошибки?

    24 ноября 2009 г. 12:38

Ответы

  • сделал как в соседней статье 
    http://technet.microsoft.com/en-us/library/bb680885.aspx,

    теперь выводится ошибка "невозможно отобразить отчет"

    гружу отчет через веб-доступ- вываливается 500 ошибка

    25 ноября 2009 г. 6:57
  • решение нашел, долнительно нужно увеличить буфер как написано здесь:


    Q. When my web reports contain a column that has more than 5000 records I get an IIS error 500 on my IIS 6.0 reporting point. How do I fix this? (Added January 21, 2004)
    A.

    You might need to adjust the AspBufferingLimit setting. The AspBufferingLimit property sets the maximum size of the ASP buffer. The default is approximately 4 MB. To change the default, open %WindowsRoot%\System32\InetSrv\MetaBase.xml and search for “AspBufferingLimit”. Adjust the setting to allow for 1 MB per 1000 records. You can make changes to the MetaBase.xml file while IIS is running only if the edit-while-running feature is enabled. Otherwise, you must stop IIS before editing the MetaBase.xml file.

    For more information about writing changes to MetaBase.xml, see “Configuring the Metabase” in the Server Administration Guideon Microsoft TechNet.

    25 ноября 2009 г. 9:09

Все ответы