none
Пропало поле на портале SharePoint RRS feed

  • Вопрос

  • Здравствуйте!

    Появилась проблема. В организации имеется портал на SharePoint 2007. На портал размещаются документы (этим занимался другой человек, теперь я...). Имеется нормативный документ (ложится в одну библиотеку) и в нем ссылка на приказ (в другую библиотеку). Так вот еще с 2008 года при размещении приказа заполнялось поле "Имя документа" (дополнительное поле), которое и являлось ссылкой на него (в нормативном в выпадающем списке выполнялся поиск этого приказа). Так вот это поле невозможно заполнить. В представлении (общим списком документов) это поле видно и заполнено (у старых документов), а при открытии документа (загружается форма EditForm.aspx) поля нет. Причем это поле видно во всех представлениях, а также в настройках библиотеки (выбор порядка, задание индексируемых полей), а в общем списке столбцов тоже нет...

    Что только не пробовал. В SharePoint Designer нашел в источниках данных это поле, ничем не отличается от остальных. xpath у него "/dsQueryResponse/Rows/Row/@NameDoc", опять таки ничем не отличается от остальных. Пробовал в строке браузера в окне редактирования столбца менять название на мое поле (NameDoc), открывается окно настройки, где могу только поменять название, тип и описание. Имеется еще один тип документа (приказ филиала), но в нем все нормально отображается... Формы точно такие же, сравнивал коды EditForm.aspx больного и здорового документа, отличаются только ID (даже ListID и WebPartID одинаковые). В чем может быть проблема? Где мне можно порыться, чтобы поле вновь появилось? (его я не видел до этого, только начал знакомится с SP, а прошлый человек говорит, что было...)

    Прошу помощи!

    Заранее благодарен)

    29 октября 2014 г. 19:15

Ответы

Все ответы