none
Project Server 2013: Не загружаются задачи в новых версиях IE RRS feed

  • Вопрос

  • Здравствуйте!

    Имеется ферма, состоящая из 2-х серверов: 1. SharePoint Server 2013 + Project Server 2013; 2. SQL Server 2012.

    На теории все версии Internet Explorer (IE), начиная с 8-ой, поддерживают полноценную работу с Project Server’ом 2013. А вот на практике имеем совсем другое…

    Во всех версиях IE, начиная с 9-ой, всё, вроде как, работает хорошо. Но в один прекрасный момент по непонятным причинам у отдельных пользователей перестаёт функционировать один из ключевых инструментов сайта PWA: страница "Задачи". Задачи просто-напросто не загружаются: бесконечно отображается индикатор загрузки... А вот в 8-ой версии такого форс-мажора не происходит! И если пользователь, столкнувшийся с проблемой в новых версиях IE, переключается на IE 8, то проблема исчезает.

    Возможно, конфликт возникает из-за каких-то доп. настроек новых версий IE. Но это лишь предположение, как подтверждение, так и опровержение которого ещё не найдено.

    Ранее сталкивался лишь с двумя причинами проблем при загрузке задач. Обе не были связаны с версиями IE:

    http://social.technet.microsoft.com/Forums/ru-RU/55195e20-f39b-4817-a342-bf6e8914b77f/project-server-2013-?forum=msoserverru

    Теперь что-то новенькое!

    В логах ULS никаких ошибок нет. При использовании панели мониторинга тоже никаких нюансов не выявлено: всё, что нужно, загружается/выполняется довольно быстро, без ошибок.

    Просьба посодействовать!

    Спасибо!

    10 июня 2014 г. 12:16

Все ответы

  • режим совместимости включите
    16 июня 2014 г. 11:40
  • режим совместимости включите

    Режим совместимости на описанное мною явление никак не влияет! Уже пробовал включать. Более того, я вообще не заметил, что он хоть на что-то влияет.

    Спасибо за предложение.

    16 июня 2014 г. 12:01
  • Найдена причина возникновения упомянутой проблемы. По крайней мере, одна из возможного ряда. Правда, совершенно не ясно, при чём тут версии IE.

    Итак, в заметках к некоторым задачам по непонятным причинам появляется следующий символ (вполне вероятно, что вместо него может быть какой-то другой):

    NotesInClientView

    Причём, отображается он только при выводе столбца “Заметки” в представление клиента. На формах же самих задач в заметках ничего не видно:

    NotesInClientTaskForm

    На сайте PWA (через браузер), где поле “Заметки” доступно только на чтение, он отображается как “v”:

    NotesInPWAView

    В случаях, когда он появляется, всё время оказывается в месте переноса строк. Но сам по себе перенос строки и близко не гарантирует возникновение данного символа.

    Если избавиться от этих символов (основные сложности заключаются на этапе поиска), проблема у соотв. ресурса исчезает.

    В общем, очередной перформанс Project’а. И уже в который раз связанный с использованием заметок!


    • Изменено Ronni10 14 сентября 2015 г. 8:27
    14 сентября 2015 г. 8:25