none
Сервер терминалов не принимает сохраненные учетные данные RRS feed

  • Вопрос

  •  Ситуация такова: Win 2008 r2, на нем сервер терминалов. Когда любой клиент присоединяется к серверу по ip, с заранее сохраненными данными (верными) для входа, сервер всё равно запрашивает логин и пароль. Так с любой версией клиента.  Что это может быть?
    • Изменено techno-W2 19 июня 2013 г. 9:43
    19 июня 2013 г. 9:43

Ответы

  • Ничего криминального не увидел.

    Давайте вот так попробуем:

    1. On your Windows 7 client, click Start, input gpedit.msc in search bar, press Enter.

    2. Navigate to Computer Configuration\Administrative Templates\System\Credentials Delegation.

    3. On the right pane, double click Allow Saved Credentials with NTLM-only Server Authentication.

    4. Click Enable. In the Show contents dialog box, click Add, type the name of remote computer(server) in this format:TERMSRV\<computername>, then click OK.

    Пост взят отсюда.

    Также вот здесь интересный момент:

    I had exactly the same problem on Windows Server 2008 R2.

    If you type IP Address of the computer to connect to the system cannot verify if the IP Address is a secure location so it does not save the credentials. But if you use server name instead of the IP Address then the name is looked up in Active Directory integrated DNS and this entry is secure so RDP will allow you to save the password.

    Try it. It worked for me.


    Понравился ответ - лайкни!

    26 июня 2013 г. 11:34

Все ответы

  • Галку поставили здесь?

    19 июня 2013 г. 10:09
  • Конечно, дело в том, что у 20 пользователей в один момент перестали приниматься учетные данные, до этого всё было в порядке. Подозреваю, что дело на сервере, но админы не трогали в этот период.
    19 июня 2013 г. 10:33
  • Так. Давайте по порядку.

    Проблема не у всех пользователей?

    При запуске файла .rdp появляется ошибка или просто просит указать пароль для учетки? Опубликуйте скрин.

    19 июня 2013 г. 10:48
  • Проблема у всех пользователей, при запуске файла rdp отображаются сохраненные данные, когда нажимаешь кнопку подключить - открывается, как положено, удаленный стол, и в нем просит ввести учетные данные. При чем логин - пароль пустые и стоит указанный домен.

    ps. На этом сервере AD.

    • Изменено techno-W2 19 июня 2013 г. 11:07 добавление
    19 июня 2013 г. 11:05
  • Если заново создать файл .rdp ситуация такая же?

    Пришлите скрин проблемного файла, аналогичный этому

    19 июня 2013 г. 12:51
  • Вот скрин с win 8. (webfile. ru/6572492) извините, что на внешнем ресурсе - сюда не даёт загрузить - профиль не проверен.  Пользователи и с win 7 и xp подключаются, как снаружи так и внутри сети. У всех просит. С новым та же ситуция.


    • Изменено techno-W2 20 июня 2013 г. 8:34 лдждж
    20 июня 2013 г. 8:33
  • Посмотрите тут и тут.

    Понравился ответ - лайкни!

    20 июня 2013 г. 9:18
  • Ответ понравился, так что лайкнул, но эти решения не работают в данной ситуации.
    20 июня 2013 г. 10:32
  • Почему?

    Понравился ответ - лайкни!

    20 июня 2013 г. 10:50
  • Попробовал все рекомендации - результат тот же.
    20 июня 2013 г. 13:38
  • Понял. Я думал, они Вам просто не подходят.

    Никаких манипуляций с GPO не совершали перед возникновением проблемы? Чтобы убедиться, что ГП тут не при чем, сделайте следующее: создайте новую аушку в AD, создайте нового пользователя, поместите его в это AU (туда же для чистоты экперимента желательно поместить  клиентскую машину и терминальный сервер), отключите наследование всех политик для этой аушки, перезагрузите клиентскую машину и сервак, залогиньтесь на ПК под данным тестовым пользователем, убедитесь, что никакие политики не были применены (gpresult), протестируйте наличие проблемы.

    TS один в организации? Шлюз терминалов используется при подключении изнутри?


    Понравился ответ - лайкни!

    20 июня 2013 г. 14:52
  • http://windowsnotes.ru/other/razreshaem-soxranenie-uchetnyx-dannyx-pri-podklyuchenii-po-rdp/
    21 июня 2013 г. 5:01
  • Не подходит - такая проблема не у одного компа и, даже не только у компов в AD.
    21 июня 2013 г. 7:22
  • Нет, шлюза нет. Сервер в этом лесу один, пока. Попробую. Но, вот странная ситуация, пытаюсь зайти под админом на сервак(dc\Администратор) вместо входа в домен, результат тот же. Ещё пробовал заходить по RDP на другой сервер в домене - сохраняет.

    • Изменено techno-W2 21 июня 2013 г. 7:35 лодлло
    21 июня 2013 г. 7:23
  • То есть это контроллер?

    Тогда подождите,  мои рекомендации по поводу ГПО пока выполнять не нужно. Опубликуйте файл, который сгенерируется в результате выполнения команды  gpresult -h c:\gpo.html на проблемном сервере


    Понравился ответ - лайкни!

    21 июня 2013 г. 12:59
  • Извиняюсь, не упомянул полную информацию. Вот файлик. rusfolder .com/36970975
    24 июня 2013 г. 6:52
  • Я бы посмотрел в сторону вот этой политики: "Сетевая безопасность: уровень проверки подлинности LAN Manager".

    Опубликуйте вывод этой же команды с терминального сервера, на котором данная проблема не наблюдается.


    Понравился ответ - лайкни!

    24 июня 2013 г. 13:26
  • Именно терминального сервера больше нет, есть обычный в домене, на котором сохраняются записи.

    Вот результат с него: rusfolder .com/36991567

    25 июня 2013 г. 11:47
  • Ничего криминального не увидел.

    Давайте вот так попробуем:

    1. On your Windows 7 client, click Start, input gpedit.msc in search bar, press Enter.

    2. Navigate to Computer Configuration\Administrative Templates\System\Credentials Delegation.

    3. On the right pane, double click Allow Saved Credentials with NTLM-only Server Authentication.

    4. Click Enable. In the Show contents dialog box, click Add, type the name of remote computer(server) in this format:TERMSRV\<computername>, then click OK.

    Пост взят отсюда.

    Также вот здесь интересный момент:

    I had exactly the same problem on Windows Server 2008 R2.

    If you type IP Address of the computer to connect to the system cannot verify if the IP Address is a secure location so it does not save the credentials. But if you use server name instead of the IP Address then the name is looked up in Active Directory integrated DNS and this entry is secure so RDP will allow you to save the password.

    Try it. It worked for me.


    Понравился ответ - лайкни!

    26 июня 2013 г. 11:34