none
Проблемы при установке Exchange 2010 RRS feed

  • Вопрос

  • Добрый день.

    Начинал обсуждение здесь http://social.technet.microsoft.com/Forums/ru-RU/exchange2010ru/thread/a113279e-a590-4126-abc8-31a8fa57fec8

    Дошел до этапа установки Exchange 2010. Ставлю через GUI.Когда выбираю - Step4:Install Microsoft Exchange то сразу выдается ошибка: Exchange Server setup encountered an error.

    В Event Log ничего нет, зато есть вот такое более старое сообщение в разделе Application (примерно тогда я обновлял схему)

    Log Name:      Application
    Source:        MSExchange Configuration Cmdlet - Management Console
    Date:          10.11.2010 16:44:50
    Event ID:      4
    Task Category: (1)
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      ex2010.domain.su
    Description:
    The description for Event ID 4 from source MSExchange Configuration Cmdlet - Management Console cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

    If the event originated on another computer, the display information had to be saved with the event.

    The following information was included with the event:

    2416
    46
    Install-ExchangeSchema
    0
    Microsoft.Exchange.Configuration.Tasks.TaskException: There was an error while running 'ldifde.exe' to import the schema file 'C:\Windows\Temp\ExchangeSetup\Setup\Data\PostExchange2003_schema18.ldf'. The error code is: 8245. More details can be found in the error file: 'C:\Users\admin\AppData\Local\Temp\ldif.err'
    {4bbfa314-3555-4d08-8206-c1970f577d8d}

    the message resource is present but the message is not found in the string/message table

    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="MSExchange Configuration Cmdlet - Management Console" />
        <EventID Qualifiers="49152">4</EventID>
        <Level>2</Level>
        <Task>1</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2010-11-10T13:44:50.000000000Z" />
        <EventRecordID>503</EventRecordID>
        <Channel>Application</Channel>
        <Computer>pstex.forte.su</Computer>
        <Security />
      </System>
      <EventData>
        <Data>2416</Data>
        <Data>46</Data>
        <Data>Install-ExchangeSchema</Data>
        <Data>0</Data>
        <Data>Microsoft.Exchange.Configuration.Tasks.TaskException: There was an error while running 'ldifde.exe' to import the schema file 'C:\Windows\Temp\ExchangeSetup\Setup\Data\PostExchange2003_schema18.ldf'. The error code is: 8245. More details can be found in the error file: 'C:\Users\admin\AppData\Local\Temp\ldif.err'</Data>
        <Data>{4bbfa314-3555-4d08-8206-c1970f577d8d}</Data>
      </EventData>
    </Event>

    Я так понял, что подробности просят смотреть в файле C:\Users\admin\AppData\Local\Temp\ldif.err. Вот его содержимое:

    Entry DN: CN=ms-Exch-Mobile-Mailbox-Policy-Link,CN=Schema,CN=Configuration,DC=domain,DC=su
    Add error on entry starting on line 358: Unwilling To Perform

    The server side error is: 0x2114 Schema update failed: An attribute with the same link identifier already exists.

    The extended server error is:

    00002114: SvcErr: DSID-032602B7, problem 5003 (WILL_NOT_PERFORM), data 8468


    An error has occurred in the program

    Возникло подозрение, что неправильно выполнилась (или вообще не выполнилась) команда setup.com/PrepareSchema (запускал ее для подготовки схемы  AD к установке Exchange 2010). Хотя при ее выполнении ошибок не было, просто шел процесс, потом окно выполнения закрылось и все.

    Есть у вас коллеги мысли по поводу этой ошибки,что посоветуете?

    12 ноября 2010 г. 8:23

Ответы

  • 1. ТО что уже выполнилось без ошибок можно не выполнять

    2. Временные файлы можно удалить

    3. Я не знаю точно какой файл используется, но я бы исправил оба. И сохранил бы исправленный дистрибутив, чтобы ставить только с него в последующем.


    Сазонов Илья http://www.itcommunity.ru/blogs/sie-wl/
    16 ноября 2010 г. 17:05
    Модератор

Все ответы

  • Возможно обновление схемы не проходит потому, что имеем вот это в файле C:\Users\admin\AppData\Local\Temp\ldif.err

     

    Entry DN: CN=ms-Exch-Mobile-Mailbox-Policy-Link,CN=Schema,CN=Configuration,DC=domain,DC=su
    Add error on entry starting on line 358: Unwilling To Perform

    The server side error is: 0x2114 Schema update failed: An attribute with the same link identifier already exists.

    The extended server error is:

    00002114: SvcErr: DSID-032602B7, problem 5003 (WILL_NOT_PERFORM), data 8468

     

    Вот это смутило - The server side error is: 0x2114 Schema update failed: An attribute with the same link identifier already exists.Открыл схему через ADSIEdit и попытался собственно найти CN=ms-Exch-Mobile-Mailbox-Policy-Link. Так вот его там НЕТ ну или он не отображается по какой-то причине (возможно как раз по причине того,что An attribute with the same link identifier already exists. (Аттрибут с таким же LinkID УЖЕ СУЩЕСТВУЕТ).

     

    Это может быть причиной?И если да, то как это лечиться, есть знатоки схемы AD?

    12 ноября 2010 г. 12:14
  • Добрый день.

    Собственно причина всех бед, я так понял вот в этом

    The server side error is: 0x2114 Schema update failed: An attribute with the same link identifier already exists.

    Перевожу-

    Аттрибут с таким же LinkID УЖЕ СУЩЕСТВУЕТ)

     

    Или это лучше спросить в разделе про Windows Server?

    13 ноября 2010 г. 7:27
  • Если линк уже существует, значит было какое-то расширение схемы. Попробуйте выяснить какой софт ставили с расширением схемы. И нужен ли он. Если не нужен, то можно похоронить его настройки, в том числе в схеме AD.
    Сазонов Илья http://www.itcommunity.ru/blogs/sie-wl/
    13 ноября 2010 г. 9:48
    Модератор
  • Про то, какой софт ставили с расширением схемы, можно только гадать.Вот когда-то давно ставили Exchange 2003, тогда и было расширение схемы. Плюс мигрировали с домена Windows 2000 на домен уровня Windows 2003. SQL сервер стоит, но не уверен, что он так грубо расширяет схему, что ее потом не поставить.

    Стоит еще IBM Cognos, система финансового учета и бюджетирования такая, не слышали?Вот он мог тоже схему расширить например (но я НЕ УВЕРЕН), но он используется нами.

    Больше ничего такого не стоит.Я так понимаю всякие антиспамы и антивирусы в схеме ничего не меняют.

    Вообще все ставилось до меня, а я точно ничего расширяющее схему не ставил...

    вот ссылку нашел http://support.microsoft.com/kb/969307

    Но по ней непонятно вот что.
    Я так понимаю из этой ссылки, что надо определить значение конфликтующего LinkID.Для этого, как сказано в статье, нам надо найти CN=ms-Exch-Mobile-Mailbox-Policy-Link (для моего случая) в файле с расширением ldf.
    В моем случае- это файл PostExchange2003_schema18.ldf.
    Так вот,я там не нахожу строки CN=ms-Exch-Mobile-Mailbox-Policy-Link.
    Есть другие атрибуты, но этого нет.
    Или я неправильно понял статью?

    Как быть то? Переходить то надо на Е2010...

    Готово ответить на любые вопросы.

    13 ноября 2010 г. 10:15
  • Я бы конечно сначала проконсультировался в тех. поддержках Microsoft и IBM по поводу этого конфликта. Не думаю, что это нарушит работоспособность того и другого ПО, но теоретически может выйти боком, если потом будете использовать какой-либо софт использующий оригинальные link ID (кроме каких-то хитрых хотфиксов к Exchange мне ничего больше в голову не приходит). Как минимум это надо хорошо задокументировать и запомнить на будущее.

    Далее конфликт решается правкой исходного файла: для каждого атриьута, который вызывает конфликт на его ID заменить на специальный, чтобы вызвать auto-generation .  http://msdn.microsoft.com/en-us/library/bb891955(VS.85).aspx

    Принцип описан в статье http://support.microsoft.com/kb/969307


    Сазонов Илья http://www.itcommunity.ru/blogs/sie-wl/
    13 ноября 2010 г. 13:20
    Модератор
  • Добрый день.

    Как указано в http://support.microsoft.com/kb/969307

    выполнил:

     

    1.Попытался узнать конфликтующий LinkID, который ПЫТАЕТЕСЯ добавиться. Я так понимаю, что смотреть надо в ДИСТРИБУТИВЕ Е2010. Нашел его тут D:\E2010SP1\Setup\Data (здесь на новом сервере у меня лежит дистрибутив Е2010).

    В файле schema61.ldf. из этой папки есть запись CN=ms-Exch-Mobile-Mailbox-Policy-Link и в ее описании есть строка такого содержания linkID: 1058 .
    Полное содержимое этого блока такое:

    Код:
    dn: CN=ms-Exch-Mobile-Mailbox-Policy-Link,<SchemaContainerDN>
    changetype: ntdsSchemaAdd
    adminDescription: ms-Exch-Mobile-Mailbox-Policy-Link
    adminDisplayName: ms-Exch-Mobile-Mailbox-Policy-Link
    attributeID: 1.2.840.113556.1.4.7000.102.50668
    attributeSecurityGuid:: iYopH5jeuEe1zVcq1T0mfg==
    attributeSyntax: 2.5.5.1
    isMemberOfPartialAttributeSet: TRUE
    isSingleValued: TRUE
    lDAPDisplayName: msExchMobileMailboxPolicyLink
    name: ms-Exch-Mobile-Mailbox-Policy-Link
    oMSyntax: 127
    oMObjectClass:: KwwCh3McAIVK
    objectCategory: CN=Attribute-Schema,<SchemaContainerDN>
    objectClass: attributeSchema
    linkID: 1058
    schemaIdGuid:: KqC15oH1QkyuYBCP58HttQ==
    searchFlags: 0

    Это то,что меня интересует???В смысле это ТОТ САМЫЙ LinkID, который конфликтует с уже существующим в схеме AD LinkID?

    2.Как написано в статье,определил объект в целевой схеме AD (то есть в той, которая у меня уже существует) объект с таким же LinkID, который пытается добавиться (LinkID:1058). Для этого выполнил на мастере схемы следующую команду:

    C:\Program Files\Support Tools>repadmin /showattr fsmo_schema: ncobj:schema: /fi
    lter:"(&(objectclass=*)(linkid=1058))" /subtree

    Выдалось следующее:

    repadmin running command /showattr against server dc1.domain.su

    DN: CN=camDBSignonRef,CN=Schema,CN=Configuration,DC=domain,DC=su
        2> objectClass: top; attributeSchema
        1> cn: camDBSignonRef
        1> distinguishedName: CN=camDBSignonRef,CN=Schema,CN=Configuration,DC=domain,
    DC=su
        1> instanceType: 0x4 = ( IT_WRITE )
        1> whenCreated: 10/19/2006 20:18:45 Russian Standard Time Russian Daylight T
    ime
        1> whenChanged: 10/19/2006 20:18:45 Russian Standard Time Russian Daylight T
    ime
        1> uSNCreated: 1720006
        1> attributeID: 1.2.840.114050.1.1.1.1.301
        1> attributeSyntax: 2.5.5.1
        1> isSingleValued: FALSE
        1> linkID: 1058
        1> uSNChanged: 1720006
        1> showInAdvancedViewOnly: TRUE
        1> adminDisplayName: camDBSignonRef
        1> oMObjectClass: <9 byte blob>
        1> oMSyntax: 127
        1> searchFlags: 0
        1> lDAPDisplayName: camDBSignonRef
        1> name: camDBSignonRef
        1> objectGUID: 85da99b7-fc15-42b0-9ea0-ba43dcb7aec4
        1> schemaIDGUID: d5923ae1-a16e-41c4-8d62-016ca167b373
        1> isMemberOfPartialAttributeSet: FALSE
        1> objectCategory: CN=Attribute-Schema,CN=Schema,CN=Configuration,DC=domain,D
    C=su
        2> dSCorePropagationData: 01/03/2007 17:59:52 Russian Standard Time Russian
    Daylight Time; 01/01/1601 03:00:05 Russian Standard Time Russian Daylight Time

    Я так понимаю, что конфликтующий LinkID имеет вот этот атрибут CN=camDBSignonRef.

    Кто-нибудь знает,что это такое за атрибут?

     

    Илья, и еще вопрос, если можно. Вы пишите "Далее конфликт решается правкой исходного файла: для каждого атрибута, который вызывает конфликт на его ID заменить на специальный, чтобы вызвать auto-generation". Вопрос такой - для какого атрибута в МОЕМ случае, я должен менять ID ???

    15 ноября 2010 г. 7:41
  • Я думаю, что атрибут CN=camDBSignonRef вы найдете в схеме IBM Cognos

    У вас ms-Exch-Mobile-Mailbox-Policy-Link не может прописаться - вот для него и поставьте "автоматику".


    Сазонов Илья http://www.itcommunity.ru/blogs/sie-wl/
    15 ноября 2010 г. 11:08
    Модератор
  • Добрый день.

    Возникли еще вопросы.

    1.Я уже запускал команды препарации, при этом:

    setup.com /PrepareLegacyEexchangePermissions - выполнилась успешно

    setup.com/PrepareSchema- завершилось ошибкой (собственно по причине здесь и обсуждаемой)

    setup.com/PrepareAD - завершилось ошибкой (по той же причине)


    Мне теперь надо запускать только setup.com/PrepareSchema и setup.com/PrepareAD ? А setup.com /PrepareLegacyEexchangePermissions уже не надо запускать?

    2.И еще вопрос. Видимо от предыдущих запусков команд препарации у меня в C:\Windows\Temp\ExchangeSetup\Setup\Data создалось куча файлов .LDF. Их лучше удалить перед повторным запуском команд препарации или можно не трогать их?

    3.Я так понял,что "автоматику" надо поставить все же в 2 местах в дистрибутиве Е2010

    D:\E2010SP1\Setup\ServerRoles\Common\Setup\Data  и

    D:\E2010SP1\Setup\Data

    Поскольку атрибут ms-Exch-Mobile-Mailbox-Policy-Link встречается в дистрибктиве в файле schema61.ldf, который лежит и в первой папке и во второй. Я правильно понял?

    После ответов на эти вопросы, приступлю к повторному запуску команд препарации.

     


    16 ноября 2010 г. 7:34
  • 1. ТО что уже выполнилось без ошибок можно не выполнять

    2. Временные файлы можно удалить

    3. Я не знаю точно какой файл используется, но я бы исправил оба. И сохранил бы исправленный дистрибутив, чтобы ставить только с него в последующем.


    Сазонов Илья http://www.itcommunity.ru/blogs/sie-wl/
    16 ноября 2010 г. 17:05
    Модератор
  • Благодарю за ответ.

    Еще вопрос - не совсем понял Пункт 5 по этой ссылке http://support.microsoft.com/kb/969307

    Я так понял, что там говориться, что надо обновить LinkID для обратных линков. Я просто не совсем понял этот пункт 5. Меня он касается или нет?

     

    17 ноября 2010 г. 7:47
  • Добрый день.

    Сегодня снова запустил setup.com/PrepareSchema, предварительно подправив LinkID у ms-Exch-Mobile-Mailbox-Policy-Link в дистрибутиве Е2010, заменив LinkID на 1.2.840.113556.1.2.50, чтобы вызвать автогенереацию LinkID. Поменял в файле schema61.ldf в папках

    D:\E2010SP1\Setup\ServerRoles\Common\Setup\Data  и

    D:\E2010SP1\Setup\Data

    В других местая я не нашел этого атрибута.

    При изменении схемы выдается абсолютно та же ошибка!!!

    There was an error while running 'ldifde.exe' to import the schema file 'C:\Windows\Temp\ExchangeSetup\Setup\Data\PostExchange2003_schema18.ldf' . The error code is: 8245. More details can be found in the error file: 'C:\Users\admin\AppData\Local\Temp\ldif.err'

    Почему ругань идет на   PostExchange2003_schema18.ldf ???Там нет атрибута ms-Exch-Mobile-Mailbox-Policy-Link !!!

    Смотрю ldif.err, в нем опять то же самое:

     

    Entry DN: CN=ms-Exch-Mobile-Mailbox-Policy-Link,CN=Schema,CN=Configuration,DC=domain,DC=su
    Add error on entry starting on line 358: Unwilling To Perform

    The server side error is: 0x2114 Schema update failed: An attribute with the same link identifier already exists.

    The extended server error is:

    00002114: SvcErr: DSID-032602B7, problem 5003 (WILL_NOT_PERFORM), data 8468


    18 ноября 2010 г. 8:22
  • Вот ошибка, которая появляется в журнале Windows:

    Log Name:      Application
    Source:        MSExchange Configuration Cmdlet - Management Console
    Date:          18.11.2010 11:48:18
    Event ID:      4
    Task Category: (1)
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      ex2010.domain.su
    Description:
    The description for Event ID 4 from source MSExchange Configuration Cmdlet - Management Console cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

    If the event originated on another computer, the display information had to be saved with the event.

    The following information was included with the event:

    700
    11
    Install-ExchangeOrganization
    0
    Microsoft.Exchange.Management.Deployment.ScriptExecutionException: The following error was generated when "$error.Clear(); install-ExchangeSchema -LdapFileName ($roleInstallPath + "Setup\Data\"+$RoleSchemaPrefix + "schema18.ldf")" was run: "There was an error while running 'ldifde.exe' to import the schema file 'C:\Windows\Temp\ExchangeSetup\Setup\Data\PostExchange2003_schema18.ldf'. The error code is: 8245. More details can be found in the error file: 'C:\Users\admin\AppData\Local\Temp\ldif.err'". ---> Microsoft.Exchange.Configuration.Tasks.TaskException: There was an error while running 'ldifde.exe' to import the schema file 'C:\Windows\Temp\ExchangeSetup\Setup\Data\PostExchange2003_schema18.ldf'. The error code is: 8245. More details can be found in the error file: 'C:\Users\stepanov\AppData\Local\Temp\ldif.err'
       --- End of inner exception stack trace ---
    {4fbae800-f38a-4cf9-8d83-c5bad29bea23}

    the message resource is present but the message is not found in the string/message table

    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="MSExchange Configuration Cmdlet - Management Console" />
        <EventID Qualifiers="49152">4</EventID>
        <Level>2</Level>
        <Task>1</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2010-11-18T08:48:18.000000000Z" />
        <EventRecordID>663</EventRecordID>
        <Channel>Application</Channel>
        <Computer>ex2010.domain.su</Computer>
        <Security />
      </System>
      <EventData>
        <Data>700</Data>
        <Data>11</Data>
        <Data>Install-ExchangeOrganization</Data>
        <Data>0</Data>
        <Data>Microsoft.Exchange.Management.Deployment.ScriptExecutionException: The following error was generated when "$error.Clear(); install-ExchangeSchema -LdapFileName ($roleInstallPath + "Setup\Data\"+$RoleSchemaPrefix + "schema18.ldf")" was run: "There was an error while running 'ldifde.exe' to import the schema file 'C:\Windows\Temp\ExchangeSetup\Setup\Data\PostExchange2003_schema18.ldf'. The error code is: 8245. More details can be found in the error file: 'C:\Users\admin\AppData\Local\Temp\ldif.err'". ---&gt; Microsoft.Exchange.Configuration.Tasks.TaskException: There was an error while running 'ldifde.exe' to import the schema file 'C:\Windows\Temp\ExchangeSetup\Setup\Data\PostExchange2003_schema18.ldf'. The error code is: 8245. More details can be found in the error file: 'C:\Users\admin\AppData\Local\Temp\ldif.err'
       --- End of inner exception stack trace ---</Data>
        <Data>{4fbae800-f38a-4cf9-8d83-c5bad29bea23}</Data>
      </EventData>
    </Event>

     

    Вот этот блок другой:

    <Data>Microsoft.Exchange.Management.Deployment.ScriptExecutionException: The following error was generated when "$error.Clear(); install-ExchangeSchema -LdapFileName ($roleInstallPath + "Setup\Data\"+$RoleSchemaPrefix + "schema18.ldf")" was run: "There was an error while running 'ldifde.exe' to import the schema file 'C:\Windows\Temp\ExchangeSetup\Setup\Data\PostExchange2003_schema18.ldf'. The error code is: 8245. More details can be found in the error file: 'C:\Users\admin\AppData\Local\Temp\ldif.err'". ---&gt; Microsoft.Exchange.Configuration.Tasks.TaskException: There was an error while running 'ldifde.exe' to import the schema file 'C:\Windows\Temp\ExchangeSetup\Setup\Data\PostExchange2003_schema18.ldf'. The error code is: 8245. More details can be found in the error file: 'C:\Users\admin\AppData\Local\Temp\ldif.err'

     

    Ума не приложу,что делать?

     

    18 ноября 2010 г. 9:04
  • Добрый день.

    Может стоит поставить не автогенерацию для конфликтующего LinkID, а выставить его значение вручную в 11900, как указано здесь http://www.winserverkb.com/Uwe/Forum.aspx/exchange-setup/18985/EXCH-2007-Schema-update-failed-during-Scheme-Prep-LDIF ???

    Честно говоря не понимаю, как теперь поставить Е2010.

    19 ноября 2010 г. 7:39
  • Обнаружил следующее, что может объяснять, откуда в сообщении об ошибке появляется файл PostExchange2003_schema18.ldf.

    Когда запускаю setup.com /PrepareSchema на этапе Copying Setup Files в папке C:\Windows\Temp\ExchangeSetup\Setup\Data появляется множество файлов LDF (они туда откуда-то копируются). В том числе там появляется и файл PostExchange2003_schema18.ldf. Так вот я открыл этот файл во время расширения схемы и обнаружил, ЧТО В НЕМ ЕСТЬ атрибут CN=ms-Exch-Mobile-Mailbox-Policy-Link с LinkID 1058 !!! Но если посмотреть содержимое этого файла в дистрибутиве Е2010 - ТО ТАМ НЕТ АТТРИБУТА CN=ms-Exch-Mobile-Mailbox-Policy-Link с LinkID 1058 !!!

    В связи с этим наблюдением, возникло 2 вопроса:

    1. Откуда копируются файлы LDF в C:\Windows\Temp\ExchangeSetup\Setup\Data ? Если из дистрибутива, то почему при копировании в темповую папку таким странным образом меняется их содержимое???

    2. Можно ли ВО ВРЕМЯ РАСШИРЕНИЯ СХЕМЫ поменять содержимое файла PostExchange2003_schema18.ldf из папке C:\Windows\Temp\ExchangeSetup\Setup\Data, то есть поменять там значение LinkID для аттрибута CN=ms-Exch-Mobile-Mailbox-Policy-Link с LinkID 1058 на 1.2.840.113556.1.2.50 (чтобы вызвать автогенерацию LinkID при импорте в существующую схему)?

    Рассчитываю на ваш ответ-)

    19 ноября 2010 г. 8:14
  • Уважаемый пользователь!
    В вашей теме отсутствует активность в течение последних 5 дней. При отсутствии каких-либо действий в течение 2 последующих дней, тема будет переведена в разряд обсуждений. Вы можете возобновить дискуссию, просто оставив сообщение в данной теме.
    23 ноября 2010 г. 15:02
  • 1. Откуда копируются файлы LDF в C:\Windows\Temp\ExchangeSetup\Setup\Data ? Если из дистрибутива, то почему при копировании в темповую папку таким странным образом меняется их содержимое???

    2. Можно ли ВО ВРЕМЯ РАСШИРЕНИЯ СХЕМЫ поменять содержимое файла PostExchange2003_schema18.ldf из папке C:\Windows\Temp\ExchangeSetup\Setup\Data, то есть поменять там значение LinkID для аттрибута CN=ms-Exch-Mobile-Mailbox-Policy-Link с LinkID 1058 на 1.2.840.113556.1.2.50 (чтобы вызвать автогенерацию LinkID при импорте в существующую схему)?

    Рассчитываю на ваш ответ-)

    Я не анализировал процесс расширения схемы. Но очевидно, что идет распаковка какого-то cab-файла.

    Если уж вы начали править LinkID для атрибута ms-Exch-Mobile-Mailbox-Policy-Link, то придется править и временный файл. Только не "во время" - не успеете :-) Надо посмотреть нельзя ли запустить процесс из папки временных файлов.


    Сазонов Илья http://www.itcommunity.ru/blogs/sie-wl/
    24 ноября 2010 г. 7:24
    Модератор
  • Добрый день.

    Илья, успел я подправить в темповых файлах-)

    В результате в логе в C:\ExchangeSetupLogs\ExchangeSetup.txt после окончания работы команды setup.com /PrepareSchema появилась в конце файла такая запись:

    11.24.2010 02:51:24.0389] [0] The Microsoft Exchange Server setup operation completed successfully.
    [11.24.2010 02:51:24.0405] [0] End of Setup
    [11.24.2010 02:51:24.0405] [0] **********************************************

    Также,чтобы удостовериться,что схема все же расширилась,я запустил на мастере схемы adsiedit и попытался найти там тот проблемный атрибут - ms-Exch-Mobile-Mailbox-Policy-Link. И я его там нашел-). Посмотрел его LinkID (ведь он должен был сгенерироваться автоматически), LinkID какой то странный, со знаком минус (-).Его значение -601021092.

    Также могу сказать,что домен после расширения схемы функционирует нормально,как обычно.

    Вопросы.

    1. Все что я увидел, означает, что схема успешно расширена?

    2. Отрицательное значение LinkID для атрибута ms-Exch-Mobile-Mailbox-Policy-Link - это нормально?

    24 ноября 2010 г. 7:39
  • Ну если написано "The Microsoft Exchange Server setup operation completed successfully", то значит так оно и есть :-)

    Это не отрицательное значение, просто так отображается большое число. Все нормально. Можно ставить основные компоненты Exchange 2010. Только читайте мануал ДО :-)


    Сазонов Илья http://www.itcommunity.ru/blogs/sie-wl/
    24 ноября 2010 г. 10:01
    Модератор
  • Так а разве не надо сначала выполнить еще setup.com /PrepareAD ?

    Эта команда я так понимаю схему уже не меняет, а в расширенной схеме создает какие-то объекты в Active Directory, необходимые для функционирования Е2010?

     

    24 ноября 2010 г. 10:06
  • Вы уже можете ставить систему через GUI: все нужные шаги будут выполнены автоматически.
    Сазонов Илья http://www.itcommunity.ru/blogs/sie-wl/
    24 ноября 2010 г. 10:46
    Модератор
  • Добрый день.

    В общем начал ставить Е2010, по схеме описанной в Exchange Server Deployment Assistant. Ставлю сначала роль сервера клиентского доступа (CAS).

    Запустил setup.exe, выбрал выборочную установку, выбрал роль сервера клиентского доступа для установки.Настроил внешнее доменное имя для сервера клиентского доступа. Далее, в Exchange Server Deployment Assistant написано, что надо настроить на следующем шаге Параметры потока почты.Написано - Выберите сервер Exchange 2003 в группе маршрутизации, к которой будет подключаться Exchange 2010. Нажмите кнопку Обзор, чтобы выбрать сервер Exchange 2003.

    Так вот у меня нет такого пункта - Параметры потока почты. Как такое может быть, или я что-то делаю не так?

    Напомню,Что мне нужна совместная работа Е2010 и Е2003.

    26 ноября 2010 г. 8:27
  • А что у вас следующим пунктом?
    Сазонов Илья http://www.itcommunity.ru/blogs/sie-wl/
    26 ноября 2010 г. 9:52
    Модератор
  • Программа улучшения качества программного обеспечения дальше идет.

    Я проверил такую вещь.Вот если выбрать одновременно установку CAS и Hub Transport, то тогда этот пункт - Параметры потока почты - появляется. Видимо он есть функция Hub Transport, а не CAS. Тогда выходит в Exchange Server Deployment Assistant - косяк в описании процесса установки.

    Допустим я поставлю сразу все роли - CAS , Hub Transport и Mailbox. Но при этом захочу чтоб внешняя почта ходила через старый Е2003.

    Может так работать?

    26 ноября 2010 г. 10:53
  • 1. Все правильно: CAS это только клиентский доступ, а все коннекторы на HUB, в том числе те, которые создаются автоматически для связи с Exchange 2003.

    2. Да такая конфигурация CAS/HUB/MB поддерживается. Если почтовых ящиков несколько сотен, то лучше разделить CAS/HUB вместе и MB отдельно.

    3. Внешняя почта будет ходит как пржде, пока вы ее не перенастроете.


    Сазонов Илья http://www.itcommunity.ru/blogs/sie-wl/
    26 ноября 2010 г. 20:59
    Модератор
  • Спасибо.

    Запустил установку сразу всех ролей. Во время проверки роли Mailbox выдается ПРЕДУПРЕЖДЕНИЕ:

    If Microsoft Outlook 2003 is in use you should replicate the free/busy folder on this server to every other free/busy server in the organization/This step should be performed once setup completes.

    У меня активно используются Общие папки и в Е2010 также будут использоваться.

    Не совсем понял, это сообщение значит,что после установки Е2010 не будут работать общие папки, если что-то не сделать?

    29 ноября 2010 г. 8:48
  • Общие папки в отличие от машрутизации почты автоматически не настраиваются. Вам нужно вручную настроить репликацию общих папок между Exchange 2003 и Exchange 2010.

    К сожалению в документации это отражено не совсем правильно как "перенос", что не подходит для совместной работы двух версий. Смотрите пункт 18 http://technet.microsoft.com/en-us/library/ee332309.aspx

    Вам нужно сделать все как там по ссылке только использовать скрипт AddReplicaToPFRecursive.ps1

    http://blogs.technet.com/b/agobbi/archive/2010/08/04/how-to-move-public-folder-from-exchange-2003-to-exchagne-2010.aspx

    http://technet.microsoft.com/en-us/library/aa997966.aspx

    Можно сделать все тоже самое ручками. Открываете оснастку Exchange 2003, включаете отображение системных папок, для каждой папки черз ее свойства настраиваете репликацию на сервер Exchange 2010. налогично настраиваете обратную репликацию через оснастку Exchange 2010. (Для справки: системных папок 5 шт. плюс ваши собственные папки)


    Сазонов Илья http://www.itcommunity.ru/blogs/sie-wl/
    29 ноября 2010 г. 9:32
    Модератор
  • Не совсем понял, на каком сервере (на Е2010 или на Е2003) необходимо выполнить скрипт AddReplicaToPFRecursive.ps1. На Е2010 видимо?

    Допустим сервер Е2003 так и называется, а Е2010 тоже так и называется в домене.Как тогда будет выглядеть эта команда, если выполнять ее на Е2010?

    Не понял ее синтаксис.
    29 ноября 2010 г. 10:27
  • Запускаем на Е2010 как я понял... Вот так будет правильно?..

    .\AddReplicaToPFRecursive.ps1 -TopPublicFolder "\" -ServerToAdd "exchange2010"

    где exchange2010 - доменное имя сервера Е2010.

    29 ноября 2010 г. 11:00
  • Да, правильно. Параметры описаны в ссылке, которую я привел.

     


    Сазонов Илья http://www.itcommunity.ru/blogs/sie-wl/
    29 ноября 2010 г. 11:25
    Модератор
  • Скрипт запустил. Смотрю закладку Replication в оснастке EMS от Е2003. Вижу, что на этой закладке для многих папок добавилось в репликацию хранилище общих папок сервера Е2010.А для некоторых общих папок- нет.

    Возможно ли такое, из-за того,что учетная запись под которой я запускал скрипт не имеет прав доступа как раз к этим общим папкам, к которым не добавился новый сервер Е2010 в качестве реплицируемого?

    Если так, то что делать?Дать этой учетке полные права на папки и заново запустить скрипт?

    30 ноября 2010 г. 8:30
  • И еще вопрос - для каких именно системных папок должна была настроиться репликация после выполнения скрипта?
    30 ноября 2010 г. 8:43
  •  

    Если так, то что делать?Дать этой учетке полные права на папки и заново запустить скрипт?


    Да руками через оснастку пропишите - быстрее будет :-)
    Сазонов Илья http://www.itcommunity.ru/blogs/sie-wl/
    30 ноября 2010 г. 9:17
    Модератор
  • Системные папки:

    OAB version 2

    OAB version 3a

    OAB version 4

    Schedule+FreeBusy:EX:/o=......

    EX:/o=..../ou=First Administrative Group

    Плюс ваши рабочие папки


    Сазонов Илья http://www.itcommunity.ru/blogs/sie-wl/
    30 ноября 2010 г. 9:21
    Модератор
  • Спасибо, все сделал, общие папки реплицируются...Их у меня около 100 гигабайт, так что небыстрый процесс.

    А следующим шагом можно начать переносить мейлбоксы?

    30 ноября 2010 г. 9:49
  • Я бы долждался окончания репликации: если появятся проблемы у клиентов вам легче будет найти причину.
    Сазонов Илья http://www.itcommunity.ru/blogs/sie-wl/
    30 ноября 2010 г. 13:09
    Модератор
  • Добрый день.

    Появилось пару вопросов

    1.Как определить, что репликация общих папок завершена?

    2.Я так понимаю,что переносить почтовые ящики со старого Е2003 в новый Е2010 можно через старую консоль Exchange System Manager. Соответственно я захожу в эту оснастку и щелкнув по ящику правой кнопкой мыши выбираю Exchange Tasks. Выбираю Move Mailbox. Появляется окно переноса ящика. В поле Current Mailbox Store у меня стоит Fist Storage Group старого сервера Е2003.

    В поле Server (это я так понимаю,куда переносить) стоит Mydomain/Exchange Administrative Group (FYDIBOHF23SPDLT) /имя моего нового сервера Е2010

    А вот в поле Mailbox Store (это я так понимаю хранилище на новом Е2010, куда можно перемещать ящик) - ПУСТО. И ничего не выбрать.

    Соответственно ящик не переместить.

    В чем может быть проблема?

    1 декабря 2010 г. 7:34
  • 1. Посмотрите размер папок :-) Проверьте логи на предмет ошибок репликации

    2. Вас трудно приучить к просмотру документации. :-) http://technet.microsoft.com/en-us/library/dd638187.aspx Все наоборот. Перенос почтовых ящиков выполняется только через новую оснастку. Для каждого почтового ящика делаете Move - создается move request (В GUI вы видите отдельный список) В результате выполнения для каждого запроса формируется лог (в свойствах есь кнопочка для просмотра)


    Сазонов Илья http://www.itcommunity.ru/blogs/sie-wl/
    1 декабря 2010 г. 9:20
    Модератор
  • Спасибо.

    Скажите пожалуйста, а как в GUI EMC 2010 увидеть почтовые ящики, которые находятся на Е2003, чтобы впоследствии сделать Move для них?

    1 декабря 2010 г. 9:45
  • В списке почтовых ящиков на Exchange 2010 отображаются ВСЕ почтовые ящики: дляящиков на Exchange 2003 они помечены как Legacy


    Сазонов Илья http://www.itcommunity.ru/blogs/sie-wl/
    1 декабря 2010 г. 18:46
    Модератор
  • Илья, спасибо.

    Вообщем решил начать со своего ящика. Он перенесся корректно, Outlook (у меня Outlook 2010) сам подцепился к нужному новому серверу, вот только непонятно следующее:

    1.Почему то на сервере Е2010 были остановлены некоторые службы Exchange 2010, например Microsoft Exchange RPC Access, хотя тип запуска у нее стоит - Авто. Я ее запустил и Outlook только после этого подключился к сеовеоу Е2010. Проверил - почта ходит и внутренняя и внешняя, общие папки открываются.

    2. При запуске  Outlook стало выдаваться предупреждение следующего содержания:

    Оповещение системы безопасности

    имя моего нового сервера Е2010

    Информация, которой вы обмениваетесь с этим сайтом не может быть просмотрена или изменена другими.Тем не менее имеются замечания по сертификату безопасности сайта. Сертификат безопасности выдан организацией, не выбранной в качестве доверенной.Посмотрите сертификат, чтобы определить, следует ли доверять центру сертификации.

    Продолжить?

    Я нажимаю Да 2 раза и все работает. Хотелось бы убрать это окно.Я так понимаю, это делается установкой сертификата от доверенного центра сертификации, например Thawte? Или есть другие способы?

    Спасибо.

     

    2 декабря 2010 г. 8:16
  • И еще заметил особенность связанную с общими папками.

    Например в определенную общую папку попадает письмо. Мои коллеги, у которых Outllok подключен еще к старому Е2003 и соответственно ящик на нем, видят это письмо в общей папке.А я не вижу. Хотя сама общая папка (ее реплика на новом Е2010) у меня видна. Как настроить,чтобы репликация общих папок на новый Е2010 происходила сразу после после получения письма в общую папку?

    2 декабря 2010 г. 8:27
  • 1. Описание назначения службы Microsoft Exchange RPC Access http://technet.microsoft.com/en-us/library/ee332317.aspx

    Т.е. она нужна как раз для доступа к Public Folder. Если она не запустилась при старте сервра, то смотрите логи на предмет ошибок.

    2. По умолчанию на всех серверах Exchange 2010 генерируется самоподписанный сертификат. Он позволяет работать с системой, но он не может быть автоматически проверен клиентом и поэтому выдается предупреждение.

    Как создать сертификат http://technet.microsoft.com/en-us/library/dd351057.aspx Его можно сгенерровать на внутреннем Центре сертификаци в домене или купить коммерческий. В любом случае надо тщательно спроектровать внутренние и внешние имена - они должны быть все включены в SAN-сертификат.

    3.По поводу репликации: посмотрите в свойствах папки как у вас настроена репликация, например, раз в час, то файл не появится мгновенно.


    Сазонов Илья http://www.itcommunity.ru/blogs/sie-wl/
    2 декабря 2010 г. 9:24
    Модератор
  • Репликация настроена - Always Run.

    Я так понимаю,что при этом варианте интеревал репликации для конкретной папки береться из общих настроек репликации хранилища общих папок. Там следующие настройки - Replication Interval for "Always Run" (minutes) = 60 min.

    Что это означает?То что репликация будет проводиться раз в час, или что ДЛИТЕЛЬНОСТЬ, которая отводиться на репликацию = 60 мин?

    2 декабря 2010 г. 9:33
  • Это именно интервал - у вас раз в час. По умолчанию обычно стоит 15 минут.

    http://technet.microsoft.com/en-us/library/bb123953(EXCHG.65).aspx

    http://technet.microsoft.com/en-us/library/bb629665.aspx


    Сазонов Илья http://www.itcommunity.ru/blogs/sie-wl/

    2 декабря 2010 г. 10:24
    Модератор
  • Уважаемый пользователь!
    В вашей теме отсутствует активность в течение последних 5 дней. При отсутствии каких-либо действий в течение 2 последующих дней, тема будет переведена в разряд обсуждений. Вы можете возобновить дискуссию, просто оставив сообщение в данной теме.
    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий
    7 декабря 2010 г. 8:43
  • Добрый день.

    Неспешно переношу ящики с Е2003 на Е2010. Возникла одна проблема.Появляется она только на клиентах Outlook 2003. Заключается она в следующем. При синхронизации Автономной адресной книги в Outlook 2003 появляется сообщение в папке Ошибки синхронизации:

    11:45:59 Синхронизатор версии 11.0.8161
    11:45:59 Синхронизация почтового ящика ''Иванов Иван''
    11:45:59 Готово
    11:45:59 Автономная адресная книга Microsoft Exchange
    11:45:59     0X8004010F

    При этом, если в Outlook 2003 нажимаю Создать сообщение - Кому, то все же какую-то адресную книгу вижу, но я так полагаю,что она просто не обновляется, так как при попытке ее загрузить появляется та же ошибка.

    На Outlook 2007 и 2010 такой проблемы нет. Перейти везде на 2007 и 2010 не могу, так как лицензии...

    Как решить, не подскажите?

    8 декабря 2010 г. 9:24
  • Вы закрывайте темы, когда вопрос исчерпан, помечайте полезные ответы, а новые вопросы задавайте в отдельных темах, а то получается каша в ответах..
    Сазонов Илья http://www.itcommunity.ru/blogs/sie-wl/
    9 декабря 2010 г. 11:13
    Модератор
  • Проблема с установкой Exchange Server 2010 на виртуальной машине.

    Делал всё основываясь вот на эту инструкцию http://okrylov.wordpress.com/2009/04/16/exchange2010-install/

    Значит всё что нужно установлено, на ВМ поднят домен так же сама ВМ и является его контроллером. Начинаем ставить, выбираю выборочную установку, добавляю вот эти роли:

    http://i001.radikal.ru/1012/96/1900dcf748fc.jpg

    Организации и клиентские компьютеры не имеют установленных Outlook 2003 и Entourage. Роль сервера клиентского доступа выбираю тот домен который поднят на ВМ. И вот такую ошибку выдаёт в конце:

    http://i004.radikal.ru/1012/ac/f220c013af34.jpg

    Подскажите пожалуйста что я не так сделал!?

     

     

    23 декабря 2010 г. 11:49
  • Подскажите пожалуйста что я не так сделал!?

    Вы разместили свой вопрос 1. в чужой теме, 2. после моей просьбы задавать новые вопросы в новой теме :-)
    Сазонов Илья http://www.itcommunity.ru/blogs/sie-wl/
    24 декабря 2010 г. 19:34
    Модератор