none
Ошибка обновления boot файла WinPE RRS feed

  • Вопрос

  • Всем привет!

    Хотел включить поддержку командной строки в загрузочном образе Boot image (x86) & (x64) WinPE на SCCM 2007 R3, но почему то падает в такую вот ошибку...

     Error: Boot image to update: 
    Microsoft Windows PE (x64)

       Error: Actions to perform: 
    Add ConfigMgr binaries
    Enable Windows PE command line support
    Add drivers

       Error: Failed to import the following drivers:

       Error: The wizard detected the following problems when updating the boot image.
    The ConfigMgr Provider reported an error.: ConfigMgr Error Object:
    instance of SMS_ExtendedStatus
    {
    Description = "Failed to insert OSD binaries into the WIM file";
    ErrorCode = 2152205056;
    File = "c:\\qfe\\nts_sms_fre\\sms\\siteserver\\sdk_provider\\smsprov\\sspbootimagepackage.cpp";
    Line = 4262;
    ObjectInfo = "CSspBootImagePackage::PreRefreshPkgSrcHook";
    Operation = "ExecMethod";
    ParameterInfo = "SMS_BootImagePackage.PackageID=\"BEE000CA\"";
    ProviderName = "WinMgmt";
    StatusCode = 2147749889;
    };

    Хотя я всего лишь хочу поставить галочку, без каких либо добавлений в образ. Что не так?

    26 июля 2012 г. 5:55

Ответы

  • Посмотрите smsprov.log там может быть дополнительная информация об ошибке
    • Помечено в качестве ответа Old_Navy 30 июля 2012 г. 9:04
    26 июля 2012 г. 6:56
    Отвечающий
  • в boot образе
    • Помечено в качестве ответа Old_Navy 30 июля 2012 г. 9:03
    26 июля 2012 г. 8:53
    Отвечающий
  • в boot образе

    Еще один вопрос, теперь как мне это сделать, удалить драйвера из boot образа? Если есть линк где это описывается, скиньте пожалуйста? 

    На той же вкладке, где вы ставили галочку.
    • Помечено в качестве ответа Old_Navy 30 июля 2012 г. 9:03
    26 июля 2012 г. 12:55
    Отвечающий
  • Запустите консоль локально на сервере с повышенными правами и попробуйте повторить операцию еще раз. На момент выполнения операции попробуйте остановить антивирус, судя по сообщению, что-то держит файлы.

    Антивирус стоит Symantec Endpoint Protection, остановил службу, локально запустил консоль SCCM с правами доменного админа, но все равно не получилось. А есть ли лог, где фиксируется работоспособность этих двух загрузочных образов? Я нашел линк по логам SCCM, но в списке такой лог не нашел. http://technet.microsoft.com/en-us/library/bb892800.aspx

    Да, конечно, такой лог есть, только это лог консоли, а не лог служб SCCM. Также посмотрите лог DISM'а, он может оказаться гораздо информативнее.
    • Изменено Vladimir ZelenovEditor 30 июля 2012 г. 5:33
    • Помечено в качестве ответа Old_Navy 30 июля 2012 г. 9:03
    30 июля 2012 г. 5:30
    Отвечающий
  • решил проблему следующим образом:

    1. удалил загрузочные образы WinPE с DP

    2. удалил их из консоли Operating System Deployment - Boot Images

    3. переустановил WAIK из дистрибутива SCCM SP2 из папки SMSSETUP\WAIK

    4. добавил заново загрузочные образы WinPE из директории \\sccm server\site server\OSD\boot\x64\boot.wim и \\sccm server\site server\OSD\boot\x86\boot.wim

    5. поставил галочку Enable Command Support на обоих образах и обновил точку распространения.

    Спасибо всем, кто участвовал в решении моей проблемы! Данный вопрос можно считать закрытым! 

    30 июля 2012 г. 13:14

Все ответы

  • Посмотрите smsprov.log там может быть дополнительная информация об ошибке
    • Помечено в качестве ответа Old_Navy 30 июля 2012 г. 9:04
    26 июля 2012 г. 6:56
    Отвечающий
  • Посмотрите smsprov.log там может быть дополнительная информация об ошибке

    Нашел там такие ошибки

    [2424][Thu 07/26/2012 10:54:11]:SMS ACCOUNT WORK SUCCEEDED
    [2424][Thu 07/26/2012 10:54:11]:CExtUserContext::LeaveThread : Releasing IWbemContextPtr=36918200
    [20D0][Thu 07/26/2012 10:54:12]:WIM_MSG_ERROR: File that failed = C:\WINDOWS\Temp\BootImages\{08892A51-0108-4095-88A7-0FCD42DEA87D}\mount\sms\bin\x64\TsCore.dll 
    [20D0][Thu 07/26/2012 10:54:12]:WIM_MSG_ERROR: Win32 Error 1450 
    [26EC][Thu 07/26/2012 10:54:12]:WIM_MSG_ERROR: File that failed = C:\WINDOWS\Temp\BootImages\{08892A51-0108-4095-88A7-0FCD42DEA87D}\mount\Users\Default\NTUSER.DAT 
    [26EC][Thu 07/26/2012 10:54:12]:WIM_MSG_ERROR: Win32 Error 1450 
    [26EC][Thu 07/26/2012 10:54:12]:WIM_MSG hit default 
    [26EC][Thu 07/26/2012 10:54:12]:WIM_MSG hit default 
    [26EC][Thu 07/26/2012 10:54:12]:WIM_MSG hit default 
    [26EC][Thu 07/26/2012 10:54:12]:WIM_MSG hit default 
    [26EC][Thu 07/26/2012 10:54:12]:ERROR> failed to unmount wim file err=1450
    [26EC][Thu 07/26/2012 10:54:12]:Failed to delete the file \\SCCM Server\Site Server\osd\boot\x64\{7EA0CA90-ED2A-4AB7-8E59-8D4B3A628710}.wim. Error code 32
    [26EC][Thu 07/26/2012 10:54:12]:
    *
    *
    c:\qfe\nts_sms_fre\sms\siteserver\sdk_provider\smsprov\sspbootimagepackage.cpp(4262) : Failed to insert OSD binaries into the WIM file
    *
    *
    [26EC][Thu 07/26/2012 10:54:12]:
    *
    *
    Failed to insert OSD binaries into the WIM file 
    *
    *

    В чем может быть проблема?

    26 июля 2012 г. 7:05
  • Скорее всего в boot-образ добавлены драйвера, к которым был изменен физический путь. Система не может их добавить в образ и процесс падает с ошибкой.

    26 июля 2012 г. 7:11
    Отвечающий
  • Скорее всего в boot-образ добавлены драйвера, к которым был изменен физический путь. Система не может их добавить в образ и процесс падает с ошибкой.

    Можете подсказать как исправить ошибку, чтобы я мог включить поддержку командной строки? Или придется удалять эти загрузочные образы с DPs и заново их устанавливать?
    26 июля 2012 г. 7:24
  • Нет, попробуйте просто куда нибудь на бумажку выписать или просто сохранить отчет по используемым драйверам в образе, удалить все драйвера из образа и включить поддержку коммандной строки, затем разобраться с тем, каких драйверов уже не хватает в шаре, добавить их в драйверы, затем уже добавить их в boot-образ.

    26 июля 2012 г. 7:49
    Отвечающий
  • Нет, попробуйте просто куда нибудь на бумажку выписать или просто сохранить отчет по используемым драйверам в образе, удалить все драйвера из образа и включить поддержку коммандной строки, затем разобраться с тем, каких драйверов уже не хватает в шаре, добавить их в драйверы, затем уже добавить их в boot-образ.

    В каком образе посмотреть используемые драйвера, в boot образе или Windows 7? 
    26 июля 2012 г. 8:45
  • в boot образе
    • Помечено в качестве ответа Old_Navy 30 июля 2012 г. 9:03
    26 июля 2012 г. 8:53
    Отвечающий
  • в boot образе
    Еще один вопрос, теперь как мне это сделать, удалить драйвера из boot образа? Если есть линк где это описывается, скиньте пожалуйста? 
    26 июля 2012 г. 9:05
  • в boot образе

    Еще один вопрос, теперь как мне это сделать, удалить драйвера из boot образа? Если есть линк где это описывается, скиньте пожалуйста? 

    На той же вкладке, где вы ставили галочку.
    • Помечено в качестве ответа Old_Navy 30 июля 2012 г. 9:03
    26 июля 2012 г. 12:55
    Отвечающий
  • в boot образе

    Еще один вопрос, теперь как мне это сделать, удалить драйвера из boot образа? Если есть линк где это описывается, скиньте пожалуйста? 


    На той же вкладке, где вы ставили галочку.
    Получается дело не в драйверах, потому что там у меня нет ни одного драйвера в списке.
    27 июля 2012 г. 4:14
  • Запустите консоль локально на сервере с повышенными правами и попробуйте повторить операцию еще раз. На момент выполнения операции попробуйте остановить антивирус, судя по сообщению, что-то держит файлы.

    27 июля 2012 г. 7:27
    Отвечающий
  • Запустите консоль локально на сервере с повышенными правами и попробуйте повторить операцию еще раз. На момент выполнения операции попробуйте остановить антивирус, судя по сообщению, что-то держит файлы.

    Антивирус стоит Symantec Endpoint Protection, остановил службу, локально запустил консоль SCCM с правами доменного админа, но все равно не получилось. А есть ли лог, где фиксируется работоспособность этих двух загрузочных образов? Я нашел линк по логам SCCM, но в списке такой лог не нашел. http://technet.microsoft.com/en-us/library/bb892800.aspx
    30 июля 2012 г. 4:20
  • Запустите консоль локально на сервере с повышенными правами и попробуйте повторить операцию еще раз. На момент выполнения операции попробуйте остановить антивирус, судя по сообщению, что-то держит файлы.

    Антивирус стоит Symantec Endpoint Protection, остановил службу, локально запустил консоль SCCM с правами доменного админа, но все равно не получилось. А есть ли лог, где фиксируется работоспособность этих двух загрузочных образов? Я нашел линк по логам SCCM, но в списке такой лог не нашел. http://technet.microsoft.com/en-us/library/bb892800.aspx
    К дополнению, моя учетка доменного админа также находится в группе локальных администраторов на сервере SCCM.
    30 июля 2012 г. 4:22
  • Запустите консоль локально на сервере с повышенными правами и попробуйте повторить операцию еще раз. На момент выполнения операции попробуйте остановить антивирус, судя по сообщению, что-то держит файлы.

    Антивирус стоит Symantec Endpoint Protection, остановил службу, локально запустил консоль SCCM с правами доменного админа, но все равно не получилось. А есть ли лог, где фиксируется работоспособность этих двух загрузочных образов? Я нашел линк по логам SCCM, но в списке такой лог не нашел. http://technet.microsoft.com/en-us/library/bb892800.aspx
    К дополнению, моя учетка доменного админа также находится в группе локальных администраторов на сервере SCCM.
    30 июля 2012 г. 4:22
  • Запустите консоль локально на сервере с повышенными правами и попробуйте повторить операцию еще раз. На момент выполнения операции попробуйте остановить антивирус, судя по сообщению, что-то держит файлы.

    Антивирус стоит Symantec Endpoint Protection, остановил службу, локально запустил консоль SCCM с правами доменного админа, но все равно не получилось. А есть ли лог, где фиксируется работоспособность этих двух загрузочных образов? Я нашел линк по логам SCCM, но в списке такой лог не нашел. http://technet.microsoft.com/en-us/library/bb892800.aspx

    Да, конечно, такой лог есть, только это лог консоли, а не лог служб SCCM. Также посмотрите лог DISM'а, он может оказаться гораздо информативнее.
    • Изменено Vladimir ZelenovEditor 30 июля 2012 г. 5:33
    • Помечено в качестве ответа Old_Navy 30 июля 2012 г. 9:03
    30 июля 2012 г. 5:30
    Отвечающий
  • Последний раз, когда я пытался произвести миграцию, в логе DICM 2 раза повторяются такие ошибки

    2012-07-27 09:35:32, Info                  CBS    Failed to find a matching version for servicing stack: C:\WINDOWS\TEMP\BootImages\{59055F0E-C668-4607-B7A0-2AB74A6DA9C0}\mount\Windows\WinSxS\x86_microsoft-windows-servicingstack_31bf3856ad364e35_6.1.7600.16385_none_0935b76c289e0fd5\ [HRESULT = 0x80070490 - ERROR_NOT_FOUND]
    2012-07-27 09:35:32, Info                  CBS    Failed to find servicing stack directory in online store. [HRESULT = 0x80070490 - ERROR_NOT_FOUND]
    2012-07-27 09:35:32, Info                  CBS    Must be doing offline servicing, using stack version from: C:\WINDOWS\TEMP\BootImages\{59055F0E-C668-4607-B7A0-2AB74A6DA9C0}\mount\Windows\WinSxS\x86_microsoft-windows-servicingstack_31bf3856ad364e35_6.1.7600.16385_none_0935b76c289e0fd5\cbscore.dll
    2012-07-27 09:35:32, Info                  CBS    Loaded Servicing Stack v6.1.7600.16385 with Core: C:\WINDOWS\TEMP\BootImages\{59055F0E-C668-4607-B7A0-2AB74A6DA9C0}\mount\Windows\WinSxS\x86_microsoft-windows-servicingstack_31bf3856ad364e35_6.1.7600.16385_none_0935b76c289e0fd5\cbscore.dll
    2012-07-27 09:35:33, Info                  CSI    00000001@2012/7/27:04:35:33.075 WcpInitialize (wcp.dll version 0.0.0.6) called (stack @0x2806d85e @0x334750a4 @0x33451695 @0x1a0415fd @0x1a0417c4 @0x1a02331b)
    2012-07-27 09:35:33, Info                  CBS    Failed to get proc address for CMP_GetServerSideDeviceInstallFlags [HRESULT = 0x8007007f - ERROR_PROC_NOT_FOUND]
    2012-07-27 09:35:33, Info                  CBS    Failed to load CfgMgr32 DLL. [HRESULT = 0x8007007f - ERROR_PROC_NOT_FOUND]
    2012-07-27 09:35:33, Info                  CBS    Could not load SrClient DLL from path: SrClient.dll.  Continuing without system restore points.

    Или я тогда пытался обновить DP загрузочных образов, точно не помню. Где тут копать? И с чем эти ошибки могут быть связаны?

    30 июля 2012 г. 6:07
  • Есть ли еще какие нибудь решения проблемы с загрузочными образами WinPE, чтобы включить поддержку командной строки?
    30 июля 2012 г. 9:30
  • решил проблему следующим образом:

    1. удалил загрузочные образы WinPE с DP

    2. удалил их из консоли Operating System Deployment - Boot Images

    3. переустановил WAIK из дистрибутива SCCM SP2 из папки SMSSETUP\WAIK

    4. добавил заново загрузочные образы WinPE из директории \\sccm server\site server\OSD\boot\x64\boot.wim и \\sccm server\site server\OSD\boot\x86\boot.wim

    5. поставил галочку Enable Command Support на обоих образах и обновил точку распространения.

    Спасибо всем, кто участвовал в решении моей проблемы! Данный вопрос можно считать закрытым! 

    30 июля 2012 г. 13:14