none
Не загружаються документы на Портал RRS feed

  • Вопрос

  • Добрый день! Буквально вчера восстановил корпоративный Портал, пересоздав БД конфигурации SP2010, все отлично заработало, база контента схватилась без проблем, а вот файлы загрузить на портал никто не может. Выходит такая ошибка:

    В журнале появилось много ошибок вот текст:

    Message ID:11, Level:ERR , Process:6116, Thread:8
    Exception thrown:
    Operation: Exception
    BlobStoreId: 0
    Log Time: 05.03.2013 9:39:56
    Exception: Microsoft.Data.SqlRemoteBlobs.RemoteBlobUsageException: The specified blob store <1> could not be found in the current database.
    ExceptionType:      Usage
    ExceptionCode:      BlobStoreNotFound
    Request Information not set.
    Session Information:
    Session Configuration:
    ConfigItemList with 11 items.
    Key: <blob_store_operation_retry_attempts>, Value:<3>, ConfigFormat: <Number>, Required Level: <Server>
    Key: <configuration_check_period>, Value:<time 00:00:00>, ConfigFormat: <Duration>, Required Level: <Application>
    Key: <db_config_version>, Value:<4>, ConfigFormat: <Number>, Required Level: <Server>
    Key: <disable_pool_slicing>, Value:<false>, ConfigFormat: <Boolean>, Required Level: <Administrator>
    Key: <garbage_collection_time_window>, Value:<days 30>, ConfigFormat: <Duration>, Required Level: <Administrator>
    Key: <gco_enum_num_blobs_per_iteration>, Value:<1000>, ConfigFormat: <Number>, Required Level: <Server>
    Key: <maintain_blob_id_compatibility>, Value:<false>, ConfigFormat: <Boolean>, Required Level: <Administrator>
    Key: <min_client_library_version_required>, Value:<10.0.0.0>, ConfigFormat: <Version>, Required Level: <Server>
    Key: <min_client_library_version_supported>, Value:<10.0.0.0>, ConfigFormat: <Version>, Required Level: <Server>
    Key: <rbs_schema_version>, Value:<10.50.0.0>, ConfigFormat: <Version>, Required Level: <Server>
    Key: <set_trust_server_certificate>, Value:<true>, ConfigFormat: <Boolean>, Required Level: <Server>

    Provider Session Details:
    ProviderSession. Id: <1>, Name: <RBSFSStore>, Type: <Filestream>, StoreVersion: <1.0.0.0>, Location: <Data Source=portal.***.**;Initial Catalog=WSS_Content;Integrated Security=True;Application Name="Remote Blob Storage FILESTREAM Provider">
    Core Configuration:
    Extended Configuration:


    ConnectionInfo:
    ConnectionString:      Data Source=portal.dtech.kz;Initial Catalog=WSS_Content;Integrated Security=True;Enlist=False;Asynchronous Processing=False;Connect Timeout=15
    ConnectionTimeout:     15
    ConnectionState:       Open

    Provider Session Information not set.

    Также в свойствах БД не задан путь к Blobstore, следующий скриншот

    Хотя на диске С есть  папка Blobstore

    В общем переры кучу информации, но решения так и не нашел, кто сталкивался помогите пожалуйста, подскажите куда надо копать.

    Нашел такую вот статью http://technet.microsoft.com/en-us/library/ee748641.aspx 

    Но выполнить выполнить запрос SQL не дает, так как уже есть запись RBS.

    5 марта 2013 г. 10:13

Ответы

  • В общем проблему решил, файлы загружаются! Решил следующим образом, удалил базу контента из приложения в центре администрирования, потом снова ее подключил и все заработало, обидно что прошел почти месяц, а решение было под носом, я кстати обратился в службу поддержки и создал там заявку почти месяц переписывались со специалистом, но не смогли решить проблему. В общем я думаю что глюк произошел как раз во время подключения БД контента к приложению. В общем проблема решена, всем кто помогал советами огромное спасибо.
    • Помечено в качестве ответа Has85 4 апреля 2013 г. 10:21
    4 апреля 2013 г. 10:20

Все ответы

  • Есть ли свободное место на диске где расположена контент БД?
    5 марта 2013 г. 15:22
  • Есть ли свободное место на диске где расположена контент БД?
    Да места предостаточно, на самом диске 216ГБ свободно и на hyper-v хосте где развернута виртуальная машина свободно 30ГБ.
    5 марта 2013 г. 17:05
  • Здравствуйте Has85,

    Вам удалось решить данную проблему? 

    Если да, то будьте добры написать как, чтобы это помогло и другим пользователям.

    28 марта 2013 г. 9:26
    Модератор
  • Нет проблема до сих пор не решена. Как найду решение отпишусь обязательно.
    1 апреля 2013 г. 4:23
  • На старой БД, поставьте порог узлов на один меньше, чем сейчас. А максимум текущем количеством.
    Создайте еще одну контентную БД.
    Создайте новый узел.
    Загрузите документ.
    Только для теста. Дальше подскажем.


    http://sharepoint3000.blogspot.ru/ Мой блог, не судите строго- только начинаю.

    1 апреля 2013 г. 5:23
  • Судя из лога видно, что проблема не в БД, а в BLOB, то есть файловым ресурсом, на котором сохраняются данные. Вы его случайно не меняли, или доступ на него может быть изменён?

    Sergey A Belskiy - MS SharePoint Consultant, MCP, MCTS, MCPD || My blog || My Twitter || My Facebook


    2 апреля 2013 г. 8:01
    Модератор
  • Понятно, что не в БД. Но если BLOB криво включен на БД, создав вторую мы проверим.


    HAS85 же и пишет, что восстановил. Видимо настройки BLOB не до поднял или криво восстановил.


    2 апреля 2013 г. 8:24
  • Андрей, подскажите новичку. где менять этот порог узлов?
    Я создал контент базу, установил RBS, ниже выкладываю скриншоты, теперь вопрос где мне создать узел? Заранее спасибо.

    4 апреля 2013 г. 3:47
  • В общем создал новое web  приложение, подключил к этому приложению новую контент базу и создал семейтство сайтов, документы загружаются, как теперь починить основной портал?
    4 апреля 2013 г. 5:35
  • На счет RBS поторопились.
    Смотрите там где Вы создавали контентную БД. В ней же и указывается порог.
    Лучше удалите . Создайте новую без RBS. для чистоты проверки. Так мы сможем точно понять, что портал восстановлен правильно, что ошибка только в RBS настройках WSS_CONTENT.
    Центр администрирования - Управление базами данных контента.
    Заходим в БД. - и меняем параметры
     Число сайтов, по достижении которого выдается предупреждение
    и
    Максимальное число сайтов, которое может быть создано в этой базе данных

    Узел же новый создавать нужно так-

    Центр администрирования-Управление приложениями-Создание семейства веб-сайтов

    В Вашей новой БД количество узлов должно стать на 1-цу больше.

    Я уверен, что с новой контентной БД должно быть все в порядке.
    Дальше нужно будет искать ошибку, где Вы и что Вы не так восстановили и как данные перенести вытащить или так далее.
    Здесь будет сложная работа. Попробуйте самостоятельно научиться восстанавливать с какой ни будь экспериментальной контентной БД с RBS.

     


    http://sharepoint3000.blogspot.ru/ Мой блог, не судите строго- только начинаю.

    4 апреля 2013 г. 5:52
  • Ок.

    И того Вы файлы видите. Но Вы не можете загрузить новые и отредактировать?

    Я не знаю размеров Вашего портала, но если он не большой. Я бы попытался перетащить данные на новую контентную БД без RBS.

    Руками, экспортом импортом или с помощью ПО 3-х разработчиков и тд.


    http://sharepoint3000.blogspot.ru/ Мой блог, не судите строго- только начинаю.

    4 апреля 2013 г. 6:08
  • Да именно так файлы вижу, но загрузить и отредактировать не могу, а как перетащить данные в ручную?  Портал не большой, размер загруженных документов 6ГБ.
    4 апреля 2013 г. 7:37
  • Вы можете попробовать узлы забекапить и на другом портале развернуть?

    http://blogs.msdn.com/b/russmax/archive/2009/10/21/sharepoint-2010-granular-backup-restore-part-1.aspx

    Вы вообще если файлы себе перетащите на рабочий стол редактировать можете?


    http://sharepoint3000.blogspot.ru/ Мой блог, не судите строго- только начинаю.

    4 апреля 2013 г. 9:21
  • В общем проблему решил, файлы загружаются! Решил следующим образом, удалил базу контента из приложения в центре администрирования, потом снова ее подключил и все заработало, обидно что прошел почти месяц, а решение было под носом, я кстати обратился в службу поддержки и создал там заявку почти месяц переписывались со специалистом, но не смогли решить проблему. В общем я думаю что глюк произошел как раз во время подключения БД контента к приложению. В общем проблема решена, всем кто помогал советами огромное спасибо.
    • Помечено в качестве ответа Has85 4 апреля 2013 г. 10:21
    4 апреля 2013 г. 10:20