none
exchange 2016 powershell команды RRS feed

  • Общие обсуждения

  • Господа, установил 2016, и его Exchange Management Shell не распознает НИОДНОЙ команды связанной с exchange. Да - системные команды видит, он на любую команду пишет следующее(и так на все команды):

    [PS] C:\Windows\system32>New-Mailbox
    New-Mailbox : The term 'New-Mailbox' is not recognized as the name of a cmdlet, function, script file, or operable prog
    ram. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.
    At line:1 char:1
    + New-Mailbox
    + ~~~~~~~~~~~
        + CategoryInfo          : ObjectNotFound: (New-Mailbox:String) [], CommandNotFoundException
        + FullyQualifiedErrorId : CommandNotFoundException

    что за беда???

    18 февраля 2016 г. 20:04

Ответы

  • нет, я просто к тому, что новые продукты слишком "сырые"... вернулся к exchange 2010 и все опять работает как часики, в т.ч. и мои любимые команды! )))  :


    • Изменено mitas.admin 21 февраля 2016 г. 18:25
    21 февраля 2016 г. 18:25

Все ответы

  • А если попытаться подключиться? $Session = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri https://<ServerFQDN>/PowerShell/ –Credentials (Get-Credentials) Ящик для этого пользователя создан?через ecp работает?
    19 февраля 2016 г. 5:21
  • Exchange Management Shell не распознает НИОДНОЙ команды связанной с exchange. Да - системные команды видит

    Покажите, что именно говорит EMS при запуске. Сообщения об ошибках, в частности.

    Evgeniy Lotosh // MCSE: Server infrastructure, MCSE: Messaging

    19 февраля 2016 г. 5:31
  • не уверен, что правильно написал команду, я особо не рабираюсь - знаю что должно работать)
    19 февраля 2016 г. 8:21
  • не уверен, что правильно написал команду, я особо не рабираюсь - знаю что должно работать)

    Попробуйте эту команду из обычного виндового powershell запустить.

    Только там внутри get-credential без буквы s на конце, ошибся при написании


    19 февраля 2016 г. 8:28
  • без "s" выдал окно с именем и паролем(ввел админские выдал ошибку в повершеле):

    19 февраля 2016 г. 8:39
  • вот еще вариант:

    19 февраля 2016 г. 8:42
  • А пользователь в группе Organization Management состоит? Что выдает команда
    get-module -all | ft name
    19 февраля 2016 г. 8:50
  • Посмотрите статью:

    https://support.microsoft.com/en-us/kb/2898571

    19 февраля 2016 г. 9:09
  • вот такое пишет:

    19 февраля 2016 г. 11:24
  • Так а все таки...

    Через ecp работает?

    В каких группах состоит пользователь от которого вы запускаете ems?

    19 февраля 2016 г. 12:14
  • ecp - да работает - вот скриншот:

    19 февраля 2016 г. 13:38
  • New? Если не из изменяет память есть Enable-MailBox
    19 февраля 2016 г. 13:42
  • в ответ на эту команду пишет - RemoteSigned

    профиль локальный который build 

    19 февраля 2016 г. 14:09
  • Enable-MailBox - работает, но я ту команду с 2013-го взял... просто нигде нет списка команд на 2016-й
    19 февраля 2016 г. 14:11
  • Enable-MailBox - работает, но я ту команду с 2013-го взял... просто нигде нет списка команд на 2016-й
    Все правильно, для существующего пользователя надо использовать Enable-mailbox. А что вы подразумеваете под командлетами 2016? Они почти все такие же как и в 2013? Еще вопрос у вас только 2016? Вы знаете про Exchange Management Shell and Mailbox Anchoring
    19 февраля 2016 г. 18:50
  • вопрос то касается не конкретно ящиков пользователей, а в целом, что команды не воспринимаются. Думаю снести этот экченж и вернуть 2010-й - с ним вообще никаких проблем не было в т.ч. и с автоопределением outlook и с моими форумами по части рассылок. Короче недоработка.
    19 февраля 2016 г. 22:09
  • вопрос то касается не конкретно ящиков пользователей, а в целом, что команды не воспринимаются. Думаю снести этот экченж и вернуть 2010-й - с ним вообще никаких проблем не было в т.ч. и с автоопределением outlook и с моими форумами по части рассылок. Короче недоработка.
    Коллега, я начинаю в вас сомневаться. Если 2010 полностью удален, вернуть его не получится, с 2013 такая же ситуация. Нельзя поставить младшую версию Exchage после установленной старшей, он об этом говорит при установке.  
    20 февраля 2016 г. 8:43
  • Коллега, а я и не говорил, что я буду делать откат - все ставиться с нуля)
    20 февраля 2016 г. 14:31
  • Коллега, а я и не говорил, что я буду делать откат - все ставиться с нуля)
    Весь лес?
    20 февраля 2016 г. 15:44
  • ага) и все политики и транспорты настраиваются заново - семь раз отрежь, один раз отмерь! )) И это учитывая, что у меня 4 почтовых имени на один почтарь, которые работают по доверенным внешним доменам... )) думаю линуху что ли пересесть...
    • Изменено mitas.admin 20 февраля 2016 г. 17:15
    20 февраля 2016 г. 17:14
  • думаю линуху что ли пересесть...
    Не суметь справиться со сложной системой и со злости перейти на примитивную - признак высокого профессионализма, да... :/

    Evgeniy Lotosh // MCSE: Server infrastructure, MCSE: Messaging

    20 февраля 2016 г. 17:36
  • нет, я просто к тому, что новые продукты слишком "сырые"... вернулся к exchange 2010 и все опять работает как часики, в т.ч. и мои любимые команды! )))  :


    • Изменено mitas.admin 21 февраля 2016 г. 18:25
    21 февраля 2016 г. 18:25
  • ну что эксперты! выяснил я причину такого косяка! неделю ковырял, но выяснил. теперь работает exchange 2016 как надо и команды все обрабатывает, и с ssl проблем нет... мда. Думаю эту уязвимость продукта мелкософцы пусть сами ищут бггг. )))
    6 марта 2016 г. 9:54
  • Поделитесь пожалуйста решением, у меня на одном из 2013 серверов вдруг ченжевый пауэршелл перестал понимать команды:

    [PS] C:\Windows\system32>Get-Exchangeserver
    Get-Exchangeserver : Имя "Get-Exchangeserver" не распознано как имя командлета, функции, файла сценария или выполняемой
     программы. Проверьте правильность написания имени, а также наличие и правильность пути, после чего повторите попытку.
    строка:1 знак:1
    + Get-Exchangeserver
    + ~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : ObjectNotFound: (Get-Exchangeserver:String) [], CommandNotFoundException
        + FullyQualifiedErrorId : CommandNotFoundException

    [PS] C:\Windows\system32>

  • Мне тоже удалось выяснить самостоятельно, проблема была в Credentials.

    5 июня 2017 г. 17:20
  • НЕ работает из за permissions. Зайдите в Active directory и добавьте пользователя в группы. И команды будут работать)