none
Ошибка при перезагрузке лезвия с установленным Hyper-V RRS feed

  • Вопрос

  • Добрый день!

    После установки на одном из лезвий службы Hyper-V лезвие при перезагрузке выкидывает стандартное окошко о завершении работы (активное), думает 15 минут и вылетает в BSOD с последущей ошибкой 1049. До установки службы такого безобразия не было.

    Что имеем в конфигурации: 3 лезвия IBM HS22 почти одинаковой конфигурации (третье лезвие имеет в 2 раза меньше оперативной памяти), дисковое хранилище IBM DS3500 серии. На нем выделены lun-ы персонально для каждого лезвия в качестве загрузочных, и 2 lun-a для всех дополнительно - один кворумный, второй под виртуальные машины. Соответственно, каждое лезвие видит свой загрузочный раздел (только свой) и два раздела вышеуказанных. Пути к дискам двойные, MPIO драйвера установлены, проверено физическим выдергиванием шнура SAS из одного из контроллеров. Операционные системы на 3-х лезвиях - Server 2008 R2 со всеми обновлениями (везде все идентично).  

    ******конфу просто скопировал с другой ветки**********

    На первом лезвии вроде такой ситуации нету, на втором - есть, на третьем - через раз.

    Есть какие нибудь догадки на эту тему?


    27 сентября 2011 г. 12:52

Ответы

  • Не стал морочиться дальше. Поставил Core версию гипервизора, которая, как это ни странно звучит, работает. Правда, в боевой режим пока не входил, ситуация пока на уровне настройки. Потом поставлю скуль на виртуалку и еще пару тяжелых сервисов, погоняю, посмотрю что и как.

     

    ЗЫ. Где-то недавно видел ссылку на некорректную работу гипервизора и процессоров семейства Nehalem, заканчивающуюся синим экраном, правда, с ошибкой, которой у меня не было. Патч от Микрософт был, но отпускаться он отказался. После этого плюнул на полные версии операционок.


    Спасибо вам всем.
    • Изменено vadik7 30 сентября 2011 г. 5:18
    • Помечено в качестве ответа Denis DyagilevEditor 30 сентября 2011 г. 5:22
    30 сентября 2011 г. 5:18

Все ответы

  • Ну, если лезвия одинаковой, конфигурации, то скорее всего (при исправном железе) отличия в прошивках/драйверах или настройках BIOS (маловероятно) .


    Кстати, не всегда последние версии прошивок - лучшие. Так что обратите внимание какие версии прошиты на стабильно работающем лезвии.
    27 сентября 2011 г. 15:16
  • http://support.microsoft.com/kb/2551127 этот хотфикс попробуйте установить.
    27 сентября 2011 г. 16:24
    Модератор
  • Для более точной диагностики стоит воспользоваться средствами отладки - http://msdn.microsoft.com/en-us/windows/hardware/gg463009

    Анализ дампа позволит точнее установить причину.

    http://www.winline.ru/articles/windows_debugging_tools_diagnostika_i_ispravlenije_bsod.php <- тут вкратце описано, как пользоваться средствами отладки.

    28 сентября 2011 г. 3:28
  • Все прошивки лезвий, контроллеров одинаковые.
    28 сентября 2011 г. 3:57
  • Сорри за кривой код ошибки.  Настоящий код - 0x0000009f

    Напомню, что ситуация началась с поднятия службы Hyper-V. До нее все стабильно работало без BSOD-ов.

    28 сентября 2011 г. 5:16
  • Попробуйте поиграть с размером файла подкачки (у меня глюки кончились при 32ГБ = RAM). Драйвера MPIO были от IBM. У них есть утилита командной строки, которая показывает состояние HBA и статус multipath. Удачи).

    P.S. Год назад я наигрался со связкой MS Hyper-V + лезвия IBM HS22 & DS3200. Играли пол-года, вместе со специалистами IBM (нашими и европейцами), поддержкой МС. Меняли по очереди _все_ железо (даже шасси!). Тогда еще небыло SP1 для 2k8 r2. Потом волевым решением решили прекратить попытки заставить все это работать. Перешли на другой продукт и уже год все работает без плясок (даже попыток небыло!). Сейчас с ужасом вспоминаю "бублик" при перезагрузке ноды, который может крутиться до 2х часов, при этом ВМ на ноде были недоступны, всевозможные BSOD, непонятные перезагрузки, различные ошибки VMM. Брр.


    WBR
    • Изменено A7ex Varlamov 29 сентября 2011 г. 4:40
    29 сентября 2011 г. 4:40
  • Не стал морочиться дальше. Поставил Core версию гипервизора, которая, как это ни странно звучит, работает. Правда, в боевой режим пока не входил, ситуация пока на уровне настройки. Потом поставлю скуль на виртуалку и еще пару тяжелых сервисов, погоняю, посмотрю что и как.

     

    ЗЫ. Где-то недавно видел ссылку на некорректную работу гипервизора и процессоров семейства Nehalem, заканчивающуюся синим экраном, правда, с ошибкой, которой у меня не было. Патч от Микрософт был, но отпускаться он отказался. После этого плюнул на полные версии операционок.


    Спасибо вам всем.
    • Изменено vadik7 30 сентября 2011 г. 5:18
    • Помечено в качестве ответа Denis DyagilevEditor 30 сентября 2011 г. 5:22
    30 сентября 2011 г. 5:18
  • Привнесу дополнения. Система заработала без BSOD в холодном режиме (виртуалок не ставил) под управлением Hyper-V 2008 R2 Core (без SP1). Обновления накатил. С сервиспаком проблема такая же, как и на полноценных операционках. По результатам "горячего режима" отпишусь позже, когда подниму несколько сервисов. Дай бог, что бы все заработало...сил уже нет.
    2 октября 2011 г. 13:23
  • Апну тему).


    vadik7, на чем в итоге остановились - остались с МС или перешли к конкурентам?


    WBR

    17 июля 2013 г. 5:21
  • В итоге уже успело сгореть все оборудование, приобрели его снова, сейчас сидим на Hyper-V 3.0. Работает интереснее, но есть свои косяки, которые чутка отравляют жизнь. Пока ищу решения по ним.
    17 июля 2013 г. 5:38