none
Проблем с подключением к Exchange 2013 через autodiscover Outlook 2007 RRS feed

  • Вопрос

  • Здравствуйте.

    Несколько дней мучаюсь, не получается подключить MS Office Outlook 2007 через autodiscover.

    Сертификаты установлены.

    В DNS домена добавил узел A autodiscover.domain

    Пишет ошибку, что нед подключения к Exchange.

    В чем может быть проблема?

    Ввожу в браузере https://autodiscover.domain/autodiscover/autodiscover.xml, просит ввести учетные данные, ввожу и появляется текст следующего содержания:

    <?xml version="1.0" encoding="UTF-8"?> 
    -<Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006"> 
    -<Response> 
    -<Error Id="4255657127" Time="11:11:22.7065867"> 
    <ErrorCode>600</ErrorCode> 
    <Message>Недопустимый запрос</Message> 
    <DebugData/> 
    </Error> 
    </Response> 
    </Autodiscover>

    • Изменено sun victory 23 июля 2015 г. 8:19
    23 июля 2015 г. 8:06

Ответы

  • Это Вы на сервере терминалов пробуете??? А На нем нет случайно Прокси сервера прописанного?? Добавьте сервер Exchange и https://autodiscover.firma.local в зону интрасети. Хотя конечно эт оскорее всего из за сертификата. .Он у Вас не применен.. Попробуйте назначит этот сертификат через ECP для IIS. И еще, в IIS на Default Web Site и Back End в Привязках этот сертификат должен быть указан в типах https

    23 июля 2015 г. 14:52

Все ответы

  • Здравствуйте,

    Попробуйте:

    Microsoft Remote Connectivity Analyzer


    23 июля 2015 г. 8:28
  • Здравствуйте,

    Попробуйте:

    Microsoft Remote Connectivity Analyzer



    У меня Win2003Server. Там я смотрел вроде как данная ось не поддерживается.
    23 июля 2015 г. 8:30
  • Я сейчас вручную сделал настройки подключения  к Exсhange как тут:

    http://wline.ws/post66-exchange-2013-kak-nastroit-outlook-vruchnuyu.html

    У меня получилось подцепиться!

    Но почему-то автоматом не получается.

    23 июля 2015 г. 8:32
  • Здравствуйте,

    Попробуйте:

    Microsoft Remote Connectivity Analyzer


    Я сейчас попробовал. Я так понимаю анализатор пытается подключиться с сайта Microsoft. Видите у меня пока Exchange не подключен на внешнее подключение. Я могу только пока в своем изолированном домене почту отправлять между пользователями.
    23 июля 2015 г. 8:52
  • Попробуйте в Outlook проверку автоконфигурации (http://www.addictivetips.com/microsoft-office/outlook-2010-test-email-auto-configuration/). Только снимите две галки с Guessmart. Потом выложите сбда пожалуйста результат со второй вкладки (Log)

    Blog - Smtp25.ru
    Полезные ссылки - Links

    23 июля 2015 г. 8:59
    Отвечающий
  • Здравствуйте,

    Попробуйте:

    Microsoft Remote Connectivity Analyzer


    Я сейчас попробовал. Я так понимаю анализатор пытается подключиться с сайта Microsoft. Видите у меня пока Exchange не подключен на внешнее подключение. Я могу только пока в своем изолированном домене почту отправлять между пользователями.
    На вкладке КЛИЕНТ установите на тот комп, на котором не работает клиента и укажите нужные данные при старте.. Там все очень досконально расскажет почему не подключается.
    23 июля 2015 г. 9:09
  • Попробуйте в Outlook проверку автоконфигурации (http://www.addictivetips.com/microsoft-office/outlook-2010-test-email-auto-configuration/). Только снимите две галки с Guessmart. Потом выложите сбда пожалуйста результат со второй вкладки (Log)

    Blog - Smtp25.ru
    Полезные ссылки - Links

    Вот что получилоь:

    SMT P=distrib@fgu12t.local Attempting URL ht tps : // MAIL-fgu12.fgu12t.local/AutoDiscover/AutoDiscover.xml found trough SCP AutoDiscover to h ttps : // MAIL-fgu12.fgu12t.local/AutoDiscover/AutoDiscover.xml starting GetLastError=0; httpStatus=401. GetLastError=0; httpStatus=200. AutoDiscover to h ttps: //MAIL-fgu12.fgu12t.local /AutoDiscover /AutoDiscover.xml succeeded (0x000000000)

    23 июля 2015 г. 9:33
  • Здравствуйте,

    Попробуйте:

    Microsoft Remote Connectivity Analyzer


    На вкладке КЛИЕНТ установите на тот комп, на котором не работает клиента и укажите нужные данные при старте.. Там все очень досконально расскажет почему не подключается.

    У меня Windows 2003. При попытке установить выдает ошибку: "Невозможно установить или запустить приложение. Для этого приложения необходимо выполнить обновление системы до версии Microsoft Common Language Runtime 4.0.30319.0"

    • Изменено sun victory 23 июля 2015 г. 10:04
    23 июля 2015 г. 10:03
  • Проверьте, установлен ли Service Pack 3 для Office 2007. Это может быть причиной такой ошибки (если версия SP более старая).

    • Изменено Tema_BYMVP 23 июля 2015 г. 11:28
    23 июля 2015 г. 11:28
  • Проверьте, установлен ли Service Pack 3 для Office 2007. Это может быть причиной такой ошибки.

    Да конечно,SP3 установлен. Более того подключил компьютер к сайту обновлений Microsoft и установил все обновления.

    • Изменено sun victory 23 июля 2015 г. 11:30
    23 июля 2015 г. 11:29
  • Еще покажите полный XML автообнаружения (где вы проверяли его с помощью Outlook). 

    И еще. В Outlook 2010 автообнаружение работает корректно?

    23 июля 2015 г. 11:32
  • Еще покажите полный XML автообнаружения (где вы проверяли его с помощью Outlook). 

    И еще. В Outlook 2010 автообнаружение работает корректно?

    А office 2010 под рукой нет, т.к. нет лицензии.  В загрузках Майкрософт не нашел пробную версию Office2010.

    Вот XML автообнаружения:

    <?xml version="1.0" encoding="utf-8"?>
    <Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
      <Response xmlns="http://schemas.microsoft.com/exchange/autodiscover/outlook/responseschema/2006a">
        <User>
          <DisplayName>distrib</DisplayName>
          <LegacyDN>/o=FKP12/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=770b335197db4872bd876d6813e2805b-distrib</LegacyDN>
          <AutoDiscoverSMTPAddress>distrib@fgu12t.local</AutoDiscoverSMTPAddress>
          <DeploymentId>11ac08ff-d21d-4d18-a687-170ca114a3b8</DeploymentId>
        </User>
        <Account>
          <AccountType>email</AccountType>
          <Action>settings</Action>
          <MicrosoftOnline>False</MicrosoftOnline>
          <Protocol>
            <Type>EXCH</Type>
            <Server>490cbb11-966e-47f7-9370-490d61041993@fgu12t.local</Server>
            <ServerDN>/o=FKP12/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=490cbb11-966e-47f7-9370-490d61041993@fgu12t.local</ServerDN>
            <ServerVersion>73C08414</ServerVersion>
            <MdbDN>/o=FKP12/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=490cbb11-966e-47f7-9370-490d61041993@fgu12t.local/cn=Microsoft Private MDB</MdbDN>
            <PublicFolderServer>mail-fgu12.fgu12t.local</PublicFolderServer>
            <AD>dc02-fgu12.fgu12t.local</AD>
            <ASUrl>https://mail-fgu12.fgu12t.local/EWS/Exchange.asmx</ASUrl>
            <EwsUrl>https://mail-fgu12.fgu12t.local/EWS/Exchange.asmx</EwsUrl>
            <EmwsUrl>https://mail-fgu12.fgu12t.local/EWS/Exchange.asmx</EmwsUrl>
            <EcpUrl>https://mail-fgu12.fgu12t.local/ecp/</EcpUrl>
            <EcpUrl-um>?rfr=olk&amp;p=customize/voicemail.aspx&amp;exsvurl=1&amp;realm=fgu12t.local</EcpUrl-um>
            <EcpUrl-aggr>?rfr=olk&amp;p=personalsettings/EmailSubscriptions.slab&amp;exsvurl=1&amp;realm=fgu12t.local</EcpUrl-aggr>
            <EcpUrl-mt>PersonalSettings/DeliveryReport.aspx?rfr=olk&amp;exsvurl=1&amp;IsOWA=&lt;IsOWA&gt;&amp;MsgID=&lt;MsgID&gt;&amp;Mbx=&lt;Mbx&gt;&amp;realm=fgu12t.local</EcpUrl-mt>
            <EcpUrl-ret>?rfr=olk&amp;p=organize/retentionpolicytags.slab&amp;exsvurl=1&amp;realm=fgu12t.local</EcpUrl-ret>
            <EcpUrl-sms>?rfr=olk&amp;p=sms/textmessaging.slab&amp;exsvurl=1&amp;realm=fgu12t.local</EcpUrl-sms>
            <EcpUrl-publish>customize/calendarpublishing.slab?rfr=olk&amp;exsvurl=1&amp;FldID=&lt;FldID&gt;&amp;realm=fgu12t.local</EcpUrl-publish>
            <EcpUrl-photo>PersonalSettings/EditAccount.aspx?rfr=olk&amp;chgPhoto=1&amp;exsvurl=1&amp;realm=fgu12t.local</EcpUrl-photo>
            <EcpUrl-extinstall>Extension/InstalledExtensions.slab?rfr=olk&amp;exsvurl=1&amp;realm=fgu12t.local</EcpUrl-extinstall>
            <OOFUrl>https://mail-fgu12.fgu12t.local/EWS/Exchange.asmx</OOFUrl>
            <UMUrl>https://mail-fgu12.fgu12t.local/EWS/UM2007Legacy.asmx</UMUrl>
            <OABUrl>https://mail-fgu12.fgu12t.local/OAB/efe5bc1c-91e9-4c77-a78a-deb51309080f/</OABUrl>
            <ServerExclusiveConnect>off</ServerExclusiveConnect>
          </Protocol>
          <Protocol>
            <Type>EXPR</Type>
            <Server>mail-fgu12.fgu12t.local</Server>
            <SSL>Off</SSL>
            <AuthPackage>Ntlm</AuthPackage>
            <ServerExclusiveConnect>on</ServerExclusiveConnect>
            <CertPrincipalName>None</CertPrincipalName>
            <GroupingInformation>Default-First-Site-Name</GroupingInformation>
          </Protocol>
          <Protocol>
            <Type>WEB</Type>
            <Internal>
              <OWAUrl AuthenticationMethod="Basic, Fba">https://mail-fgu12.fgu12t.local/owa/</OWAUrl>
              <Protocol>
                <Type>EXCH</Type>
                <ASUrl>https://mail-fgu12.fgu12t.local/EWS/Exchange.asmx</ASUrl>
              </Protocol>
            </Internal>
          </Protocol>
          <Protocol>
            <Type>EXHTTP</Type>
            <Server>mail-fgu12.fgu12t.local</Server>
            <SSL>Off</SSL>
            <AuthPackage>Ntlm</AuthPackage>
            <ASUrl>https://mail-fgu12.fgu12t.local/EWS/Exchange.asmx</ASUrl>
            <EwsUrl>https://mail-fgu12.fgu12t.local/EWS/Exchange.asmx</EwsUrl>
            <EmwsUrl>https://mail-fgu12.fgu12t.local/EWS/Exchange.asmx</EmwsUrl>
            <EcpUrl>https://mail-fgu12.fgu12t.local/ecp/</EcpUrl>
            <EcpUrl-um>?rfr=olk&amp;p=customize/voicemail.aspx&amp;exsvurl=1&amp;realm=fgu12t.local</EcpUrl-um>
            <EcpUrl-aggr>?rfr=olk&amp;p=personalsettings/EmailSubscriptions.slab&amp;exsvurl=1&amp;realm=fgu12t.local</EcpUrl-aggr>
            <EcpUrl-mt>PersonalSettings/DeliveryReport.aspx?rfr=olk&amp;exsvurl=1&amp;IsOWA=&lt;IsOWA&gt;&amp;MsgID=&lt;MsgID&gt;&amp;Mbx=&lt;Mbx&gt;&amp;realm=fgu12t.local</EcpUrl-mt>
            <EcpUrl-ret>?rfr=olk&amp;p=organize/retentionpolicytags.slab&amp;exsvurl=1&amp;realm=fgu12t.local</EcpUrl-ret>
            <EcpUrl-sms>?rfr=olk&amp;p=sms/textmessaging.slab&amp;exsvurl=1&amp;realm=fgu12t.local</EcpUrl-sms>
            <EcpUrl-publish>customize/calendarpublishing.slab?rfr=olk&amp;exsvurl=1&amp;FldID=&lt;FldID&gt;&amp;realm=fgu12t.local</EcpUrl-publish>
            <EcpUrl-photo>PersonalSettings/EditAccount.aspx?rfr=olk&amp;chgPhoto=1&amp;exsvurl=1&amp;realm=fgu12t.local</EcpUrl-photo>
            <EcpUrl-extinstall>Extension/InstalledExtensions.slab?rfr=olk&amp;exsvurl=1&amp;realm=fgu12t.local</EcpUrl-extinstall>
            <OOFUrl>https://mail-fgu12.fgu12t.local/EWS/Exchange.asmx</OOFUrl>
            <UMUrl>https://mail-fgu12.fgu12t.local/EWS/UM2007Legacy.asmx</UMUrl>
            <OABUrl>https://mail-fgu12.fgu12t.local/OAB/efe5bc1c-91e9-4c77-a78a-deb51309080f/</OABUrl>
            <ServerExclusiveConnect>On</ServerExclusiveConnect>
            <CertPrincipalName>None</CertPrincipalName>
          </Protocol>
          <PublicFolderInformation>
            <SmtpAddress>it@fgu12t.local</SmtpAddress>
          </PublicFolderInformation>
        </Account>
      </Response>
    </Autodiscover>

    23 июля 2015 г. 12:42
  • Попробуйте указать сертификат:

    Set-OutlookProvider EXPR -CertPrincipalName msstd:_YOUR_CERT_NAME_

    Далее выполните iisreset (будет простой сервиса секунд 40) и проверьте автообнаружение снова. Надо чтобы появилось имя сертификата тут:

    <Type>EXPR</Type>
            <Server>mail-fgu12.fgu12t.local</Server>
            <SSL>Off</SSL>
            <AuthPackage>Ntlm</AuthPackage>
            <ServerExclusiveConnect>on</ServerExclusiveConnect>
            <CertPrincipalName>None</CertPrincipalName>

    23 июля 2015 г. 12:56
  • Попробуйте указать сертификат:

    Set-OutlookProvider EXPR -CertPrincipalName msstd:_YOUR_CERT_NAME_


    У меня в Exchnage в EAC сертификат называется Fgu12t Exchange Certificate New.

    Выполнил команду:

    Set-OutlookProvider EXPR -CertPrincipalName "msstd:Fgu12t Exchange Certificate New"

    И у меня теперь xml не формируется.

    Видимо я неправильно синтаксис указал. Не подскажите как правильно?

    23 июля 2015 г. 13:34
  • Покажите вывод:

    Get-ExchangeCertificate -Server test-cas-01  | fl Subject

    Имя сертификата, которое надо указать, будет после "CN="

    23 июля 2015 г. 14:03
  • Покажите вывод:

    Get-ExchangeCertificate -Server test-cas-01  | fl Subject

    Имя сертификата, которое надо указать, будет после "CN="

    У меня выдало четыре CN, которых из них даже не знаю:

    CN=MAIL-fgu12.fgu12t.local, OU=Filial, .... и т.д.

    CN=Microsoft Exchange Server Auth Certificate

    CN=MAIL-fgu12

    CN=WMSvc-MAIL-fgu12

    23 июля 2015 г. 14:12
  • MAIL-fgu12.fgu12t.local
    23 июля 2015 г. 14:16
  • MAIL-fgu12.fgu12t.local

    написал так Set-OutlookProvider EXPR -CertPrincipalName msstd:MAIL-fgu12.fgu12t.local

    Затем IISreset.

    Файл XML автообнаружения сформировался, но опять пусто:

    <Type>EXPR</Type>
            <Server>mail-fgu12.fgu12t.local</Server>
            <SSL>Off</SSL>
            <AuthPackage>Ntlm</AuthPackage>
            <ServerExclusiveConnect>on</ServerExclusiveConnect>
            <CertPrincipalName>None</CertPrincipalName>

    да еще куча ошибок.

    23 июля 2015 г. 14:38
  • А что за ошибки?

    Так же попробуйте настроить учетную запись с помощью автообнаружения.

    23 июля 2015 г. 14:49
  • Попробовал так Set-OutlookProvider EXPR -CertPrincipalName msstd:_MAIL-fgu12.fgu12t.local_

    Все по-прежнему.

    23 июля 2015 г. 14:50
  • Это Вы на сервере терминалов пробуете??? А На нем нет случайно Прокси сервера прописанного?? Добавьте сервер Exchange и https://autodiscover.firma.local в зону интрасети. Хотя конечно эт оскорее всего из за сертификата. .Он у Вас не применен.. Попробуйте назначит этот сертификат через ECP для IIS. И еще, в IIS на Default Web Site и Back End в Привязках этот сертификат должен быть указан в типах https

    23 июля 2015 г. 14:52
  • А что за ошибки?

    Так же попробуйте настроить учетную запись с помощью автообнаружения.

    Здравствуйте.
    Значит ошибки следующие, см. скриншоты Лог3.jgp и Лог4.jpg:
    Не получилось вставить картинки через сайт.

    h tt ps : / /  drive.google.com/open? id =0B2dTF-74Lk2UYVJ2cnVaY3VOY1k


    • Изменено sun victory 28 июля 2015 г. 13:00
    28 июля 2015 г. 12:59
  • Это Вы на сервере терминалов пробуете??? А На нем нет случайно Прокси сервера прописанного?? Добавьте сервер Exchange и https://autodiscover.firma.local в зону интрасети. Хотя конечно эт оскорее всего из за сертификата. .Он у Вас не применен.. Попробуйте назначит этот сертификат через ECP для IIS. И еще, в IIS на Default Web Site и Back End в Привязках этот сертификат должен быть указан в типах https

    Не совсем понял про сервер терминалов.  Outlook2007 установлен на ПК с Win2003Server. Там нет прописан прокси. Добавил https://mail-fgu12.fgu12t.local, https://autodiscovery.fgu12t.local в узлы интрасети. В ECP сертификат у меня был назначен для служб IMAP,POP,SMTP,IIS. В диспетчерее IIS я в привязках  на Default Web Site и Back End  для httpps назначил сертификата нужный.  В привязках для https для 443 и 444 порта не было имени Exchange, прописал.

    Перезапутил службу IIS но Outlook все равно не нащел автообнаружением.

    Может быть это из-за того что я вносил изменения  командой Set-OutlookProvider EXPR -CertPrincipalName msstd:MAIL-fgu12.fgu12t.local .

    28 июля 2015 г. 13:36
  • Перезагрузил сервер Exchange. Теперь при проверке автоконфигурации Outlook2007 в журнале у меня нет ошибок, но во вкладке результаты в овсех протоколах Certificate Principal Name везде стоит None.

    Я так понял причина отказа автоообнаружения сервера Exchange - это отсуствует назначенный сертификат. Поэтому как мне назначить этот сертификат? Не могу понять.

    28 июля 2015 г. 14:40
  • Так вы же выполняли:

    Set-OutlookProvider EXPR -CertPrincipalName "msstd:MAIL-fgu12.fgu12t.local"

    Проверьте через Get-OutlookProvider

    28 июля 2015 г. 14:49
  • Так вы же выполняли:

    Set-OutlookProvider EXPR -CertPrincipalName "msstd:MAIL-fgu12.fgu12t.local"

    Проверьте через Get-OutlookProvider

    Артем, при выполнении данной команды пишет, что выполнено успешно, но параметры EXPR не были изменены. Затем я с делал iisreset. Запустил Get-OutlookProvider у EXPR в столбце CertPrincipalName указано msstd:MAIL-fgu.fgu12t.local

    Но при запуске "Проверить автоконфигурацию" пишет None.

    28 июля 2015 г. 15:13
  • Прошу модератора убрать отметку о правильном ответе. Помеченный ответ не решил проблему.

    Понятно теперь почему так не долюбливают Exchange.

    30 июля 2015 г. 14:14