none
Как обновить CentOS 5.11 cо старой версией LIS RRS feed

  • Вопрос

  • Добрый день.

    Есть виртуальная машина под CentOS 5.11 ядро 2.6.18-406.el5, стал делать очередное обновление (yum update), выходит ошибка kernel is needed by (installed) kmod-microsoft-hyper-v-4.0.11-20150727.x86_64, машина старая и LIS уже не помню какой версии ставилась, но года 2 уже, может год...

    В итоге решил обновить LIS до 4.0.11, пытаюсь сделать апгрейд выходит

    ошибка: Неудовлетворенные зависимости:
            kernel < 2.6.18-399 нужен для kmod-microsoft-hyper-v-4.0.11-20150727.x86_64
    Microsoft-Hyper-V rpm Upgradation failed, Exiting

    Вопрос - как выйти из этой коллизии?

    9 декабря 2015 г. 13:19

Ответы

  • Здравствуйте,

    1) Уточните каким методом (tar.gz или монтирование ISO) пытались обновиться до 4.0.1.1?
    2) Также согласно официальной информации ваша версия ядра 2.6.18-406, отсутствует в списке совместимых:

    # Kernel version
    #  7.1    3.10.0-229
    #  7.0    3.10.0-123
    #  6.7    2.6.32-573
    #  6.6    2.6.32-504
    #  6.5    2.6.32-431
    #  6.4    2.6.32-358
    #  6.3    2.6.32-279
    #  6.2    2.6.32-220
    #  6.1    2.6.32-131.0.15
    #  6.0    2.6.32-71
    #  5.11   2.6.18-398
    #  5.10   2.6.18-371
    #  5.9    2.6.18-348
    #  5.8    2.6.18-308
    #  5.7    2.6.18-274
    #  5.6    2.6.18-238
    #  5.5    2.6.18-194
    #
    #  Other releases are not supported.

    Вам скорее всего следует воспользоваться следующей специализированной веткой на форуме.

    Customers can provide feedback through the Linux and FreeBSD Virtual Machines on Hyper-V forum. We look forward to hearing about your experiences with LIS.


    Best Regards, Andrei ...
    Microsoft Certified Professional

    9 декабря 2015 г. 21:11
    Модератор