none
Проблема с PF на Exchange 2010 RRS feed

  • Общие обсуждения

  • Осуществляли переход с Exch 2003 на Exch 2010.

    В результате, похоже, пропустили момент с репликацией общих папок

    В настоящее время имеем следующую проблему

    [PS] C:\Windows\system32>Get-PublicFolder -Recurse | Format-List Name,Replicas
    Не существует "PublicFolder", соответствующего следующему идентификатору: "\". Убедитесь в том, что указан правильный и
    дентификатор "PublicFolder" и имеются необходимые разрешения для просмотра "PublicFolder".
      + CategoryInfo     : NotSpecified: (0:Int32) [Get-PublicFolder], MapiOperationException
      + FullyQualifiedErrorId : 8F7C8211,Microsoft.Exchange.Management.MapiTasks.GetPublicFolder
    
    
    

    Через "Консоль управления общими папками" в ЕМС тоже к ним нет доступа.

    Public folder database смонтирована. Важной информации в PF нет. Посоветуйте, как запустить этот механизм?

     

     

Все ответы

  • Вот тут посмотрите - http://msexchangeteam.com/archive/2010/05/05/454821.aspx, возможно ваш случай.

    Alexx
  • Указанная в статье ошибка не возникает.

    Непонятен следующий момент: база папок исправна и подключена, но структура папок отсутствует .

    Через "Консоль управления общими папками" в ЕМС к ним нет доступа. Т.е. Консоль не видит существующего хранилища.

    siteFolderServer указывает на текущую базу.  Как-то я не совсем логику работы этого инструмента понимаю...

    Вопрос можно сформулировать проще:

    1. откуда команда

    Get-PublicFolder 

    берет путь к базе общих папок.

    2. Как можно сформировать(восстановить) требуемые для работы этого инструмента структуры

     

  • Я правильно понимаю, что вы при установке сервера ответили , что у вас нет Outlook 2003?

    Для начала в принципе правильно посмотреть вот это

     

    Модератор
  • Неправильно :). При установке сервера он не спрашивал по Outlook 2003 т.к. была попытка перехода с 2003 на 2010.

    Ящики перенеслись успешно а PF заметили только тогда, когда OAB на клиентах отвалился.

    Хранилище PF на 2010 создано и смонтировано, но в упор не видится инструментами сервера.

    Т.е. не видится корень дерева MAPI.

    Где-то что-то встало криво. Exch 2003 уже снесен.

     

  • Добрый день,

    опишите, пожалуйста , как вы делали миграцию, или ссылочку, по которой вы ее производили.

    Посмотрите вот это.

    Ошибки какие есть в журнале?

    Модератор
  • Использовались

    http://support.microsoft.com/kb/273478/ru

    http://technet.microsoft.com/ru-ru/library/bb125110%28EXCHG.65%29.aspx

    http://www.redline-software.com/rus/support/articles/msexchange/2007/removing-exchange2003-exchange2007-part1.php

    Ошибка в логах:

    Имя журнала:  Application
    Источник:   MSExchange Mailbox Replication
    Дата:     17.05.2010 8:51:53
    Код события:  1121
    Категория задачи:Mailbox Move
    Уровень:    Ошибка
    Ключевые слова:Классический
    Пользователь: Н/Д
    Компьютер:   mx1.xxxxx.local
    Описание:
    The Mailbox Replication service was unable to process a Move job due to an unexpected error.
    Mailbox Guid: '8dd024a7-acdc-40a6-a442-a4d811cf127f' 
    Database Guid: '1df54692-8728-45fd-b8a4-0155f322c1ea'
    Error: Свойство не может быть пустым..
    

    Здесь утверждают, что на это можно не обращать внимания.

    Смущает то, что EMS видит два сервера - 2003 и 2010

    Ваша ссылка относится к ситуации, когда сервер Exch 2003 еще жив. В нашей - увы, поторопились.

     

    Вижу три возможных пути:

    - плюнуть и оставить как есть. Однако, непорядок в инфраструктуре напрягает и однажды где-нибудь вылезет.

    - попробовать вылечит то, что есть. Однако пока непонятно как.

    - попробовать снова установить Exch 2003 (и снова снести). Однако неизвестны последствия данного шага (все может еще больше запутаться).

    Буду благодарен, если кто-то укажет верный путь... :)