none
Проблема ContentEditor+jQuery UI RRS feed

  • Вопрос

  • Всем доброго вечера!

    Есть непонятная проблема, может кто сталкивался подскажите как решить!

    Необходимо в ContentEditor нарисовать набор фильтров. Для отрисовки использую jQuery слайдер и датапикер. Через CustomAction/ScriptLink добавляю jquery-1.10.2.min.js, jquery-ui.min.js. Все работает отлично. Но если на этой же странице открыть на редактирование любую другую вебчасть, что нибудь подправить и сохранить, jQuery UI начинает глючить: слайдер работает, но как то криво, датапикер вообще не работает.
    15 января 2014 г. 16:12

Ответы

  • Сам же и отвечаю.

    Вообщем методом научного тыка выяснилось, что такое поведение справедливо для SP2010 и SP2013. То ли это баг вебчасти, то ли так и было задумано. А для корректной работы моих фильтров использую HTML Form Web Part.

    • Помечено в качестве ответа sacha_kk3 16 января 2014 г. 8:56
    16 января 2014 г. 8:55

Все ответы

  • Сам же и отвечаю.

    Вообщем методом научного тыка выяснилось, что такое поведение справедливо для SP2010 и SP2013. То ли это баг вебчасти, то ли так и было задумано. А для корректной работы моих фильтров использую HTML Form Web Part.

    • Помечено в качестве ответа sacha_kk3 16 января 2014 г. 8:56
    16 января 2014 г. 8:55
  • Спасибо за то, что поделились решением!

    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий.

    16 января 2014 г. 8:59
    Модератор