none
Не работает Autodiscover??? RRS feed

  • Общие обсуждения

  • Добрый день! Бьюсь с такой проблемой не первую неделю.

    Есть малый офис и небольшая сеть в нем. Работал хорошо и успешно Exchange 2003 в нем(только в качестве локальной почты, выход наружу не нужен). (клиенты outlook 2003 и outlook 2007) Был выполнен переезд на Exchange 2010. Установил, ящики мигрировал. У клиентов настройки учётных записей почты автоматом поменялись, всё хорошо, почта ходит. Но есть проблема: с некоторым интервалом появляется сообщение в папке "ошибка синхронизации", там сказано: 

    33 Автономная адресная книга Microsoft Exchange

    9:51:33  Не загружаются файлы автономной адресной книги. Сервер (URL-адрес) не найден.

    9:51:33 0X80004005

    Начал копать в сторону адресной книги, удалял, её пересоздавал, делал принудительное обновление. Да, сама OAB успешно опубликована на сервере, физически файлы лежат. Если пройти по url на который публикуется OAB то сервер запросит учётные данные а потом пишет что "Acces Denied" (но вроде так и должно быть). 

    Но самое интересное было замечено позже: если попробовать проверить автоконфигурацию эл почты из outlook, оставить только галку "Автоопределение", вбить ящик и пароль и нажать "проверка", то ничего, совсем ничего не происходит. Как будто Autodiscover не работает...... 

    Т.е. нужно начать с того чтобы понять почему не работает Autodiscover. Чем его протестировать и как, чтобы хоть лог какой то увидеть и т.п. 

    Да, при этом outlook-web-app успешно работает.

    1 ноября 2016 г. 7:44

Все ответы

  • Попробуйте удалить эту адресную книгу, затем создать новую с другим именем.
    1 ноября 2016 г. 7:57
  • Пробовал. Повторюсь, нужно разобраться с autodiscovery, чтобы он заработал. ТАк как насколько мне известно именно эта служба отвечает за синхронизацию OAB у клиентов
    1 ноября 2016 г. 7:59
  • Тоесть я правильно понимаю, что клиентов outlook вы вручную настраиваете, не прилетают автоматом настройки ?
    1 ноября 2016 г. 8:07
  • Да именно так. И если в outlook сделать "Проверку автоконфигурации" ( вбить ящик,пароль, нажать проверка) то ничего не происходит вообще!!!! Никакой ошибки не выдает,ничего.Просто ничего не происходит, и так у всех клиентов.
    1 ноября 2016 г. 8:10
  • ДНС проверяли на наличие записи для autodiscover ?

    Get-ClientAccessServer <name> | fl

    в  AutoDiscoverServiceInternalUri указан путь вида https://autodiscover.domain.com/Autodiscover/Autodiscover.xml ?

    1 ноября 2016 г. 8:18
  •  ДА

    Creating a new session for implicit remoting of "Get-ClientAccessServer" command...


    RunspaceId                           : 17b7b95f-8c0c-4d0a-a465-0b5f6f17458b
    Name                                 : MAIL-OSK2013
    Fqdn                                 : Mail-Osk2013.oskol-bank
    OutlookAnywhereEnabled               : True
    AutoDiscoverServiceCN                : Mail-Osk2013
    AutoDiscoverServiceClassName         : ms-Exchange-AutoDiscover-Service
    AutoDiscoverServiceInternalUri       : https://mail-osk2013.oskol-bank/Autodiscover/Autodiscover.xml
    AutoDiscoverServiceGuid              : 77378f46-2c66-4aa9-a6a6-3e7a48b19596
    AutoDiscoverSiteScope                : {Default-First-Site-Name}
    AlternateServiceAccountConfiguration :
    IrmLogEnabled                        : True
    IrmLogMaxAge                         : 30.00:00:00
    IrmLogMaxDirectorySize               : 250 MB (262,144,000 bytes)
    IrmLogMaxFileSize                    : 10 MB (10,485,760 bytes)
    IrmLogPath                           : C:\Program Files\Microsoft\Exchange Server\V14\Logging\IRMLogs
    IsOutOfService                       : False
    MigrationLogLoggingLevel             : Information
    MigrationLogFilePath                 :
    MigrationLogMaxAge                   : 180.00:00:00
    MigrationLogMaxDirectorySize         : 10 GB (10,737,418,240 bytes)
    MigrationLogMaxFileSize              : 100 MB (104,857,600 bytes)
    IsValid                              : True
    ExchangeVersion                      : 0.1 (8.0.535.0)
    DistinguishedName                    : CN=MAIL-OSK2013,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN
                                           =Administrative Groups,CN=oskolbank,CN=Microsoft Exchange,CN=Services,CN=Configu
                                           ration,DC=oskol-bank
    Identity                             : MAIL-OSK2013
    Guid                                 : 3f96062b-c968-4548-80b2-78f5a5ce42c6
    ObjectCategory                       : oskol-bank/Configuration/Schema/ms-Exch-Exchange-Server
    ObjectClass                          : {top, server, msExchExchangeServer}
    WhenChanged                          : 28.10.2016 14:57:04
    WhenCreated                          : 25.10.2016 10:34:14
    WhenChangedUTC                       : 28.10.2016 11:57:04
    WhenCreatedUTC                       : 25.10.2016 7:34:14
    OrganizationId                       :
    OriginatingServer                    : Serv_Osk.oskol-bank

    Если в браузере пройти по https://mail-osk2013.oskol-bank/autodiscover/autodiscover.xml

    То браузер напишет "невозможно отобразить страницу" (сначала  ругнется на сертификат о том что он недоверенный. Кстати сертификат самоподписанный.)

    1 ноября 2016 г. 8:29
  • По поводу DNS

    Cname запись создавал, да. Autodiscover разрешается в ip адрес нормально

    1 ноября 2016 г. 8:33
  • посмотрите test-outlookwebservices | fl

    1 ноября 2016 г. 8:47
  • В EMS запросил эту команду, вот резульат


    [PS] C:\Windows\system32>test-outlookwebservices | fl

    WARNING: An unexpected error has occurred and a Watson dump is being generated: Failed to find the mailbox. Mailbox =
    'extest_a27abd39abcf4@oskol-bank'.
    Failed to find the mailbox. Mailbox = 'extest_a27abd39abcf4@oskol-bank'.
        + CategoryInfo          : NotSpecified: (:) [Test-OutlookWebServices], MailboxNotFoundException
        + FullyQualifiedErrorId : Microsoft.Exchange.Monitoring.MailboxNotFoundException,Microsoft.Exchange.Management.Sys
       temConfigurationTasks.TestOutlookWebServicesTask
        + PSComputerName        : mail-osk2013.oskol-bank

    Если запустить данную команду с параметром какого нибудь ящика ( заведомо рабочего) то вот:

    [PS] C:\Windows\system32>Test-OutlookWebServices -Identity:ima@oskol-bank


    RunspaceId : 14fd3e72-5aed-480e-beda-47aa54e0d1b6
    Id         : 1019
    Type       : Information
    Message    : A valid Autodiscover service connection point was found. The Autodiscover URL on this object is https://Mail-Osk2013.oskol-bank/Autodiscover/Autodiscover.xml.

    RunspaceId : 14fd3e72-5aed-480e-beda-47aa54e0d1b6
    Id         : 1013
    Type       : Error
    Message    : When contacting https://Mail-Osk2013.oskol-bank/Autodiscover/Autodiscover.xml received the error The under
                 lying connection was closed: An unexpected error occurred on a receive.

    RunspaceId : 14fd3e72-5aed-480e-beda-47aa54e0d1b6
    Id         : 1013
    Type       : Error
    Message    : When contacting https://Mail-Osk2013.oskol-bank/Autodiscover/Autodiscover.xml received the error Unable to
                  read data from the transport connection: An existing connection was forcibly closed by the remote host.

    RunspaceId : 14fd3e72-5aed-480e-beda-47aa54e0d1b6
    Id         : 1013
    Type       : Error
    Message    : When contacting https://Mail-Osk2013.oskol-bank/Autodiscover/Autodiscover.xml received the error An existi
                 ng connection was forcibly closed by the remote host

    RunspaceId : 14fd3e72-5aed-480e-beda-47aa54e0d1b6
    Id         : 1023
    Type       : Error
    Message    : The Autodiscover service couldn't be contacted.

    RunspaceId : 14fd3e72-5aed-480e-beda-47aa54e0d1b6
    Id         : 1024
    Type       : Success
    Message    : [EXCH] Successfully contacted the AS service at https://mail-osk2013.oskol-bank/EWS/Exchange.asmx. The ela
                 psed time was 91 milliseconds.

    RunspaceId : 14fd3e72-5aed-480e-beda-47aa54e0d1b6
    Id         : 1026
    Type       : Success
    Message    : [EXCH] Successfully contacted the UM service at https://mail-osk2013.oskol-bank/EWS/Exchange.asmx. The ela
                 psed time was 751 milliseconds.

    RunspaceId : 14fd3e72-5aed-480e-beda-47aa54e0d1b6
    Id         : 1124
    Type       : Success
    Message    : [Server] Successfully contacted the AS service at https://mail-osk2013.oskol-bank/ews/exchange.asmx. The e
                 lapsed time was 333 milliseconds.

    RunspaceId : 14fd3e72-5aed-480e-beda-47aa54e0d1b6
    Id         : 1126
    Type       : Success
    Message    : [Server] Successfully contacted the UM service at https://mail-osk2013.oskol-bank/ews/exchange.asmx. The e
                 lapsed time was 426 milliseconds.

    1 ноября 2016 г. 9:00
  • Пересоздайте виртуальные каталоги для autodiscover

    1 ноября 2016 г. 9:04
  • Вот как раз сейчас ищу как это сделать через EM Shell

    Не подскажете команду?

    1 ноября 2016 г. 9:07
  • remove/new-autodiscovervirtualdirectory
    1 ноября 2016 г. 9:11
  • [PS] C:\Windows\system32>Remove-AutodiscoverVirtualDirectory -Identity "Mail-Osk2013\Autodiscover"
    The operation couldn't be performed because object 'Mail-Osk2013\Autodiscover' couldn't be found on 'Serv_Osk.oskol-ban
    k'.
        + CategoryInfo          : NotSpecified: (0:Int32) [Remove-AutodiscoverVirtualDirectory], ManagementObjectNotFoundE
       xception
        + FullyQualifiedErrorId : 9E32CB50,Microsoft.Exchange.Management.SystemConfigurationTasks.RemoveAutodiscoverVirtua
       lDirectory
        + PSComputerName        : mail-osk2013.oskol-bank

    Не понял ошибку......  Mail-Osk2013\Autodiscover не может быть найден на контроллере домена... При чём тут контроллер домена...

    1 ноября 2016 г. 9:19
  • Извиняюсь, не совсем правильный синтаксис был.

    Вот так удалился:

    [PS] C:\Windows\system32>Remove-AutodiscoverVirtualDirectory -Identity "Mail-Osk2013\Autodiscover (Default Web Site)"

    Confirm
    Are you sure you want to perform this action?
    Removing the Autodiscover virtual directory.
    [Y] Yes  [A] Yes to All  [N] No  [L] No to All  [?] Help (default is "Y"): y
    [PS] C:\Windows\system32>

    1 ноября 2016 г. 9:34
  • Виртуальный каталог создал (создался успешно)

    [PS] C:\Windows\system32>Remove-AutodiscoverVirtualDirectory -Identity "Mail-Osk2013\Autodiscover (Default Web Site)"

    Confirm
    Are you sure you want to perform this action?
    Removing the Autodiscover virtual directory.
    [Y] Yes  [A] Yes to All  [N] No  [L] No to All  [?] Help (default is "Y"): y
    [PS] C:\Windows\system32>New-AutodiscoverVirtualDirectory -Websitename "Default Web Site" -BasicAuthentication:$true -Wi
    ndowsAuthentication:$true

    Name                                    Server                                  InternalUrl
    ----                                    ------                                  -----------
    Autodiscover (Default Web Site)         MAIL-OSK2013

    Теперь если пройти по url то:

    Насколько мне известно,это нормальная ошибка.

    Теперь Test-OutlookWebServices |fl выдаёт

    А вот если запросить по рабочему ящику то ситуация лучше, автодискавери теперь вроде как отвечает, но автоконфигурация в аутлук по прежнему молчит

    [PS] C:\Windows\system32>test-outlookwebservices -Identity:ima@oskol-bank


    RunspaceId : 4a2e65f3-c82a-4ecb-9ed3-7113c3399bc6
    Id         : 1019
    Type       : Information
    Message    : A valid Autodiscover service connection point was found. The Autodiscover URL on this object is https://Ma
                 il-Osk2013.oskol-bank/Autodiscover/Autodiscover.xml.

    RunspaceId : 4a2e65f3-c82a-4ecb-9ed3-7113c3399bc6
    Id         : 1006
    Type       : Information
    Message    : Contacted the Autodiscover service at https://Mail-Osk2013.oskol-bank/Autodiscover/Autodiscover.xml.

    RunspaceId : 4a2e65f3-c82a-4ecb-9ed3-7113c3399bc6
    Id         : 1016
    Type       : Information
    Message    : [EXCH] The AS service is configured for this user in the Autodiscover response received from https://Mail-
                 Osk2013.oskol-bank/Autodiscover/Autodiscover.xml.

    RunspaceId : 4a2e65f3-c82a-4ecb-9ed3-7113c3399bc6
    Id         : 1015
    Type       : Information
    Message    : [EXCH] The OAB service is configured for this user in the Autodiscover response received from https://Mail
                 -Osk2013.oskol-bank/Autodiscover/Autodiscover.xml.

    RunspaceId : 4a2e65f3-c82a-4ecb-9ed3-7113c3399bc6
    Id         : 1014
    Type       : Information
    Message    : [EXCH] The UM service is configured for this user in the Autodiscover response received from https://Mail-
                 Osk2013.oskol-bank/Autodiscover/Autodiscover.xml.

    RunspaceId : 4a2e65f3-c82a-4ecb-9ed3-7113c3399bc6
    Id         : 1016
    Type       : Warning
    Message    : [EXPR] The AS service isn't configured for this user in the Autodiscover response received from https://Ma
                 il-Osk2013.oskol-bank/Autodiscover/Autodiscover.xml.

    RunspaceId : 4a2e65f3-c82a-4ecb-9ed3-7113c3399bc6
    Id         : 1015
    Type       : Information
    Message    : [EXPR] The OAB service is configured for this user in the Autodiscover response received from https://Mail
                 -Osk2013.oskol-bank/Autodiscover/Autodiscover.xml.

    RunspaceId : 4a2e65f3-c82a-4ecb-9ed3-7113c3399bc6
    Id         : 1014
    Type       : Warning
    Message    : [EXPR] The UM service isn't configured for this user in the Autodiscover response received from https://Ma
                 il-Osk2013.oskol-bank/Autodiscover/Autodiscover.xml.

    RunspaceId : 4a2e65f3-c82a-4ecb-9ed3-7113c3399bc6
    Id         : 1022
    Type       : Success
    Message    : Autodiscover was tested successfully.

    RunspaceId : 4a2e65f3-c82a-4ecb-9ed3-7113c3399bc6
    Id         : 1021
    Type       : Information
    Message    : The following web services generated errors: As,UM in EXPR. Use the previous output to diagnose and correc
                 t the errors.

    RunspaceId : 4a2e65f3-c82a-4ecb-9ed3-7113c3399bc6
    Id         : 1024
    Type       : Success
    Message    : [EXCH] Successfully contacted the AS service at https://mail-osk2013.oskol-bank/EWS/Exchange.asmx. The ela
                 psed time was 601 milliseconds.

    RunspaceId : 4a2e65f3-c82a-4ecb-9ed3-7113c3399bc6
    Id         : 1026
    Type       : Success
    Message    : [EXCH] Successfully contacted the UM service at https://mail-osk2013.oskol-bank/EWS/Exchange.asmx. The ela
                 psed time was 790 milliseconds.

    RunspaceId : 4a2e65f3-c82a-4ecb-9ed3-7113c3399bc6
    Id         : 1124
    Type       : Success
    Message    : [Server] Successfully contacted the AS service at https://mail-osk2013.oskol-bank/ews/exchange.asmx. The e
                 lapsed time was 337 milliseconds.

    RunspaceId : 4a2e65f3-c82a-4ecb-9ed3-7113c3399bc6
    Id         : 1126
    Type       : Success
    Message    : [Server] Successfully contacted the UM service at https://mail-osk2013.oskol-bank/ews/exchange.asmx. The e
                 lapsed time was 515 milliseconds.

    1 ноября 2016 г. 9:51
  • Перезапустите outlook и попробуйте проверить автоконфигурацию эл. почты
    1 ноября 2016 г. 10:09
  • перезапустил и outlook и сервер EX

    тоже самое. По кнопке "Проверка" в автоконфигурации ничего не происходит....

    1 ноября 2016 г. 10:37
  • проверьте привязки в IIS, имя autodiscover присутствует в сертификате ?
    1 ноября 2016 г. 10:47
  • извините, а конкретнее можно? какие именно привязки?
    1 ноября 2016 г. 10:47
  • А по поводу имени в сертификате. В каком поле они должны быть?? Сертификат у меня самоподписанный, сервер его сгенерил и выдал сам себе при инсталяции, поэтому подозреваю что про autodiscover там нет упоминаний:

    1 ноября 2016 г. 10:54
  • Касаемо привязки:

    1 ноября 2016 г. 11:15
  • проверьте autodiscover s другой машины, фаерволы, сеть
    1 ноября 2016 г. 11:21
  • на тестовой машине нет антивируса, нет фаерволов, отключен брандмауэр

    Более того можно попытаться проверить автоконфигурацию  в outlook на самом сервере(ящик заведомо рабочий)

    1 ноября 2016 г. 11:25
  • только щас обратил внимание на ваш почтовый домен, у вас имя домена AD какое ?
    1 ноября 2016 г. 11:42
  • почтовый домен указан правильно.

    К сожалению когда то завели домен без префикса. (oskol-bank)

    1 ноября 2016 г. 11:48
  • а когда ошибка в outlook возникает в журнале приложений и служб мс офиса есть события какие н-ть с ошибками, варнингами?
    1 ноября 2016 г. 11:56
  • Нет. Только информационные логи, мол сессия outlook длилась столько то.
    1 ноября 2016 г. 12:13
  • Если есть доменный центр сертификации, попробуйте выпустить сертификат для Exchange вместо самоподписного.
    1 ноября 2016 г. 12:50
  • Центр сертификации есть. Но что это изменит???

    autodiscover.domen  используется же только для пользователей из-вне. У доменных пользователей инфа должна браться из АД?

    1 ноября 2016 г. 12:52
  • внутри тоже нужно
    1 ноября 2016 г. 13:08
  • Привязал новый сертификат ( в поле San теперь есть autodiscovery).

    Cname запись напомню в днс присутствует и имя autodiscover.domen разрешается нормально в ip адрес exchange сервера

    Но ситуация таже. При попытке савтоконфигурировать почту в аутглюке даже на сервере exchange пишет ошибка связи. 

    2 ноября 2016 г. 8:33
  • Чем можно детально протестировать autodiscovery с клиента. Куда он обращается, какие ответы получает...... В настройках мне больше проверить нечего, вроде всё в норме и напомню test-outlookwebservices  на сервере проходит нормально.
    2 ноября 2016 г. 8:35
  • В outlookе как раз и нужно его проверять. Кстати он у вас какой ? Со всеми обновленниями ?
    2 ноября 2016 г. 8:50
  • Поставил SP3, всё тоже самое

    2 ноября 2016 г. 9:35
  • создайте локальный c:\temp\autodiscover.xml файл:

    <?xml version="1.0" encoding="utf-8"?>
    <Autodiscover xmlns="
    http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006"><Response
    xmlns="
    http://schemas.microsoft.com/exchange/autodiscover/outlook/responseschema/2006a">
    <Account>
    <AccountType>email</AccountType>
    <Action>settings</Action>
    <Protocol>
    <Type>EXCH</Type>
    <Server>
    Mail-Osk2013.oskol-bank</Server>
    </Protocol>
    </Account>
    </Response></Autodiscover>

    в реестре reg_sz

    [HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\AutoDiscover]
     "oskol-bank"="c:\temp\autodiscover.xml"
     "PreferLocalXML"=dword:00000001

    и

    "ExcludeScpLookup"=dword:00000001

    перезапустите outlook и проверте

    2 ноября 2016 г. 11:46
  • Сделал. Создал ключи в реестре

    Создал xml-ку

    Результат тот же. При попытке с-автоконфигурировать сразу пишет "ошибка соединения". Такое ощущение что и не пытается ничего делать.

    Думал может глючный аутглюк. Скачал родной 2010. Там всё тоже самое. Создал такие же ключи в реестре но в папке 14.0 для 10 аутлука, тоже самое.

    Складывается ощущение что он не понял что ему нужно конфигурироваться из локальной xml-ки

    Да, на саму xml-ку дал права для "всех" на всякй случай.

    2 ноября 2016 г. 14:19