none
Восстановление фермы RRS feed

  • Вопрос

  • Здравствуйте уважаемые дамы и господа!!! я вляпалась в историю, помогите, очень прошу. Устроилась на новую работу, а там у них плохоработающий портал. веб-части не отображались, центра администрирования не было. решила попробовать исправить, не сделав бэкапа. пошла самым простым способом и запустила мастер настройки, в итоге пропало все. у них один сервер, на нем стоит sql 2008 r2 и sharepoint 2010. в журналах написано, что не работает служба маркеров. нашла статью, проделала все, чтобы забустить из iis manager эту службу и пулы приложении и центра администрирования (они почему-то были отключены). после запуска пытаюсь запустить сайт, обновить, а они опять отключаются и пулы и служба. пошла дальше, посоветовали в power shell запустить position(). также временно запустились, а потом опять в даун. нашла статейку,в которой посоветовали переподключиться к ферме. и тут самое интересное. я ведь ...ненормальная это сделала (не обратив внимания, что у меня всего один сервер, на котором и веб-прилодение центра администрирования и прочее). в итоге во время запуска мастера настройки выбрала отсоединиться от фермы. и все-конец. я все вообще потеряла. когда опять запускаю мастер настройки, выбираю подключиться к существующей, загружаю имена баз, выбираю нужную, а он просит парольную фразу, а я ее НЕ ЗНАЮ. через командную строку пыталась сбросить, узнала, что теперь локальной фермы не существует и сбросить ее нельзя. помогите, что делать. в базе ведь остались и база конфигурации и контента, как опять все поднять и к ним подключиться. не знаю что делать. пожалуйста.

    начинающий разработчик

    25 октября 2012 г. 7:26

Ответы

  • в это случае проще сделать следующее:

    1. зайти в SQL и его средствами забекапить ВСЕ контентные базы 

    2. по новой развернуть SP и настроить его.

    3. подоткнуть контентые базы к новому SP

    риски:

    1. нужно точно знать что там стояло (все решения) и установить вновь, иначе чтото может не работать (может не работать многое) 

    PS. хотя по моему терять уже нечего

    будут конктетные вопросы - обращайтесь.

     




    • Изменено Kaplin VladimirModerator 25 октября 2012 г. 7:53
    • Помечено в качестве ответа crowsay 6 ноября 2012 г. 3:53
    25 октября 2012 г. 7:50
    Модератор
  • главное указать правильный адрес вебприложения, а в контентной  базе уже находится адрес каждого сайта.
    • Помечено в качестве ответа crowsay 6 ноября 2012 г. 3:54
    25 октября 2012 г. 9:17
    Модератор
  • создайте веб приложение с именем http://server:80, а потом зайдите в центр администрирования > Управление приложениями > Сопоставления для альтернативного доступа  и там переименуйте вебприложение.

    еще можно посмотреть старый адрес на DNS сервере, там должно быть сопоставление какой адрес с каким IP .

    • Помечено в качестве ответа crowsay 6 ноября 2012 г. 3:55
    28 октября 2012 г. 8:40
    Модератор
  • а бекап востанавливала согласно статье? http://technet.microsoft.com/ru-ru/library/ee428314.aspx
    • Помечено в качестве ответа crowsay 6 ноября 2012 г. 3:55
    28 октября 2012 г. 9:57
    Модератор
  • проверте права на SQL. 
    • Помечено в качестве ответа crowsay 6 ноября 2012 г. 3:55
    28 октября 2012 г. 10:30
    Модератор
  • странно чо по новой не создается...

    точно там нет базы с именем SharePoint_Config и точно у пользователя из под которого хотите создать ферму права на создание баз еще вот это посмотрите  http://technet.microsoft.com/ru-ru/library/ff607733.aspx 

    • Помечено в качестве ответа crowsay 6 ноября 2012 г. 3:55
    28 октября 2012 г. 11:51
    Модератор
  • у меня стоят галочки еще securityadmin и public.

    сложно сказать.

    можно попробовать поставить бесплатный фундейшен и посмотреть, в решении или в учетке

    • Помечено в качестве ответа crowsay 6 ноября 2012 г. 3:55
    28 октября 2012 г. 12:15
    Модератор
    • Помечено в качестве ответа crowsay 6 ноября 2012 г. 3:56
    28 октября 2012 г. 13:59
    Модератор
  • даже и не знаю что сказать. удаленно не понятно что происходит 

    еще предлагаю посмотреть инструкцию Установка и настройка Microsoft SharePoint Server 2010

    так же предлагаю посмотреть события в Event Viver

    или посмотреть логи с помошью ULS Viewer

    • Помечено в качестве ответа crowsay 6 ноября 2012 г. 3:56
    29 октября 2012 г. 9:50
    Модератор
  • Да входят. Единственное я узнала, что они изменили домен.

    после смена домена. однозначно не восстановите ферму из бекапа 2011.
    • Помечено в качестве ответа crowsay 6 ноября 2012 г. 3:56
    29 октября 2012 г. 13:31
    Модератор

Все ответы

  • в это случае проще сделать следующее:

    1. зайти в SQL и его средствами забекапить ВСЕ контентные базы 

    2. по новой развернуть SP и настроить его.

    3. подоткнуть контентые базы к новому SP

    риски:

    1. нужно точно знать что там стояло (все решения) и установить вновь, иначе чтото может не работать (может не работать многое) 

    PS. хотя по моему терять уже нечего

    будут конктетные вопросы - обращайтесь.

     




    • Изменено Kaplin VladimirModerator 25 октября 2012 г. 7:53
    • Помечено в качестве ответа crowsay 6 ноября 2012 г. 3:53
    25 октября 2012 г. 7:50
    Модератор
  • Получается, что нужно запустить мастер настройки, выбрать создать новую, в качестве базы конфигурации написать, например, config2. затем пойдет работа. после окончания нужно полностью настраивать? и веб-приложения?. Просто в одной статье я читала, что после окончания настройки, нужно пойти удалить созданное веб-приложение, создать новое, указав старую базу контента. Проблема в том, что я не помню, а точнее не знаю, как называются сайты, только головной. Восстановится ли все как было? или уже все? можно идти увольняться не проработав недели! просто стыдно очень.

    начинающий разработчик

    25 октября 2012 г. 8:00
  • главное указать правильный адрес вебприложения, а в контентной  базе уже находится адрес каждого сайта.
    • Помечено в качестве ответа crowsay 6 ноября 2012 г. 3:54
    25 октября 2012 г. 9:17
    Модератор
  • Здравствуйте! подскажите пож-ста. столкнулась с препятствием. пытаюсь определить название веб-приложения, которое у них было, чтобы сделать подмену. в iis manager в application pool нашла пулы типа test.home.ru80, здесь же сайт sharepoint-test.home.ru80. т.е. видимо веб-приложение у них называлось test.home.ru с портом 80. вот сейчас я пытаюсь создать такое же приложение и подменить ему базу контента.   не получается даже без подмены. если приложение обычное типа http://server:80 создается, сайты создаются, все хорошо. и базу меняла ему ,тоже все хорошо. но если я создаю приложение такого test.home.ru с портом 80, потом для проверки не меняя базу создаю для него семейство, сайты не работают. в журнале событий выдает 2 ошибки 8088 и 8306-Служба управляемы метаданных не доступна и Исключение при попытке выдать маркер безопасности. А мне ведь надо именно test.home.ru. насколько я знаю ,что если я угадаю имя приложения, то есть шанс все восстановить. подскажите пож-ста.

    начинающий разработчик

    28 октября 2012 г. 4:47
  • создайте веб приложение с именем http://server:80, а потом зайдите в центр администрирования > Управление приложениями > Сопоставления для альтернативного доступа  и там переименуйте вебприложение.

    еще можно посмотреть старый адрес на DNS сервере, там должно быть сопоставление какой адрес с каким IP .

    • Помечено в качестве ответа crowsay 6 ноября 2012 г. 3:55
    28 октября 2012 г. 8:40
    Модератор
  • у меня, жалко, нет доступа в оснастку dns


    начинающий разработчик

    28 октября 2012 г. 9:00
  • я запустила мастер настройки для создания новой фермы. В итоге сбой, что не может найти процедуру или не хватает прав. хотя проверила, у этой учетки админские права на базу. на диске у них я нашла бэкап сделанный через центр администрирования ,но он аж 2011 года. могу ли я через командную строку сделать восстановление фермы, а потом просто подменить базу?


    начинающий разработчик

    28 октября 2012 г. 9:03
  • Зачем мастер настройки? вы же говорили что все создается?
    28 октября 2012 г. 9:24
    Модератор
  • а что касается восстановление ферму. я не подскажу... не пробовал.

    еще бекап 2011 года это может плюс... единственно. могло много измениться.

    28 октября 2012 г. 9:31
    Модератор
  • Все создавалось на тестовом полигоне, а сейчас решила рискнуть и проделать все на продуктиве. в итоге даже настройка и новая ферма не создалась. Вот и решила попробовать восстановить хотя бы старый бэкам и подменить. ну или потом перезаписать, если во время восстановления он заменит базу контента.

    начинающий разработчик

    28 октября 2012 г. 9:45

  • Я вас, видимо , совсем запутала. просто я пыталась повторить все на своей домашней машине. т.к. пытаться продолжать там уже страшно. Попробовала проделать по вашему совету о сопоставлении альтернативного доступа. ну а теперь хотела проделать  уже на продуктиве. В итоге полный минус.

    начинающий разработчик

    28 октября 2012 г. 9:49
  • а бекап востанавливала согласно статье? http://technet.microsoft.com/ru-ru/library/ee428314.aspx
    • Помечено в качестве ответа crowsay 6 ноября 2012 г. 3:55
    28 октября 2012 г. 9:57
    Модератор
  • а если по новой создавать чистую ферму что говорит?
    28 октября 2012 г. 9:59
    Модератор
  • Я как раз и пыталась сначала создать новую ферму (запускаю мастер настройки и выбираю новую, ввожу данные и пуск, но на 3й шаге сбой, типа не может создать базу конфигурации). а если вы имели в виду вообще новый сервер ,то у меня нет такой возможности. нового сервера не дали.

    бэкап еще не восстанавливала. в power shel набрала restore spfarm -directory c:\backup

    но он пишет ,что имя restore не распознано как имя командлета powershell. теперь ищу как его добавить))) как ни шаг, так препятствие.


    начинающий разработчик

    28 октября 2012 г. 10:19
  • проверте права на SQL. 
    • Помечено в качестве ответа crowsay 6 ноября 2012 г. 3:55
    28 октября 2012 г. 10:30
    Модератор
  • права полные.

    начинающий разработчик

    28 октября 2012 г. 10:58
  • подскажите, как добавить командлет restore? я не могу найти. пожалуйста!

    начинающий разработчик

    28 октября 2012 г. 11:01
  • Разобралась, запустила команду, он спросил метод-overwrite, со все согласилась и с перезаписью, но опять ошибка-Ферма не доступна. почему же все так не получается.  теперь точно не знаю что делать((((

    начинающий разработчик

    28 октября 2012 г. 11:14
  • странно чо по новой не создается...

    точно там нет базы с именем SharePoint_Config и точно у пользователя из под которого хотите создать ферму права на создание баз еще вот это посмотрите  http://technet.microsoft.com/ru-ru/library/ff607733.aspx 

    • Помечено в качестве ответа crowsay 6 ноября 2012 г. 3:55
    28 октября 2012 г. 11:51
    Модератор
  • Права полные : serveradmin, sysadmin, db creator . А что касаемо базы я указываю сразу sharepoint_config2. я не понимаю в чем еще может быть дело. единственное я знаю, что это у них не полноценный, а купленный продукт разработанный третьей фирмой. может быть из-за этого? или это все-таки что-то с учеткой?

    начинающий разработчик

    28 октября 2012 г. 12:06
  • у меня стоят галочки еще securityadmin и public.

    сложно сказать.

    можно попробовать поставить бесплатный фундейшен и посмотреть, в решении или в учетке

    • Помечено в качестве ответа crowsay 6 ноября 2012 г. 3:55
    28 октября 2012 г. 12:15
    Модератор
  • Я с таким еще не сталкивалась. у меня получилось следующее: полезла проверить хозяина wss_content, там другая учетка, не та, от которой запущены службы, и для конфига аналогично. дальше я попыталась опять запустить мастер ,он также оборвался на 3м шаге ,что не может создать базу конфигурации.  в sql она все-таки создалась, ну само собой что не полностью. полезла в нее (хотела проверить безопасность) и попыталась прописать имя той учетки, которую мне дали  (от которой я все и пытаюсь проделать), при попытке ее добавление выдает исключение sql. только я пытаюсь добавить какую-нибудь другую учетку в эту базу, все проходит удачно. решила еще про экспериментировать. в локальные админы прописала себя, также прописала себя в базе данных (owner, sysadmin, serveradmin и прочее). по идее раньше этого мне хватало ,чтобы запустить установку.

    запускаю от своего имени, все тоже самое, сбой на 3м шаге. в итоге я пришла к выводу, что видимо что-то , возможно специально, заблокировано. а пароля учетки, которая является owner для config и content мне не сказали. как думаете, я права? или все-таки не догоняю?


    начинающий разработчик

    28 октября 2012 г. 13:55
    • Помечено в качестве ответа crowsay 6 ноября 2012 г. 3:56
    28 октября 2012 г. 13:59
    Модератор
  • еще, учетки в ходят в группу локальных администаторов на сервере SP?
    28 октября 2012 г. 14:48
    Модератор
  • Да входят. Единственное я узнала, что они изменили домен.


    начинающий разработчик

    29 октября 2012 г. 9:34
  • даже и не знаю что сказать. удаленно не понятно что происходит 

    еще предлагаю посмотреть инструкцию Установка и настройка Microsoft SharePoint Server 2010

    так же предлагаю посмотреть события в Event Viver

    или посмотреть логи с помошью ULS Viewer

    • Помечено в качестве ответа crowsay 6 ноября 2012 г. 3:56
    29 октября 2012 г. 9:50
    Модератор
  • Да входят. Единственное я узнала, что они изменили домен.

    после смена домена. однозначно не восстановите ферму из бекапа 2011.
    • Помечено в качестве ответа crowsay 6 ноября 2012 г. 3:56
    29 октября 2012 г. 13:31
    Модератор
  • Владимир спасибо вам огромное за помощь! у меня все получилось! все заработало! спасибо!!!!

    начинающий разработчик

    6 ноября 2012 г. 3:52
  • Я рад что Вы справились!

    буду надеятся, что Вас оценят на новой работе!

    6 ноября 2012 г. 4:26
    Модератор