none
не открывается сайт sharepoint на самом сервере RRS feed

  • Вопрос

  • Здравствуйте дорогие коллеги. Помогите пожалуйста разобраться с проблемой. Есть три виртуальных сервера.1-Домен, 2-SQL, 3-sharepoint.ситуация такая. Это все настраивал другой человек и теперь его нет и нет связи с ним. Локально сайт http://contoso/ работал и в один день он перестал работать. Потом я заметил , что в диспетчере IIS на веб сервере sharepoint-80 не было привязки http-contoso-ip адрес сервера. После этого сайт заработал, но на самом сервере я не могу его открыть. Ошибка 404. Default Web Site в диспетчере IIS у меня отключен так как если его включить то при переходе на сайт http://contoso/  открывается официальная страница IIS. Подскажите пожалуйста в чем может быть причина того что на сервере не открывается сайт шарика.
    22 сентября 2017 г. 6:16

Ответы

Все ответы

  • Запустился каким то чудесным образом ). 
    НО вообще то у меня проблема в другом. я думал это как то взаимосвязано. у меня перестали запускаться работающие до этого без проблем рабочие процессы. статус приостановлено. возобновить не получается. уже проделал все что советовали в интернете . ничего не помогает. вот ошибка - RequestorId: f82ed662-52ff-8f2d-0000-000000000000. Сведения: An unhandled exception occurred during the execution of the workflow instance. Exception details: System.ApplicationException: HTTP 404 <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN""http://www.w3.org/TR/html4/strict.dtd"> <HTML><HEAD><TITLE>Not Found</TITLE> <META HTTP-EQUIV="Content-Type" Content="text/html; charset=us-ascii"></HEAD> <BODY><h2>Not Found</h2> <hr><p>HTTP Error 404. The requested resource is not found.</p> </BODY></HTML> {"Connection":["close"],"Date":["Fri, 22 Sep 2017 06:21:20 GMT"],"Server":["Microsoft-HTTPAPI\/2.0"]} в Microsoft.Activities.Hosting.Runtime.Subroutine.SubroutineChild.Execute(CodeActivityContext context) в System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager) в System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation).

    22 сентября 2017 г. 6:59
  • заметил такую закономерность. Рабочие процессы на платформе 2010 работают на 2013 не работают. Подскажите что делать. Если какая то возможность переустановить платформу WF 2013 c сохранением использующих рабочих процессов ?
    22 сентября 2017 г. 11:15
  • проверьте что активирована фича сайта


    мой блог не много о SharePoint

    22 сентября 2017 г. 11:26
    Модератор
  • да она включена

    22 сентября 2017 г. 11:48
  • может есть какой то метод заново переустановить WF 2013 ?
    22 сентября 2017 г. 11:48
  • может есть какой то метод заново переустановить WF 2013 ?
    Может вам для начала перезапустить Configuration Wizard, проверить установлены ли все обновления для SharePoint, если нет, то обязательно установить их, а уже потом искать альтернативу стандартным действиям.
    22 сентября 2017 г. 12:38
  • проверил. все установлено. заново переустановил WFManager не удаляя базы. Вообщем опять создаю РП 2013 зависают в состоянии "запушен" а РП 2010 прекрасно работают. Пожалуйста подскажите в чем может быть проблема ? может где надо права дать WF ? Хотя везде где возможно добавил дал права.
    23 сентября 2017 г. 21:28
  • решил заново регистрировать рабочие процессы командой Register-SPWorkflowService. выдает ошибку не удалось запросить конечную точку метаданных OAuth S2S в URI ' http: // server **** / sites / workflow / _layouts / 15 / metadata / json / 1. как мне исправить эту ошибку. я уже все возможные варианты перепробовал. даже удалили все РП 2013 командой Get-SPWorkflowServiceApplicationProxy | Remove-SPServiceApplicationProxy. Что делать ???
    23 сентября 2017 г. 22:53
  • я полность удалил workflow 2013 . теперь повторно не могу установить . service bus выдает ошибку. в диспетчере IIS надо самому создавать сайт WorkFlow или он сам автоматически создается ?
    25 сентября 2017 г. 7:10
  • смог установить заново WorkFlow . Но при попытке создать новый рабочий процесс в дизайнере шарпоинт то выходит сообщение что служба не настроена. Пытаюсь запустить эту команду (

    Register-SPWorkflowService -SPSite "http://myserver/mysitecollection" -WorkflowHostUri "http://workflow.example.com:12291" -AllowOAuthHttp

    ) выдает ошибку (не удалось запросить конечную точку методанных OAuth по URL http://***/_layouts/15/metadata/json/1). в чем проблема у меня?

    25 сентября 2017 г. 8:09
  • помогите пожалуйста очень прошу. Уже две недели это проблема покоя не дает.

    25 сентября 2017 г. 8:10
  • есть предположение что у Вас проблемы с IIS или DNS (возможно в hosts) или AAM.

    предлагаю проверить:
    1. ping сайта на сервере

    2. зайти в ЦА и посмотреть настройки "Сопоставления для альтернативного доступа"


    мой блог не много о SharePoint

    25 сентября 2017 г. 8:32
    Модератор
  • пинг идет. сайт работает. как настроить диспетчер рабочих процессов?

    25 сентября 2017 г. 12:46
  • Пытаюсь запустить эту команду (Register-SPWorkflowService -SPSite "http://myserver/mysitecollection" -WorkflowHostUri "http://workflow.example.com:12291" -AllowOAuthHttp) выдает ошибку (не удалось запросить конечную точку методанных OAuth по URL http://***/_layouts/15/metadata/json/1). в чем проблема у меня? все остальное работает. все службу запущены. 

    26 сентября 2017 г. 11:17
  • я не могу открыть сайт ( http: // xxxx / _layouts / 15 / metadata / json / 1 ) а основной сайт открывается http: // xxxx /. вся беда в этом. как мне это исправить ? Workflow Manager я устанавливаю на сервер Sharepoint а не отдельно.

    26 сентября 2017 г. 13:33
  • заметил такую странную штуку. мой сайт http://myshare/ на гугл хром открывается а вот через internet explorer не открывается. снизил уровень защиты IE до нуля , антивир нету . в чем может быть проблема?
    27 сентября 2017 г. 10:56
  • разобрался. теперь другая ошибка XAML рабочего процесса не прошел проверку из за следующих ошибок.

    invalid types "Microsoft.Activities.Cachescope"

    27 сентября 2017 г. 12:04
  • разобрался. теперь другая ошибка XAML рабочего процесса не прошел проверку из за следующих ошибок.

    invalid types "Microsoft.Activities.Cachescope"

    Все указывает на то, что у вас отсутствуют необходимые обновления для Workflow Manager, уже писал об этом выше. 

    Cumulative Update for Service Bus 1.0 (KB2799752) 

    Cumulative Update 3 for Workflow Manager 1.0 (KB3104066)


    28 сентября 2017 г. 7:49