none
IIS на базе 2003 RRS feed

  • Вопрос

  •  

    Помогите настроить веб хостинг. Что то у меня не правильно получается и ни один сайт не открывается.

     

    DynDNS настроил правильно ссылка идет. С начала открывалась администраторская страница модема но я изменил порт модема с 80 на другой и все равно не работает. Если что то модем Zyxel 600-ой серии и Kerio WinRoute используется. Как все настроить?

    • Перемещено Nikita Panov 22 сентября 2010 г. 20:05 IIS (От:Windows Server 2003/2000/NT)
    15 сентября 2008 г. 5:07

Ответы

Все ответы

  • А вы 80-й порт пробросили за маршрутизатор? Как я понимаю, зуксель у вас работает в режиме NAT.

    15 сентября 2008 г. 5:31
  • В каком смысле за маршрутизатор? Я не порт перебросил а администраторскую страницу модема с 80 го перебросил на 800, а то при наборе URL выходила она. NAT включен. Я все делал как описано в DynDNS по модему. Но видимо в IIS не все правильно настроено.

    15 сентября 2008 г. 5:52
  • повторяю ещё раз: вы 80-й порт пробросили с маршрутизатора на ваш сервер с IIS?

    15 сентября 2008 г. 6:01
  •  

    Не уверен. А где это делается?

     

    15 сентября 2008 г. 13:02
  • Как я понял, вам необходим доступ снаружи к веб-серверу, который расположен за NAT маршрутизатором. Следовательно вам нужно зайти в настройки NAT-маршрутизатора (зукселя) и найти там что-то похожее на Port Forwarding или Port Mapping в котором вы указываете порт (или диапазон портов, в вашем случае только порт 80), протокол (TCP/UDP, в вашем случае только TCP) и адрес машины, которая находится за NAT'ом (это может быть 192.168.0.10) и который недоступен для прямого соединения из интернета.

    15 сентября 2008 г. 13:42
  • Это все сделал. Дома у меня керио нет и ХР стоит. Пробую сделать тоже самое не выходит.

     

    NAT  Port Forwarding  и lFirewall WAN to LAN Rules порты 2121 для ftp и 8080 для www направляют на 192.168.1.5

    и эти же данные ставлю в свойствах сайта.
    15 сентября 2008 г. 13:53
  • а дальше нужно разбираться с самим сервером. Локально с веб-сервера сайт доступен из браузера?

     

    з.ы. в таком случае в браузере вы должны набирать www.website.ru:8080 если ваш веб-сервер использует нестандартный порт.

    15 сентября 2008 г. 13:58
  • Открываю ИИС, через контекстное меню выбираю обзор :

     

    Этот веб-узел отказывается показать эту веб-страницу

     

    Тоже самое делаю с ФТП показывает содержимое папки.

     

    15 сентября 2008 г. 14:06
  •  

    Так и делаю ни сайт ни фтп не открывается.
    15 сентября 2008 г. 14:11
  • ну так настройте веб-сервер как полагается. Задайте серверу IP, далее укажите home directory, а так же и home page. Так же пользователь IUSR должен иметь как минимум право Read на каталог с веб-содержимым. И настройте анонимную аутентификацию (включена по дефолту). После этого можно будет продолжать.

     

    15 сентября 2008 г. 16:36
  •  

    Я и хочу узнать как пологается.

    Сервер получает IP от модема но он фиксированный по Мас-у

    IUSR имеет уровень доступа "Гость", сайт имеет доттуп для чтения.

    Сейчас у меня при наборе http://192.168.1.5:8080/ сайт отображается нормально.

    каталог есть, содержит index.htm.

    анонимная аутентификация есть.

    при наборе http://url:8080/ ошибка

     

    Internet Explorer не может отобразить эту веб-страницу

     
     

    Возможные причины:

    • Нет подключения к Интернету.
    • На веб-узле возникли неполадки.
    • Возможно, сделана опечатка в адресе.
     

    Попробуйте сделать следующее:

     

    Проверьте подключение к Интернету. Попробуйте посетить другой веб-узел, чтобы убедиться в наличии подключения.

     

    Заново введите адрес.

     

    Перейдите на предыдущую страницу.

     

    Подробнее

    15 сентября 2008 г. 17:12
  • гут. А кто у вас занимается разрешением имён внутри сети? А что говорит http://localhost:8080 ?

    и я бы на вашем месте удалил на сервере получение адреса от DHCP и включил бы статику. Это полезно и избавит от возможных проблем.

    15 сентября 2008 г. 17:57
  •  

    В общем то я и занимаюсь. http://localhost:8080 грузит страницу index.htm

    На работе IP сервера прописан. Вчера пробовал отключить фаервол и нат на модеме, результат тот же.

    16 сентября 2008 г. 4:16
  • простите, а зачем вы отключали NAT на модеме?

    И если при обращении на 192.168.1.5 сайт открывается, то сервер работоспособен. Теперь вам необходимо проверить Port Forwarding. Для этого нужно пробиться на сайт через внешний IP модема.

     

    16 сентября 2008 г. 5:33
  • Что бы убедиться, что модем не блокирует доступ. Потом включит Лог и наблюдал. При вызове через инет в логе пишет acces forward.

    16 сентября 2008 г. 7:54
  • и? Страница открывается или нет? почему я должен всё из вас клещами вытягивать? Это не мне надо, а вам.

     

    16 сентября 2008 г. 7:57
  •  

    Если бы открывалась, что бы я тут дела.
    16 сентября 2008 г. 9:24
  • работает ли

    Code Snippet
    telnet <внешний IP маршрутизатора> 8080

     

     

    ?

    16 сентября 2008 г. 10:04
  •  

    Code Snippet

     telnet <внешний IP маршрутизатора> 8080

     
    И внешний и внутренний набираю остается черный экран с мигающим курсором.
     
     
    Может мне все это с ноля заново начать?
    16 сентября 2008 г. 10:35
  •  ICEBERG@ написано:

    Что бы убедиться, что модем не блокирует доступ. Потом включит Лог и наблюдал. При вызове через инет в логе пишет acces forward.

    А в логах IIS и системы есть какие-нибудь записи?

    16 сентября 2008 г. 10:48
  • отлично, транспорт до веб-сервера существует. Теперь нужно выяснить причину. Например, изнутри сети зайти на веб-сервер? С соседнего компьютера. Будет ли открываться сайт?

    16 сентября 2008 г. 10:49
  • А где лог ИИС можно посмотреть?

     

    С соседнего компьютера требует пароль. С самого сервера тоже самое хотя я поставил на анонимный вход.

     

     

    В свойствах сайта - безопасность каталога - управление доступом :

    анонимный доступ +

    iusr_server

    паролья нет

    встроенная проверка подлинности Windows + (если убираю галочку "У вас отсутствует разрешение для просмотра данной страницы")

    16 сентября 2008 г. 11:53
  • должно быть так:

    16 сентября 2008 г. 11:59
  •  ICEBERG@ написано:

    А где лог ИИС можно посмотреть?



    в свойствах сайта посмотрите, куда у вас логи складываются. по умолчанию  - %systemroot%\system32\LogFiles

     ICEBERG@ написано:

    С соседнего компьютера требует пароль. С самого сервера тоже самое хотя я поставил на анонимный вход.

    а Вы уверены, что это сайт пароль запрашивает, а не прокси?


    16 сентября 2008 г. 12:04
  •  

    Все так и есть.

     

    Я тут еще одну вещь обнаружил. Возможно в этом и есть проблема. Когда сайту назначаю IP 192.168.1.2 при запуске сайта на самом сервере требует пароль. Когда убираю IP ("значения не присвоены") сайт грузится с самого сервера без проблем.

    16 сентября 2008 г. 12:11
  • у меня веб-сайт так и работает (IP Address: All unasigned) через NAT.

    16 сентября 2008 г. 13:12
  • Я сейчас дома пробую тут нет прокси. Пароль все равно требовал. Убрал IP из свойств сайта 192.168.1.5

    При обзоре и самого ИИС сайт грузится.

    При вызове с интернет эксплорера http://192.168.1.5:8080/ требует пароль.

    При вызове через внешний IP ничего не грузит.

     

     

    16 сентября 2008 г. 13:53
  • Если требует пароль, то неверно настроена аутентификация. Между прочим у IUSR_SERVER пароль не пустой. Попробуйте остановить текущий сайт и создайте новый с настройками по умолчанию. Убедитесь, что IUSR имеет NTFS права чтения на каталог с сайтом. Так же убедитесь, что окно аутентификации выглядит именно так, как показано на скриншоте. Сначала со стандартным портом. Должен работать из IE и из соседних машин спокойно.

     

    16 сентября 2008 г. 14:23
  • Уже удалили все и модем обнулил все заново начал.

    Это окно атутентификации:

    Это окно каталога:

    16 сентября 2008 г. 16:37
  • Есть какой нибудь способ для того что бы проверить с интернета сайт открывается или нет?

    Попробовал с соседнего клуба открыть, все нормально работает но пока на ХР. А так только по 192.168.0.2 могу смотреть. На 2003-ем все еще пароль требует.

     

    17 сентября 2008 г. 16:01
  • только один способ - ходить на веб-сайт через внешний IP вашего NAT маршрутизатора. И если на XP у вас работает, то нужно повторить всё то же и на 2003.

    17 сентября 2008 г. 16:28
  •  

    Через внешний не открывается ни на ХР ни на сервере. Не могу понять почему.
    18 сентября 2008 г. 4:08
  • И еще один глюк.

    Если по умолчанию стоит загрузка index.htm по внутреннему грузится нормально, если iisstart.asp то требует пароль к хосту. С чем это связано?

    18 сентября 2008 г. 4:33