none
Изменение доменной части SIP-адреса. RRS feed

  • Вопрос

  • Добрый день!

    Нужно заменить доменную часть СИП-адреса. Сервера настроил, сертификаты обновил, ДНСы переделал. Перевел нескольких тестовых пользователей - все работает, но не работает автовход так прописанный раннее адрес не совпадает с текущим. Знаю что можно решать или вводом вручную нового адреса (не вариант) или удалением записи в реестре (во всяком случае в 10 клиенте так решали проблему.

    Есть ли еще какие-нибудь методы замены sip-домена пользователям?

    Спасибо!

    14 сентября 2016 г. 8:00

Ответы

  • Если я правильно понял вашу конфигурацию, то раньше клиент в пользовательском лесу получал информацию о том, что надо идти в ресурсный лес, а уже там получал рабочую конфигурацию (если там не было sip адреса в proxyaddresses , то сложно сказать почему работало). Теперь клиент должен получить все атрибуты в пользовательском лесу.

    Сазонов Илья

    https://isazonov.wordpress.com/

    • Помечено в качестве ответа Alan.Pro 18 октября 2016 г. 6:53
    5 октября 2016 г. 14:25
    Модератор
  • Пустил скрипт по добавлению sip адреса  (и изменению, в случае смены почтового домена или фамилии) в proxyaddresses в пользовтельском домене. Пока все работает хорошо. Думаю вопрос можно закрывать.
    • Помечено в качестве ответа Alan.Pro 18 октября 2016 г. 6:53
    18 октября 2016 г. 6:53

Все ответы

  • Привет!

    Нужно создать в DNS необходимые записи для нового sip-домена.

    14 сентября 2016 г. 8:49
  • Я создал. автодискавер, автодискавер интерна, _сип_тлс. Все есть.
    14 сентября 2016 г. 9:09
  • нужна lyncdiscoverinternal.newsipdomain.com
    14 сентября 2016 г. 9:17
  • Я так понимаю, вопрос исключительно в перенастройке клиента.

    В домене самое простое это удаление ветки реестра с помощью Group Policy Preferences: только поставьте галку однократного применения GPP. Еще можно включить синхронное применение политики на время миграции.


    Сазонов Илья

    https://isazonov.wordpress.com/

    14 сентября 2016 г. 11:21
    Модератор
  • Есть такая. После первого входа проблем с нахождением сервера нет.
    14 сентября 2016 г. 11:26
  • Ну вот пока только такой метод и остается. Неприятность в том, что версии клиентов разбросаны от 10 до с4б. Это разные ветки.

    Для 16 офиса я так понимаю нужно тереть эту: HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Lync\%sipusername%

    Думал может есть еще какие методы. Но если только реестр, то придется так )

    14 сентября 2016 г. 11:37
  • GPP имеет для каждого элемента фильтр применения, так что не проблема для разных версий настроить.

    Сазонов Илья

    https://isazonov.wordpress.com/

    14 сентября 2016 г. 12:45
    Модератор
  • Мы удаляли две ветки в реестре:

    HKEY_CURRENT_USER/Software/Microsoft/Communicatorshow
    HKEY_CURRENT_USER/Software/Microsoft/Shared/UcClientshow


    Сазонов Илья

    https://isazonov.wordpress.com/

    21 сентября 2016 г. 9:19
    Модератор
  • Это было для 10 линка похоже. 13 и более молодые этими путями не пользуются.
    21 сентября 2016 г. 9:26
  • procmon вам в помощь.

    Сазонов Илья

    https://isazonov.wordpress.com/

    • Предложено в качестве ответа Vasilev VasilMicrosoft contingent staff 28 сентября 2016 г. 11:50
    • Отменено предложение в качестве ответа Alan.Pro 29 сентября 2016 г. 11:31
    21 сентября 2016 г. 10:52
    Модератор
  • Илья, оказывается дело не в кэше, а в автодискавери.

    Есть все три записи _sipinternaltls._tcp, lyncdiscover и lyncdiscoverinternal. Все направлены так же, как и для других доменов (на которых автодискавер работает).

    Я создал новую учетную запись и залогинился ей на новой для нее машине, с4б не смог залогиниться автоматически (поле для логина с дефолтными данными). Если вести однажды туда логин, то все равботает, но первого входа не происходит. Так я сделал вывод что домен настроен нормально и функционирует, не работает только линкдискавер(интернал). При этом он отлично лукапится.

    29 сентября 2016 г. 11:35
  • Возьмите клиент для проверки отсюда https://testconnectivity.microsoft.com/

    Сазонов Илья

    https://isazonov.wordpress.com/

    29 сентября 2016 г. 12:01
    Модератор
  • Илья, добрый день.

    Вы имели в виду Lync Connectivity Analyzer?

    Там все проходит хорошо (при тесте изнутри):

    Server discovery succeeded for secure (HTTPS) internal channel against URL https://lyncdiscoverinternal.**.ru/
    Server discovery succeeded for unsecure (HTTP) internal channel against URL http://lyncdiscoverinternal.**.ru/
    Server discovery succeeded for secure (HTTPS) external channel against URL https://lyncdiscover.**.ru/

    Если вы имели в виду Skype for business Autodisccovery Web Service тест, то и он пройден:

    Testing connectivity to the Lync Autodiscover Web Service server for a secure connection on port 443 to obtain the root token.
      Connectivity to the Lync Autodiscover Web Service test successful.
      Additional Details
      Elapsed Time: 2248 ms.
      Test Steps
      Attempting to test Autodiscover Web Service URL https://lyncdiscover.**.ru/Autodiscover/AutodiscoverService.svc/root.
      Autodiscover Web Service URL successfully tested.

    Изначально ругался на сертификат (при втором тесте извне, так как Lyncdiscover для внешней зоны ведет на реверс-прокси, а на РП был установлен вайлдкард с примари доменом (для нормальной работы мобильного линка), который на новый не похож. Для теста установил внутренний с прописанным lyncdiscover.новыйдомен.ру и тест прошел успешно. В любом лсучае изнутри все тесты успешно пройдены и Lyncdiscoverinternal тестерами находится.

    30 сентября 2016 г. 9:17
  • Тогда не в этом дело.

    Опигшите подробнее, что происходит при тесте с новой учеткой.


    Сазонов Илья

    https://isazonov.wordpress.com/

    30 сентября 2016 г. 11:22
    Модератор
  • При тесте новой учеткой (которая не изменялась, а сразу создавалась с новым доменом) запускается с4б, но графа "Адрес для входа" не заполнена.

    Если входить тестовым клиентом(которому был изменен сип-домен), который логинился уже раньше на этой машине, то будет введен его старый адрес.


    • Изменено Alan.Pro 30 сентября 2016 г. 11:55 дополнение
    30 сентября 2016 г. 11:53
  • А машина для теста тоже нулевая как и учетка?

    Сазонов Илья

    https://isazonov.wordpress.com/

    30 сентября 2016 г. 12:19
    Модератор
  • Машина не совсем нулевая, но тестировал на нескольких разных. На вин 10, на вин7. В понедельник попробую на нулевой, но к машинам причин не придумал.
    30 сентября 2016 г. 12:51
  • Проверил на нулевой. То же самое. При открытии линка графа "Адрес для входа" пустая.
    3 октября 2016 г. 12:53
  • Кажется нашел в чем дело, но не понял почему.

    У нас два домена, пользовательский и ресурсный. В ресурсном созданы клоны четок из пользоватльского, у них прописан сид их оригинала из первого домена в атрибут "msRTCSIP-OriginatorSid".

    Раньше, при использовании lync 2010 как клиента, так и сервера, работал скрипт, добавляющий пользователям из пользовательского домена sip-адрес в атрибут proxyAddresses и вообще для линка создавались отдельные клоны-учетки.

    Со временем перехода на lync 2013 необходимость в этом отпала и новым пользователям атрибут уже не прописывался. Все находилось отлично.

    И вот теперь при создании нового SIP-домена автообнаружения пользователя, как и настроек, снова не работает у тех, кто переведен в новый домен. Почему - я пока не понял.

    Другими словами, если в пользовательском домене добавить учетке в proxyaddresses ее sip-адрес, то автовход работает. Почему так я пока не понял, т.к. со всеми старыми сип-доменами такого не возникало.

    4 октября 2016 г. 13:39
  • Что-то у вас не по фэншую: в proxyaddresses учетки адрес sip должен быть обязательно. Раньше его клиент цеплял в ресурсном лесу, а теперь он только с учеткой пользовательского работает.

    Сазонов Илья

    https://isazonov.wordpress.com/

    5 октября 2016 г. 11:10
    Модератор
  • Илья, добрый день.

    Раньше для линка вообще отдельные учетки в ресурсном лесу создавались. Итого там были одни для эксченьджа, другие для линка. Затем произошло слияние, с сервера линка удалялись линковские учетки, добавлялись эксченьджевские. Что бы одна учетка была и не плодилась куча скриптов синхрониазции и учеток. 

    С тех пор новые учетки создаются всесте с эксченьджевскими. Срипт ищет в ресурсном домене учетки в оюшках, у которых есть почта, но их нет на сервере линка и добавляет на сервер. В пользовательском домене уже давно не дописывается сип в addresses и все работает. Пользователи входят и вполне себе работают без этой записи в proxyaddresses пользовательского домена. 

    Даже если не по фэншую, вопрос почему с новым сип-доменом не работает.

    В принципе можно допилить скрипт что бы при добавлении на линк новых учеток дописывал сип-адрес им в пользовательскую подсеть, но хотел бы понять почему не работает как раньше. Фразу "Раньше его клиент цеплял в ресурсном лесу, а теперь он только с учеткой пользовательского работает" можно считать ответом? В принципе это объясняет почему не работает на новом, но почему работает на старом, учитывая что учетки создавались так около полугода с разными sip-доменами и работали?

    5 октября 2016 г. 11:22
  • То есть теперь вопрос скорее не почему не работает, а почему работало.
    5 октября 2016 г. 11:27
  • Если я правильно понял вашу конфигурацию, то раньше клиент в пользовательском лесу получал информацию о том, что надо идти в ресурсный лес, а уже там получал рабочую конфигурацию (если там не было sip адреса в proxyaddresses , то сложно сказать почему работало). Теперь клиент должен получить все атрибуты в пользовательском лесу.

    Сазонов Илья

    https://isazonov.wordpress.com/

    • Помечено в качестве ответа Alan.Pro 18 октября 2016 г. 6:53
    5 октября 2016 г. 14:25
    Модератор
  • Пустил скрипт по добавлению sip адреса  (и изменению, в случае смены почтового домена или фамилии) в proxyaddresses в пользовтельском домене. Пока все работает хорошо. Думаю вопрос можно закрывать.
    • Помечено в качестве ответа Alan.Pro 18 октября 2016 г. 6:53
    18 октября 2016 г. 6:53