none
Проблемы с сетью на гостевой ОС MS Windows Server 2008 R2 после ее перезагрузки RRS feed

  • Вопрос

  • Здравствуйте!

    Сервер IBM x3850m2 под управлением MS Windows Server 2008 R2. На сервере поднята роль Hyper-V. Установлены две виртуальные машины MS Windows Server 2008 R2.  Обе виртуальные машины, как и сам сервер hyper-v в домене, IP адреса статические.

    На одной из виртуальных машин проблема с сетью после ее перезагрузки. А именно, после перезагрузки не стартуют сетевые службы, не отрабатывается logon скрипты, в журнале событий сообщения, что не удается найти контроллер домена, при этом сама виртуальная машина пингуется. Через RDP  войти на виртуальную машину тоже не удается, только через консоль Hyper-V. В результате виртуальная машина по факту работает без перезагрузок, что не приемлемо, т.к. все таки бывает необходимость выполнить рестарт.

    В настоящее время решение нашел только одно, крайне неудобное:

    1. Выключаем виртуальную машину.

    2. В оснаске Hyper-V удаляем сетевой адаптер виртуальной машины.

    3. Запускаем виртуальную машину, логинемся доменной учетной записью

    4. Ждем 2-5 минут, виртуальная машина обнаруживает сетевую карту, прописываем статические IP адреса.

    5. Все работает!

    Но если виртуальную машину перезагрузить, то опять все сетевые службы встают колом.


    Помогите разобраться в решении этой проблемы! Спасибо.


    • Изменено MoguL82 5 сентября 2015 г. 8:25
    5 сентября 2015 г. 8:19

Ответы

  • Проблема разрешилась:

    1. Удалил сетевой адаптер гостевой ОС в оснаске hyper-v

    2. Удалил виртуальный коммутатор.

    3. Заново создал виртуальный коммутатор и внешнюю сеть для гостевой ОС.

    • Помечено в качестве ответа MoguL82 8 сентября 2015 г. 9:20
    8 сентября 2015 г. 9:20

Все ответы

  • Что будет если зайти локальной учеткой и посмотреть что происходит с виртуалкой (логи, состояние сети и тд.)?

    Как настроена сеть и виртуальный коммутатор?


    The opinion expressed by me is not an official position of Microsoft

    5 сентября 2015 г. 9:49
    Модератор
  • Если зайти под локальной учетной записью, загружается чистый рабочий стол, без ярлыков. Загрузил журнал событий через ctrl+alt+del, cmd - eventvwr, но ничего подозрительного не нашел.

    Состояние сети: "Соединение установлено". Но по факту зайти на любую сетевую шару не удается, все зависает.

    Выключаю виртуальную машину, удаляю сетевой адаптер в диспетчере виртуальных машин, включаю виртуальную машину, Windows загружается без проблем.

    Выключаю виртуальную машину, добавляю сетевой адаптер в диспетчере hyper-v, выбираю "подключение по локальной сети - Виртуальная сеть". Включаю виртуальную машину, логинюсь, система обнаруживает "Адаптер магистральной сети виртуальной машины", прописываю IP адрес и все работает.

    Скрины:

    http://s020.radikal.ru/i717/1509/46/853ab1004dc3.jpg

    http://s018.radikal.ru/i525/1509/e5/d4b0f7b31b07.jpg


    • Изменено MoguL82 7 сентября 2015 г. 13:07
    7 сентября 2015 г. 13:04
  • так а с адресом что когда машина в неадеквате? Вы пробовали сетевые настройки проверить?

    The opinion expressed by me is not an official position of Microsoft

    7 сентября 2015 г. 13:10
    Модератор
  • Проблема разрешилась:

    1. Удалил сетевой адаптер гостевой ОС в оснаске hyper-v

    2. Удалил виртуальный коммутатор.

    3. Заново создал виртуальный коммутатор и внешнюю сеть для гостевой ОС.

    • Помечено в качестве ответа MoguL82 8 сентября 2015 г. 9:20
    8 сентября 2015 г. 9:20