none
Exchange 2010 pop3/imap RRS feed

  • Общие обсуждения

  • Доброго дня, никак не получается подружить внешний любой почтовый клиент с внутренним почтовиком, но при этом отправка текстового сообщения осуществляется при проверки соединения.
    В моей схеме используется роутер и хостовая машина с развернутым керио, два правила для CA мапит на IIS
    и отдельно для протоколов, которые мапится на Edge на прямую

    подскажите, что не учитываю или что не до настроил на самом сервере?
    Outlook AnyWhere - вписал свой домен smail.smbuil.ru

    з.ы. На роутере правило 25/2525 перенаправлять на керио
    (делал отдельные правила для pop3 imap не помогло)
    по telnet попасть на 110 порт не могу, на 25 все ок

    з.ы. понимаю, что видимая проблема именно из-за этого и не могу почему не подключается или не пропускает пакеты.

    Спасибо.

    использовал статью http://www.alexxhost.ru/2010/06/exchange-2010-pop3.html
    не помогло 8(

    29 марта 2015 г. 9:48

Все ответы

  • Полагаю, вам нужно более четко описать конфигурацию, сценарий работы и проблему: сейчас все слишком туманно и отрывочно.

    Сазонов Илья http://isazonov.wordpress.com/

    29 марта 2015 г. 16:10
    Модератор
  • на текущий момент у меня схема:

    DMZ зоны: Керио и Edge c WAN интерфейсами

    на роутере NAT правило на порт 25 и 443 перенаправлять на Kerio. Правило на Керио мапит все по портам 443 на CA сервер внутри сети.

    Второе правило, все пакеты касающиеся Mail service мапятся на EDGE, там работает связка с ORF

    у EDGE есть интерфейс LAN по которому на связан уже с CA+MB+HT

    надеюсь так более понятно

    29 марта 2015 г. 20:06
  • Exchange Edge не предназначен для организации внешнего доступа к Exchange. Для этого нужен или обратный прокси, или проброс портов. Посмотрите статью про публикацию IMAP4 и POP3.

    Do not multiply entities beyond what is necessary

    30 марта 2015 г. 8:29
  • Я перенастроил правила нат, все стало доступно

    к сожалению у меня почему то не работает вот эта команда ругается

    Set-ReceiveConnector -Identity "hubtransport\Client HUBTRANSPORT" -AdvertiseClientSettings:$true

    "hubtransport\Client HUBTRANSPORT" - возможно я тут что-то пишу не правильно, ведь я должен указать свой сервер?

    а мне нужно создавать какие либо коннекторы на HT для каждого протокола?

    30 марта 2015 г. 17:18
  • я так думаю что мне надо сделать так http://it-connection.ru/?p=823
    30 марта 2015 г. 19:35
  • коннекторы создаются только для транспортного протокола (SMTP), POP3 и IMAP это протоколы клиентского доступа и для них не нужны коннекторы.

    Do not multiply entities beyond what is necessary

    31 марта 2015 г. 4:28
  • на текущий момент у меня по pop3 и imap и telnet, и входящее подключение проходит

    все тесты проходят https://testconnectivity.microsoft.com, но ругается что в сертификате smail нет информации о smail.smbuil.ru

    и на текущий момент, если использовать 25 порт при отправке он дает отбой

    550 5.7.1 Unable to relay

    не могу понять как правильно сделать коннектор на HT


    к сожалению у меня почему то не работает вот эта команда ругается

    Set-ReceiveConnector -Identity "hubtransport\Client HUBTRANSPORT" -AdvertiseClientSettings:$true

    "hubtransport\Client HUBTRANSPORT" - возможно я тут что-то пишу не правильно, ведь я должен указать свой сервер?

    а с этим как?
    • Изменено exfant 31 марта 2015 г. 5:29
    31 марта 2015 г. 5:28
  • Самое простой способ все узнать, это открыть на роутере и на прокси общий доступ т..е. все отключить и что бы все бегало туда сюда. и сразу будет понятно. (таким способом на freebsd правила и сервисы всегда проверяются )))  открой все и смотри ))) )
    31 марта 2015 г. 6:55
  • Все сделал, коннектор отдельный порт и настроил все =)

    сделав авторизацию тока доменых учеток, но все же с командой мне не понятно

    • Изменено exfant 31 марта 2015 г. 18:58
    31 марта 2015 г. 18:58