none
Расширение схемы AD для Exchange 365 RRS feed

  • Вопрос

  • Доброго всем!

    Используем у себя в компании облачный Exchange 365 Online. Все ок!

    Теперь появилась некоторая задача, которая требует того, чтобы мы расширили схему своего домена и подготовили домен.

    Домен у нас на базе Windows 2008R2.

    1) Скачали с личного кабинета из дистрибутивов, дистрибутив Exchange 2016 Standard

    2) Запускаем из командной строки Setup.exe /PrepareSchema /IAcceptExchangeServerLicenseTerms и получили сообщение о том что наша операционная система не поддерживается!

    Команду выполняли на контроллере домена из под админа! В требованиях к установке Exchange 2016, Windows 2008R2 присутствует.

    Почему имеет место быть подобное сообщение?

    Спасибо!

    15 марта 2017 г. 13:07

Ответы

  • Добрый день,

    Потому что так работает инсталлятор. Он проверяет все pre-requisites и вы под них не проходите по минимальной ОС для E2016, т.е. WinServer 2012.

    • Помечено в качестве ответа ItDen 15 марта 2017 г. 14:30
    15 марта 2017 г. 13:18

Все ответы

  • Добрый день,

    Потому что так работает инсталлятор. Он проверяет все pre-requisites и вы под них не проходите по минимальной ОС для E2016, т.е. WinServer 2012.

    • Помечено в качестве ответа ItDen 15 марта 2017 г. 14:30
    15 марта 2017 г. 13:18
  • а можно точную ошибку?

    у вас уровень леса 2008 и выше?


    scientia potentia est
    My blog

    15 марта 2017 г. 13:19
  • Точный текст ошибки звучит так: 

    Обнаружена неподдерживаемая операционная система. Роли сервера почтового ящика Exchange Server 2016 и пограничного транспортного сервера поддерживают Windows Server 2012 или более позднюю версию.

    А режимы работы леса, только заметил 2003 (у нас есть еще другой домен, который в доверительных отношениях с нашим основным). А режим работы домена 2008 R2.

    Из-за режима работы леса, не хочет расширять схему?




    • Изменено ItDen 15 марта 2017 г. 14:09
    15 марта 2017 г. 14:08
  • Точный текст ошибки звучит так: 

    Обнаружена неподдерживаемая операционная система. Роли сервера почтового ящика Exchange Server 2016 и пограничного транспортного сервера поддерживают Windows Server 2012 или более позднюю версию.

    А режимы работы леса, только заметил 2003 (у нас есть еще другой домен, который в доверительных отношениях с нашим основным). А режим работы домена 2008 R2.

    Из-за режима работы леса, не хочет расширять схему?




    нет, не заметил, что вы с контроллера делали.

    Нужно как ответил Иван делать расширение с машинки 2012 и выше, плюс уровень леса надо все равно поднять.

    не понял как доверительные отношения влияют на уровень леса?


    scientia potentia est
    My blog

    15 марта 2017 г. 14:14
  • Извиняюсь, но я не понял про рекомендацию Ивана. Мне что ставить новый сервак с 2012 и переводить домен на эту ОСь?

    Доверительные отношения не причем, это я так вкратце упомянул наш старый домен.

    Все когда-то держалось на 2003 домене. Пару лет назад установили новые сервера и завели 2008r2 домен. Это было еще до меня в компании и всех настроек как было сделано, не смогу сказать. И в старом домене еще осталось часть сервисов (уже минимум, т.к. постепенно все переезжает в 2008R2) и были настроены доверительные отношения между старым доменом и новым. И видимо уровень леса остался на уровне 2003!

    15 марта 2017 г. 14:26
  • Иван, но в требованиях ведь написано, что и 2008R2 может быть!

    https://technet.microsoft.com/ru-ru/library/aa996719(v=exchg.160).aspx

    Правда там написано ее в шапке "Все контроллеры доменов в лесу должны работать под управлением одной из указанных ниже операционных систем"

    Т.е. схему мы не обновим пока лес не будет 2008 R2?

    Но я, извиняюсь, все равно не понял про 2012 WinServer. Мне что, поднимать на этой ОС сервак + AD и реплицировать на него все хозяйство?

    15 марта 2017 г. 14:29
  • 1) Иван, но в требованиях ведь написано, что и 2008R2 может быть!

    https://technet.microsoft.com/ru-ru/library/aa996719(v=exchg.160).aspx

    2) Правда там написано ее в шапке "Все контроллеры доменов в лесу должны работать под управлением одной из указанных ниже операционных систем"

    3) Т.е. схему мы не обновим пока лес не будет 2008 R2?

    4)Но я, извиняюсь, все равно не понял про 2012 WinServer. Мне что, поднимать на этой ОС сервак + AD и реплицировать на него все хозяйство?

    Разбил на пункты. Итак,

    1) Это версии ОС для контроллера домена

    2) Все верно, опять же это касается только контроллеров домена

    3) Неверное утверждение. Основное требование это уровень леса 2008 и выше

    4) Нет. Вам нужен рядовой сервер 2012 или выше в вашем AD. С него вам надо запускать подготовку схемы и все остальное.

    Смотрите, инсталлятор не умеет распознавать, что вы его запустили на КД и проверяет абсолютно все пререквизиты, нужные для установки самого Exchange при любой операции schemaprep, adprep, domain prep. На WinServer 2008, в той частности и 2008 R2, Exchange 2016 не устанавливается, о чем он вам и сообщает.





    • Изменено Ivan.Basov 15 марта 2017 г. 15:12 поправил
    15 марта 2017 г. 14:52