none
MOSS: проблемы с поиском. RRS feed

  • Общие обсуждения

  • Суть:

    1) ставлю MOSS

    2) настраиваю Shared Services

    3) восстанавливаю из бекапа сайт

    4) запускаю crawl.

    Симптомы:

    1) crawl дает ошибку:

    sts3://site:4444
    An unrecognized HTTP status was received. Check that the address can be accessed using Internet Explorer. (HttpStatusCode ProxyAuthenticationRequired The request failed with HTTP status 407: Proxy Authentication Required.)

    2) При попытке провести поиск на этом сайте выдается Unknown Error

    3) Никаких настроек прокси, насколько я знаю, нет

     

    Вопрос: как решить проблему или, хотя бы, в чем она?

     

    20 декабря 2007 г. 11:27

Все ответы

  • В веб.конфиг прописан proxy?

    Остальные прилжения индексируются без проблем?

    20 декабря 2007 г. 13:45
  • 1) web.config где?

    2) Остальных приложений просто нет, но если нужно - создам. Говорите параметры.

    20 декабря 2007 г. 15:04
  • какие приложения созданы?

    не может быть такого, чтобы не было других приложений вообще.

    та ссылка (типа "sts3") - это поиск и индексирование людей. помимо этого приложения есть еще и другие, само приложение поиска, приложение в котором будет вестись групповая работа (сам портал).

    в вебконфиге приложения общих служб (в \Inetpub\wwwroot\wss\VirtualDirectories\<номер порта приложения общих служб (обычно, можно и изменить)>) посмотри <defaultproxy>, какие там параметры?

     

    21 декабря 2007 г. 7:46
  • Хммм... Что-то я, видимо, сделал такого, что индексация прошла без ошибок, но при этом в индексе оказалось мало объектов - 33 штуки. И поиск на сайте по прежнему выдает unknown error. Все остальные приложения индексировались нормально.

    В файле вроде выставлен autodetect. что туда прописать?

     

    21 декабря 2007 г. 10:01
  • что пишется в журналах обхода содержимого?

    Если индексация идет, поиск не работает пока она не закончится 

    Если менялись аккаунты службы поиска -надо смотреть разрешения на базы в сиквеле

    21 декабря 2007 г. 14:13
  •  

    Возможно, следует указать прокси, раз уж эта ошибка, чтобы индексация фермы осуществлялась через прокси. На сайте центрального администрирования в разделе управления приложениями выбрать Manage search service, и далее  - proxy
    21 декабря 2007 г. 22:16
    Отвечающий
  •  Budya написано:

    что пишется в журналах обхода содержимого?

    Если индексация идет, поиск не работает пока она не закончится 

    Если менялись аккаунты службы поиска -надо смотреть разрешения на базы в сиквеле

    Где найти эти журналы?

    аккаунты не менялись.

     

     Kichin Denis написано:

     

    Возможно, следует указать прокси, раз уж эта ошибка, чтобы индексация фермы осуществлялась через прокси. На сайте центрального администрирования в разделе управления приложениями выбрать Manage search service, и далее  - proxy

    Это... А зачем мне прокси для индексирования локального содержимого? =)

    К тому же ошибка уже пропала вроде.

    26 декабря 2007 г. 7:57
  • в журнала пишется к какому именно содержимому небыло доступа и примерно по какой проблеме.

    Администрирование общих служб: SharedServices1 > Параметры поиска > Сводка имен узлов  

     

    прокси надо прописывать обязательно без этого не хочет работать поиск даже локальных узлов , хотя для корректного обхода содержимого лучше указать - не использовать локальные адреса (в одном домене) или прописать зону *.my.ru  (для леса).

    26 декабря 2007 г. 8:14
  • Ммм... В английском варианте это crawl logs,  я так понимаю... Там чисто, я уже говорил, что ошибки исчезли все, кроме одной:

    при попытке поиска на сайте выдается Unexpected Error.

    Насчет прокси - можно ссылочку?

     

    26 декабря 2007 г. 8:25
  • т.е. если правильно понял индексация идет без ошибок. а при попытке поиска на портале выдает ошибку Unexpected Error ?

    что то подобное было не помню как вылечил. толи переустановкой ASP.NET 2 (и 3 ), толи перезапуском мастера настройки параметров или вообще после переустановки  портала за ново и подъема из бэкапа .Сейчас попробую найти.. В эвентах есть что нибуть после зависания поиска ?  

     

    прокси настраивается

    Центр администрирования > Управление приложениями > Служба поиска > Параметры поиска на уровне фермы  

    26 декабря 2007 г. 9:01
  • В Event Log  - пусто.

    Я про прокси имел в виду - где сказано, что оно должно быть настроено?

    26 декабря 2007 г. 9:28
  • Вообще в гайде (справочник администратора MOSS 2007 Билл Инглиш и С- спец. издание распространяется бесплатно - выдавали на в Kite на Платформе 2008 (Москва)) стр. 629 - часть 3 - глава17 Развертывание системы корпоративного поиска -  Параметры поиска на уровне фермы) 

     описан порядок настройки написано "можно настроить" т.е на усмотрения админа.

     

    Из практики - при бэкапе узла, и ресторе на новом сервере средствами stsadm, поиск перестанет работать, в журнале поиска будет запись - не найден узел, неправильная настройка прокси сервера.

    пока не настроиш работать не будет...

     

     
     

    26 декабря 2007 г. 10:11
  • Эээ... Тут выяснилась забавная подробность - он не работал и до переноса, поиск этот.

    К тому же у меня нет в логах ошибок.

    26 декабря 2007 г. 11:18
  • Тогда установка с 0 - настройка - создание тест приложения - проверка индексации и поиска - перенос контента -

    Поиск практически не рально запустить если на ферму были поставлены обновления 934525 для сервиса, ставте уж сразу SP1.

    На сегодня схема работает для фермы с доп. SQL 2005, но на том же сервере,что и SPS+SP1, схему установки SP1 на работающую ферму не проверял..    

     

    26 декабря 2007 г. 11:33
  • байзевей, а установка MOSS в каком варианте?

    26 декабря 2007 г. 13:04
  • Full.

     

    26 декабря 2007 г. 13:22