none
Выполнение функции при закрытом исходном документе RRS feed

  • Вопрос

  • Есть 2-а документа, заполненные данными.

    1) В первом документе, назовем его - ИСХ.xlsx, есть ряд цифровых значений.

    2) Во втором документе, назовем его - РЕЗ.xlsx, используется функция СУММЕСЛИ(диапазон значений из ИСХ.xlsx, сравниваем в значением в таблице документа РЕЗ.xlsx, заполняем значения из файла ИСХ.xlsx).

    Суть вопроса:

    При закрытом файле из которого берутся данные, в поле с использованием функции СУММЕСЛИ, подставляется значение #ЗНАЧ.

    Достаточно открыть файл ИСХ.xlsx и функция срабатывает корректно.

    P.S. Простейшая функция сложения нескольких чисел, корректно работает даже при закрытом исходном документе.

    Описал пример, только для одной функции, по факту используется очень много функций и очень большое количество ведет себя подобным образом.

    Не могли бы Вы написать полный список функций которые могут забирать данные даже при закрытом исходном файле. А еще лучше, если Вы распространите функционал простейших функций (сложение в данном случае), на все оставшиеся функции, чтобы они работали с закрытым исходным файлом.

    Заранее спасибо.

    Роман.

    23 сентября 2014 г. 13:47

Ответы

  • Действительно, мне сложно понять логику людей ;)

    Ваши файлы-примеры, только больше запутали, дополните:

    -зачем для простого переноса данных из одной книги в другую, использовать СУММЕСЛИ,

    так как для переноса суммы данных из закрытой книги, согласно статьи, нужно использовать другую формулу, причём формулу массива, результатом выполнения которой станет:

    Для получения такого результата при закрытой книге:

    необходимо для Вашего примера, использовать формулу:

    =СУММПРОИЗВ(([исх1.xlsx]Лист1!$A$2:$A$6=$A2)*[исх1.xlsx]Лист1!B2)


    Да, я Жук, три пары лапок и фасеточные глаза :))




    • Изменено ЖукMVP, Moderator 25 сентября 2014 г. 11:19
    • Предложено в качестве ответа piligrim2180 25 сентября 2014 г. 21:58
    • Помечено в качестве ответа ЖукMVP, Moderator 29 сентября 2014 г. 6:50
    25 сентября 2014 г. 10:53
    Модератор

Все ответы

  • Дополните Ваш вопрос, полной формулой при выполнении которой у Вас происходит ошибка #ЗНАЧ!.

    Ошибка #ЗНАЧ! появляется в том случае, если формула содержит ячейки с разными типами данных. Если включена проверка ошибок в формулах, при наведении указателя мыши на смарт-тег появится всплывающая подсказка "Значение, используемое в формуле, имеет неправильный тип данных". Обычно для исправления этой ошибки достаточно внести в формулу небольшие изменения.

    Воспользуйтесь разделом Q9 справки, загрузите Ваши файлы-примеры в общедоступную папку бесплатного хранилища OneDrive, ссылку на папку с файлами-примерами введите в своё сообщение.


    Да, я Жук, три пары лапок и фасеточные глаза :))

    24 сентября 2014 г. 13:30
    Модератор
  • В описании ошибки #ЗНАЧ! указано следующее - "ошибка в значении".

    Жук, Вы меня наверно не совсем поняли.

    Ошибка #ЗНАЧ! пропадает, как только открывается исходный документ и в поля, где используется формула, подставляются правильные значения.

    Вот два файла - http://1drv.ms/1mtSfR6

    25 сентября 2014 г. 7:01
  • Действительно, мне сложно понять логику людей ;)

    Ваши файлы-примеры, только больше запутали, дополните:

    -зачем для простого переноса данных из одной книги в другую, использовать СУММЕСЛИ,

    так как для переноса суммы данных из закрытой книги, согласно статьи, нужно использовать другую формулу, причём формулу массива, результатом выполнения которой станет:

    Для получения такого результата при закрытой книге:

    необходимо для Вашего примера, использовать формулу:

    =СУММПРОИЗВ(([исх1.xlsx]Лист1!$A$2:$A$6=$A2)*[исх1.xlsx]Лист1!B2)


    Да, я Жук, три пары лапок и фасеточные глаза :))




    • Изменено ЖукMVP, Moderator 25 сентября 2014 г. 11:19
    • Предложено в качестве ответа piligrim2180 25 сентября 2014 г. 21:58
    • Помечено в качестве ответа ЖукMVP, Moderator 29 сентября 2014 г. 6:50
    25 сентября 2014 г. 10:53
    Модератор