none
Hyper-V не запускается [Драйвер "Низкоуровневая оболочка" не установлен] RRS feed

  • Вопрос

  • Здравствуйте. Вот поставил себе Windows Server 2008 R2 Standard Edition, настройку выполнял в точности по инструкции начала работы с сервером (ну окошко это, где предлагает активироваться, настроить сеть, установить апдейты, установить роли и компоненты" и т.д.) Выполнил всё в точности, никакого ПО не устанавливал. ОС лицензионней некуда.

    И получил такую проблему:

    Честно прочитав technet, яндекс и гугл я понял, чт это проблема аппаратной виртуализации. Однако процессор AMD FX-4100 Black технологию поддерживает, в биосе она включена (Virtual PC работают без проблем). В свойствах компьютера аппаратный DEP тоже включён. Вторые сутки бьюсь с проблемой, как это вылечить?

    Запрос в cmd о наличии и включённости DEP вернул TRUE:

    C:\Users\Администратор>wmic OS Get DataExecutionPrevention_Available
    DataExecutionPrevention_Available
    TRUE


    MSDN AA User


    24 апреля 2012 г. 6:27

Ответы

  • ОС утром переустановил, гипервизор ставился на абсолютно чистую ОС.

    Проблема решена. Этот не баг, это фича. Процессоры с новой архитектурой Buldozer содержат иной набор инструкций, нежели предыдущие архитектуры и протокол виртуализации работает немного некорректно из-за этого. Лечится установкой этого фикса: http://support.microsoft.com/kb/2568088/en-us Спасибо за участие в поиске решения.


    MSDN AA User






    24 апреля 2012 г. 12:31

Все ответы

  • Выключите питание сервера. Совсем, с отключением шнура питания от разъема.
    24 апреля 2012 г. 6:39
    Модератор
  • Не помогло. Выключил, отключил шнур - ткнул в кнопку питания чтобы сбросить остаточный заряд на пусковых конденсаторах, подключил шнур и включил. Ничего не изменилось. На всякий случай выкладываю скриншоты тех настроек, которые, как мне кажется, имеютотношение к процессору и виртуализации.

    SkyDrive


    MSDN AA User

    24 апреля 2012 г. 7:14
  • В командной строке с повышением привилегий выполните bcdedit /set hypervisorlaunchtype auto

    24 апреля 2012 г. 7:21
    Модератор
  • Ничего не изменилось, виртуалки не стартуют, 14098 по-прежнему появляется.


    MSDN AA User

    24 апреля 2012 г. 7:36
  • Конфигурацию ВМ приведите.
    24 апреля 2012 г. 8:26
    Модератор
  • Вот конфиг ВМ:

    Все остальные параметры по-умолчанию. Службы интеграции включены все. Но даже если нету ни одноу ВМ, то всё равно возникает ошиба (подозреваю что этот драйвер грузится во время старта самой службы ВМ).

    ПС: так же пробовал переключать режим работы HDD с AHCI на IDE с полным отключением питания - ничего не изменилось.


    MSDN AA User

    24 апреля 2012 г. 11:50
  • Нужна конфигурация, "взятая" из свойств Вм в консоли Hyper-V.

    Проверьте утилитой Securable поддержку виртуализации, возможно, проблема кроется в BIOS. Если не поможет и это - переустановка роли, и/или операционной системы.

    24 апреля 2012 г. 12:02
    Модератор
  • ОС утром переустановил, гипервизор ставился на абсолютно чистую ОС.

    Проблема решена. Этот не баг, это фича. Процессоры с новой архитектурой Buldozer содержат иной набор инструкций, нежели предыдущие архитектуры и протокол виртуализации работает немного некорректно из-за этого. Лечится установкой этого фикса: http://support.microsoft.com/kb/2568088/en-us Спасибо за участие в поиске решения.


    MSDN AA User






    24 апреля 2012 г. 12:31
  • Спасибо, очень помогло.
    4 октября 2013 г. 12:40