none
Публикация SharePoint 2010 RRS feed

  • Общие обсуждения

  • При публикация SharePoint 2010 через TMG 2010 не проходит тест

    Testing http://portal.test.ru:80/_vti_inf.html*
    Category: General error
    Error details: An unexpected response was received from the server. HTTP response: 400 Bad Request
    Action: Verify that the intended server is published and that virtual directories exist. Ensure that you can browse the published site directly from an internal client computer

    Скажите, в чем может быть проблема?

    • Изменено Vitaly Lisapov 21 февраля 2011 г. 10:10
    • Изменен тип Yuriy Lenchenkov 11 марта 2011 г. 8:33 пользователь покинул тему
    18 февраля 2011 г. 6:24

Все ответы

  • такая ошибка через любой браузер возникает?

    посмотрите в логах iis более подробную информацию

    и вот статья по логам sharepoint http://technet.microsoft.com/en-us/library/ee748656.aspx


    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий
    18 февраля 2011 г. 8:32
  • https на 80 порту? нигде ошибки нет?
    20 февраля 2011 г. 21:54
    Отвечающий
  • эта ошибка возникает при проверке правила в TMG 2010.
    21 февраля 2011 г. 7:19
  • Для сайта SharePoint не настроен https, все узлы находятся на http, альтернативные пути тоже http, все на 80 порту.

    21 февраля 2011 г. 7:20
  • а почему у тебя https в тексте ошибки?
    21 февраля 2011 г. 10:08
    Отвечающий
  • это я опечатался, извините

    21 февраля 2011 г. 10:11
  • а внешнее имя по которому паблишится присутствует среди паблик урлов на шарике?

    21 февраля 2011 г. 13:28
    Отвечающий
  • а внешнее имя по которому паблишится присутствует среди паблик урлов на шарике?


    да, оно имеется в списке сопоставления альтернативного доступа

    http://portal зона по умолчанию

    http://portal.test.com/ зона интернет

    В IIS настроена соответствующие привязки.

    21 февраля 2011 г. 13:41
  • у меня кстати этот тест тоже не проходит, но публикация работает :)
    21 февраля 2011 г. 16:00
    Отвечающий
  • у меня кстати этот тест тоже не проходит, но публикация работает :)

    публикация прошла успешно тоже. Но при попытке перейти по адресу http://portal.test.com/ в не локальной сети браузер не может отобразить страницу, если перейти по адресу https://portal.test.com/ , то появляется страница с сертификатом, выбираю разрешить и получаю ошибку 403.
    28 февраля 2011 г. 8:09
  • ну если ты публиковал https то по http и не пройдет (в листенере можно поставить редирект, или в самом iis)
    по поводу 403: хеадер оригинальный перенаправляешь или подставляешь другой? аутенфикация и делегирование какие включены?

    28 февраля 2011 г. 11:29
    Отвечающий
  • Vitaliy Lisapov, вам удалось решить проблему?
    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий
    4 марта 2011 г. 12:15
  • Уважаемый пользователь!
    В вашей теме отсутствует активность в течение последних 5 дней. При отсутствии каких-либо действий в течение 2 последующих дней, тема будет переведена в разряд обсуждений. Вы можете возобновить дискуссию, просто оставив сообщение в данной теме.
    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий
    9 марта 2011 г. 8:07