none
Свойству PublishPTRRecords для сети "Имя: " присвоено значение 1 (Включено). RRS feed

  • Вопрос

  • Здравствуйте!

    Windows server 2012 node1

    Windows server 2012 node2

    Cluster!

    Настроил кластер запустил проверку, обнаружил вот такое предупреждение,

     не у бабке Яндекса не у деда гугла ответа не нашлось

    Свойству PublishPTRRecords для сети "Имя: k002" присвоено значение 1 (Включено).

    Это сетевое имя будет публиковать PTR-записи на DNS-сервере. Для этого значения

    по умолчанию задана конфигурация кластера 0 (Отключено).

    Убедитесь, что DNS-сервер поддерживает обратный поиск в DNS на основе PTR-записей.

     cluster.exe /cluster: < clusteralias > ресурс «Имя кластера» / Priv PublishPTRRecords = 1

    При попытке ввода данной команды не нашелся cluster.exe поиск по файлам результата тоже не дал. скажите как исправить это предупреждение. Спасибо!



    • Изменено mazf 25 марта 2014 г. 13:36
    25 марта 2014 г. 13:35

Ответы

  • Разве Вы для cluster name используете DHCP? Это не слишком рекомендуемая конфигурация...

    Конфигурация по умолчанию (рекомендуемая): Static IP + PublishPTRRecords со значением 0

    Если необходимо PTR регистрировать, то делайте как описано в статье. Каким образом менять значения параметра PublishPTRRecords я Вам показал.


    Roman Levchenko, MCITP, MCTS http://www.rlevchenko.com

    26 марта 2014 г. 11:07

Все ответы

  • Попробуйте из Powershell (с правами администратора):

     Get-ClusterResource “Cluster Name” | Set-ClusterParameter –Name PublishPTRRecords -Value 0


    Roman Levchenko, MCITP, MCTS http://www.rlevchenko.com

    25 марта 2014 г. 15:45
  • Попробуйте из Powershell (с правами администратора):

     Get-ClusterResource “Cluster Name” | Set-ClusterParameter –Name PublishPTRRecords -Value 0


    Roman Levchenko, MCITP, MCTS http://www.rlevchenko.com

    PS C:\Windows\system32> Get-ClusterResource k002 | Set-ClusterParameter -Name PublishPTRRecords -Value 1
    Get-ClusterResource : Возникла ошибка при открытии ресурса "k002".
    строка:1 знак:1
    + Get-ClusterResource k002 | Set-ClusterParameter -Name PublishPTRRecords -Value 1
    + ~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : ObjectNotFound: (:) [Get-ClusterResource], ClusterCmdletException
        + FullyQualifiedErrorId : ClusterObjectNotFound,Microsoft.FailoverClusters.PowerShell.GetResourceCommand

    не удается. Может как то в ручную можно при помощи реестра?
    26 марта 2014 г. 5:34
  • Get-ClusterResource выдаёт k002? Проверьте. он ссылается на недоступность ресурса.

    Roman Levchenko, MCITP, MCTS http://www.rlevchenko.com

    26 марта 2014 г. 5:39
  • Get-ClusterResource выдаёт k002? Проверьте. он ссылается на недоступность ресурса.

    Roman Levchenko, MCITP, MCTS http://www.rlevchenko.com

    PS C:\Windows\system32> nslookup
    ╤хЁтхЁ яю єьюыўрэш■:  domen.rabota.ru
    Address:  10.200.1.240
    
    > k002
    ╤хЁтхЁ:  domen.rabota.ru
    Address:  10.200.1.240
    
    ╚ь :     k002.rabota.ru
    Address:  10.200.1.2
    
    > PS C:\Windows\system32> ping 10.200.1.2
    
    Обмен пакетами с 10.200.1.2 по с 32 байтами данных:
    Ответ от 10.200.1.2: число байт=32 время<1мс TTL=128
    
    
    PS C:\Windows\system32> ping k002
    
    Обмен пакетами с k002.rabota.ru [10.200.1.2] с 32 байтами данных:
    Ответ от 10.200.1.2: число байт=32 время<1мс TTL=128

    http://i7.pixs.ru/storage/6/4/0/111jpg_6906893_11407640.jpg

    как можно еще его проверить?

    • Изменено mazf 26 марта 2014 г. 6:22
    26 марта 2014 г. 6:18
  • k002 - имя кластера?

    Выполните ровно так , как ниже (ничего не меняйте.копируйте и выполните):

    Get-ClusterResource "cluster name"|Get-ClusterParameter -Name PublishPTRRecords

    Приведите результат


    Roman Levchenko, MCITP, MCTS http://www.rlevchenko.com

    26 марта 2014 г. 6:20
  • k002 - имя кластера?

    Roman Levchenko, MCITP, MCTS http://www.rlevchenko.com

    да
    26 марта 2014 г. 6:29
  • k002 - имя кластера?


    Roman Levchenko, MCITP, MCTS http://www.rlevchenko.com

    да
    Выполните cmdlet чуть выше, который я добавил в пост. Приведите вывод

    Roman Levchenko, MCITP, MCTS http://www.rlevchenko.com

    26 марта 2014 г. 6:31
  • k002 - имя кластера?


    Roman Levchenko, MCITP, MCTS http://www.rlevchenko.com

    да

    Выполните cmdlet чуть выше, который я добавил в пост. Приведите вывод

    Roman Levchenko, MCITP, MCTS http://www.rlevchenko.com

    PS C:\Windows\system32> Get-ClusterResource "cluster name"|Get-ClusterParameter -Name PublishPTRRecords
    Get-ClusterResource : Возникла ошибка при открытии ресурса "cluster name".
    строка:1 знак:1
    + Get-ClusterResource "cluster name"|Get-ClusterParameter -Name PublishPTRRecords
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : ObjectNotFound: (:) [Get-ClusterResource], ClusterCmdletException
        + FullyQualifiedErrorId : ClusterObjectNotFound,Microsoft.FailoverClusters.PowerShell.GetResourceCommand

    ха подразумеваю команда та другая должна быть

    Get-ClusterResource Для выбора ресурса кластера
    Get-Cluster а вот тут можно выбрать и сам кластер


    и теперь вот такая вот каша,

    PS C:\Windows\system32> Get-Cluster "K002" | Set-ClusterParameter -Name PublishPTRRecords -Value 1
    Set-ClusterParameter : Параметр "PublishPTRRecords" не существует в объекте кластера "k002". Если вы пытаетесь обновить
     существующий параметр, убедитесь, что его имя указано правильно. Вы можете проверить текущие параметры, передав в кома
    ндлет "| Get-ClusterParameter" объект .NET, полученный с помощью соответствующего командлета Get-Cluster*. Если вы пыта
    етесь обновить общее свойство объекта кластера, необходимо задать его непосредственно для объекта .NET, полученного с п
    омощью соответствующего командлета Get-Cluster*. Вы можете проверить текущие общие свойства, передав в командлет "| fl
    *" объект .NET, полученный с помощью соответствующего командлета Get-Cluster*. Если вы хотите создать неизвестный парам
    етр, используйте параметр  -Create для командлета Set-ClusterParameter.
    строка:1 знак:22
    + Get-Cluster "K002" | Set-ClusterParameter -Name PublishPTRRecords -Value 1
    +                      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation: (:) [Set-ClusterParameter], ClusterCmdletException
        + FullyQualifiedErrorId : InvalidOperation,Microsoft.FailoverClusters.PowerShell.SetClusterParameterCommand

    курю

    • Изменено mazf 26 марта 2014 г. 10:30
    26 марта 2014 г. 10:16
  • PS C:\Windows\system32> Get-ClusterResource "Имя кластера" |Get-ClusterParameter -Name PublishPTRRecords

    Object                        Name                          Value                         Type
    ------                        ----                          -----                         ----
    Имя кластера                  PublishPTRRecords             1                             UInt32

    )))

    26 марта 2014 г. 10:39
  • Get-ClusterResource "Имя кластера" |Set-ClusterParameter -Name PublishPTRRecords -Value 0
    Выполните и запустите проверку.  

    Roman Levchenko, MCITP, MCTS http://www.rlevchenko.com

    Еще вычитал вот такую вещь

    Please Note: Even if the Cluster service defaulted to registering the PTR record, it may not be able to override the record registered by DHCP if aging and scavenging are enabled on the DNS server, or only secure updates are used.

    у меня как раз таки и используется только безопасное обновление.

    т.е мне даже перерегистрация данным способом не поможет так? и могу ли я в ручную добавить данную запись дабы ликвидировать предупреждение? 

    Спасибо!

    26 марта 2014 г. 10:54
  • Разве Вы для cluster name используете DHCP? Это не слишком рекомендуемая конфигурация...

    Конфигурация по умолчанию (рекомендуемая): Static IP + PublishPTRRecords со значением 0

    Если необходимо PTR регистрировать, то делайте как описано в статье. Каким образом менять значения параметра PublishPTRRecords я Вам показал.


    Roman Levchenko, MCITP, MCTS http://www.rlevchenko.com

    26 марта 2014 г. 11:07
  • Разве Вы для cluster name используете DHCP? Это не слишком рекомендуемая конфигурация...

    Конфигурация по умолчанию (рекомендуемая): Static IP + PublishPTRRecords со значением 0

    Если необходимо PTR регистрировать, то делайте как описано в статье. Каким образом менять значения параметра PublishPTRRecords я Вам показал.


    Roman Levchenko, MCITP, MCTS http://www.rlevchenko.com

    нет, у меня статические ип. но и способом данным удалось обновить птр! Спасибо!
    26 марта 2014 г. 11:15
  • Очень рад, что получилось. Если считаете, что проблема решена, то,пожалуйста, помечайте ответ в теме.

    Roman Levchenko, MCITP, MCTS http://www.rlevchenko.com

    26 марта 2014 г. 11:37