none
Ошибка при нажатии на "общий доступ" RRS feed

  • Вопрос

  • Создан сайт в нем библиотеки документов. И при нажатии на три точки -> "общий доступ" вылетает ошибка. Во всех других местах на портале такие ошибки не возникают... Так же под учеткой с правами админа (полный доступ), появляется ожидаемое окно. Как только права делаешь ниже - ошибка вновь появляется.

    Скриншоты ошибок:

    Далее щелкаем на "общий доступ". И возникает вот такое:

    За ранее благодарю за ответы.


    • Изменено Sotnik13 1 августа 2014 г. 7:35
    1 августа 2014 г. 7:17

Ответы

  • Ну факт остается фактом, ну да ладно... Еще по разбираюсь, а пока в качестве ответа помечу переключение в режим "пользовательских" сообщений об ошибках.

    Параметры настройки web.config:

    <customErrors mode="Off" />

    <SafeMode ... CallStack="false" ... >

    По крайней мере я установил такие параметры и сообщение об ошибке приняло "человеческий" вид.

    • Изменено Sotnik13 11 августа 2014 г. 5:20
    • Помечено в качестве ответа Sotnik13 11 августа 2014 г. 5:20
    11 августа 2014 г. 5:17

Все ответы

  • добрый день

    скажите, а прав на библиотеку достаточно?

    1 августа 2014 г. 7:26
    Модератор
  • Права допустим "только просмотр". И так и должно быть - админ выкладывает файлики, а пользователи на них смотрят. И надо чтобы у них при нажатии вот га эту "кнопку" не появлялось такой "порнографии", а например что нибудь нормальное типа "У вас недостаточно прав для совершения операции". Тоесть повышением прав пользователей на библиотеку проблему не решить, да и в других библиотеках на других сайтах при правах "только просмотр" эта штука открывается. Может что с настройками сайта не так? Ибо такая ошибка только на этом сайте...
    1 августа 2014 г. 7:41
  • веб приложения разные у сайтов?
    1 августа 2014 г. 7:52
    Модератор
  • думаю что разные

    на том где ошибка, как на скриншоте, нужно в webconfig изменить <customErrors mode="RemoteOnly" />

    подробнее customErrors Element (ASP.NET Settings Schema) 

    1 августа 2014 г. 7:58
    Модератор
  • Нет приложение одно и то же... Все эти сайты работают на одном портальном приложении. В том то и проблема, что ошибка возникают только на одном сайте, а на других, в принципе, идентичных сайтах ошибка не возникает =(
    1 августа 2014 г. 9:34
  • скажите, а другие ошибки в этом сайте такие-же?
    1 августа 2014 г. 9:47
    Модератор
  • Других ошибок пока замечено не было... Сайту пару недель. Если имеется в виду у всех ли однотипных пользователей такая ошибка, то да она одинакова для всех.
    1 августа 2014 г. 10:51
  • просто хотелось понять, все ли ошибки такие 

    можно попробовать вызвать ошибку, к примеру загрузить файл с "не правильным именем"

    1 августа 2014 г. 10:57
    Модератор
  • Попробовал как вы сказали - добавил файл неверного расширения. Результат такой же, ошибка выглядит так же...

    Так же протестил на других сайтах приложения этим способом и таки да результат тот же...

    Теперь я так понимаю в файле веб-конфига надо поправить строчку <customErrors mode="RemoteOnly" /> и ошибка из такой вот должна превратится в пользовательскую? У меня на данный момент <customErrors mode="Off" />


    • Изменено Sotnik13 4 августа 2014 г. 6:04
    4 августа 2014 г. 5:49
  • посмотрел что у меня сейчас <customErrors mode="On" />
    4 августа 2014 г. 6:26
    Модератор
  • Так в итоге, чтобы у меня отображалась "человеческая ошибка", а не вот это вот мне нужно поставить параметр в "On" или "RemoteOnly?"
    4 августа 2014 г. 7:05
  • Но не смотря на все это - почему на других сайтах при нажатии на кнопку "общий доступ" ошибка не вылетает, а на другом сайте выскакивает? =(
    4 августа 2014 г. 7:42
  • странно, если вебприложение одно, то поведение должно быть одинаковое. (как я понимаю)
    4 августа 2014 г. 11:50
    Модератор
  • Ну факт остается фактом, ну да ладно... Еще по разбираюсь, а пока в качестве ответа помечу переключение в режим "пользовательских" сообщений об ошибках.

    Параметры настройки web.config:

    <customErrors mode="Off" />

    <SafeMode ... CallStack="false" ... >

    По крайней мере я установил такие параметры и сообщение об ошибке приняло "человеческий" вид.

    • Изменено Sotnik13 11 августа 2014 г. 5:20
    • Помечено в качестве ответа Sotnik13 11 августа 2014 г. 5:20
    11 августа 2014 г. 5:17