none
Exchange Server 2016 после CU1 долго загружаются чужие календари. RRS feed

  • Вопрос

  • Коллеги, добрый день!

    После обновления до CU1 у пользователей в Outlook'e долго (до нескольких минут) загружаются сведенья из календарей других пользователей - "идет проверка календарей всех пользователей". Проблема не постоянна, но возникает очень часто; какой либо закономерности не нашел. Проверял в Outlook 2010/2013/2016. В OWA - всё хорошо.

    Подскажите, в какую сторону копать?

    28 апреля 2016 г. 11:18

Ответы

Все ответы

  • Добрый день.

    Вопрос интересный. А какой протокол используете для подключения Outlook?

    29 апреля 2016 г. 6:01
  • mapi over http.

    Забыл уточнить: ES все роли на одной ВМ, (есть еще EDGE) всё на Hyper-v 2012R2. В момент проявления проблемы сильной нагрузки на ЦП\память\диск\сеть нет. Для очистки совести добавил еще 2 виртуальных ЦП (до восьми), памяти до 24Гб и еще один сетевой адаптер - совершенно никаких изменений.

    29 апреля 2016 г. 6:41
  • Попробуйте сниффером или Fiddler-ом посмотреть трафик Outlook - возможно увидите ошибки в именах, аутентификации или что-то ещё интересное.

    Сазонов Илья

    https://isazonov.wordpress.com/

    Модератор
  • Доброго дня всем. Таже самая проблема с CU1. Календари загружаются долго. Причем что через mapi что через rpc. Клиенты также разные пробовались, что в режиме кэширования, что без-результат один и тот же.

    Если смотреть через состояние подключения в outlook то видно что при подключении календаря создается дополнительное соедиение и оно в статусе "Установлено", но обновление идет долго.

  • Параллельно имею проблему со счётчиками производительности (msexchange common 106 "custom counters file view is out of memory"), как следствие - забитый журнал событий.

    При детальном разборе журнала нашел "[Ews] The number of outstanding requests for guard SlsByDagGuard("ServerFQDN") has exceeded the max limit 20. Current request will be rejected."; поправил  web.config как тут, ошибка не ушла.

    P.S. после перезагрузки сервера, проблема проявилась часа через 3...


  • А саму проблему со счетчиками удалось победить? Логи тоже все забиты, по многим счетчикам, пересоздание счетчиков особого эффекта не дает... Один сервер апдейтил с RTM до CU1 и логи все забиты, второй сервер ставил уже с дистрибутива с включенным CU1 и там проблем нет(пришлось только подправить один xml файл)...
  • чтобы не оффтоп, про счётчики посмотрите пожалуйста, у меня так.
  • проблема сохраняется...
  • Открывайте кейс.

    Сазонов Илья

    https://isazonov.wordpress.com/

    Модератор
  • только сейчас удалось вернуться к проблеме: в журналах обнаружил, что 'MSExchangeServicesAppPool' не может связаться со службой активации процессов Windows (WAS, 5011). Запись в журнале появляется довольно-таки часто.

    P.S. мне не дают 500$ на эту проблему (

  • Сообщение полностью приведите.

    Сазонов Илья

    https://isazonov.wordpress.com/

    Модератор
  • A process serving application pool 'MSExchangeServicesAppPool' suffered a fatal communication error with the Windows Process Activation Service. The process id was '25796'. The data field contains the error number.

    Сообщение возникает практически каждую минуту.

    Сегодня установил обновления на систему, пробовал руками перепускать MSExchnageServicesAppPool. В итоге получил "Application pool 'MSExchangeServicesAppPool' is being automatically disabled due to a series of failures in the process(es) serving that application pool." (WAS, id 5002) - пул приложений остановился совсем.
  • мда... теперь, после десятка ошибок 5011 Application pool 'MSExchangeServicesAppPool' останавливается и календари совсем недоступны...

    Пробовал пересоздать \EWS, пробовал пересоздать пул приложений - эффекта нет.

  • XML сообщения скопируйте сюда

    Сазонов Илья

    https://isazonov.wordpress.com/

    Модератор
  • - <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    - <System>
      <Provider Name="Microsoft-Windows-WAS" Guid="{524B5D04-133C-4A62-8362-64E8EDB9CE40}" EventSourceName="WAS" />
      <EventID Qualifiers="32768">5011</EventID>
      <Version>0</Version>
      <Level>3</Level>
      <Task>0</Task>
      <Opcode>0</Opcode>
      <Keywords>0x80000000000000</Keywords>
      <TimeCreated SystemTime="2016-05-17T14:32:06.000000000Z" />
      <EventRecordID>2439496</EventRecordID>
      <Correlation />
      <Execution ProcessID="0" ThreadID="0" />
      <Channel>System</Channel>
      <Computer>***</Computer>
      <Security />
      </System>
    - <EventData>
      <Data Name="AppPoolID">MSExchangeServicesAppPool</Data>
      <Data Name="ProcessID">18412</Data>
      <Binary>6D000780</Binary>
      </EventData>
      </Event>
  • Это не информативно. Попробуйте восстановить сервер Exchange с ключом Recovery

    Сазонов Илья

    https://isazonov.wordpress.com/

    Модератор
  • Попробуйте восстановить сервер Exchange с ключом Recovery

    Прошу прощения, а это как? setup /m:RecoverServer - говорит, что все роли уже установлены...

    P.S. в журналах есть еще записи, что MSExchangeServicesAppPool был неожиданно завершен с кодом ошибки 0xdeadd00d (сдох чувак).

  • Надо сервер переставлять, чтобы чистый был.

    Сазонов Илья

    https://isazonov.wordpress.com/

    Модератор
  • Развернул параллельно чистый Exchange 2016 CU1, настроил по-быстрому (сертификаты, методы авторизации и т.д.). В DNS поправил запись mail.domain.ru (указан в качестве и внешнего и внутреннего адресов для всех, кроме autodiscover, каталогов IIS) на ip нового сервера; ipconfig /flushdns и перезапуск Outlook на моей машине - Outlook обновился, но с календарями та же проблема.

    P.S. почтовые ящики остались на старом сервере. На новом проблем с крэшем EWS пула приложений нет, но есть ошибки со счётчиками.

  • Попробуйте на новом сервере базу сделать и туда ящик для теста перенести.

    Сазонов Илья

    https://isazonov.wordpress.com/

    Модератор
  • развернул сервер - ошибок не было.

    во время миграции старый сервер упал с синим экраном (critical process died, ntoskrnl.exe), принял решение мигрировать все почтовые ящики. Запустил процесс на ночь.

    только с утра заметил, что в логах системы нового сервера вижу WAS 5011 - примерно со времени начала миграции, зато со старого сервера проблема ушла...

  • Очень уж часто крашится 'MSExchangeServicesAppPool'. Может ли быть это связано с интеграцией Lync (Skype 4B 2015)?
  • откатился на 2016 RTM, вроде ошибок пока нет, календари открываются нормально
    • Помечено в качестве ответа Peter Koreshkov 31 мая 2016 г. 7:14