none
Microsoft CRM Asynchronous Processing Service не стартует RRS feed

  • Вопрос

  • ДОбрый день всем!

    Помогите пожалуйста решить такую проблему:

    жил был MS CRM for Workgroup  на сервере Windows server 2008r2 с установленным SQL server 2008 Std

    все шло хорошо, пока в один момент не перестал запускатся:  Microsoft CRM Asynchronous Processing Service service

    в журнале системы регистрируется два события:

    Event id 7000 :The Microsoft CRM Asynchronous Processing Service service failed to start due to the following error:
    The service did not respond to the start or control request in a timely fashion.

    и

    Event 7009:

    A timeout was reached (30000 milliseconds) while waiting for the Microsoft CRM Asynchronous Processing Service service to connect.

    а в журнале приложений (Application) при попытке открытия страницы и/или из outlook`a  обращения:

    Event 1309:Event code: 3005
    Event message: An unhandled exception has occurred.
    Event time: 7/13/2010 6:05:51 PM
    Event time (UTC): 7/13/2010 2:05:51 PM
    Event ID: fc603ab2132f4ae4a3c17736a728f147
    Event sequence: 2603
    Event occurrence: 12
    Event detail code: 0
     
    Application information:
        Application domain: /LM/W3SVC/1/ROOT-1-129234696651590088
        Trust level: Full
        Application Virtual Path: /
        Application Path: C:\inetpub\wwwroot\
        Machine name: FS
     
    Process information:
        Process ID: 7224
        Process name: w3wp.exe
        Account name: NT AUTHORITY\NETWORK SERVICE
     
    Exception information:
        Exception type: CrmException
        Exception message: The key specified to compute a hash value is expired, only active keys are valid.  Expired Key : CrmKey(Id:7f96e5e2-9070-df11-96a0-005056c00008, ScaleGroupId:00000000-0000-0000-0000-000000000000, KeyType:CrmWRPCTokenKey, Expired:True, ValidOn:06/05/2010 10:55:43, ExpiresOn:07/08/2010 10:55:43, CreatedOn:06/05/2010 10:55:43, CreatedBy:NT AUTHORITY\NETWORK SERVICE.
     
    Request information:
        Request URL: http://f****/********CRM/loader.aspx
        Request path: /*********CRM/loader.aspx
        User host address: ********
        User: *********
        Is authenticated: True
        Authentication Type: Negotiate
        Thread account name: NT AUTHORITY\NETWORK SERVICE
     
    Thread information:
        Thread ID: 9
        Thread account name: NT AUTHORITY\NETWORK SERVICE
        Is impersonating: False
        Stack trace:    at Microsoft.Crm.CrmKeyService.ComputeHash(CrmKey key, Guid scaleGroupId, HashParameterBase[] parameters)
       at Microsoft.Crm.CrmKeyService.ComputeHash(CrmKey key, HashParameterBase[] parameters)
       at Microsoft.Crm.Application.Security.WRPCContext..ctor()
       at Microsoft.Crm.Application.Controls.AppPage.ValidateWrpcContext()
       at Microsoft.Crm.Application.Controls.AppPage.OnInit(EventArgs e)
       at System.Web.UI.Control.InitRecursive(Control namingContainer)
       at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

    Теперь что пытался делать:

    1. обновить на Rollup11  - пишет что сервер не найден.

    2. http://support.microsoft.com/kb/953586/EN-US/ - поставил это обновление, не помогло.

    3. при попытке запустить инсталяцию И выбрать Repair  - всё идет до регистрации сервиса, потом возникает ошибка или сервис помечен на удаление (и после перезагрузки исчезает) или сервис не запускается и повторяются ошибки описанные выше.

    4. загружал заново счетчики производительности с командой lodctr /R

    5. обновил .net 3.5 до sp1

    В общем ничего особо не помогло, подскажите что делать? :)

    Сегодня включу трассировку и смогу скинуть уже более подробные логи.

     

     

    13 июля 2010 г. 16:32

Ответы

  • У Вас слабенькая машинка :) сервис не успевает стартовать и отваливается по таймауту :)

    В реестре пропишите такой DWORD ключик:

    [HKEY_LOCAL_MACHINE \System \CurrentControlSet \Control]
    ServicesPipeTimeout = "90000"

    90000 это таймаут в миллисикундах (по умолчанию равен 30000)

    Перезапустите сервак

    • Помечено в качестве ответа Fuzzy_logik 14 июля 2010 г. 15:25
    14 июля 2010 г. 4:01

Все ответы

  • У Вас слабенькая машинка :) сервис не успевает стартовать и отваливается по таймауту :)

    В реестре пропишите такой DWORD ключик:

    [HKEY_LOCAL_MACHINE \System \CurrentControlSet \Control]
    ServicesPipeTimeout = "90000"

    90000 это таймаут в миллисикундах (по умолчанию равен 30000)

    Перезапустите сервак

    • Помечено в качестве ответа Fuzzy_logik 14 июля 2010 г. 15:25
    14 июля 2010 г. 4:01
  •  

    оказывается помог спасибо большое :)

    • Изменено Fuzzy_logik 14 июля 2010 г. 15:25 всё изменилось
    14 июля 2010 г. 14:46