none
Lync 2010 + Exchange UM не приходят сообщения отпавляемые на Voice Mail RRS feed

  • Вопрос

  • Доброго времени суток.

    Не знаю куда вернее писать в эту тему или в Exchange. Решил написать сюда, так как может оказаться полезным при внедрении Lync в организациях.

    Столкнулся с весьма интересно задачей, подружил Lync с Exchange, c клиента линк можно позвонить в свою голосовую почту и пообщаться с робо-бабой, так же можно выслать голосовое сообщение пользователям, которое чудесно доходит.  Если позвонить на VoiceMail сотрудника, милая робо-баба любезно вас поприветствует и предложит записать сообщение для того, кому вы собственно и звоните. Так же любезно предлагает изменить статус сообщения на важное, в целом адекватно работает и записывает, и даже говорит, что сообщение отправлено. НО к человеку оно не доходит, в журналах Exchange через час появляется сообщение следующего содержания

    The Unified Messaging server failed to process the message with header file "C:\Program Files\Microsoft\Exchange Server\V14\UnifiedMessaging\voicemail\ce55b7d2-a989-435b-9b01-0eacca77e373.txt" within "23" minutes. The UM server will continue to process and deliver the message, but the "MSExchangeUMAvailability: % of Messages Successfully Processed Over the Last Hour" performance counter will be decreased.

    Содержание txt файла

    MessageType : SMTPVoiceMail
    ProcessedCount : 2
    MessageID : 1541f95e-d6f3-447b-b072-2362ff3d4673
    SentTime : 03/14/2012 15:07:05
    CallerId : a@sra.com.ua
    RecipientName : кому в виде Имени и Фамилии
    RecipientObjectGuid : 53efc424-666d-4c02-948e-aefba83f591d
    CallerNAme : Имя и Фамилия
    CallerIdDisplayName : Имя и Фамилия
    CallerAddress : a@sra.com.ua
    CultureInfo : ru-RU
    CallId : f01ca50aa55ef2e26670e407b461b54a
    AttachmentPath : C:\Program Files\Microsoft\Exchange Server\V14\UnifiedMessaging\voicemail\1a880f59-1d42-496b-942a-1a6e039f1c91.wav
    Duration : 21
    Codec : Mp3
    Important : True
    CallAnswering : True
    Private : False

    Все сообщения кладутся в папку  "C:\Program Files\Microsoft\Exchange Server\V14\UnifiedMessaging\voicemail\" wav и текстовый файл.

    В какую сторону смотреть, чтобы они начали приходить пользователям?!

    14 марта 2012 г. 15:08

Ответы

  • Тогда, проблема, скорее всего, аналогична той, которую я по ссылке приводил.

    Можем проверить ещё такой вариант: добавить на новый сервер роли MBX и HUB, перенести ящик тестового пользователя на него, отключить принимающий коннектор на нынешнем HUB'е, чтоб приём через него гарантированно не шёл и попробовать отправить сообщение этому тестовому пользователю...

    • Помечено в качестве ответа vshihov 16 марта 2012 г. 16:48
    16 марта 2012 г. 15:07
    Модератор

Все ответы

  • Есть у меня подозрение, что на HUB-сервере у вас для принимающего коннектора выставлено имя, которое не соответствует имени самого сервера.
    14 марта 2012 г. 15:40
    Модератор
  • Отчасти Вы правы, было установлено имя сервера на которое он откликается в мире, я подправил и установил доменное. Ошибка с тем, что имя не подходит исчезла, проблема с тем что не приходят в ящик осталась :(
    14 марта 2012 г. 15:46
  • Давайте так - отключите, пока что, свой коннектор, созданный для приёма почты из интернета и включите "Default". Надеюсь, его настройки вы не меняли :) .
    14 марта 2012 г. 15:49
    Модератор
  • ВЫключил для пиёма почты с мира... Попробовать повторить звонок в почту?!
    14 марта 2012 г. 15:54
  • Да. А ещё лучше, для убедительности, перезагрузить Exchange-сервера...

    14 марта 2012 г. 15:57
    Модератор
  • :))))))))))))))))))
    14 марта 2012 г. 16:05
  • Это как понимать?
    14 марта 2012 г. 16:07
    Модератор
  • Это все без почты :)))
    14 марта 2012 г. 16:10
  • umworkerProcess.exe

    lsass.exe

    Грузят проц на 85% это нормально?!

    Сервер перегрузил... Что делать дальше?


    Попробовал позвонить, ничего не происходит, как и прежде :(
    • Изменено vshihov 14 марта 2012 г. 16:25
    14 марта 2012 г. 16:22
  • В принципе - не очень, но я ведь не знаю что у вас там и на чём крутится ;) .

    Так я же вам изначально сказал - включить Default-коннектор на HUB'е. Ну а дальше, можете для форсирования процесса, отправить голосовую почту...

    14 марта 2012 г. 16:25
    Модератор
  • Александр, мы видимо не совсем друг друга поняли :(

    Давайте так - отключите, пока что, свой коннектор, созданный для приёма почты из интернета и включите "Default". Надеюсь, его настройки вы не меняли :) .

    У меня есть send connectors, который я выключил и есть Recieve Connectors которые включены... Я попробовал позвонить, ничего не изменилось.. У меня всё крутится на одном сервере. У меня нету Default...


    • Изменено vshihov 14 марта 2012 г. 16:29
    14 марта 2012 г. 16:29
  • Я же изначально говорил о принимающем ;) .

    То есть, вы Default удалили?

    14 марта 2012 г. 16:30
    Модератор
  • Насколько я помню, send connectors необходимо создавать в момент установки Exchange, автоматом создаются именно Recieve Connectors.
    Которые нетронуты... Почта из мира не ходит :) Внутри организации бегает без проблем
    14 марта 2012 г. 16:35
  • Send - отправляющие, а я о принимающих говорю ;) . Покажите, лучше, картинкой...
    14 марта 2012 г. 16:37
    Модератор
  • Я верно Вас понял?

    14 марта 2012 г. 16:43
  • Верно :) .

    А что за UM-коннектор у вас в списке?

    14 марта 2012 г. 16:45
    Модератор
  • Я его выключил :)

    14 марта 2012 г. 16:46
  • Имя, указанное в EHLO, соответствует FQDN'у вашего сервера?

    А вот на закладке аутентификации, по умолчанию, стоят только Exchange и Integrated-аутентификация ;) .

    Покажите уж и остальные две закладки...

    14 марта 2012 г. 16:49
    Модератор
  • Да соответствует внутреннему имени сервера, которое записано в DNS моего домена

    14 марта 2012 г. 16:53
  • Я не про DNS, а про имя самого компьютера говорю ;) . Ну, в общем-то, так как у вас Exchange-аутентификация включена, оно не может отличаться.

    В общем, делаем следующее, чтоб свести к минимуму площадь для ошибок:

    Выключаете все коннекторы, кроме Default.

    Отключаете TLS и Basic-аутентификацию.

    Отключаете анонимов.

    Перезагружаете сервер.

    Отправляете голосовое сообщение.

    14 марта 2012 г. 16:58
    Модератор
  • Так точно :)
    14 марта 2012 г. 17:00
  • Ничего не изменилось :(
    14 марта 2012 г. 17:14
  • Что в SMTP логах? Какие ошибки присутствуют в системном журнале?
    14 марта 2012 г. 17:16
    Модератор
  • C:\Program Files\Microsoft\Exchange Server\V14\TransportRoles\Logs\ProtocolLog\SmtpSend тут вообще пусто

    В журналах только сообщения про удаление старых недоставленных писем

    14 марта 2012 г. 17:21
  • Смотреть надо не отправленные, а принятые ;) .

    Антивирус какой-нибудь на сервере присутствует?

    14 марта 2012 г. 17:23
    Модератор
  • Не стоит..


    Вот что пишется после попытки отправки голосового сообщения :(
    • Изменено vshihov 14 марта 2012 г. 17:28
    14 марта 2012 г. 17:26
  • Это печально, когда не стоит :) .

    Тогда, попробуйте этот вариант...

    14 марта 2012 г. 17:28
    Модератор
  • Согласен :)

    Т.е. единственный вариант накатить сверху?! :))))

    14 марта 2012 г. 17:30
  • Ну, это единственный адекватный вариант, соответствующий вашей проблеме, который я нашёл.

    А есть у вас возможность развернуть UM на другом сервере для теста?

    14 марта 2012 г. 17:32
    Модератор
  • Вот это особенно радует....

    so that's why the UM Core and UMWorkerProcess errors where still generating


    У человека были глобальные проблемы, с тем, что у него рвались звонки и прочее.. Есть мысли почему нормально можно выслать голосовое сообщение воспользовавшись меню Voice Access?
    • Изменено vshihov 14 марта 2012 г. 17:34
    14 марта 2012 г. 17:32
  • Есть! Мощный сервер и VMware способствуют этому :) Придётся по новой его дружить с Lync :) Повторение как говорится... :)

    На этом эту роль надо удалить я верно понимаю, она как все продукты MS удаляется очень специфически?!


    И попутно создам кейс в MS пусть и у них голова поболит, решение отпишу сюда :)
    • Изменено vshihov 14 марта 2012 г. 17:38
    14 марта 2012 г. 17:36
  • А зачем заново дружить и удалять нынешнюю?

    А с какой спецификой удаления вы сталкивались?

    14 марта 2012 г. 17:43
    Модератор
  • Значит, попытка отправки, всё же, происходит?
    14 марта 2012 г. 17:43
    Модератор
  • Установил, надо будет по новой проходить процедуру дружбы его с Lync?
    15 марта 2012 г. 11:53
  • Не совсем понял вопроса?! Что происходит?!
    15 марта 2012 г. 11:59
  • Зачем заново-то? У вас же уже всё настроено - нужно просто Dial Plan привязать к новому UM-серверу и всё ;) .

    15 марта 2012 г. 17:21
    Модератор
  • Происходит попытка отправки голосовой почты по SMTP. Это был вопрос на вашу картинку с логом ;) .
    15 марта 2012 г. 17:22
    Модератор
  • я нашёл где была ошибка, в настройка CDP, подправил кое что и все сертификаты стали недействительными :( Я пришёл к тому, что у меня идут звонки на голосовую почту, но милая женщина мне не отвечает :)))

    И на UM сервере появилась ошибка

    The following UM IP gateways did not respond as expected to a SIP OPTIONS request.
    Transport = TLS, Address = srv-lync.sххххa.ua, Port = 5061, Response Code = 400, Message = Malformed Edge Proxy header

    И вопрос, можно на одном сервере установить Lync EDGE и Exchange UM?

    • Изменено vshihov 15 марта 2012 г. 18:11
    15 марта 2012 г. 18:05
  • Судя по всему, у вас опять проблема в сертификатах ;) . Скорее всего, служба UM использует самоподписанный сертификат, генерирующийся при установке. Что выдаёт команда "Get-ExchangeCertificate" на UM-сервере?

    Думаю, если постораться, то можно, но чего ради вам эти проблемы? Как минимум, я вижу загвоздку в том, что оба используют для коммуникаций SIP и запросто могут конфликтовать по портам...

    15 марта 2012 г. 20:16
    Модератор
  • Я попробовал установить и понял что нельзя, потому как для Exchange UM нужен MS Unified Communication API v 2.0 а для Lync Edge нужна версия 3.0 )) И ещё получается у них один и тот же сертификат :)
    16 марта 2012 г. 6:50
  • Ну, сертификат - вопрос решаемый. А вот пересечение по общим компонентам и портам - это уже требует усилий.

    В общем, лучше, разверните его на отдельной машине...

    16 марта 2012 г. 7:14
    Модератор
  • Развернул его, но проблема осталась :( Можно наговорить файл формируется, но ни каким образом не шлётся...
    16 марта 2012 г. 14:58
  • Тогда, проблема, скорее всего, аналогична той, которую я по ссылке приводил.

    Можем проверить ещё такой вариант: добавить на новый сервер роли MBX и HUB, перенести ящик тестового пользователя на него, отключить принимающий коннектор на нынешнем HUB'е, чтоб приём через него гарантированно не шёл и попробовать отправить сообщение этому тестовому пользователю...

    • Помечено в качестве ответа vshihov 16 марта 2012 г. 16:48
    16 марта 2012 г. 15:07
    Модератор
  • А что за роль MBX?
    16 марта 2012 г. 15:26
  • Mailbox же ;) .
    16 марта 2012 г. 15:27
    Модератор
  • Не знаешь как можно удалить записанной голосом имя пользователя, эксчендж его предлагает записать, при первом обращении к почтовому ящику, если ты его не записываешь он берёт его из AD
    16 марта 2012 г. 15:32
  • А новый коннектор создавать надо?!
    16 марта 2012 г. 15:46
  • Ты абсолютно прав относительно HUB сервера... Вот какую ошибку нарыл на новом серваке

    The Unified Messaging server encountered an error while trying to process the message with header file "C:\Program Files\Microsoft\Exchange Server\V14\UnifiedMessaging\voicemail\0b4298c8-85e9-4154-b1b8-0a182d6c2356.txt". Error details: "Microsoft.Exchange.UM.UMCore.SmtpSubmissionException: Submission to the Hub Transport server failed. The operation will be retried. ---> Microsoft.Exchange.Net.ExSmtpClient.FailedToConnectToSMTPServerException: Couldn't connect to the SMTP server with address EUM.

    16 марта 2012 г. 15:57
  • Знаю :) . Заходим в OVA, выбираем Personal Options, жмём 2 (запись приветствий), жмём 3 (запись имени), жмём 3 (удаление).
    16 марта 2012 г. 16:22
    Модератор
  • Нет - при установке HUB'а он создаётся по умолчанию.

    16 марта 2012 г. 16:23
    Модератор
  • А это на который сервер он не смог отправить? На старый?
    16 марта 2012 г. 16:24
    Модератор
  • У меня тётка не понимает фразу "Персональные опции" :)))) Всё получилось, интересно что это было???!!!
    16 марта 2012 г. 16:48
  • Как только я добавляю дополнительные роли эти 2 процесса umworkerProcess.exe lsass.exe Грузят проц на 100%. Что может быть?!
    16 марта 2012 г. 16:55
  • Тётка - такая тётка :) .

    Не понял вопроса - что получилось и что было?

    16 марта 2012 г. 19:22
    Модератор
  • Трудно так сказать без дополнительного анализа вашей инфраструктуры. Может, он отправкой какой занимается или ещё чем...
    16 марта 2012 г. 19:28
    Модератор
  • Добрый день!

    Получилось настроить то, что теперь можно оставлять сообщения в голосовую почту и она приходит в почту, чего раньше не получалось.

    Я сделал то, что Вы посоветовали, я поставил новый exchange и прикрутил к нему роли Mailbox, Transport и UM. Перетащил на него ящики, после чего всё стало работать нормально. Но инетерсен тот факт, что при добавлении роли UM сервер загружен на 100% эта ситуация повторяется в не зависимости от сервера, на старом сервере было всё тоже самое. Как только роль удаляю, то загрузка процессора 5-15%. Как вы думаете может снести на старом сервере все роли, и накатить их по новой?! Сейчас отсылка осуществляется сообщений осуществляется через один и тот же сервер, в идеале хотелось бы разнести эти роли.

    Спасибо

    19 марта 2012 г. 10:00
  • Да - это было бы оптимально.
    19 марта 2012 г. 10:14
    Модератор
  • Что ещё интересно, то переносить пользователей не нужно, нормально работает траспорт нового сервера с пользователями которые находятся на старом, так что проблема явно в транспорте, как Вы думаете, может стоит снести роли транспорта на старом, а потом установить по новой, такое же помочь может?!
    19 марта 2012 г. 10:31
  • Вполне возможно - пробуйте...
    19 марта 2012 г. 18:25
    Модератор