none
Периодическое "зависание" проводника на сервере терминалов RRS feed

  • Вопрос

  • Уважаемые коллеги,

    Столкнулись с непонятным эффектом. Имеется три сервера терминалов (W3k R2 sp2 rus) на всех проявляется одинаковая проблема.  Достаточно часто (при 3-4 открытии) Проводник зависает в состоянии "поиск элементов". Зависание длится от нескольких минут до бесконечности. При попытке закрытия пишет что программа не отвечает. При этом новый экземпляр проводника может открыться нормально (а может тоже зависнуть при открытии). При завершении сеанса при зависшем Проводнике часто выдается ошибка на то, что ctfmon.exe не отвечает. Реже на то, что не  отвечает explorer.exe

    Сначала я думал, что такое странное поведение связано с использованием NW Client, но недавно сервер Novell NetWare был выведен из эксплуатации и с терминальных серверов был удален его клиент. При этом проблемы остались. 

    Специфического софта на серверах нет. Установлен КАВ WS EE и Офис 2007, 7-zip.   КАВ пробовал удалять - проблема остается.

    Сталкивался ли кто с похожими проблемами?

     

    • Изменено Igor V. Oskin 17 июня 2010 г. 9:12 Еще одно уточнение.
    15 июня 2010 г. 6:41

Ответы

  • После удаления пространства имен DFS  \\domain\public\ и создания нового пространства с точно таким же именем (ручками, с нуля), "зависания" проводника на терминальных серверах прекратились.

    Т.о. проблема была связанна с конкретным пространством имен.  Хотя, не совсем понятна суть проблемы.  Да и решение не очень красивое.


    • Помечено в качестве ответа Igor V. Oskin 23 июня 2010 г. 12:30
    23 июня 2010 г. 12:30

Все ответы

  • //Установлен КАВ WS EE

    попробуйте поставить последний для серверов не ЕЕ.

    //Если отключить все подключенные сетевые диски (подключаются при логине, скриптом, через ссылки DFS) то, вроде бы проблема пропадает

    просмотрите пути, куда ссылаются диски, может проблема в подключении??

    если использовать тотал/фар, проблема сохраняется??

    15 июня 2010 г. 7:49
  • Клиента NW Вы удалили, проверте может протоколы остались NW остались
    Dmitriy Poberezhniy (my web blog http://dimsan.blogspot.com)
    15 июня 2010 г. 8:00
    Отвечающий
  • to levii

    ЕЕ поставили по рекомендации КАВ (они вообще сказали что для терминальных серверов у них только ЕЕ). MP4 у нас  глючил на терминалах. 

     

    В ФАРе проблемы нет.

     

    to _dim_

    Протоколы тоже удалены.

     

     

     

    15 июня 2010 г. 10:49
  • P.S. Провел еще один эксперимент. В консоли тоже наблюдается подвисание при активной работе с Проводником (открытие, переходе по сетевым дискам)

    В ФАРе при этом проблем не замечено.

    Буду проверять ссылки DFS

     

    P.P.S В логах периодически ошибка:

     

    Тип события:	Уведомление
    
    Источник события:	Winlogon
    
    Категория события:	Отсутствует
    
    Код события:	1002
    
    Дата:		15.06.2010
    
    Время:		15:18:46
    
    Пользователь:		Н/Д
    
    Компьютер:	SRV002
    
    Описание:
    
    Оболочка неожиданно завершила работу, и программа "Explorer.exe" была перезапущена.
    
    
    
    ВИдимо, пользователи завершают работу "зависших" проводников

     

     

    15 июня 2010 г. 11:16
  • Что такое KAB EE?

    Если что-то касперское или а-ля, уберите и посмотрите, что изменится.


    MCPIT: Enterprise Administrator; MCT; Microsoft Security Trusted Advisor
    15 июня 2010 г. 13:13
    Отвечающий
  • Что такое KAB EE?

    Если что-то касперское или а-ля, уберите и посмотрите, что изменится.


    MCPIT: Enterprise Administrator; MCT; Microsoft Security Trusted Advisor

    KAV EE - KAV for Windows server Enterprise Edition 

    Уже пробовал удалять на одном сервере - проблема остается.

    Опять же, проблема только с Проводником (Explorer.exe). Тот же FAR замечательно работает без всяких зависаний. Думаю, KAV мешал бы жить всем сразу.

     

    15 июня 2010 г. 14:00
  • //Думаю, KAV мешал бы жить всем сразу.

    не скажите, у меня проводник тупил, именно эксплорер, пока не обновил версию касперского.

    попробуйте все же поставить http://www.kaspersky.ru/productupdates?chapter=147083907. у меня замечательно работает на 2к3 и 2к8, как в терминале так и консольно.

    если в фаре все гуд, значит это программные ошибки, а не файловая система (жесткие). какие еще приложения установлены на сервере?? и что же все-таки с сетевыми дисками, место куда они ссылаются корректно открывается с других компов??

    15 июня 2010 г. 14:25
  • //Думаю, KAV мешал бы жить всем сразу.

    не скажите, у меня проводник тупил, именно эксплорер, пока не обновил версию касперского.

    попробуйте все же поставить http://www.kaspersky.ru/productupdates?chapter=147083907. у меня замечательно работает на 2к3 и 2к8, как в терминале так и консольно.

    если в фаре все гуд, значит это программные ошибки, а не файловая система (жесткие). какие еще приложения установлены на сервере?? и что же все-таки с сетевыми дисками, место куда они ссылаются корректно открывается с других компов??

    1. Вы указали ссылку на Антивирус Касперского для Windows Workstations.  Это ошибка или Вам действительно как-то удалось установить его на Windows 2003 server? 

     

    2. На рабочих станциях в сети и других серверах такой проблемы не замечено. 

    Сегодня попробую провести эксперимент на тестовом сервере с установкой КАВ EE и других версий. Отпишусь по результатам.


     

     


    16 июня 2010 г. 5:52
  • прошу прощения, ошибся.

    http://www.kaspersky.ru/productupdates?chapter=147083911

    а на остальные вопросы вы ответите??

    16 июня 2010 г. 6:02
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon параметр Shell - значение должно быть Explorer.exe, если есть ещё какие-то значения после этого => удалите их.

    http://www.eventid.net/display.asp?eventid=1002&eventno=826&source=Winlogon&phase=1 , читаем комментарии там описано много путей к решению и возможных причин.

    16 июня 2010 г. 6:45
  • прошу прощения, ошибся.

    http://www.kaspersky.ru/productupdates?chapter=147083911

    а на остальные вопросы вы ответите??

    1. На сервере установлено:
    7-Zip 4.57
    Adaptec Storage Manager
    Adobe Flash Player 10 ActiveX
    Adobe Reader 9.3.2 - Russian
    ATI - Software Uninstall Utility
    ATI Control Panel
    ATI Display Driver
    ATI Parental Control & Encoder
    CCleaner
    FAR file manager
    Intel(R) Network Connections 15.2.89.0
    Inter-PRO Client v5
    Java(TM) 6 Update 2
    Java(TM) 6 Update 7
    KOMPAS-3D Viewer V10
    Microsoft .NET Framework 2.0 Service Pack 2
    Microsoft .NET Framework 2.0 Service Pack 2 Language Pack - RUS
    Microsoft .NET Framework 3.0 Russian Language Pack
    Microsoft .NET Framework 3.0 Service Pack 2
    Microsoft .NET Framework 3.0 Service Pack 2 Language Pack - RUS
    Microsoft .NET Framework 3.5 SP1
    Microsoft Office Стандартный 2007
    Microsoft Silverlight
    Microsoft Visual C++ 2005 Redistributable
    MSXML 6 Service Pack 2 (KB954459)
    Sentinel Protection Installer 7.1.0
    Spelling Dictionaries Support For Adobe Reader 9

    TopPlan 2006 NetOffice Edition Санкт-Петербург - Удаление
    Visual FoxPro ODBC Driver
    Windows Internet Explorer 8
    Windows Server 2003 Access-based Enumeration
    Windows Server 2003 Service Pack 2
    Агент администрирования Лаборатории Касперского
    Антивирус Касперского 6.0 для Windows Servers Enterprise Edition
    БЭСТ-5 (3.4)
    Клиент межсетевого экрана Microsoft
    Языковой пакет Microsoft .NET Framework 3.5 SP1 — RUS

    2. В сети развернута DFS с доменным пространством имен. С других рабочих станций и серверов сетевые ресурсы доступны без описанных выше проблем.

     

     

    16 июня 2010 г. 8:45
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon параметр Shell - значение должно быть Explorer.exe, если есть ещё какие-то значения после этого => удалите их.

    http://www.eventid.net/display.asp?eventid=1002&eventno=826&source=Winlogon&phase=1 , читаем комментарии там описано много путей к решению и возможных причин.

    1. Значение параметра только Explorer.exe, ничего лишнего нет

    2. В целом, не совсем мой случай.  Перезапуск эксплорера периодический и  не автоматический, а по команде пользователя, после "подвисания" при обращении к сетевым дискам. В первом посте подробное описание ситуации.

    16 июня 2010 г. 9:03
  • \\а по команде пользователя, после "подвисания" при обращении к сетевым дискам

    а если отключить сетевые диски, и открыть путь через \\<шара>, проблема сохраняется??

    как они подключаются - автоматом через скрипт или ручками??

    16 июня 2010 г. 9:54
  • \\а по команде пользователя, после "подвисания" при обращении к сетевым дискам

    а если отключить сетевые диски, и открыть путь через \\<шара>, проблема сохраняется??

    как они подключаются - автоматом через скрипт или ручками??

    1. При отключенных сетевых дисках и открытии через \\шара..  в Проводнике проблема сохраняется..

    2. Подключаются автоматом через GP. В логон скрипте батник с командами

     

    net use l: \\domain\public\documents

    net use j: \\domain\public\otdels

    net use o: \\domain\public\general

    net use u: \\domain\public\utils

    net use t: \\domain\public\foto

     

    16 июня 2010 г. 12:06
  • а для проверки эксперимента, если заходить не на указанные шары, а другие в сети, проблема сохраняется??

     

    16 июня 2010 г. 12:41
  • а для проверки эксперимента, если заходить не на указанные шары, а другие в сети, проблема сохраняется??

     

    Если подключить другие шары или даже эти, но не через DFS ссылки, а напрямую к конечным папкам, проблема не наблюдается. 

    Похоже, дело именно в DFS.  

    Интересно, а не может ли это быть связано с тем, что сервера пространства имен работают под управлением w8k, а "глючные" термнинальные сервера под управлением w3k?  

    И еще не совсем понятно, почему этот эффект не проявляется на других серверах и рабочих станциях.


    17 июня 2010 г. 7:04
  • Очень похоже, что проблема связанна с конкретным пространством имен \\domain\public\

    Попробовал создать новое пространство \\domain\pub\  настроил в нем те же конечные папки и подключил их  - проблем нет.

    После нескольких обращений папкам расположенным в старом пространстве имен опять "словил" подвисание проводника.

    Единственное отличие - в новом пространстве не настроена репликация папок.

    Проверю чуть позже с репликацией.

    P.S. w8k Не причем, т.к. корневой сервер пространства имен для нового пространства создавался тоже на сервере с w8k


    • Помечено в качестве ответа Igor V. Oskin 23 июня 2010 г. 12:25
    • Снята пометка об ответе Igor V. Oskin 23 июня 2010 г. 12:26
    17 июня 2010 г. 9:11
  • После удаления пространства имен DFS  \\domain\public\ и создания нового пространства с точно таким же именем (ручками, с нуля), "зависания" проводника на терминальных серверах прекратились.

    Т.о. проблема была связанна с конкретным пространством имен.  Хотя, не совсем понятна суть проблемы.  Да и решение не очень красивое.


    • Помечено в качестве ответа Igor V. Oskin 23 июня 2010 г. 12:30
    23 июня 2010 г. 12:30
  • Столкнулись с подобной проблемой.

    Помогло включение опции Enable Classic Shell в ГПО

    Описание: http://www.howtonetworking.com/winissues/windowsexplorerslow.htm

    • Предложено в качестве ответа Dr_Zlo 18 февраля 2014 г. 8:09
    23 декабря 2013 г. 12:28