none
Ошибка при отправке почты. RRS feed

  • Вопрос

  • Здравствуйте. Я хотел обновить Exchange 2010 до версии 2013, для этого поставил на новый сервер Exchange 2013, он увидел все настройки старого сервера и заработал. В коннекторе исходящих писем добавил новый сервер для отправки. Сделал на Exchange 2013 тестовый почтовый ящик, почта ходит в обе стороны внутри серверов (со старого на новый и обратно),  из инета почта тоже нормально приходит на 2013, а вот в интернет с него не уходит, возвращается ошибка

    Remote Server at 172.16.0.5 (172.16.0.5) returned '400 4.4.7 Message delayed'
    12.08.2015 20:55:03 - Remote Server at 172.16.0.5 (172.16.0.5) returned '451 4.4.0 Primary target IP address responded with: "554 mx.mail.biz." Attempted failover to alternate host, but that did not succeed. Either there are no alternate hosts, or delivery failed to all alternate hosts. The last endpoint attempted was 172.16.0.5:25'
    Исходные заголовки сообщения:

    Received: from EXCHANGE1.test.local (172.16.0.41) by exchange1.test.local (172.16.0.41) with Microsoft SMTP Server (TLS) id 15.0.913.22; Wed, 12 Aug 2015 23:57:40 +0700 Received: from EXCHANGE1.test.local ([fe80::29e0:f791:f955:abc1]) by exchange1.test.local ([fe80::29e0:f791:f955:abc1%12]) with mapi id 15.00.0913.011; Wed, 12 Aug 2015 23:57:40 +0700 From: TestExchange <TestExchange@test.biz> To: "test@mail.ru" <test@mail.ru> Subject: jkjk Thread-Topic: jkjk Thread-Index: AQHQ1R/8wjUTim8wzUWWr3zGd9n5Eg== Date: Wed, 12 Aug 2015 16:57:34 +0000 Message-ID: <0e584c2b6bbe4d1a8da5180965e99839@exchange1.rb.local> Accept-Language: ru-RU, en-US Content-Language: ru-RU X-MS-Has-Attach: X-MS-TNEF-Correlator: x-originating-ip: [172.16.11.33] Content-Type: multipart/alternative; boundary="_000_0e584c2b6bbe4d1a8da5180965e99839exchange1rblocal_" MIME-Version: 1.0

    Что я делаю не так?

    13 августа 2015 г. 8:07

Ответы

  • Настройки коннекторов вроде корректные. Смотрите настройки и логи на 172.16.0.5. Вероятно, надо указать на нем IP серверов Exchagne 2013 в разрешенных.
    13 августа 2015 г. 9:38
  • 1. Перезапуск Outlook не помогает? Через OWA тоже не уходит?

    2. Проверьте очередь на серверах (Get-TransportServer | Get-Queue)

    Если перестали приходить письма, значит что-то не то настроили на IronPort. ВСЕ входящие письма должны приходить на сервер Exchange 2013. А уже он разбирается, положить их в базу 2010 или 2013. 

    13 августа 2015 г. 10:35
  • Да, проверьте настройки коннекторов получения на 2013 (хотя странно, мы же их не меняли). И убедитесь, что IponPort ВСЮ входящую почту доставляет на Exchange 2013. 
    13 августа 2015 г. 10:54

Все ответы

  • Для Exchange 2013 надо создать отдельный коннектор отправки и добавить в него только серверы MBX 2013. Создавайте его строго через Exchange 2013 (EMS или ECP).
    13 августа 2015 г. 8:31
  • Да, а случайно Exchange 2013 не пытается отправлять письма через старый EDGE (mx.mail.biz)? Если это так, то вы обновляли подписку?
    13 августа 2015 г. 8:33
  • Создал и почта с Exchange 2013 совсем перестала ходить. Сейчас у меня 2 коннектора, по одному для Exc 2013 и 2013.
    13 августа 2015 г. 8:56
  • Что-то не то сделали. В коннекторе для 2010 exchange указаны HUB серверы 2010? 

    И что это за сервер: 172.16.0.5 mx.mail.biz? Это EDGE?

    13 августа 2015 г. 9:12
  • Покажите вывод (укажите имена ваших коннекторов):

    Get-Sendconnector "Internet 2010" | fl
    
    Get-Sendconnector "Internet 2013" | fl
    
    

    13 августа 2015 г. 9:15
  • Сам понимаю что где то накосячил, но не понимаю где.

    Вот вывод команд:

    [PS] C:\Windows\system32>Get-Sendconnector "Exchange2013" | fl


    AddressSpaces                : {SMTP:*;1}
    AuthenticationCredential     :
    CloudServicesMailEnabled     : False
    Comment                      :
    ConnectedDomains             : {}
    ConnectionInactivityTimeOut  : 00:10:00
    DNSRoutingEnabled            : False
    DomainSecureEnabled          : False
    Enabled                      : True
    ErrorPolicies                : Default
    ForceHELO                    : False
    Fqdn                         : mail.test.biz
    FrontendProxyEnabled         : False
    HomeMTA                      : Microsoft MTA
    HomeMtaServerId              : EXCHANGE1
    Identity                     : Exchange2013
    IgnoreSTARTTLS               : False
    IsScopedConnector            : False
    IsSmtpConnector              : True
    MaxMessageSize               : 35 MB (36,700,160 bytes)
    Name                         : Exchange2013
    Port                         : 25
    ProtocolLoggingLevel         : Verbose
    RequireOorg                  : False
    RequireTLS                   : False
    SmartHostAuthMechanism       : None
    SmartHosts                   : {[172.16.0.5]}
    SmartHostsString             : [172.16.0.5]
    SmtpMaxMessagesPerConnection : 20
    SourceIPAddress              : 0.0.0.0
    SourceRoutingGroup           : Exchange Routing Group (DWBGZMFD01QNBJR)
    SourceTransportServers       : {EXCHANGE2, EXCHANGE1}
    TlsAuthLevel                 :
    TlsCertificateName           :
    TlsDomain                    :
    UseExternalDNSServersEnabled : False



    [PS] C:\Windows\system32>Get-Sendconnector "All external mail" | fl


    AddressSpaces                : {SMTP:*;1}
    AuthenticationCredential     :
    CloudServicesMailEnabled     : False
    Comment                      :
    ConnectedDomains             : {}
    ConnectionInactivityTimeOut  : 00:10:00
    DNSRoutingEnabled            : False
    DomainSecureEnabled          : False
    Enabled                      : True
    ErrorPolicies                : Default
    ForceHELO                    : False
    Fqdn                         : mail.test.biz
    FrontendProxyEnabled         : False
    HomeMTA                      : Microsoft MTA
    HomeMtaServerId              : EXCHANGE
    Identity                     : All external mail
    IgnoreSTARTTLS               : False
    IsScopedConnector            : False
    IsSmtpConnector              : True
    MaxMessageSize               : 32 MB (33,554,432 bytes)
    Name                         : All external mail
    Port                         : 25
    ProtocolLoggingLevel         : Verbose
    RequireOorg                  : False
    RequireTLS                   : False
    SmartHostAuthMechanism       : None
    SmartHosts                   : {[172.16.0.5]}
    SmartHostsString             : [172.16.0.5]
    SmtpMaxMessagesPerConnection : 20
    SourceIPAddress              : 0.0.0.0
    SourceRoutingGroup           : Exchange Routing Group (DWBGZMFD01QNBJR)
    SourceTransportServers       : {EXCHANGE}
    TlsAuthLevel                 :
    TlsCertificateName           :
    TlsDomain                    :
    UseExternalDNSServersEnabled : False

    172.16.0.5 - это Cisco IronPort, он у нас фильтрует всю входящую и выходящую почту.

    13 августа 2015 г. 9:30
  • Настройки коннекторов вроде корректные. Смотрите настройки и логи на 172.16.0.5. Вероятно, надо указать на нем IP серверов Exchagne 2013 в разрешенных.
    13 августа 2015 г. 9:38
  • Прописал. Старые письма все пришли, а вот новые просто ложатся у пользователя в папку "черновики" и никуда не отправляются. Я перезагрузил Exchange 2013 и не помогло. Пробовал просто удалить письма из черновиков, но не помогает, они просто восстанавливаются при обновлении страницы. И сейчас письма совсем перестали ходить на Exc 2013 ни входящие, ни исходящие.

    • Изменено intel-1 13 августа 2015 г. 10:27
    13 августа 2015 г. 10:03
  • 1. Перезапуск Outlook не помогает? Через OWA тоже не уходит?

    2. Проверьте очередь на серверах (Get-TransportServer | Get-Queue)

    Если перестали приходить письма, значит что-то не то настроили на IronPort. ВСЕ входящие письма должны приходить на сервер Exchange 2013. А уже он разбирается, положить их в базу 2010 или 2013. 

    13 августа 2015 г. 10:35
  • Ну вот потихоньку все исправляю. Исходящая почта пошла как в инет, так и в локально, на старый exchange2010. Но вот входящая на exc2013 так и не работает. Тут видимо коннекторы.
    13 августа 2015 г. 10:40
  • Да, проверьте настройки коннекторов получения на 2013 (хотя странно, мы же их не меняли). И убедитесь, что IponPort ВСЮ входящую почту доставляет на Exchange 2013. 
    13 августа 2015 г. 10:54