none
outlook web app стили css и скрипты не найдены (ошибка 404,1) RRS feed

  • Вопрос

  •  Если быть более точным то при заходе на страницу http://mail.domain/owa

    У нас проходит авторизация, но не доступны стили, оформление, и в общем все почта через web app.

    Ниже я приведу скрины, так как в логах ничего нет. (да, совсем ничего).

    http://img-fotki.yandex.ru/get/4905/dolphin-ovk.11/0_4798f_b8c8cc66_XL

    Ссылка на эррор. причем ошибка возникает независимо от того, с какого хоста заходили, с внутреннего, внешнего или localhost.

    Где я ошибся?

     

    4 сентября 2010 г. 15:27

Ответы

  • Проблема решена установкой SP1 beta. Но все же в логах масса ошибок. Буду дальше искоренять по чуть-чуть по мере сил и возможностей.

     

    13 сентября 2010 г. 16:46

Все ответы

  • Вы не где скорее всего не ошиблись... попробуйте пересоздать OWA
    1. Get-OwaVirtualDirectory | fl > vd.txt
    2. далее удаляем виртуальную директорию http://technet.microsoft.com/en-us/library/aa998237.aspx
    3. и создаем ее заново с помощью http://technet.microsoft.com/en-us/library/bb123752.aspx
    при это старые настйроки можно глянуть в vd.txt
    и не забывать что если были кастомизации файлов OWA то сохранить их где нибудь.

     


    Regards, Dmitriy Ilyin
    6 сентября 2010 г. 7:37
  • Спасибо за дельный совет. Сделал именно так, но не вышло.

    Вот что открывает страничка по запросу. Причем неважно, с локального хоста или из внешнего. Все одно и то-же.

    https://localhost/owa/auth/logon.aspx?url=https://localhost/owa/&reason=0

    Так же перед открытием выдает нужный сертификат совершенно нормально.

    6 сентября 2010 г. 18:59
  • Добрый день,

    а есть какие-либо события в журнале IIS'а?



    Daniil Khabarov, MSFT  Follow MSTechnetForum on Twitter
    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий
    Посетите Блог Инженеров
    8 сентября 2010 г. 12:31
    Модератор
  • Да, в IIS есть несколько логов. Причем они появляются не в момент пробы подключения к OWA а регулярно появляются. Вот события которые критичные.

    Имя журнала:   System
    Источник:      Service Control Manager
    Дата:          12.09.2010 23:13:17
    Код события:   7030
    Категория задачи:Отсутствует
    Уровень:       Ошибка
    Ключевые слова:Классический
    Пользователь:  Н/Д
    Компьютер:     servername.domainname.ru
    Описание:
    Служба "Служба проверки подлинности на основе форм Microsoft Exchange" помечена как интерактивная.  Однако в конфигурации системы интерактивные службы не допускаются.  Возможна неправильная работа службы.
    Xml события:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Service Control Manager" Guid="{555908d1-a6d7-4695-8e1e-26931d2012f4}" EventSourceName="Service Control Manager" />
        <EventID Qualifiers="49152">7030</EventID>
        <Version>0</Version>
        <Level>2</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x8080000000000000</Keywords>
        <TimeCreated SystemTime="2010-09-12T19:13:17.913362300Z" />
        <EventRecordID>6623</EventRecordID>
        <Correlation />
        <Execution ProcessID="500" ThreadID="6720" />
        <Channel>System</Channel>
        <Computer>servername.domainname.ru </Computer>
        <Security />
      </System>
      <EventData>
        <Data Name="param1">Служба проверки подлинности на основе форм Microsoft Exchange</Data>
      </EventData>
    </Event>

     

     

     

    12 сентября 2010 г. 19:29
  • И еще по несколько логов в секунду: Но со статусом предупреждение.

    Имя журнала:   Microsoft-IIS-Configuration/Administrative
    Источник:      Microsoft-Windows-IIS-Configuration
    Дата:          12.09.2010 23:28:53
    Код события:   12
    Категория задачи:Отсутствует
    Уровень:       Предупреждение
    Ключевые слова:
    Пользователь:  система
    Компьютер:     %name%
    Описание:
    Не удается найти схему для раздела конфигурации "system.serviceModel/serviceHostingEnvironment". Этот раздел будет пропущен.
    Xml события:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-Windows-IIS-Configuration" Guid="{DC0B8E51-4863-407A-BC3C-1B479B2978AC}" />
        <EventID>12</EventID>
        <Version>0</Version>
        <Level>3</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x8000000000000000</Keywords>
        <TimeCreated SystemTime="2010-09-12T19:28:53.088204800Z" />
        <EventRecordID>14309</EventRecordID>
        <Correlation />
        <Execution ProcessID="3420" ThreadID="11608" />
        <Channel>Microsoft-IIS-Configuration/Administrative</Channel>
        <Computer>%name% </Computer>
        <Security UserID="S-1-5-18" />
      </System>
      <EventData>
        <Data Name="PhysicalPath">\\?\C:\Windows\Microsoft.NET\Framework64\v2.0.50727\CONFIG\web.config</Data>
        <Data Name="FileConfigPath">MACHINE/WEBROOT</Data>
        <Data Name="EffectiveLocationPath">
        </Data>
        <Data Name="SectionPath">system.serviceModel/serviceHostingEnvironment</Data>
      </EventData>
    </Event>

    Вот как то вот так(

    а owa нужна уже вчера.

    12 сентября 2010 г. 19:33
  • Проблема решена установкой SP1 beta. Но все же в логах масса ошибок. Буду дальше искоренять по чуть-чуть по мере сил и возможностей.

     

    13 сентября 2010 г. 16:46