none
Не отрабатывает sysprep для WDS в Windows XP SP3. RRS feed

  • Вопрос

  • Здравствуйте!

    Уже который день не могу захватить образ с Windows XP. Путём эксперимента, оказалось, что на стадии запуска Sysprep, он не отрабатывает. Т.е. не помечает (как должно быть) диск C:\ для захвата. При загрузке PXE с WDS, я не могу захватить диск "C:\" на этапе "Захвата образов", в окне мастера, где нужно выбрать том для захвата, тома не отображаются. При развёртывании Windows 7, всё получилось с первого раза. Я уже и sysprep скачивал отдельно с Microsoft - не помогло, пробовал и с мини-установкой запечатывать и без - безрезультатно. Делал по аналогии как на видео: http://www.techdays.ru/videos/2093.html

    Последовательность моих действий (пробовал на ESX сервере и на ноуте - VMware Workstation 7):

    1. На 2008 R2 rus развернул домен, DHCP и WDS (на 2008 eng тоже самое).

    2. За основу WinPE взял sysprep с DVD - 2008 R2 (для 2008 аналогично, только с диска 2008-го соответственно).

    3. На основе созданного образа (в п.2) создал образ захвата.

    4. Подготовил виртуалку с XP (для эксперимента установил WinRAR, ну и VMware Tools встало автоматом).

    5. Разархивировал deploy.cab (брал сначала с CD для XP SP3 rus, потом с Microsoft) в c:\sysprep.  Запустил sysprep, нажал "Запечатать компьютер":

    - выбирал и как "Завершение работы", так и "Перезагрузка";

    - перед запуском sysprep, пробовал создавать файл ответов, при помощи setupmgr.exe

    - пробовал запускать с параметром "Мини-установка" и без него.

    6. После включения XP, жму F12 загружаюсь при помощи образа для захвата и при выборе захвата диска, там пусто.

    Ознакомился со следующими материалами:

    http://www.microsoft.com/rus/windowsserver2008/docs/Windows_Deployment_services_in_WS08/Windows_Deployment_Services_in_WS08_ru_page1.aspx#top1

    http://habrahabr.ru/blogs/windows/73268/

    http://swdukk.livejournal.com/1051.html

    http://oszone.net/2747

    http://support.microsoft.com/kb/302577

     MDT в данном случае не подходит. Нужно именно WDS. Кто подскажет, куда копать? Завтра ещё попробую поэкспериментировать при помощи другого дистрибутива XP (SP2). В данном примере, я брал корпоративный дистрибутив XP (OEM).

     


    MCTS
    6 ноября 2011 г. 11:24

Все ответы

  • Вчера проверил на ESX (WDS на 2008R2, клиент - XP SP3). Всё заработало. Я вроде не запускал sysprep. А вот в домашних условиях (где WDS на 2008 и клиент - XP) по-прежнему не отрабатывает.

    Дело в том, что где ESX, там за основу образов (WinPE и Образ захвата) брался *.WIN из XP, а в домашних условиях *.WIN брался из дистрибутива 2008. Т.е. в производственной сфере работает, но повторить тоже самое на 2008 пока не получается. Буду пробывать разворачивать всё с нуля (в двух вариантах: сначала за основу образов возьму *.win из XP, потом из 2008).


    MCTS
    8 ноября 2011 г. 12:23