none
Постоянный поиск устройств... RRS feed

  • Вопрос

  • Система Windows XP SP2  (в домене) + все обновления... С очень продолжительного времени (год наверное точное) стало отмечаться странное поведение системы: при запуске "мастера установки нового оборудования" система отвечает тем, что у вас (у  меня) уже идет установка оборудования и следует дождаться её окончания. Данный момент впрочем не мешает устанавливать новое оборудование и драйвера за исключением единичных программ и драйверов, которые проверяют на предмет установки устройств в данный момент времени (напр. последние версии ПО от NOKIA). В каком направлении "копать"?! Где зарыта собака?

    P.S.: рекомендации вроде переустановки системы не пройдут - потребуется переустановка не одного десятка ПО.

    11 октября 2006 г. 12:09

Ответы

Все ответы

  • Есть отличный файлик setupapi.log и статья, как его читать: http://www.microsoft.com/whdc/driver/install/setupapilog.mspx

     

    12 октября 2006 г. 6:03
  • Проблема точно не в ПО от Nokia.
    Так, как я сам регулярно ставлю (обновляю) Nokia PC Suite на двух машинах (одна в домене, другая локальная).
    Подумаю, где собака зарыта...
    16 октября 2006 г. 7:51
  • Уточните, пожалуйста. Эта проблема с самой устновки ОС, или она приобретена во время работы?

    Попробуйте забекапить системный диск и установить Windows обновлением.

    16 октября 2006 г. 8:58
  •  DmitryK написано:

    Есть отличный файлик setupapi.log и статья, как его читать: http://www.microsoft.com/whdc/driver/install/setupapilog.mspx

     

    Это тут не причём(?): система нормально устанавливает драйвера и устройства, о чем собственно и говорят записи в этом файле. Причина в том, что при запуске "мастера оборудования" система сообщает, что у меня уже запущен мастер установки оборудование (кем и когда?) и следует дождаться окончания его работы. Тоже самое происходит и с программами, которые видимо проверяют этот факт (запуск мастера оборудования), напр. тот же софт от Nokia.

    P.S.: проблема еще не решена. Вопрос остаётся открытым.

    20 ноября 2006 г. 8:32
  •  SV Foster написано:

    Уточните, пожалуйста. Эта проблема с самой устновки ОС, или она приобретена во время работы?

    Попробуйте забекапить системный диск и установить Windows обновлением.

    Наверное же во время работы: у меня нет манеры переустанавливать Windows каждый месяц - всё прекрасно работает по несколько лет (в моём случае OS работает с 2003 года), за исключением вышеописанной проблеммы.
    20 ноября 2006 г. 8:37
  • Вот этот совет вам не поможет?

    http://www.lurkhere.com/forum/DCForumID12/198.html

    I found a solution and am hoping that it will help others.

    Navigate to HKEY_LOCAL_MACHINE\System\Setup

    If there is any key or values named "FactoryPreInstallInProgress", please right click and delete it.

    I also deleted the entire HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Factory key

    20 ноября 2006 г. 12:28
  •  Michael Gotch написано:

    Вот этот совет вам не поможет?

    http://www.lurkhere.com/forum/DCForumID12/198.html

    I found a solution and am hoping that it will help others.

    Navigate to HKEY_LOCAL_MACHINE\System\Setup

    If there is any key or values named "FactoryPreInstallInProgress", please right click and delete it.

    I also deleted the entire HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Factory key

    Помогло, еще как помогло.
    22 ноября 2006 г. 5:32
  • Может и мне что-нибудь посоветуете? У меня глюк такой: после загрузки (каждый раз) мастер устанообнаруживает НЕСУЩЕСТВУЮЩИЙ ПРИНТЕР и просит установить соответствующий драйвер, что никогда не вки выходит. Принтера у меня никогда не было. Система свежая и я ОЧЕНЬ НЕ ХОЧУ ее переустанавливать! Пробовал удалять все из USB-портов (вебка, блютуз и кардридер) - он все равно принтер "видит". Что можно сделать? Если можно, пишите сюда - volt73@list.ru  Спасибо.

    8 сентября 2007 г. 8:40