none
Intel X-520 DA и Hyper-v server core 2012r2 RRS feed

  • Общие обсуждения

  • Добрый день. 
    Есть два сервера
    1. Hyper-v server core 2012r2 
    2. Nas-free (release 9.1**) - файловое хранилище
    В оба сервера вставлены сетевые карты Intel x520 DA.
    При помощи кабеля "SFP+ Direct Attached Cable (DAC)" компании NAG.ru они подключены между собой напрямую. 
    В настройках указал 10 GBe full duplex на обеих машинах. (Hyper-v: драйвер INTEL+настройка в реестре дуплекса)
    На Nas-free так же определяется : IX1 "media: Ethernet autoselect (10Gbase-Twinax )"

    В один момент было такое что после того, как я выставил настройки в реестре (поставил full-duplex 10 gbit в Hyper-V server) и перезагрузился у меня все заработало.
    Заработало, скорость достигала 8-9 GBe read\write. После объединение порта с виртуальным коммутатором в мост скорость снова упала.
    Выдвинул предположение что причина в последнем действии, и вернул обратно.
    Скорость при тесте опять не превышала 500 Mbs.

    Перепробовал все что можно. 
    Проверял сетевые карты на других платформах в разных связках. Такая же ситуация. 
    Ставил карточки на Windows server 2012r2 с интерфейсом выставлял руками и проводил тесты, вторую карту поставил в Windows 8.1.
    Тоже самое.
    Прибегал к решениям 
    Возможно дело в прошивке самих сетевых карт. Я не совсем понял как обновить прошивки у сетевых карт Intel.
    17 марта 2014 г. 13:54

Все ответы

  • По прошивке:

    http://downloadmirror.intel.com/19186/eng/BootUtil.txt ниже есть примеры использования команд

    https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=19186

    Если сервера брендовые, то используйте утилиты обновления от вендора ( к примеру, HP SUM или Dell Repository Manager ...)

    Обратите внимание так же на:

    Tuning Intel® Ethernet Adapter throughput performance


    Roman Levchenko, MCITP, MCTS http://www.rlevchenko.com


    17 марта 2014 г. 14:31
  • Возможно, проблема в работе VMQ на данном адаптере. Попробуйте выключить эту функцию командлетом

    Get-NetAdapterVmq | Disable-NetAdapterVmq

    17 марта 2014 г. 16:36
    Отвечающий
  • VMQ возможно. Вендорам должно быть уже стыдно,если честно. Что ни кейс, то VMQ :)

    Roman Levchenko, MCITP, MCTS http://www.rlevchenko.com

    18 марта 2014 г. 10:03
  • Совершенно случайно поставил голос напротив VMQ  а вот отменить не смог.

    VMQ, я видел это решение. Нам не помогло. Сейчас разбираюсь с сетевыми карточками, существует вероятность что это аппаратная часть сетевых карт "заставляет тратить" кучу времени.

    Как решу вопрос, обязательно отпишусь.

    18 марта 2014 г. 12:31
  • Совершенно случайно поставил голос напротив VMQ  а вот отменить не смог.

    VMQ, я видел это решение. Нам не помогло. Сейчас разбираюсь с сетевыми карточками, существует вероятность что это аппаратная часть сетевых карт "заставляет тратить" кучу времени.

    Как решу вопрос, обязательно отпишусь.

    Для начала обновитесь по максимуму. Если есть возможность проверить с другим DAC кабелем, то было бы здорово.

    + настройки драйвера (надеюсь, что он последней версии) смотрели? 

    http://www.intel.com/support/network/adapter/pro100/sb/CS-031949.htm

    Можно ещё отключить offload settings на адаптерах ради теста  

    http://www.intel.com/support/network/adapter/pro100/sb/CS-029402.htm#tco


    Roman Levchenko, MCITP, MCTS http://www.rlevchenko.com

    18 марта 2014 г. 15:07
  • Отключать TCP offloading на физической карте пробовали?
    19 марта 2014 г. 9:20
    Отвечающий
  • Пробовал.

    Итак, что мы имеем в итоге.

    1. Настройки и драйвера:

    При стандартных драйверах и настройках (кроме переключения с AUTO на Full duplex) я получил 8-9 GBs на запись и чтение. Однако при объедении их с адаптером hyper-v, скорость опять упала. После отката на пред идущий этап достигнуть скорости в 8-9 GBs  не удалось.

    2. Тестирование карточек на других системах:

    а. Win8.1-Win7: 1. С берега Win7 cкорость 1.2 GBs чтение записать. 2. C берега Win8.1 скорость не выше 343 MBs ч\з. Однако показывает в интерфейсе. Прошу заметить что настройки одинаковые.

    Однако если  перезапустить систему то при точно таком же тесте показание совершенное другие. Показывают 1.2, 1.6, 0.8, 0.3

    Перезапускаю систему на другом компьютере. Показания в тесте практически не меняются.

    Вы меня простите конечно за такие наглядные практические тесты дилетанта. Если подумать все настройки карточки предназначены для того, чтобы достигнуть максимальной производительности в тех или иных условиях. А когда карточка показывает результат ниже чем обычная гигабитная то я считаю дело  в самом устройстве. Поправьте меня если я не прав. Завтра буду договариваться с компанией о тестах карточек. Будем искать истину. Обязательно отпишусь как будут результаты. Большое все спасибо за потраченное время и внимание. 

    19 марта 2014 г. 15:25