none
Ошибка установки: сервер Exchange Server находится в несогласованном состоянии RRS feed

  • Вопрос

  • Расскажу по порядку.

    До развертывания Exchange 2010 на "боевом" сервере, я развернул Exchange для тестов в виртуальной среде. Перед установкой Exchange на виртуальном сервере я добавил этот сервер в домен и получилось DNS-имя mail.company.local.

    Спустя пару недель я вообще забыл, что разворачивал Exchange в виртуальной среде. И вот наконец-то у меня появился выделенный, физический, сервер для Exchange 2010 на котором я принялся разворачивать Exchange.

    Установил Windows Server 2008 R2, дал имя серверу srv3, а когда добавил его  домен, то получил DNS-имя srv3.company.local

    Начал разворачивать Exchange и всё бы хорошо, но после установки я запустил оснастку Exchange и увидел там 2 сервере Exchange - SRV3 и MAIL. Я сначала не мог понять, каким образом у меня получилось 2 Exchange сервера, а не один. И вот тогда я понял, что пару недель назад я разворачивал Exchange в тестовой среде. А так как тестовый сервер был в домене, то все стандартные учетные записи и контейнеры Exchange создались на контроллере домена.

    Сделал резервную копию КД и удалил из оснастки Пользователи и компьютеры все упоминания об Exchange. В оснастке DNS удалил все ресурсные и т.п. записи о виртуальном сервере, который я пару недель назад водил в домен.

    Откатил "боевой" сервер до точки, когда не был установлен Exchange.

    Переименовал "боевой" сервер на MAIL и получилось имя mail.company.local.

    А теперь то, с чем я столкнулся при попытке снова развернуть Exchange 2010 на "боевом" сервере.

    Запускаю setup.exe, выбираю язык, выбираю Установить Еxchange 2010. Идет загрузка нужных установочных файлов и... получаю сообщение:

    ---------------------------
    Microsoft Exchange
    ---------------------------
    Некоторые элементы управления недопустимы
     - Сервер Exchange Server работает в несогласованном состоянии. Доступен только режим аварийного восстановления. Чтобы восстановить этот сервер Exchange, используйте команду Setup /m:RecoverServer.

    ---------------------------
    ОК  
    ---------------------------

    Скриншот этой ошибки http://s001.radikal.ru/i196/1004/e0/64a5b3cdfb2f.jpg

    Лог-файл установки Exchange:

    [04.06.2010 06:20:59.0413] [0] **********************************************
    [04.06.2010 06:20:59.0413] [0] Starting Microsoft Exchange Server 2010 Setup
    [04.06.2010 06:20:59.0413] [0] **********************************************
    [04.06.2010 06:20:59.0428] [0] Local Time Zone: (UTC+10:00) Владивосток.
    [04.06.2010 06:20:59.0428] [0] Operating System version: Microsoft Windows NT 6.1.7600.0.
    [04.06.2010 06:20:59.0428] [0] Setup version: 14.0.639.21.
    [04.06.2010 06:20:59.0428] [0] Logged on user: COMPANY\Администратор.
    [04.06.2010 06:21:01.0035] [0] Command Line Parameter Name='mode', Value='Install'.
    [04.06.2010 06:21:01.0035] [0] Command Line Parameter Name='sourcedir', Value='F:\'.
    [04.06.2010 06:21:01.0035] [0] Command Line Parameter Name='fromsetup', Value=''.
    [04.06.2010 06:21:01.0051] [0] ExSetupUI was started with the following command: '-mode:install -sourcedir:F:" /FromSetup'.
    [04.06.2010 06:21:01.0846] [0] Setup is choosing the domain controller to use
    [04.06.2010 06:21:02.0220] [0] Setup is choosing a local domain controller...
    [04.06.2010 06:21:04.0358] [0] Setup has chosen the local domain controller srv1.company.local for initial queries
    [04.06.2010 06:21:04.0529] [0] PrepareAD has been run, and has replicated to this domain controller; so setup will use srv1.company.local
    [04.06.2010 06:21:04.0529] [0] Setup is choosing a global catalog...
    [04.06.2010 06:21:04.0529] [0] Setup has chosen the global catalog server srv1.company.local.
    [04.06.2010 06:21:04.0560] [0] Setup will use the domain controller 'srv1.company.local'.
    [04.06.2010 06:21:04.0576] [0] Setup will use the global catalog 'srv1.company.local'.
    [04.06.2010 06:21:04.0576] [0] Exchange configuration container for the organization is 'CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=company,DC=local'.
    [04.06.2010 06:21:04.0576] [0] Exchange organization container for the organization is 'CN=company,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=company,DC=local'.
    [04.06.2010 06:21:04.0638] [0] Setup will search for an Exchange Server object for the local machine with name 'MAIL'.
    [04.06.2010 06:21:04.0841] [0] Exchange Server object found : 'CN=MAIL,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=company,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=company,DC=local'.
    [04.06.2010 06:21:05.0028] [0] The following roles have been unpacked:
    [04.06.2010 06:21:05.0044] [0] The following datacenter roles are unpacked:
    [04.06.2010 06:21:05.0044] [0] The following roles are installed:
    [04.06.2010 06:21:05.0044] [0] The local server does not have any Exchange files installed.
    [04.06.2010 06:21:05.0169] [0] Setup will use the path 'F:\' for installing Exchange.
    [04.06.2010 06:21:05.0169] [0] Setup will discover the installed roles from server object 'CN=MAIL,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=company,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=company,DC=local'.
    [04.06.2010 06:21:05.0169] [0] 'BridgeheadRole' is installed on the server object.
    [04.06.2010 06:21:05.0169] [0] 'ClientAccessRole' is installed on the server object.
    [04.06.2010 06:21:05.0169] [0] 'MailboxRole' is installed on the server object.
    [04.06.2010 06:21:05.0169] [0] The installation mode is set to: 'Install'.
    [04.06.2010 06:21:35.0525] [0] An Exchange organization with name 'company' was found in this forest.
    [04.06.2010 06:21:35.0525] [0] Active Directory Initialization status : 'True'.
    [04.06.2010 06:21:35.0525] [0] Schema Update Required Status : 'False'.
    [04.06.2010 06:21:35.0525] [0] Organization Configuration Update Required Status : 'False'.
    [04.06.2010 06:21:35.0525] [0] Domain Configuration Update Required Status : 'True'.
    [04.06.2010 06:21:35.0571] [0] Applying default role selection state
    [04.06.2010 06:21:35.0618] [0] Setup is determining what organization-level operations to perform.
    [04.06.2010 06:21:35.0618] [0] Setup has detected a missing value. Setup is adding the value PrepareDomain.
    [04.06.2010 06:21:35.0634] [0] Because the value was specified, setup is setting the argument OrganizationName to the value company.
    [04.06.2010 06:21:35.0634] [0] Setup will run from path 'C:\Windows\Temp\ExchangeSetup'.
    [04.06.2010 06:21:35.0681] [0] InstallModeDataHandler has 9 DataHandlers
    [04.06.2010 06:21:35.0696] [0] Setup is determining what organization-level operations to perform.
    [04.06.2010 06:21:35.0696] [0] Setup has detected a missing value. Setup is adding the value PrepareDomain.
    [04.06.2010 06:21:35.0696] [0] Because the value was specified, setup is setting the argument OrganizationName to the value company.
    [04.06.2010 06:21:35.0696] [0] Setup will run from path 'C:\Windows\Temp\ExchangeSetup'.
    [04.06.2010 06:21:35.0696] [0] InstallModeDataHandler has 9 DataHandlers
    [04.06.2010 06:21:35.0696] [0] RootDataHandler has 1 DataHandlers

    Меня смущает время в событий в лог-файле 06:21:35, когда время на системных часах было 17:21

    Прошу подсказать где моя ошибка и почему  Exchange считает, что он уже был установлен? Как выйти из этого круговорота?

    6 апреля 2010 г. 6:40

Ответы

  • Нашел статью и удалил последние остатки http://msexchangehelp.wordpress.com/2010/02/10/manually-uninstall-last-exchange-2010-server-from-organization/ буду пробовать переустановить. О результатах отпишусь, но скорей всего завтра.
    • Помечено в качестве ответа MaxRAF 9 апреля 2010 г. 8:14
    8 апреля 2010 г. 5:49
  • [04.06.2010 06:21:05.0169] [0] Setup will discover the installed roles from server object 'CN=MAIL ,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=company,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=company,DC=local'.
    [04.06.2010 06:21:05.0169] [0] 'BridgeheadRole' is installed on the server object.
    [04.06.2010 06:21:05.0169] [0] 'ClientAccessRole' is installed on the server object.
    [04.06.2010 06:21:05.0169] [0] 'MailboxRole' is installed on the server object.
    [04.06.2010 06:21:05.0169] [0] The installation mode is set to: 'Install'.

     

     

    Под именем MAIL уже была (есть) установка, следовательно установка запускается с ключом -mode:install и выподает с ошибкой так как такой сервер уже есть и роли на нем.

    вам поможет,
    запуск с ключем Setup /m:RecoverServer (простой способ, лечения) Подробно тут Recover an Exchange Server


    или удаление старых объектов AD используя ADSI Edit (adsiedit.msc) (что нужно делать аккуратно! )

     

    Ждем результата

     


    Arman Obosyan, http://postmaster.ge/blog
    • Предложено в качестве ответа Arman Obosyan 6 апреля 2010 г. 7:06
    • Помечено в качестве ответа MaxRAF 9 апреля 2010 г. 8:15
    6 апреля 2010 г. 6:56

Все ответы

  • [04.06.2010 06:21:05.0169] [0] Setup will discover the installed roles from server object 'CN=MAIL ,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=company,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=company,DC=local'.
    [04.06.2010 06:21:05.0169] [0] 'BridgeheadRole' is installed on the server object.
    [04.06.2010 06:21:05.0169] [0] 'ClientAccessRole' is installed on the server object.
    [04.06.2010 06:21:05.0169] [0] 'MailboxRole' is installed on the server object.
    [04.06.2010 06:21:05.0169] [0] The installation mode is set to: 'Install'.

     

     

    Под именем MAIL уже была (есть) установка, следовательно установка запускается с ключом -mode:install и выподает с ошибкой так как такой сервер уже есть и роли на нем.

    вам поможет,
    запуск с ключем Setup /m:RecoverServer (простой способ, лечения) Подробно тут Recover an Exchange Server


    или удаление старых объектов AD используя ADSI Edit (adsiedit.msc) (что нужно делать аккуратно! )

     

    Ждем результата

     


    Arman Obosyan, http://postmaster.ge/blog
    • Предложено в качестве ответа Arman Obosyan 6 апреля 2010 г. 7:06
    • Помечено в качестве ответа MaxRAF 9 апреля 2010 г. 8:15
    6 апреля 2010 г. 6:56
  • А зачем вы удаляли сервер таким образом ? Что мешало сделать нормальный Uninstall ?

    Запись в логе "Setup will discover the installed roles from server object 'CN=MAIL,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=company,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=company,DC=local'.
    "

    Говорит что объект с именем "MAIL" уже есть в структуре AD.

    Тут есть два способа.

    1. Сделать Backup System state с контроллеров домена и попробовать через ADSI удалить данный объект. Но я бы вам не советовал пока бы это делать.

    2. Переименовать существующий сервер и попробовать установить сервер Exchange с другим именем.

     

     

    6 апреля 2010 г. 7:00
  • Setup /m:RecoverServer не решил мою проблему - Exchange установился, но когда запускаю оснастку "Exchange Management Console" появляется ошибка: http://s004.radikal.ru/i208/1004/18/ec3aad56aa60.jpg

    Вечером планирую сделать так:

    1. Откатить КД до состояния, когда я не удалял контейнеры и группы Exchange

    2. Откатить srv3.company.local до состояния, когда не был установлен Exchange.

    3. Запустить виртуальную машину mail.company.local и удалить Exchange с помощью "Программы и компоненты", после чего утилизировать эту виртуальную машину.

    4. Переименовать srv3.company.local на mail.company.local и установить Exchange.

    Сработает ли такое действие?

    6 апреля 2010 г. 22:48
  • Setup /m:RecoverServer не решил мою проблему - Exchange установился , но когда запускаю оснастку "Exchange Management Console" появляется ошибка: http://s004.radikal.ru/i208/1004/18/ec3aad56aa60.jpg


    Setup /m:RecoverServer решил вашу проблему! Exchange установился!,

    но теперь у вас другая поблема с подключением...

    вы проверяли рузультат подключения c Exchange Management Shell ? из командной строки подключаетесь?

     

    1,2,3,4, выглядит как план действий, но яб не стал так делать на боевой системе, думаю лучше исправить ошибку которая вылезла полсе установки


    Arman Obosyan, http://postmaster.ge/blog
    7 апреля 2010 г. 3:13
  • Setup /m:RecoverServer не решил мою проблему - Exchange установился , но когда запускаю оснастку "Exchange Management Console" появляется ошибка: http://s004.radikal.ru/i208/1004/18/ec3aad56aa60.jpg


    Setup /m:RecoverServer решил вашу проблему! Exchange установился!,

    но теперь у вас другая поблема с подключением...

    вы проверяли рузультат подключения c Exchange Management Shell ? из командной строки подключаетесь?

     

    1,2,3,4, выглядит как план действий, но яб не стал так делать на боевой системе, думаю лучше исправить ошибку которая вылезла полсе установки


    Arman Obosyan, http://postmaster.ge/blog


    Если фактически, то она не боевая. Порой бывает быстрее переустановить всё, чем исправлять ошибки. Мне например не хватает знаний, так как я подобным не сталкивался, а информации в интернете найти не могу. 

    Еще такой думаю попрбовать вариант

    Откатить все до того момента, когда было:

    Начал разворачивать Exchange и всё бы хорошо, но после установки я запустил оснастку Exchange и увидел там 2 сервере Exchange - SRV3 и MAIL. Я сначала не мог понять, каким образом у меня получилось 2 Exchange сервера, а не один.

    После этого корректно удалить Exchange на виртуальной машине и переименовать боевой сервер на mail.

     

    7 апреля 2010 г. 4:46
  • o! если она не боевая то можно делать с ней все что угодно!, если есть время и желание то можно поковырятся с проблемой, выяснить причину, потом уже все переустановить, если нет времени или желания (или и того и тругого) тогда откатите и ставте по новой.

    Ждем решения и результата

     


    Arman Obosyan, http://postmaster.ge/blog
    7 апреля 2010 г. 5:26
  • o! если она не боевая то можно делать с ней все что угодно!, если есть время и желание то можно поковырятся с проблемой, выяснить причину, потом уже все переустановить, если нет времени или желания (или и того и тругого) тогда откатите и ставте по новой.

    Ждем решения и результата

     


    Arman Obosyan, http://postmaster.ge/blog

    О результатах напишу. Но тут дело не в "боевой" машине, а в КД, так как там хранятся записи от виртуального экченджа. А КД на боевой машине и выход из строя КД будет означать только одно - проблемы на работе и с работой. Времени увы нет, чтобы разбираться.
    7 апреля 2010 г. 5:56
  • ну тогда ждем!

     


    Arman Obosyan, http://postmaster.ge/blog
    7 апреля 2010 г. 6:27
  • Увы, ничего не вышло. При установке получаю ошибку http://i066.radikal.ru/1004/a2/79afab703995.jpg

    Удалял в ADSI запись Exchange, но всё равно та же ошибка. Больше в ADSI ни какого упоминания Exchange не нашёл.

    Пробовал переименовать сервер, но и здесь не помогло - ругается на то, что надо подготовить AD и запустить Setup /PrepareAD Пробовал Setup /PrepareAD , но ничего не вышло.

    На английских форумах по этому поводу тишина, но есть статья для Exchange 2007 http://technet.microsoft.com/ru-ru/library/bb288905%28EXCHG.80%29.aspx, которая как я понял не подходит к Exchange 2010, так как нету у меня в ADSI CN=Configuration или CN=Services.

    Уже думаю о переустановке КД, благо пользователей пока около 15-ти в АД, но надо ждать выходных, что очень долго.

    Всё же надеюсь на помощь.

    7 апреля 2010 г. 22:58
  • Нашел статью и удалил последние остатки http://msexchangehelp.wordpress.com/2010/02/10/manually-uninstall-last-exchange-2010-server-from-organization/ буду пробовать переустановить. О результатах отпишусь, но скорей всего завтра.
    • Помечено в качестве ответа MaxRAF 9 апреля 2010 г. 8:14
    8 апреля 2010 г. 5:49
  • Всё! Exchange был успешно установлен без единой ошибки или предупреждения. Всё работает. Большое спасибо за наводки.
    9 апреля 2010 г. 8:14