none
После запуска рабочего процесса не отправляется сообщение электронной почты RRS feed

  • Вопрос

  • Добрый день! Недавно возникла следующая проблема:перестали отправляться сообщения электронной почты после запуска рабочего процесса.

    Если создать рабочий процесс, требующий отправки сообщения, то пишет, что рабочий процесс завершен, но сообщение так и не приходит.

    Если же создать рабочий процесс, НЕ связанный с отправкой сообщения, то все работает. Значит проблема не в рабочих процессах, а именно в отправке сообщения. Также пробовал подписаться на оповещения при изменении элементов списка, здесь тоже все работает. Оповещения прилетают на почту.

    В итоге, возникла проблема с рабочими процессами, связанными с отправкой сообщений. (до недавнего времени все работало). В чем может быть дело?

    31 марта 2016 г. 6:26

Ответы

  • Добрый день,

    смотрите логи почтовика, может в спам фильтр попадают. Просто либо почта отсылается, либо нет, у вас же и то и другое, такого не должно быть.

    • Помечено в качестве ответа bde_043spec 3 апреля 2016 г. 23:36
    31 марта 2016 г. 9:37

Все ответы

  • Здравствуйте!
    Попробуйте создать тестовый рабочий процесс и в нем создать действие отправки почты.
    Сообщите результат.


    Блог о SharePoint

    31 марта 2016 г. 7:46
  • Создал тестовый рабочий процесс, в нем создал действие отправки почты, запустил, результат тот же. Пишет, что рабочий процесс завершен, а на почту так ничего и не пришло.

    31 марта 2016 г. 8:49
  • Добрый день,

    смотрите логи почтовика, может в спам фильтр попадают. Просто либо почта отсылается, либо нет, у вас же и то и другое, такого не должно быть.

    • Помечено в качестве ответа bde_043spec 3 апреля 2016 г. 23:36
    31 марта 2016 г. 9:37
  • Добрый день! Спасибо за помощь, оказалось, что письма блокируются не самим почтовиком, а касперским. Добавил в белый список, сообщения стали прилетать некоторое время.

    Только спустя некоторое время появилась другая проблема. Рабочие процессы с отправкой сообщения не завершаются, пишется "отменено". Хотя другие рабочие процессы, не связанные с отправкой сообщения, завершаются. Ну и также приходят оповещения при изменениях элементов списка. Информация следующая:

    RequestorId: f9dff485-080b-ad83-ab99-6b9538b458f6. Details: System.ApplicationException: HTTP 401 {"x-ms-diagnostics":["3000006;reason=\"Token contains invalid signature.\";category=\"invalid_client\""],"SPRequestGuid":["f9dff485-080b-ad83-ab99-6b9538b458f6"],"request-id":["f9dff485-080b-ad83-ab99-6b9538b458f6"],"X-FRAME-OPTIONS":["SAMEORIGIN"],"SPRequestDuration":["4"],"SPIisLatency":["0"],"Server":["Microsoft-IIS\/7.5"],"WWW-Authenticate":["Bearer realm=\"91a7d702-4ffd-47e8-9061-8ee56c676bb0\",client_id=\"00000003-0000-0ff1-ce00-000000000000\",trusted_issuers=\"00000005-0000-0000-c000-000000000000@*,00000003-0000-0ff1-ce00-000000000000@91a7d702-4ffd-47e8-9061-8ee56c676bb0\"","Negotiate","NTLM"],"X-Powered-By":["ASP.NET"],"MicrosoftSharePointTeamServices":["15.0.0.4420"],"X-Content-Type-Options":["nosniff"],"X-MS-InvokeApp":["1; RequireReadOnly"],"Date":["Fri, 01 Apr 2016 02:21:06 GMT"]} {"error_description":"Invalid JWT token. Could not resolve issuer token."}   at Microsoft.Activities.Hosting.Runtime.Subroutine`1.

    Из за чего это могло произойти? может быть в настройках случайно поменял что то?

    1 апреля 2016 г. 2:32
  • Разобрался как исправить эту ошибку! Необходимо открыть Центр администрирования - Отслеживание - Просмотр определений заданий - Обновление веб-канала метаданных доверенной службы маркеров безопасности. Здесь нужно вручную запустить это обновление, после чего приведенная выше ошибка перестанет появляться, и рабочие процессы с отправкой сообщения будут завершаться и приходить на почту.
    • Помечено в качестве ответа bde_043spec 3 апреля 2016 г. 23:35
    • Снята пометка об ответе bde_043spec 3 апреля 2016 г. 23:37
    3 апреля 2016 г. 23:34